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1 Introduction

1.1 Product Description

Backup4all  is  an  award-winning  backup  software  for  Windows.  Backup4all  protects  your  valuable
data from partial or total loss by automating backup tasks, password protecting and compressing it to
save storage space. Using Backup4all you can easily backup to any local, network drive, backup to FTP
(with  support  for  SSL  encryption,  proxy  server,  passive  mode),  SFTP,  Amazon  S3,  Azure,  Dropbox
(Personal or Business), OneDrive (Personal or Business), Google Cloud Storage,  Box,  HiDrive,  Hubic,
backup to CD, DVD or Blu-ray disc, Google Drive, or other removable media (such as USB or Firewire
drives).
You can also use multiple Amazon S3 compatible clouds as backup destination: Akaza, Aruba Cloud,
Backblaze  B2,  Caringo,  CenturyLink,  Cisco,  Claudian,  Connectia,  Constant,  DDN,  dinCloud,  Dream
Objects, Dunkel, T Cloud, Exoscale, Green Qloud, HGST, Hitachi, HostEurope, IDC Frontier, LeoNovus,
Mandic, Minio, NetApp, NiftyClouds, Numergy, QNAP, Revera, Scality, Seeweb, SwiftStack, ThinkOn,
Tiscali,  vCloud Air, Verizon, Walrus and Zettagrid. You can also use a custom S3 compatible server by
entering the specific information.

 

Backup4all  can  backup  open/locked  files  (if  the  files  are  located  on  local  partitions  on  Windows
XP/2003/Vista/Windows 7/Windows 8/8.1/Windows 10) and it can perform smart, full, differential,
incremental and mirror backups. When defining a backup you can also set file filters and schedule the
backup for automatic execution. Once a backup is performed, in Explore View (F2) you can see what
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files  have  been  changed since  the  last  backup  or  in  Statistics  View  (F3)  you  can  read  the  statistics
about the next backup execution. In Explore View, when you right click a file, you can use the context
menu to run standard actions associated with the file type.

In  Backup4all  you  can  manually  select  which  files  and  folders  to  be  backed  up.  There  is  also  the
option to use backup plugins which will automatically pick the necesarily files for backup. There are
some  predefined  plugins  available  in  application:  My  Documents,  My  Pictures,  Google  Chome,
Internet  Explorer  Favorites,  Mozilla  FireFox  Profiles,  Mozilla  Thunderbird,  Windows  Live  Mail  or
Outlook emails and settings. Users can create their own plugins using the Plugin Creator application.

Backup4all has ZIP64 support (can create backups over 2 GB) and creates standard zip files, meaning
that  you  can  access  it  with  any  zip  compatible  utility.  Backup4all  also  allows  you  to  encrypt  your
backup using AES encryption (128/192/256-bit).

Backup4all keeps track of file versions. You can easily restore any version of files or a whole folder.
You can also filter the files to be restored by different criteria such as: type of the file,  date, size or
attributes.

Backup4all tests  the backup files automatically  to ensure the backup is  safe and correctly  executed
(uses CRC32).  You  can  also  enable  email  notifications  to  receive an  email  in  case  of  success/error/
warning.

Backup4all  works with  any  drive  letter,  including  mapped  network  drives  and  UNC  paths.  It  comes
with its own built-in CD/DVD/Blu-ray burning support.

 Backup4all runs on Windows Server 2019/Server 2016/10/Server 2012/8.1/8/Server 2008/7/Server
2003/XP and offers multi language support.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

1.2 System Requirements

To  install  Backup4all  you  need  Windows  Server  2019/Server  2016/10/Server  2012/8.1/8/Server
2008/7/Server  2003/XP  and  at  least  200  MB  of  free  disk  space.  Because  the  application  uses  zip
compression, additional disk space is needed for the temporary directory. The amount of free space
depends on the size of files to backup.
 
Note:  Backup4all  can  backup  open  files  only  if  installed  on  Windows  Server  2016/10/Server
2012/8.1/8/Server 2008/7/Server 2003/XP and if the files are stored on NTFS partitions.

1.3 Installation

Install
 
To install Backup4all on a computer you need to have administrative rights. The installation process
does  not  take  much time.  All  you need  to  do is  to  follow  the  instructions  of  the  Backup4all  Setup
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Wizard.  A reboot will be required after installing of SPTD driver.

If you have already installed an older version of Backup4all, you can install the new version on top of
the older one, no need to uninstall it (the installer will recognize if the program is running and will ask
if you wish to close it in order to continue). You might need to close Backup4all manually if it is in a
middle of an operation.
Note: If you have version 8.x (or previous) installed, you can install  version 9.x without uninstalling
the  other  one.  Backup4all  9  will  be  installed  and  run  separately,  and  will  give  you  the  option  to
import your backup jobs and settings from the previous versions.
 

When you start the installation process you can select another language for the setup wizard and the
location  where  the  application  will  be  installed.  Click  on  the  Install  Now  button  to  start  the
installation process. On the bottom you can also read the License Agreement.

 
Uninstall
 
To uninstall Backup4all, first you need to close the application. Then go to Start->Settings->Control
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Panel and select Uninstall a Program option.

 
Deactivate licenses - When uninstalling Backup4all you can deactivate it from that computer. That is
useful if you plan to move it on another computer.
Delete configurations - A second option allows you to also delete the application configurations on
uninstall.

1.3.1 Command Line Parameters

Installing Backup4all with command line parameters

The parameters for .msi installer
Backup4all  can  be  installed  with  various  command  line  parameters  that  are  useful  when  an
unattended installation is needed.

Syntax
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msiexec /i  b4asetup.msi [switches]
 
Switches can be any combination of the following parameters:

/INSTALL_FOLDER  -  Overrides  the  default  directory  name  displayed  on  the  Select  Destination
Location wizard page. A fully qualified pathname must be specified.

/INSTALL_LANGUAGE - Overrides the default installation language.

The parameters for .exe installer

/SILENT, /VERYSILENT -  Instructs  Setup to  be  silent  or  very  silent.  When  Setup is  silent  the  wizard
and the background window are not displayed but the installation progress window is. When a setup
is  very  silent  this  installation  progress  window  is  not  displayed.  Everything  else  is  normal,  so  for
example error messages during installation are displayed.
If a restart is necessary and the /NORESTART command isn't used (see below) and Setup is silent, it
will display a Reboot now? message box. If it's very silent it will reboot without asking.

/SUPPRESSMSGBOXES  -  Instructs  Setup  to  suppress  message  boxes.  Only  has  an  effect  when
combined with /SILENT and /VERYSILENT.

/NOCANCEL  -  Prevents  the  user  from  canceling  during  the  installation  process,  by  disabling  the
Cancel button and ignoring clicks on the Close button. Useful along with /SILENT or /VERYSILENT.

/NORESTART - Instructs Setup not to reboot even if it's necessary.

/RESTARTEXITCODE=exit code - Specifies the custom exit code that Setup is to return when a restart
is needed. Useful along with /NORESTART.

/DIR="x:\dirname"  -  Overrides  the  default  directory  name  displayed  on  the  Select  Destination
Location wizard page. A fully qualified pathname must be specified.

/GROUP="folder  name"  -  Overrides  the  default  folder  name  displayed  on  the  Select  Start  Menu
Folder wizard page.

/NOICONS - Instructs Setup to initially check the Don't create a Start Menu folder check box on the
Select Start Menu Folder wizard page.

/LANG="language"  -  Specifies  the  language  to  use  for  the  installation.  When  a  valid  /LANG
parameter is used, the Select Language dialog will be suppressed.

/Default - Instructs Setup to set the printer as default printer.

/NoInstallIfExists -  Instructs  setup to check if  the same edition of Backup4all  is  already installed.  If
found it does not start the installation.
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/NoInstallIfVersion="major version.minor version.build no"

Instructs setup to check if Backup4all is already installed. If found it checks what version is installed.
If the version installed is older then the given parameter, it proceeds with installation. If the installed
version is the same or newer then the given parameter, it does not start the installation.

The parameters for uninstall Backup4all

The uninstaller has also some parameters for silent uninstall (they have the same meaning as for the
installer, see above for details):

/SILENT

/VERYSILENT

/SUPPRESSMSGBOXES

/NORESTART

1.4 Features Summary

Intuitive interface
The Getting Started window allows you to easily define/run backup jobs or restore backed up data.
By switching to the Explore View, you can see all the files/folders that are in the backup job and the
new files that  will  be  stored  at  the  next  backup  execution.  You  can  sort  and  search  the  file  tree  in
Explore view. You can start this backup application at windows startup or minimize it to the system
tray. 
 
Backup  locked  or  open  files  (XP/2003/Vista/Windows  7/Windows  2008/Windows  8/Windows
8.1/Windows 10)
Backup4all  uses the Volume Shadow Copy  service  that  allows  you to  back  up  local  open  files  from
NTFS partitions in Windows XP/2003/Vista/2008 Server/Windows 8/8.1/Windows 10.  Now you can
backup your emails and settings without closing Microsoft Outlook,  Outlook Express  or  other email
clients.
 
File and Folder Filters
Powerful file and folder filtering engine with lots of options to filter by attribute, size, date, name and
type). You can create filters using a combination of restrictions and you can define separate filters for
inclusion and exclusion. 
 
Manage multiple backup jobs
This  backup  software allows  defining  multiple  backup  jobs  and  saving  them for  future  use.  On  the
main application view, you have an overview of all defined backup jobs.
   
Email notifications
You can configure Backup4all to send custom emails after a backup finished, with success, error and
warning  notifications.  Environmental  variables  can  be  used  in  the  email  title  and  body.  Additional
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options allow you to attach the backup log file and send the email to several addresses.
 
Pause/Resume or Stop operation
The backup operation supports  pausing and  resuming,  so  running  a  backup  job can  be  interrupted
and continued at a later time. There is also a Stop operation now, that when pressed will not Cancel
the backup, but instead will save everything until that point when it was pressed.

Automatic updates
Backup4all  can  now  check  for  updates  either  manually  or  automatically  at  a  scheduled  date.  This
allows you to better stay in touch with the latest development of Backup4all.

Backup catalog file
Backup4all stores a summary snapshot of the file and folder information into a backup catalog file (" .
bkc ") each time a backup is executed. This catalog is stored in a different file than the backup itself
and  it  allows  Backup4all  to  keep  track  of  the  backed  up  files.  The  advantage  of  using  a  catalog  is
faster  backup  execution.  Another  advantage  is  that  you  can  run  Backup4all  together  with  other
backup applications because they will not interfere with each other.
 
Backup directly to CD/DVD/Blu-ray
This  backup  software  comes  with  its  own  built-in  CD/DVD/Blu-ray  burning  support.  Just  set  the
destination on CD/DVD/Blu-ray disc and execute the backup job. However, you can use UDF format
(using SPTD driver installed with Backup4all, or other products such as DirectCD or InCD) or the Joliet
format. Backup4all also has the possibility to erase CD-RW/DVD-RW/Blu-ray media.
 
FTP Backup
You can backup your files to remote locations using the FTP service (with SSL support, active/passive
transfer  modes,  firewall  support,  XCRC tests).  You  just  have  to  select  FTP  as  destination,  enter  the
connection details and you are ready to backup to FTP.

SFTP Backup
You  can  backup  your  files  to  remote  locations  using  the  SFTP  service.  Select  SFTP  as  destination,
enter the configurations and you are ready to backup to SFTP.
 
Azure Backup
You  can  backup  your  files  to  Azure  destination.  Select  Azure  as  backup  destination  and  type  the
Account name, the Key and the Container to configure the Azure destination.

Amazon S3 Backup
You can also use Amazon as backup destination. Select  Amazon S3  as  backup  destination and  type
the  Access  key  ID,  the  Secret  Access  Key  and  the  Bucket  in  order  to  configure  the  Amazon  S3
destination.

Google Cloud Storage Backup
You  can  backup  your  files  to  Google  Cloud  Storage  destination.  Select  Google  Cloud  Storage  as
backup destination, choose the account and destination folder.

Google Drive Backup
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You  can  backup  your  files  to  Google  Drive  destination.  Select  Google  Drive  as  backup  destination,
choose the account and destination folder.

OneDrive Backup
You can backup your files to OneDrive destination. Select OneDrive as backup destination, choose the
account and destination folder.

Box Backup
You can backup your files to Box destination. Select Box as backup destination,  choose the account
and destination folder.

Dropbox Backup
You can backup your files to Dropbox destination. Select Dropbox as backup destination, choose the
account and destination folder.

HiDrive Backup
You  can  backup  your  files  to  HiDrive  destination.  Select  HiDrive  as  backup  destination,  choose  the
account and destination folder.

Hubic Backup
You  can  backup  your  files  to  Hubic  destination.  Select  Hubic  as  backup  destination,  choose  the
account and destination folder.

S3 Compatible Backup
You can backup your files to S3 Compatible destination. Select S3 Compatible as backup destination,
choose the S3 server, enter the credentials, bucket and destination folder.

Backup Destination
You can store the backup in a local folder, on another computer in the same LAN, on media such as:
CD-R,  CD-RW,  DVD+R,  DVD-R,  DVD+RW,  DVD-RW,  Blu-ray,  Blu-ray  RW,  on  USB  drives  or  other
removable media, on FTP, SFTP, Amazon, Azure, Google Cloud Storage, Google Drive, OneDrive, Box,
Dropbox, HiDrive, Hubic or S3 Compatible.

Extra Actions
Perform extra actions before and/or after backup execution.
 
Create shortcut for backup job/tag
You can create a "shortcut" of a backup job or backup tag to a  desired location. Whenever you will
double-click  that  shortcut,  the  backup  job  defined  will  start  running.  You  can  make  it  a  "one  click
backup" if you place that shortcut in the Quick Launch menu.
 
Statistics
You can actually see the number of files that will be processed at next backup (very useful when you
have a large number of files). Other information refers to the size and date of the executed backups
and the available free space on storage destination.
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Play custom sounds
Backup4all can play custom success/warning/error sounds at the end of the backup.
 
File warnings
File  warnings  are  displayed  to  the  user  during  backup  execution  if  the  user  chooses  so.  These
warnings are also written to the log file. Scheduled backups do not show these warnings even when
this option is set.

New Backup Wizard
This  backup  software  provides  step-by-step  instructions  to  create  a  new  backup  job  by  selecting
Where, What, How and When to backup.

Easy File and Folder Selection
You can browse a folder tree to select  several  files and folders  as source of  the  backup  or  you can
include or  exclude  them individually.  Multiple  files/folders  can  be  added  as  Sources  at  once  (drag-
and-drop supported).
 
Backup Types
Different backup types to choose from: smart  backup, full  backup,  differential  backup,  incremental
backup and mirror backup.
   
Smart backup
This  backup type was designed  to  automatically  decide  the  backup  type  to  use  and  the  number  of
versions to store, giving a backup destination, without asking you every time what to do.

Block backup
This option is useful when you have large files changed frequently (as .PST or databases).  Using the
block backup option, allows you to back up only the changes inside the file, not the whole large file.

Standard Zip Compression and zip64 support
If the zip file size is less than 2 Gbytes, Backup4all creates standard zip files. This format is compatible
with any zip utility available on the market. Unlike other backup softwares, for zip files greater than 2
Gbytes, Backup4all uses zip64 technology (which allows unlimited zip file size).

Backup Plugins
In  Backup4all  you can  load plugins  to  backup/restore  the  settings  of  specific  programs.  A  plugin  is
actually  an  XML  file  that  once  imported  in  Backup4all  adds  a  predefined  backup.  For  instance,  a
backup plugin for Mozilla FireFox, when loaded, will automatically add in the Predefined Backup list
an entry for Firefox, so when defining a new backup job if that’s selected, the FireFox profiles will be
added as source for the new backup.

Customized Zip Names
You can customize name prefixes for the zip archives, which store your backup versions. Backup4all
also supports file/folder paths longer than 260 characters (turn off file parsing).

Password Protection
You can protect your ZIP files by setting a  password for each backup job. Besides  normal password
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protection,  Backup4all  also  supports  128-bit,  192-bit  and  256-bit  AES  encryption.  These  numbers
reflect  the  encryption  key  size  used  to  encrypt  the  data  -  a  higher  key  strenght  provides  stronger
encryption.

Snapshots
Mirror backup type makes an exact copy of selected files and folders (copying NTFS permissions and
alternate  streams),  including  empty  folders  too  (for  an  exact  copy  of  the  source).  Optionally,  for
mirror backups you can choose to zip the backed up files individually.

Disk Spanning
Automated support for splitting  your  backup  between many  removable  disks  or  even  on the  same
media. You can specify the maximum size of the zip archives. When performing a mirror backup and
using  disk  spanning  you can  choose not  to  split  the  files.  This  is  an  useful  option  because  you can
copy your music/movies to CD, DVD or Blu-ray disc and not have them split up when the CD, DVD or
Blu-ray disc is full.

Logs
The operations performed by Backup4all are logged. This allows you to see the status of performed
operations (backup/test/cleanup/restore). A backup job/tag History view is available too (which also
lets you export the information as .csv). 
 
Command Line
A  command  line  version  of  this  backup  application  is  available  too  (that  lets  you  run  different
operations using parameters).
 
Restore Wizard
Restore backed up data step-by-step. Allows you to choose the version of files which will be restored
and filter  them to  restore only  the  needed  versions  (file  versioning  applies  to  full,  differential  and
incremental  backups  only).  You  can  quickly  restore  the  latest  version  of  a  file/folder  as  well  as
restoring versions of files backed up at a specific date.
 
Compatibility
You can restore data using any standard zip software. Backup4all gives you this way more flexibility if
you  need  to  restore  data  on  a  different  computer  (if  the  backup  was  created  using  independent
splits, see this section on how to restore correctly using 3rd party zip software).
 
One touch backup
Some USB enclosures have a button to start the execution of an associated program. If you have such
a device, you can configure Backup4all to execute a backup job or a backup tag when this button is
pressed (works only with certain USB enclosures).
 
Summary
Text description of the full setup for each backup job that allows you to easily review the information
regarding the backup.
 
Program security
Backup4all  offers  an  option  to  lock  its  interface  so  that  when  it  starts  you  will  need  to  provide  a
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password in order to unlock it and be able to make changes to its settings.
 
Test backup
The  application  tests  the  backups  (using  CRC32).  This  ensures  that  the  files  have  been  backed  up
properly  and  the  backup  is  safe.  You  can  also  test  the  backup  integrity  at  a  later  time  from
Backup4all's  main menu. When backing up to removable media,  after  each media  item written  the
backup test is performed (for spanned backups). When backing up to FTP, the XCRC command can be
used (if  supported by server). This speeds up the testing as Backup4all will  verify the backup based
on the CRC information received from server. If a cloud destination is used as the backup destination,
the test will  be made based on the CRC information and the files won't  be downloaded again  after
backup.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

1.5 Feature Matrix

Backup4all comes in three* editions: Lite, Standard and Professional.

Professional  is  the  full  edition  with  all  features  enabled,  while  Standard  and  Lite  are  the  limited-
functionality editions.
Below you can find a comparison of the features available in each edition.
*Backup4all Portable Edition is a custom version of Backup4all that works only on portable devices.

Backup Destinations    

 Lite Standard Professional Portable
Edition

UPDATED: Cloud backups to Google Drive

UPDATED: Cloud backups to Microsoft OneDrive

UPDATED: Cloud backups to Box Cloud

UPDATED: Cloud backups to Dropbox

UPDATED: Cloud backups to Amazon S3

UPDATED: Cloud backups to Azure

UPDATED: Cloud backups to Hidrive

UPDATED: Cloud backups to Hubic

UPDATED:  37+  Amazon  S3  Compatible  cloud
destinations

Backup to FTP (active/passive transfer modes)

Backup to FTPS (FTPES, FTP-SSL or FTP Secure)
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Backup to SFTP (SSH File Transfer Protocol)

Backup to CD/DVD (single/dual layer)

Backup to Blu-ray/HD-DVD

Backup to external hdd (USB/Firewire)

UPDATED: Backup to network drives

Backup  to  removable  media  (USB  flash  drive,
floppy)

Backup to local hard drives

Backup to ZIP drives

Can be installed only on portable USB flash drives

NEW: Backup to Google Cloud Storage

Interface

 Lite Standard Professional Portable
Edition

Customizable ribbon interface

UPDATED: Show job details in card/list mode

Navigation pane

Notification messages

Windows Explorer contextual right-click menu

Explore View

Backup View

Progress View

View backup statistics

Group backup configurations using tags

Access application according to system privileges

Lock program interface with a password

Show "Getting Started" window

Show versions in Explore View 

Start application at Windows startup

Minimize application to system tray

Add sources with drag-drop
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Search as-you-type for backup jobs/tags in backup
list 

History window with backup, restore, test, cleanup
logs

Show  available  space  in  destination  on  Statistics
View

Create  desktop  shortcuts  to  backup  jobs  and
backup tags

Default predefined backups

Microsoft Outlook backup plugin

Quick access toolbar

Advanced backup properties configurations

Customizable backup options

Visualization modes for application startup

Automatic updates

Multi-language support

MSI setup for automatic deployment 

Backup Sources

Lite Standard Professional
Portable
Edition

Backup from local hard drives

Backup from CD/DVD/Blu-ray

Backup from external hdd drives

Backup from removable media

Backup from network drives

Backup from ZIP drives

Backup    

 Lite Standard Professional Portable
Edition

Block-backup

Scheduled Suspend

Backup open files

UPDATED: New Backup Wizard

Stop/cancel all backup jobs
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Password store management

Select individual files and folders to be backed up

UPDATED:  Inclusion  and  exclusion  filters  for  files
and folders

UPDATED:  Create  and  use  general  predefined
filters

Possibility to pause, resume or stop the backup

Override filters

Suspend application

Run missed schedules

AES encryption (128-bit, 192-bit and 256-bit)

Email notifications on success, errors, warnings

Run program/action before and/or after backup

Run program/action only once

Run backup at system shutdown

"Clean backup" action with parameters

Clear backup before executing a scheduled job

Erase disc before backup

Use local catalogs

Play sound on success, warning, error

Assign volume labels for removable media

Assign label for each backup version

Set backup thread priority

One Touch Backup

Independent spanned backups

Back up empty folders

Delete Sources after successful backup

Create backup log

Create backup catalog file

Run backup at log-on or log-off

Free Backup Plugins
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Plugin creator to generate your own plugins

Possibility to set memory usage for backing up

Browsable file and folder selection

Assign volume labels for removable media

Assign label for each backup version

Search file/folder in Backup view

Backup types    

 Lite Standard Professional Portable
Edition

Smart backup

Mirror backup - without compression

Mirror  backup  with  individual  file  compression
(zip)

Full backup

Store multiple versions for full backup type

Differential backup

Store multiple versions for differential backup type

True incremental backup

Store  multiple  versions  for  incremental  backup
type

Limit number of backup versions

Backup format    

 Lite Standard Professional Portable
Edition

Compress backup files (zip format)

Obfuscate file/folder name in zip archive

Support for zip64 technology

Choose zip compression level

Password protected zip files

Customize zip name prefix

Split zip files

One-to-one copy

Copy  files  with  NTFS  security  permissions  and
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alternate streams

Use NTFS change journal

Custom application data file locations

Backup execution    

 Lite Standard Professional Portable
Edition

Show backup progress

Compress catalog on destination

Smart file scanning mode

Execute all backup configurations in a tag

Perform  unattended  backups  using  Windows
scheduler

Command line

Verify backup integrity before execution

NEW: Keep multiple catalog versions in destination

Test    

 Lite Standard Professional Portable
Edition

Test backups

Test backup tags

Test & repair backups

Test FTP/FTPS/SFTP backups

Test after backup option

Set test thread priority

Backup test performed after writing each disc

Create test log

Restore    

 Lite Standard Professional Portable
Edition

Restore wizard

Schedule a restore operation

Restore using command line

Restore specific backup increments
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Filter files to restore

Restore all files as of specific date

Restore to different folder

Restore selected file

Restore selected version of a file
 

Restore selected folder

Restore preview

Set restore thread priority

Create restore log

NEW:  Restore  only  specific  files  from  cloud
backups

Legend    

"New" means the feature is new and is available only from Backup4all 9.
"Updated" means the feature was improved in Backup4all 9.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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2 Getting Started

2.1 How to Configure a New Backup

To create a new backup job, click on the New Backup Wizard toolbar button ( ). For each backup
job you must specify at least its name, a valid storage destination and the source files (first two steps
of this wizard), the rest of the options not being mandatory. In New Backup Wizard, you can switch
anytime to Advanced mode for more configuration options.
 
These are the steps you must perform in the New Backup Wizard:

1) Select a location where you want to save the backup. You can choose as destination:

· your local hard drive

· an external hard drive

· a CD, DVD or Blu-ray drive

· a removable drive

· a network drive

· a network location

· an FTP location (Online->FTP) 

· an SFTP location (Online->SFTP)

· an Azure account (Online->Azure)

· an Amazon account (Online->Amazon S3)

· a Google Cloud Storage account (Online->Google Cloud Storage)

· a Google Drive account (Online->Google Drive)

· an OneDrive account (Online->OneDrive)

· a Box account (Online->Box)

· a Dropbox account (Online->DropBox)

· a HiDrive account (Online->HiDrive)

· a Hubic account (Online->Hubic)

· an S3 compatible account (Online->S3 compatible)
 

Click Next to go to the following step.
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2) Select the files and folders you want to backup (sources of the backup) from the local drives or
choose a backup plugin or an online location then click Next.

You can combine sources from local drives with backup plugins and with online sources.
Online connections available are: LAN, Google Drive, Dropbox, FTP, SFTP, Azure, Amazon S3, Google
Cloud Storage, OneDrive, Box, HiDrive, Hubic and S3 Compatible.

Press Define new button to add a new online connection which you can use as backup source.
All  online  connections  added  in  File->Options->Online  connections,  will  also  be  available  in  New
Backup Wizard, on Sources page.



Backup4all 930

Backup4all 9 User Manual Copyright © 2021 Softland

3) Filter your sources
By default, only system and temporary files are excluded from the backup sources (as Automatic
filters).  If  you want  to  include  only  Documents,  Images,  Music  files  or  Video  files,  you need  to
enable  those  predefined  filters  (as  User  defined  filters).  Please  note  this  way  only  the  files
matching the filters will be included in backup.
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4) Select how do you want to backup. By default, the Smart type is selected. 
By default, Smart type is using 80% of the destination space. If you want to use the entire destination
space only for that backup job, you can select the "Use the entire available destination space" option.
If you back up large files, you might want to enable the "Use block backup" option, to back up only
the modified parts of each file.
You can also use encryption for the backup types that creates zip files. 
 



Backup4all 932

Backup4all 9 User Manual Copyright © 2021 Softland

5)  Choose  when  do  you  want  to  backup:  how  often,  what  day  and  what  hour.  Schedule  the
backup job for unattended backup executions.

If you want to receive email notifications, you can configure the SMTP server and then set the email
address where to receive the notifications. The log file can also be attached to email  in  the original
format or compressed.
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6) Enter the name of the backup in the Backup name field, then press Next
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7) To finish the job and run the backup, press Save->Save and run.
 

Backup4all  provides  extended  information  about  the  backup,  which  can  be  consulted  before  the
backup execution. You can switch between views by selecting one of the available views from the Job
view menu:

· Explore - shows the source files and folders for the backup job

· Backup - shows the list of backup executions with their sources statuses before each execution

· Statistics - shows statistics about the latest backup and the next backup job
  
The  wizard  creates  an  ".ini"  file  in  the  IniFiles  folder  (usually  in  C:
\<user>\AppData\Roaming\Softland\Backup4all  9\)  with  the  same  name  as  the  backup  job's  ID.  In
addition, a backup catalog file (".bkc") is  created both in the destination and locally  in the Catalogs
folder (the same directory as where the IniFiles folder is created).
 
Manually modifying ".bkc" or ".ini" files may result in corrupted backup jobs and the impossibility of
restoring the data you backed up. A backup job is automatically created when double clicking on a ".
bkc" file. You can also recreate the backup job by opening a ".bkc" or ".ini" file from the File->Open
menu.
 
Once the backup job is  created,  it  will  be displayed on the center column of the application's  main
window. On the right, you will see the content of the backup job (files and folders), depending on the
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chosen view (explore, backup or statistics) and on the left side you will see the tags list.

 
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.2 How to Run a Backup Job

To start a backup click the Backup button ( ) from the application's toolbar or press F6.
You can also right click the backup job and select the Backup action to start. 

If an error occurred during backup and the backup was aborted, the Error icon appears in front of the
backup job. Read the log files (from Jobs tab, History section, View log) for details about the errors.
The icon will disappear when the backup is executed again and the execution is successful.

If  one  or  more  files  could  not  be  backed  up  (not  enough  user  rights  etc.),  then  the  Warning  icon
appears  in front  of  the  default  backup  job icon,  after  the  backup  finished.  Read  the  log  files  (from
Jobs tab, Tools section, View Log) for details about the files that were not backed up. The Warning
icon will disappear when the backup is executed again and all files were backed up.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.3 How to Manage Backup Jobs

Copy an Existing Backup Configuration

You  can  use  the  Duplicate  (Ctrl+L)  option  from  the  Jobs  tab  to  create  a  duplicate  of  the  selected
backup job, then you can easily  modify  its  configuration.  This option can also be selected from the
right-click menu of the backup job.
 
 
Modify a Backup Job Configuration

First you must select  the backup job you want to modify.  Then press the Properties  button ( )
from the application's toolbar. This will open the Backup Properties window. You can also change its
configuration  by  choosing  Properties  from  the  right-click  menu  of  the  backup  job.  After  the
Properties window is opened, select the page with the settings you want to modify.
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Delete a Backup Job

Select  the  backup  job  you  want  to  delete  and  select  Delete  option  from  the  Jobs  tab.  Another
possibility  is  to  choose Delete  (CTRL+Del)  from the  right-click  menu  of  the  backup  job.  In  order  to
prevent mistakes, a confirmation window will appear when you select this option.
Files and folders from the source and destination will not be deleted, by any of these operations.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.4 How to Restore from a Backup

With Backup4all you can do the following restore operations:

· restore the latest version of all files

· restore all files as they were on a specified date

· filtered restore

· restore all files from a folder

· restore the latest version of a particular file

· restore the latest version of multiple selected files

· restore any version of a particular file

To make a full or a filtered restore start the Restore Wizard by pressing the Restore button (
)  from  the  application's  toolbar.  You  can  restore  the  files  in  the  original  location  or  in  a  different
location your choose.
 
Alternatively, you can restore the latest version of a file, several selected files or all files from a folder
by selecting the files or  folder in the Explore View,  right-click and select  Restore Latest  Version  or
Restore Latest Version To...
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If you want to restore a particular file version, switch to the Explore View, select the targeted file in
the tree, right-click on a file version from the bottom list and choose Restore or Restore to...

Beside files, folder information is also added to backup, so a restore process can recreate the original
folder structure.
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Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.5 How to Test a Backup

With Backup4all you can:

· test one or more versions of a backup (you can select any version for testing)

· automatically test latest version of a backup at each backup job execution

To test a selection or all the versions for the selected backup job, open the Test Backup  window by

pressing the Test button ( ) from the application's toolbar (or using the keyboard shortcut F9). 

In the Test Backup window, select the backup version you want to test, then press the Test  button.
You can also  select multiple versions to be tested and you can modify the priority of the test process
by moving the slider to a lower or higher priority (default is Normal). A High priority process finishes
faster but consumes more resources than a Normal priority process.
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You can also test a backup execution if you switch to Backup View, right-click on a version and select
Test.
There is a Quick Test option which will perform a faster test, which means only the existence of the
files in destination will be tested.
Backup4all  runs  tests  after  every  backup  execution  by  default.  To  disable  automatic  testing  of  a

backup, open the Backup Properties window by pressing the Properties button ( ) from the main
toolbar, select the Advanced page, then un-check Test after backup option.
When an automatic backup test has failed, an Error icon will appear in front of the backup job icon.
You can find the error details in the log file (Jobs ribbon tab ->  Tools group ->  View Log).  The Error
icon will disappear the next time the backup job completes successfully.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

2.6 How to Repair a Backup

With Backup4all you can:

· repair the backup 

· repair only the catalog 

Repair the backup
Running a repair action will  first  test all  versions of the selected backup job. The missing files from
destination will be deleted from the backup catalog and they will be backed up again. 

Repair only the catalog
If you choose to repair only the catalog, the backup will be tested against the destination files and the
missing files will  have their  versions deleted from the backup catalog,  without running the backup.
Those files will be included in the next backup, if they are still in backup sources.

Quick repair and Quick repair catalog only options will perform a quick test instead of a normal one.
That means the application will only test if the files in destination exists or not.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

2.7 How to Password Protect a Backup

Passwords are used to protect your backup files from unauthorized access.
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Setting the Password
 
You  can  enable  backup  encryption  for  a  job  from  that  job's  Properties  menu  (Jobs  ribbon  ->
Properties button -> Compression page). Encryption can also be set up when creating a new backup
job with the New Backup Wizard. Note that the encryption option is not available for Mirror type jobs
without zip archiving.
 
By default the No encryption option is selected.
If you want to protect your backup, you can choose an encryption method (AES or Zip2).
The Zip2 compatible encryption  offers moderate security  but  is  compatible  with  all  third  party  zip
applications.
 
The best choice is the AES encryption which is  the new standard in ZIP protection. However AES is
only  recognized  by  the  latest  versions  of  third  party  zip  applications  (like  Winzip  or  PKWare).
Backup4all  supports  AES  encryption  with  3  different  key  strengths:  128-bit,  192-bit  and  256-bit.
These  numbers  reflect  the  size  of  the  encryption  keys  used  to  protect  the  data  -  the  higher  the
number  the  stronger  the  encryption.  All  three  types  provide  higher  security  than  the  password
protection method.
A  strong  password  should  be  at  least  8  characters  long  and  contain  a  combination  of  letters,
numbers, and symbols.
 
You should manually  enter  the password in the New password  field  and re-enter it  in  the Confirm
new password field to avoid typing errors.
The Old password field is enabled only when the backup job already has a password. You can change
the password only if you enter the old one in this field.
In this way only the owner of the backup is allowed to change the password.

A  newly  created  password  will  only  affect  subsequently  created  zip  files.  Hence  different  backup
versions of the same job may be encrypted using different passwords. Make sure that you remember
all  past  passwords  that  have  been  used  for  a  backup  job,  or  you  will  not  be  able  to  restore  older
versions.

By default, Backup4all stores the passwords on the local Windows account. In this way you will  not
be asked to enter the password every time you want to run or test a backup from the local computer.
You can also protect the stored passwords using a master password or you can chose not to store any
passwords. To change these settings go to File->Options->Passwords.

The zip files encrypted with a password will protect the file content, but the files/folders names in zip
are still visible. If you need to also protect the files/folders names, you must use the "Obfuscate file
names in zip" option from Backup Properties->Compression page.  In this  case,  you need to restore
the backup using Backup4all in order to get the original filenames back.

Changing or removing a password
 
To  change  a  password  go  to  Backup  Properties->Compression  then  click  on  Set  Password  in  the
Encrypt the zip files section. To set a new password you must enter the current password in the Old
Password field. To remove a password, simply select No Encryption. You will still need to provide the
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old password in order to make this change.
If you have the Zip2 compatible encryption or AES encryption option selected, you can also remove
the  password  by  entering  the  Old  password  and  leave  the  New  password  and  Confirm  new
password fields empty.
  
 
Using Passwords when Restoring
 
During the restore process of backups with password protection, if you do not use the option to store
the  passwords  in  the  local  Windows  account,  the  Enter  Password  dialog  will  appear.  Enter  the
password and press OK. If you do not know the password for this backup number you can:

· press Skip backup to go to the next archive - the restore may be incomplete in this case.

· press Stop restore to stop the whole process - the restore will  be incomplete, because only a
part of the files were restored.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.8 How to Schedule a Backup

You can schedule a backup either from the Backup Properties window or from the Scheduler view.

Open the Backup Properties window by pressing the Properties button ( ) from the Jobs ribbon
tab  then  selecting  the  Scheduler  page.  Alternatively  you  can  open  the  Scheduler  view  window  by
pressing the Scheduler (F11) button located at the bottom of the application interface.
 
The difference between the two methods is  that  the Scheduler view displays  all  existing  scheduled
tasks whereas the Properties window only focuses on the job that is currently selected.
  
Backup4all uses the Windows Task Scheduler in order to run the scheduled backups. By default, the
option to Run only if the user is logged on is selected. If you want the task to run when the user is
logged off, you need to select the Run whether the user is logged on or not option. You can use the
Windows  Help  in  order  to  find  out  more  information  about  scheduling  a  task  using  the  Task
Scheduler.
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In order to add a new scheduled backup from the Scheduler view, press the Add button that's found
on the Scheduler ribbon tab.
In  the  Scheduler  Properties  window,  on  General  page  you  can  set  whether  the  main  application
interface is brought up during a running scheduled backup.
After defining the scheduled backup, you must establish a timetable. In the When tab you can specify
multiple conditions  for executing a backup.  If  you skip  this  step  the  default  Windows  value  will  be
used (current time). Use the Windows Help in order to find out more information about scheduling a
task using the Task Scheduler.

The last step is to select the action to be executed. By default the backup action is selected, but you
can also schedule a test, repair, cleanup or restore action.

 
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.9 How to Backup to FTP

Backup4all  supports  backing  up  to  a  remote  computer  or  device  using  FTP  (File  Transfer  Protocol)
connection. This is a practical backup destination because the backed up data can be easily accessed
from any other computer with an Internet connection.

Defining FTP configuration
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Before using FTP as a destination for backing up, you should define a new FTP configuration using the
 File->Options->Online connections->FTP  window. Once defined,  you will  be able  to  apply  this  FTP
configuration to individual backup jobs.
Press the Add button once in File->Options->Online connections->FTP to add a new FTP connection.
The name New FTP configuration  will appear in the list. You can enter the following settings for the
connection:

· Configuration name - Enter here an arbitrary name for the connection.

· Server name or IP - Here you must enter the FTP server name or its IP address

· Transfer mode - Here you can chose between: Binary, ASCII and Auto

· Port - Here you can change the port number, in case it is different than the default value (21).

· Destination folder - Here you can enter the destination path if different than root.

· User name - If this is a private FTP server (no anonymous access allowed) enter the user name
for your account.

· Password - In this field enter the password for the FTP server.

Some FTP servers allow anonymous access (public FTP servers). Usually, you connect to this type of
servers  using  "Anonymous"  as  your  username,  and  your  email  address  as  your  password.  It  is  not
recommended to backup important files to public FTP servers.
Also  in  the  Online  connections  page  you can  set  the  number  of  retry  attempts  and  interval  length
(wait) for connecting to FTP a server. This is a global setting for all FTP connections. By default,  if  a
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FTP  server  cannot  be  reached  the  first  time,  Backup4all  will  attempt  to  connect  5  more  times  at
intervals of 60 seconds. If all attempts fail, then the backup is aborted.
Additional settings like bandwidth, SSL connection and firewall can also be configured from this page.
 
Once you have finished defining the connection, press the Test button to check if the FTP details you
have  entered  are  correct.  If  the  test  was  successful,  The  FTP  connection  was  tested  successfully
message will be displayed.
 
 
Setting the destination to FTP
 
When  defining  a  new  backup  job  using  the  New  Backup  Wizard,  select  the  FTP  option  in  the
Destination section (1st  page of the wizard).  If  you already have a defined backup  job and  want  to
change the destination to FTP, select that backup job, open the Properties window (Ctrl+P), go to the
Destination  page and select  FTP.  There you can chose from existing  FTP  configurations  or  create  a
new connection.
 
If you have any defined FTP configuration, you will be able select it from the drop down list (to define
a  configuration  go  to  File->Options->Online  connections->FTP).   Alternatively,  you  may  define  a
custom configuration during the same step of the Backup Wizard.
You can change the defined settings by selecting the Custom configuration option and pressing the
Edit  configuration button.  Here  you can  modify  the  data  in  the  fields  and  press  OK  to  save.  Once
you've entered the FTP connection details,  it  is  recommended to run a connection test by  pressing
the Test button.

In case of a connection error, Backup4all will  notify you with a message in the pop-up Notifications
window. To change the number of connection retries and retry intervals go to File->Options->Online
connections  and select  FTP.  There  you can  edit  the  Retry  and  Wait  parameters  to  be  used  for  FTP
connections.

As  a  requirement,  the  FTP  transfer  mode  used  for  most  backup  types  is  Binary.  However,  for  the
Mirror type you may choose between Binary, ASCII, and Auto modes. The list of ASCII file types can
be found in File->Options->Online connections->FTP.

Recommendations for backing up to FTP

1) After each change to the FTP configuration be sure to use the Test function.
2)  Most  FTP  sites  have  policies  against  hammering  (repeatedly  attempting  to  connect  to  an
unavailable  FTP  server  with  little  or  no  time  between  connection  attempts).  Thus  they  require
FTP clients to set retry times at specific intervals, commonly at least 120 seconds between each
connection  attempt.  Most  FTP  sites  can  also  monitor  for  devices  that  hammer,  and  once
detected  the  server  will  ban  access  to  the  offending  IP  address,  either  permanently  or  for  a
limited  amount  of  time.  Therefore,  when  you  set  the  retry  time  intervals  in  File->Options-
>Online connections->FTP, you should use 60 seconds or more.
3) If you backup important data to a remote location using FTP, encrypt the zip files for increased
security.  In  this  case,  even  if  another  person manages  to  gain  unauthorized  access  to  the  FTP,
your files will still be protected.
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4) 4) It is faster to use XCRC when testing FTP backups (on by default).

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

2.9.1 Passive and Active modes

Some  FTP  servers  require  the  connection  to  be  established  in  a  passive  mode  (i.e.  your  computer
establishes the connection so the flow of data is set up and initiated by you).
Most server companies have started using Passive FTP mode for  the  ir  clients'  convenience.  Unlike
Active  FTP,  Passive  FTP  mode  provides  does  not  interfere  with  the  client's  firewall,  as  it  does  not
involve  the  server  accessing  random  ports  on  the  client  side  which  is  generally  interpreted  as  an
attack.  Backup4all is also using Passive FTP by default.

To check the connection type which is currently in use, open the FTP Configuration window, either by
accessing  File->Options->Online  connections->FTP,  selecting  a  predefined  connection  and  clicking
on  Edit,  or  from  Properties->Destination->Edit  configuration,  for  Jobs  that  use  a  custom  FTP
configuration.
 
If  the  Use  passive  mode  for  transfers  checkbox  is  not  checked,  then  the  connection  is  in  Active
mode. You should always test the connection after making a configuration change.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

2.9.2 Connecting Through Proxy

If  you are connecting to the Internet through a proxy server,  you will  have to enter  the connection
details in the FTP Configuration window in order to be able to backup to FTP.
 
Setting Backup4all to backup to FTP using proxy

1)  Go  to  Backup  Properties->Destination->FTP->Edit  configuration  (or  File->Options->Online
connections->FTP->Edit)
2) Select a Proxy Type from the available options:

· None - Sends the User name and optional Password for the FTP server as entered in the
FTP window

· Send command USER - Sends the User name and optional Password defined in the proxy
settings,  followed  immediately  by  the  User  name  and  optional  Password  for  the  FTP
server.

· Send command SITE - Sends the User name and optional Password defined in the proxy
settings,  the  SITE  command  with  the  Host  value,  and  the  User  name  and  optional
Password for the FTP site.

· Send  command  OPEN  -   Sends  the  User  name  and  optional  Password  defined  in  the
proxy settings,  sends the  OPEN  command  with  the  Host  value,  and  the  User  name  and
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optional Password for the FTP site.

· USER  user@firewalluser@hostname  /  PASS  pass@firewallpass  -  Sends  the  command
USER  user@proxyuser@host,  then  the  command  PASS  pwd@proxypwd,  or  optionally
PASS pwd.

· Transparent  -   Sends  the  User  name  and  optional  Password  defined  in  the   proxy
settings, followed immediately by the FTP server User name and optional Password.

3) Enter the name or IP address for the proxy server (firewall) in the Host name or IP field. 
4) Enter the port number in the Host Port field. 
5)  Enter the user  name and  password  needed for  this  proxy  connection  in  the  User  name  and
Password fields. 
6) Press OK and then test the connection.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

2.9.3 Using SSL Encryption

When you connect through FTP to a remote computer you send the username and password in clear,
unencrypted  text.  Also,  when  you  backup  your  files  to  a  remote  computer,  the  information  is  not
sent  directly  to  that  computer.  Instead  it  is  routed  through  several  other  computers  to  get  there.
Anyone along the route can access what you are sending, including your username and password, if
the data is  not  encrypted. If  an unauthorized  person has  access  to  this  data,  your  account  and  the
remote system you have access to, may no longer be secure. Backup4all solves this by allowing SSL
encryption support when using FTP (and also AES encryption for the backed up zip files).
 
SSL (Secure Sockets Layer) is a protocol used for transmitting private documents via the Internet. The
SSL  cryptographic  system  uses  two  keys  to  encrypt  data  -  a  public  key  known  to  everyone  and  a
private or secret key known only to the recipient of the message.
 
 
Backing up to FTP using SSL encryption

1)  Go  to  Properties->Destination->FTP->Edit  configuration  (for  a  selected  job)  or  in  File-
>Options->Online connections->FTP window (for predefined connections).
2) From the FTPS (SSL encryption) list select an option that applies to your situation:

· No SSL - the server does not require Secure Socket Layer transport

· Implicit SSL - implies that Secure Socket Layer is in use

· Only explicit SSL - allows the connection to the FTP server only if SSL is available.

· Explicit  SSL,  if  available  -  When  SSL  is  available,  uses  explicit  security  by  default.  The
server allows regular  FTP sessions without encryption as  well  as  encrypted  FTP  sessions
using SSL.

3) Press OK and test your connection

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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2.10 How to Backup to SFTP

Backup4all  supports  backing  up  to  a  remote  computer  or  device  using  the  SFTP  (SSH  File  Transfer
Protocol) connection. This is also a practical backup destination because the backed up data can be
easily accessed by any other computer with an Internet connection.

Defining SFTP configuration
 

Before using SFTP as a destination for backing up, you should define a new SFTP configuration using
the File->Options->Online connections->SFTP window. Once defined,  you will  be able  to apply this
SFTP configuration to individual backup jobs.

Press  the  Add  button  once  in  File->Options->Online  connections->SFTP  to  add  a  new  SFTP
connection .  The New SFTP configuration  name will  appear in the list  and you can enter  the  other
settings for this connection:

· Configuration name - Set a name of your choice for the connection.

· Server name or IP - In this field you have to enter the name or IP address for the SFTP server

· Port - In this field you have to enter  the port  number if  different  than the default  SFTP ports
(22).
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· Destination folder - Here you can enter the destination path if different than root.

· User name - If this is a private SFTP server (no anonymous access allowed) enter the user name
for your account.

· Password - In this field enter the password for the SFTP server.

Additional  settings  like  private  key,  bandwidth  limitation,  authentications,  encryption  and
compression can also be configured from this page.  
In the Online connections page you can set the number of retry attempts and interval length (wait)
for connecting to a SFTP server. This is a global setting for all SFTP connections. By default, if a SFTP
server cannot be reached the first time, Backup4all will attempt to connect 5 more times at intervals
of 60 seconds. If all attempts fail, then the backup is aborted.
 
Once you have  finished  defining  the  connection,  press  the  Test  button  to  check  if  the  SFTP details
you  have  entered  are  correct.  If  the  test  was  successful,  The  SFTP  connection  was  tested
successfully message will be displayed.

 
Setting the destination to SFTP
 
When  defining  a  new  backup  job  using  the  New  Backup  Wizard,  select  the  SFTP  option  in  the
Destination section (1st page of the wizard).  If  you already have a defined backup job and want to
change the destination to SFTP,  select  that  backup job, open the Properties  window (Ctrl+P),  go to
the  Destination  page  and  select  SFTP.  There  you  can  choose  from  existing  SFTP  configurations  or
create a new connection.

If you have any defined SFTP  configurations, you will  be able select one from the dropdown list  (to
define  a  configuration  go  to  File->Options->Online  connections->SFTP).  Alternatively,  you  may
define a custom configuration during the same step of the Backup Wizard. 

Once  you've  entered  the  SFTP  connection  details,  it  is  recommended  to  run  a  connection  test  by
pressing the Test button.

In case of a connection error,  Backup4all will notify you with a message in the pop-up Notifications
window. To change the number of connection retries and retry intervals go to File->Options->Online
connections->Backup and select SFTP. There you can edit the Retry and Wait parameters to be used
for SFTP connections.
 
Recommendations for backing up to SFTP 

1) After each change to the SFTP configuration be sure to use the Test function.
2)  Most  SFTP  sites  have  policies  against  hammering  (repeatedly  attempting  to  connect  to  an
unavailable SFTP server with little or  no time between connection attempts).  Thus  they require
SFTP clients to set retry times at specific intervals, commonly at least 120 seconds between each
connection  attempt.  Most  SFTP  sites  can  also  monitor  for  devices  that  hammer,  and  once
detected  the  server  will  ban  access  to  the  offending  IP  address,  either  permanently  or  for  a
limited  amount  of  time.  Therefore,  when  you  set  the  retry  time  intervals  in  File->Options-
>Online connections->SFTP, you should use 60 seconds or more.
3)  If  you  backup  important  data  to  a  remote  location  using  SFTP,  encrypt  the  zip  files  for
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increased security. In this case, even if another person manages to gain unauthorized access  to
the SFTP, your files will still be protected.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.11 How to Backup to Azure

Backup4all  supports  backing  up  to  Microsoft's  Azure  cloud  service.  This  is  a  practical  backup
destination  because  the  backed  up  data  can  be  easily  accessed  from  any  other  computer  with  an
Internet connection.

Defining an Azure configuration

 

Before  using  Azure  as  a  destination  for  backing  up,  you  should  define  a  new  Azure  configuration
using  the  File->Options->Online  connections->Azure  window.  Once  defined,  you  will  be  able  to
apply this Azure configuration to individual backup jobs.

Press  the  Add  button  once  in  File->Options->Online  connections->Azure  to  add  a  new  Azure
configuration. The New Azure configuration name will appear in the list and you can enter the other
settings for this connection:

· Configuration name - Set the name of your choice for the connection.

· Account name - In this field you have to enter the name of the Azure account.
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· Key - In this field you have to enter the key for your Azure account. If the key is a Shared Access
Signature (SAS), you must select the "Key is Shared Access Signature" option. A shared access
signature provides delegated access to resources in your storage account. This means that you
can grant a client limited permissions to your blobs, queues, or tables for a specified period of
time and with a specified set of permissions, without having to share your account access keys.

· Container - Here you have to enter the container's name.

· Folder - If you want to use a specific folder, enter its name here.

In the Online connections page you can set the number of retry attempts and interval length (wait)
for connecting to the Azure  server. This is a global setting for all Azure connections. By default, if  a
server cannot be reached the first time, Backup4all will attempt to connect 5 more times at intervals
of 60 seconds. If all attempts fail, then the backup is aborted. 

Once you have finished defining the connection, press the Test  button to check if  the Azure details
you  have  entered  are  correct.  If  the  test  was  successful,  The  Azure  connection  was  tested
successfully message will be displayed.

 
Setting the destination to Azure
 
When  defining  a  new  backup  job  using  the  New  Backup  Wizard,  select  the  Azure  option  in  the
Destination section (1st page of the wizard).  If  you already have a defined backup job and want to
change the destination to Azure, select that backup job, open the Properties window (Ctrl+P), go to
the Destination page and select Azure.  There you can choose from existing Azure configurations or
create a new connection.

If you have any defined Azure configurations, you will  be able to select one from the dropdown list
(to define a configuration go to File->Options->Online connections->Azure).  Alternatively, you may
define a custom configuration during the same step of the Backup Wizard.

Once  you've  entered  the  Azure connection  details,  it  is  recommended  to  run  a  connection  test  by
pressing the Test button.

 
Recommendations for backing up to Azure 

1) After each change to the Azure configuration be sure to use the Test function.
2)  If  you  backup  important  data  to  a  remote  location  using  Azure,  encrypt  the  zip  files  for
increased security. In this case, even if another person manages to gain unauthorized access  to
your Azure account, your files will still be protected.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.12 How to Backup to Amazon S3

Backup4all supports backing up to the Amazon S3 cloud service. This is a practical backup destination
because  the  backed  up  data  can  be  easily  accessed  from  any  other  computer  with  an  Internet
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connection.

Defining an Amazon S3 configuration
 

Before using Amazon as a destination for backing up, you should define a new Amazon configuration
using the File->Options->Online connections->Amazon S3 window. Once defined, you will be able to
apply this Amazon S3 configuration to individual backup jobs.

Press the Add button once in File->Options->Online connections->Amazon S3 to add a new Amazon
connection . The New Amazon S3 configuration name will  appear in the list  and you can enter  the
other settings for this connection:

· Configuration name - Set the name of your choice for the connection.

· Access Key ID - In this field you have to enter the key for your Amazon account.

· Secret Access Key - In this field you have to enter the secret key for your account.

· Region - From the drop down list, select the region where your account is located.

· Bucket- Here you have to enter the name of the bucket, or you can create a new bucket.

· Folder - If you want to use a specific folder, enter its name here.

· Storage  class  -  Select  the  storage  class  you  want  to  use.  You  can  choose  between:  Default,
Standard,  Standard -  Infrequent Access Storage,  One Zone -  Infrequent Access Storage  and
Reduced Redundancy Storage.

Transfer acceleration 
Selecting this option will accelerate data transfer to/from Amazon S3 with 50% - 500% by making use
of AWS network and infrastructure. It could also generates additional fees from Amazon S3.
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In the Online connections page you can set the number of retry attempts and interval length (wait)
for  connecting to the  Amazon S3  server.  This  is  a  global  setting  for  all  Amazon S3  connections.  By
default, if a server cannot be reached the first time, Backup4all will attempt to connect 5 more times
at intervals of 60 seconds. If all attempts fail, then the backup is aborted. 

Once  you  have  finished  defining  the  connection,  press  the  Test  button  to  check  if  the  Amazon  S3
details  you  have  entered  are  correct.  If  the  test  was  successful,  The  Amazon  S3  connection  was
tested successfully message will be displayed.

 
Setting the destination to Amazon S3
 
When defining a new backup job using the New Backup Wizard, select the Amazon S3 option in the
Destination section (1st page of the wizard).  If  you already have a defined backup job and want to
change the destination to Amazon S3, select that backup job, open the Properties window (Ctrl+P),
go to the Destination  page and select  Amazon S3.  There you can choose from existing Amazon S3
configurations or create a new connection.

If you have any defined Amazon S3 configurations, you will  be able select one from the drop down
list (to define a configuration go to  File->Options->Online connections->Amazon S3). Alternatively,
you may define a custom configuration during the same step of the Backup Wizard.

Once you've entered the connection details, it is recommended to run a connection test by pressing
the Test button.
 

Recommendations for backing up to Amazon S3 
1) After each change to the Amazon S3 configuration be sure to use the Test function.
2) If you backup important data to a remote location using Amazon S3,  encrypt the zip  files for
increased security. In this case, even if another person manages to gain unauthorized access  to
your Amazon S3 account, your files will still be protected.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.13 How to Backup to Google Cloud Storage

Backup4all supports backing up to Google Cloud Storage. This is a paid cloud storage location.

Defining a Google Cloud Storage configuration
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Before using Google Cloud Storage as a destination for backing up, you should define a new Google
Cloud  Storage  configuration  in  File->Options->Online  connections->Google  Cloud  Storage  page.
Once defined, you will be able to apply this Google Cloud Storage configuration to individual backup
jobs.

Press  the  Add  button  once  in  File->Options->Online  connections->Google  Cloud  Storage  to  add  a
new Google Cloud Storage connection . After you press Add button, the New Google Cloud Storage
configuration name will appear in the list and you can enter the other settings for this connection:

· Configuration name - Set the name of your choice for the connection.

· Access Key ID - In this field you have to enter the key for your Google Cloud Storage account.

· Secret Access Key - In this field you have to enter the secret key for your account.

· Region - From the drop down list, select the region where your account is located.

· Bucket- Here you have to enter the name of the bucket, or you can create a new bucket.

· Folder - If you want to use a specific folder, enter its name here.

· Storage  class  -  Select  the  storage  class  you  want  to  use.  You  can  choose  between:  Default,
Regional Storage, Multi-Regional Storage, Nearline Storage, Coldline Storage.

In the Online connections page you can set the number of retry attempts and interval length (wait)
for  connecting  to  the  Google  Cloud  Storage  server.  This  is  a  global  setting  for  all  Google  Cloud
Storage  connections.  By  default,  if  the  server  cannot  be  reached  the  first  time,  Backup4all  will
attempt to connect  5 more times at intervals of 60 seconds.  If  all  attempts  fail,  then  the  backup  is
aborted. 
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Once you have finished defining the connection, press the Test  button to check if the Google Cloud
Storage details  you have entered are correct.  If  the test was successful,  The Google  Cloud  Storage
connection was tested successfully message will be displayed.

 
Setting the destination to Google Cloud Storage
 
When defining  a  new backup  job using  the  New Backup Wizard,  select  the  Google  Cloud  Storage
option in the Destination section (1st page of the wizard). If you already have a defined backup job
and  want  to  change  the  destination  to  Google  Cloud  Storage,  select  that  backup  job,  open  the
Properties window (Ctrl+P), go to the Destination page and select Google Cloud Storage. There you
can choose from existing Google Cloud Storage configurations or create a new connection.

If  you have any defined Google Cloud Storage  configurations, you will  be able  select  one from the
dropdown  list  (to  define  a  configuration  go  to  File->Options->Online  connections->Google  Cloud
Storage).  Alternatively, you may define a custom configuration during the same step of the Backup
Wizard.

Once you've entered the connection details, it is recommended to run a connection test by pressing
the Test button.

 
Recommendations for backing up to Google Cloud Storage

1) After each change to the Google Cloud Storage configuration be sure to use the Test function.
2) If you backup important data to a remote location using Google Cloud Storage, encrypt the zip
files  for  increased  security.  In  this  case,  even  if  another  person  manages  to  gain  unauthorized
access to your Google Cloud Storage account, your files will still be protected.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.14 How to Backup to Google Drive

Backup4all supports backing up to Google Drive. This is a very used cloud storage location as it offers
a lot of disk space for free.

Defining a Google Drive configuration
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Before  using  Google  Drive  as  a  destination  for  backing  up,  you  should  define  a  new  Google  Drive
configuration in File->Options->Online connections->Google Drive page. Once defined,  you will  be
able to apply this Google Drive configuration to individual backup jobs.

Press  the  Add  button  once  in  File->Options->Online  connections->Google  Drive  to  add  a  new
Google Drive connection .  After you press  Add button,  the  New Google  Drive  configuration  name
will appear in the list and you can enter the other settings for this connection:

· Configuration name - Set the name of your choice for the connection.

· Drive  type  -  here you can choose "Personal"  or  "Team",  depending  on the  account  type  you
have.

· Authentication  -  pressing  the  "Choose  account"  button  will  open  an  authentication  page  in
your default Browser application. You will need to be logged in into your Google account, then
allow Backup4all access to Google Drive.

· Folder - If you want to use a specific folder, press the Browse button to select the folder or to
create a new one.

In the Online connections page you can set the number of retry attempts and interval length (wait)
for connecting to the Google Drive server. This is a global setting for all Google Drive connections. By
default,  if  the  server  cannot  be  reached  the  first  time,  Backup4all  will  attempt  to  connect  5  more
times at intervals of 60 seconds. If all attempts fail, then the backup is aborted. 

Once you have finished defining the connection, press the Test  button to check if  the Google  Drive
details  you have  entered  are  correct.  If  the  test  was  successful,  The Google  Drive  connection was
tested successfully message will be displayed.
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Setting the destination to Google Drive
 
When defining a new backup job using the New Backup Wizard,  select  the Google Drive  option in
the Destination section (1st page of the wizard). If you already have a defined backup job and want
to  change  the  destination  to  Google  Drive,  select  that  backup  job,  open  the  Properties  window
(Ctrl+P),  go  to  the  Destination  page  and  select  Google  Drive.  There  you  can  choose  from  existing
Google Drive configurations or create a new connection.

If you have any defined Google Drive configurations, you will be able select one from the dropdown
list  (to  define  a  configuration  go  to  File->Options->Online  connections->Google  Drive).
Alternatively, you may define a custom configuration during the same step of the Backup Wizard.

Once you've entered the connection details, it is recommended to run a connection test by pressing
the Test button.

 
Recommendations for backing up to Google Drive

1) After each change to the Google Drive configuration be sure to use the Test function.
2) If you backup important data to a remote location using Google Drive, encrypt the zip files for
increased security. In this case, even if another person manages to gain unauthorized access  to
your Google Drive account, your files will still be protected.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.15 How to Backup to OneDrive

Backup4all  supports  backing up to Microsoft's  OneDrive cloud service. OneDrive  is  a  popular  cloud
storage service for both personal and business use.

Defining a OneDrive configuration
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Before  using  OneDrive  as  a  destination  for  backing  up,  you  should  define  a  new  OneDrive
configuration in File->Options->Online connections->OneDrive page. Once defined, you will be able
to apply this OneDrive configuration to individual backup jobs.

Press the Add button once in File->Options->Online connections->OneDrive to add a new OneDrive
connection . After you press Add button, the New OneDrive configuration name will  appear in the
list and you can enter the other settings for this connection:

· Configuration name - Set the name of your choice for the connection.

· Account type - here you can choose "Personal" or "Business", depending on the account type
you have.

· Authentication  -  pressing  the  "Choose  account"  button  will  open  an  authentication  page  in
your default Browser application. Log into OneDrive to allow Backup4all access to the account.

· Folder - If you want to use a specific folder, press the Browse button to select the folder or to
create a new one.

· Custom max file size - this option allows you to set a custom file size (by default is 15 GB). It is
useful if you don't want large files to be split on upload.

In the Online connections page you can set the number of retry attempts and interval length (wait)
for  connecting  to  OneDrive.  This  is  a  global  setting  for  all  OneDrive  connections.  By  default,  if  the
server cannot be reached the first time, Backup4all will attempt to connect 5 more times at intervals
of 60 seconds. If all attempts fail, then the backup is aborted. 

Once  you  have  finished  defining  the  connection,  press  the  Test  button  to  check  if  the  OneDrive
details you have entered are correct. If the test was successful, The OneDrive connection was tested
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successfully message will be displayed.

 
Setting the destination to OneDrive
 
When defining a new backup job using the New Backup Wizard,  select  the OneDrive  option in the
Destination section (1st page of the wizard).  If  you already have a defined backup job and want to
change the destination to OneDrive, select that backup job, open the Properties window (Ctrl+P), go
to  the  Destination  page  and  select  OneDrive.  There  you  can  choose  from  existing  OneDrive
configurations or create a new connection.

If you have any defined OneDrive configurations, you will be able select one from the dropdown list
(to define a configuration go to File->Options->Online connections->OneDrive).   Alternatively,  you
may define a custom configuration during the same step of the Backup Wizard.

Once you've entered the connection details, it is recommended to run a connection test by pressing
the Test button.

 
Recommendations for backing up to OneDrive

1) After each change to the OneDrive configuration be sure to use the Test function.
2)  If  you  backup  important  data  to  a  remote  location  using  OneDrive,  encrypt  the  zip  files  for
increased security. In this case, even if another person manages to gain unauthorized access  to
your OneDrive account, your files will still be protected.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.16 How to Backup to Box

Backup4all supports backing up to Box. This is a cloud storage location and it offers enough free disk
space for normal use.

Defining a Box configuration
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Before using Box as a destination for backing up, you should define a new Box configuration in File-
>Options->Online  connections->Box  page.  Once  defined,  you  will  be  able  to  apply  this  Box
configuration to individual backup jobs.

Press the Add button once in File->Options->Online connections->Box to add a new Box connection
.  After you press Add button, the New Box configuration  name will  appear  in  the  list  and  you can
enter the other settings for this connection:

· Configuration name - Set the name of your choice for the connection.

· Authentication  -  pressing  the  "Choose  account"  button  will  open  an  authentication  page  in
your default Browser application. Log into Box to allow Backup4all access to the account.

· Folder - If you want to use a specific folder, press the Browse button to select the folder or to
create a new one.

In the Online connections page you can set the number of retry attempts and interval length (wait)
for connecting to Box. This is a global setting for all Box connections. By default, if the server cannot
be reached the first time, Backup4all will attempt to connect 5 more times at intervals of 60 seconds.
If all attempts fail, then the backup is aborted.

Once you have finished defining the connection, press the Test button to check if the Box details you
have  entered  are  correct.  If  the  test  was  successful,  The  Box  connection  was  tested  successfully
message will be displayed.

 
Setting the destination to Box
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When  defining  a  new  backup  job  using  the  New  Backup  Wizard,  select  Box  in  the  Destination
section (1st  page of the wizard).  If  you already  have  a  defined backup  job and  want  to  change  the
destination  to  Box,  select  that  backup  job,  open  the  Properties  window  (Ctrl+P),  go  to  the
Destination page and select Box. There you can choose from existing Box configurations or create a
new connection.

If  you have any defined Box  configurations, you will  be able  select  one  from the  dropdown  list  (to
define  a  configuration  go  to  File->Options->Online  connections->Box).   Alternatively,  you  may
define a custom configuration during the same step of the Backup Wizard.

Once you've entered the connection details, it is recommended to run a connection test by pressing
the Test button.

 
Recommendations for backing up to Box

1) After each change to the Box configuration be sure to use the Test function.
2) If you backup important data to a remote location using Box, encrypt the zip files for increased
security.  In this  case,  even if  another  person manages to gain  unauthorized  access  to  your  Box
account, your files will still be protected.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.17 How to Backup to Dropbox

Backup4all supports backing up to Dropbox. This cloud storage location is known to offer  adequate
storage space for regular use.

Defining a Dropbox configuration
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Before  using  Dropbox  as  a  destination  for  backing  up,  you  should  define  a  new  Dropbox
configuration in File->Options->Online connections->Dropbox page. Once defined, you will  be able
to apply this Dropbox configuration to individual backup jobs.

Press the Add button once in File->Options->Online connections->Dropbox to add a new Dropbox
connection . After you press Add button, the New Dropbox configuration name will appear in the list
and you can enter the other settings for this connection:

· Configuration name - Set the name of your choice for the connection.

· Account type - here you can choose "Personal" or "Business", depending on the account type you
have.

· Authentication  -  pressing  the  "Choose  account"  button  will  open  an  authentication  page  in
your default Browser application. Log into Dropbox to allow Backup4all access to the account.

· Folder - If you want to use a specific folder, press the Browse button to select the folder or to
create a new one.

· Custom max file size - this option allows you to set a custom file size (by default is 5 GB). It is
useful if you don't want large files to be split on upload.

In the Online connections page you can set the number of retry attempts and interval length (wait)
for  connecting  to  Dropbox.  This  is  a  global  setting  for  all  Dropbox  connections.  By  default,  if  the
server cannot be reached the first time, Backup4all will attempt to connect 5 more times at intervals
of 60 seconds. If all attempts fail, then the backup is aborted.
 
Once you have finished defining the connection, press the Test button to check if the Dropbox details
you  have  entered  are  correct.  If  the  test  was  successful,  The  Dropbox  connection  was  tested
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successfully message will be displayed.

 
Setting the destination to Dropbox
 
When defining a new backup job using the New Backup Wizard,  select Dropbox  in the Destination
section (1st  page of the wizard).  If  you already  have  a  defined backup  job and  want  to  change  the
destination  to  Dropbox,  select  that  backup  job,  open  the  Properties  window  (Ctrl+P),  go  to  the
Destination page and select Dropbox. There you can choose from existing Dropbox configurations or
create a new connection.

If you have any defined Dropbox configurations, you will be able select one from the dropdown list
(to  define  a  configuration  go  to  File->Options->Online  connections->Dropbox).   Alternatively,  you
may define a custom configuration during the same step of the Backup Wizard.

Once you've entered the connection details, it is recommended to run a connection test by pressing
the Test button.

 
Recommendations for backing up to Dropbox

1) After each change to the Dropbox configuration be sure to use the Test function.
2)  If  you  backup  important  data  to  a  remote  location  using  Dropbox,  encrypt  the  zip  files  for
increased security. In this case, even if another person manages to gain unauthorized access  to
your Dropbox account, your files will still be protected.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.18 How to Backup to HiDrive

Backup4all  supports  backing  up  to  HiDrive.  This  cloud  storage  location  is  known  to  offer  adequate
storage space for regular use.

Defining a HiDrive configuration
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Before using HiDrive as a destination for backing up, you should define a new HiDrive configuration
in  File->Options->Online  connections->HiDrive  page.  Once  defined,  you  will  be  able  to  apply  this
HiDrive configuration to individual backup jobs.

Press  the  Add  button  once  in  File->Options->Online  connections->HiDrive  to  add  a  new  HiDrive
connection . After you press Add button, the New HiDrive configuration name will appear in the list
and you can enter the other settings for this connection:

· Configuration name - Set the name of your choice for the connection.

· Authentication  -  pressing  the  "Choose  account"  button  will  open  an  authentication  page  in
your default Browser application. Log into HiDrive to allow Backup4all access to the account.

· Folder - If you want to use a specific folder, press the Browse button to select the folder or to
create a new one.

· Custom max  file  size  -  this  option  allows  you  to  set  a  custom  file  size  (by  default  is  2  GB).  It  is
useful if you don't want large files to be split on upload.

In the Online connections page you can set the number of retry attempts and interval length (wait)
for connecting to HiDrive. This is a global setting for all HiDrive connections. By default, if the server
cannot be reached the first time, Backup4all will attempt to connect 5 more times at intervals of 60
seconds. If all attempts fail, then the backup is aborted.
 
Once you have finished defining the connection, press the Test button to check if the HiDrive details
you  have  entered  are  correct.  If  the  test  was  successful,  The  HiDrive  connection  was  tested
successfully message will be displayed.
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Setting the destination to HiDrive
 
When defining a new backup job using  the  New Backup Wizard,  select  HiDrive  in  the  Destination
section (1st  page of the wizard).  If  you already  have  a  defined backup  job and  want  to  change  the
destination  to  HiDrive,  select  that  backup  job,  open  the  Properties  window  (Ctrl+P),  go  to  the
Destination page and select HiDrive.  There you can choose from existing HiDrive  configurations or
create a new connection.

If you have any defined HiDrive configurations,  you will  be able  select  one from the dropdown list
(to  define  a  configuration  go  to  File->Options->Online  connections->HiDrive).   Alternatively,  you
may define a custom configuration during the same step of the Backup Wizard.

Once you've entered the connection details, it is recommended to run a connection test by pressing
the Test button.

 
Recommendations for backing up to HiDrive

1) After each change to the HiDrive configuration be sure to use the Test function.
2)  If  you  backup  important  data  to  a  remote  location  using  HiDrive,  encrypt  the  zip  files  for
increased security. In this case, even if another person manages to gain unauthorized access  to
your HiDrive account, your files will still be protected.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.19 How to Backup to Hubic

Backup4all  supports  backing  up  to  Hubic.  This  cloud  storage  location  is  known  to  offer  adequate
storage space for regular use.

Defining a Hubic configuration
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Before using Hubic as a destination for backing up,  you should define a new Hubic configuration in
File->Options->Online connections->Hubic page. Once defined, you will  be able to apply this Hubic
configuration to individual backup jobs.

Press  the  Add  button  once  in  File->Options->Online  connections->Hubic  to  add  a  new  Hubic
connection . After you press Add button, the New Hubic configuration  name will  appear in the list
and you can enter the other settings for this connection:

· Configuration name - Set the name of your choice for the connection.

· Authentication  -  pressing  the  "Choose  account"  button  will  open  an  authentication  page  in
your default Browser application. Log into Hubic to allow Backup4all access to the account.

· Folder - If you want to use a specific folder, press the Browse button to select the folder or to
create a new one.

· Custom max  file  size  -  this  option  allows  you  to  set  a  custom  file  size  (by  default  is  5  GB).  It  is
useful if you don't want large files to be split on upload.

In the Online connections page you can set the number of retry attempts and interval length (wait)
for  connecting  to  Hubic.  This  is  a  global  setting  for  all  Hubic  connections.  By  default,  if  the  server
cannot be reached the first time, Backup4all will attempt to connect 5 more times at intervals of 60
seconds. If all attempts fail, then the backup is aborted. 

Once you have finished defining the connection, press the Test  button to check if  the Hubic details
you  have  entered  are  correct.  If  the  test  was  successful,  The  Hubic  connection  was  tested
successfully message will be displayed.
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Setting the destination to Hubic
 
When  defining  a  new  backup  job  using  the  New  Backup  Wizard,  select  Hubic  in  the  Destination
section (1st  page of the wizard).  If  you already  have  a  defined backup  job and  want  to  change  the
destination  to  Hubic,  select  that  backup  job,  open  the  Properties  window  (Ctrl+P),  go  to  the
Destination  page  and  select  Hubic.  There  you  can  choose  from  existing  Hubic  configurations  or
create a new connection.

If you have any defined Hubic configurations, you will be able select one from the dropdown list (to
define  a  configuration  go  to  File->Options->Online  connections->Hubic).   Alternatively,  you  may
define a custom configuration during the same step of the Backup Wizard.

Once you've entered the connection details, it is recommended to run a connection test by pressing
the Test button.
In  the  File->Options->Online  connections->Backup  window you can  set  the  number  of  retries  and
the time between the retries when the Hubic server is unavailable (the When destination not ready
section).

 
Recommendations for backing up to Hubic

1) After each change to the Hubic configuration be sure to use the Test function.
2)  If  you  backup  important  data  to  a  remote  location  using  Hubic,  encrypt  the  zip  files  for
increased security. In this case, even if another person manages to gain unauthorized access  to
your Hubic account, your files will still be protected.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.20 How to Backup to S3 Compatible

Backup4all supports backing up to multiple S3 Compatible servers. These cloud backup destinations
are  hosted  by  different  companies.  The  backed  up  data  can  be  easily  accessed  from  any  other
computer with an Internet connection.
The Amazon S3 compatible clouds that can be selected as backup destinations are as follows: Akaza,
Aruba  Cloud,  Backblaze  B2,  Caringo,  CenturyLink,  Cisco,  Cloudian,  Connectria,  Constant,  DDN,
dinCloud,  DreamObjects,  Dunkel,  T  Cloud,  Exoscale,  GreenQloud,  HGST,  Hitachi,  HostEurope,  IDC
Frontier,  LeoNovus, Mandic,  Minio,  NetApp, NiftyClouds,  Numergy,  QNAP, Revera,  Scality,  Seeweb,
SwiftStack, ThinkOn, Tiscali,  vCloud Air (EMC), Verizon, Walrus, and Zettagrid. You can also connect
another compatible S3 server by manually editing the Settings.

Defining an S3 Compatible configuration
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Before using S3 Compatible as a destination for backing up, you should define a new S3 compatible
configuration using the File->Options->Online connections->S3 compatible  window. Once defined,
you will be able to apply this S3 compatible configuration to individual backup jobs.

Press the Add  button once in  File->Options->Online  connections->S3 compatible  to  add  a  new S3
compatible connection . The New S3 compatible configuration name will appear in the list and you
can enter the other settings for this connection:

· Configuration name - Set a name of your choice for the connection.

· S3 Server - Select one of the S3 Compatible servers from the dropdown list. Leave it on custom
if you are connecting to a different server. You can also edit the fields after selecting a server.

· Endpoint - Type the S3 server endpoint (address:port).

· Use SSL - Check this option if the selected S3 server uses SSL encryption.

· Access Key ID - In this field you have to enter the key for your S3 compatible account.

· Secret Access Key - In this field you'll have to enter the secret key for your account.

· Signature version - Select the signature version used by the S3 Compatible server.

· Region - From the drop down list, select the region where your account is located.

· Bucket- Here you'll have to enter the name of the bucket. You can also create a new bucket at
the selected Region.
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· Folder - If you want to use a specific folder, enter its name here.

· Storage  class  -  Select  the  storage  class  you  want  to  use.  You  can  choose  between:  Default,
Standard,  Standard -  Infrequent Access Storage,  One Zone -  Infrequent Access Storage  and
Reduced Redundancy.

In the Online connections page you can set the number of retry attempts and interval length (wait)
for  connecting  to  S3  server.  This  is  a  global  setting  for  all  S3  server  connections.  By  default,  if  the
server cannot be reached the first time, Backup4all will attempt to connect 5 more times at intervals
of 60 seconds. If all attempts fail, then the backup is aborted. 

Once  you  have  finished  defining  the  connection,  press  the  Test  button  to  check  if  the  S3  server
details you have entered are correct. If the test was successful, The S3 server connection was tested
successfully message will be displayed.

 
Setting the destination to S3 server
 
When  defining  a  new  backup  job  using  the  New  Backup  Wizard,  select  S3  Compatible  in  the
Destination section (1st page of the wizard).  If  you already have a defined backup job and want to
change  the  destination  to  S3  Compatible,  select  that  backup  job,  open  the  Properties  window
(Ctrl+P), go to the Destination page and select S3 Compatible. There you can choose from existing S3
Compatible configurations or create a new connection.

If you have any defined S3 Compatible configurations, you will be able select one from the dropdown
list  (to  define  a  configuration  go  to  File->Options->Online  connections->S3  Compatible).
 Alternatively, you may define a custom configuration during the same step of the Backup Wizard.

Once you've entered the connection details, it is recommended to run a connection test by pressing
the Test button.

Recommendations for backing up to S3 Compatible 
1) After each change to the S3 Compatible configuration be sure to use the Test function.
2) If you backup important data to a  remote location using S3 Compatible,  encrypt the zip  files
for increased security. In this case, even if another person manages to gain unauthorized access
to your S3 Compatible, your files will still be protected.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

2.21 How to Backup to USB or Firewire drives

You can backup your data to a USB or Firewire drive. These are practical backup destinations as they
allow you to store important files to external devices, increasing portability. It can be considered as
an additional protection from of hardware failures and other natural disasters.

There are external USB hard drives with performance comparable to conventional hard drives. These
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portable drives (called enclosures)  are composed of devices that  connect  through  USB  on one  side
and to  conventional  hard  drives  on the  other  side.  A  hard  drive  is  installed  into  the  enclosure  and
then the enclosure is  plugged into the computer,  thus creating a  normal USB backup device.  Given
the size of nowadays hard drives, this can be considered a mass storage device for backup purposes.

There are external hard drives that, besides USB technology, also use Firewire as a connection port.
Even though USB ports are ubiquitous, Firewire hard drives tend to have increased speeds.

Steps for backing up to USB drive with Backup4all:

1) Connect your USB device. In case of disk drives, before setting up the backup job, make sure
that the USB drive is  turned on and working.  Usually,  the enclosure has a  start button and LED
signal lights. A green or blue LED light is usually the indication that the device is running.
2)  Make sure your drive  is  formatted.  If  you intend  to  use  a  new/unused  external  hard  drive,
you might not be able to see it as a distinct drive in Windows Explorer after connecting it. This is
because  the  drive  has  not  yet  been  formatted  for  use.  In  Windows,  navigate  to  Computer
Management and select Disk Management. From there, you can see and format your new drive.
If however, the drive is present in Windows Explorer, formatting is not required. USB Flash drives
always come pre-formatted.

· Go  to  Start->Settings->Control  panel->System  and  Maintenance->Administrative
Tools->Computer Management

If  you are prompted for an administrator  password or  confirmation,  type the password  or
provide confirmation.

· Under Storage click Disk Management

· To format the volume with the default  settings,  in  the  Format  dialog  box,  click  OK,  and
then click OK again.

· Test  to  see  if  the  drive  is  now  recognized  by  going  to  File  Explorer  (a  new  drive  letter
should appear)

3)  Configure  Backup4all.  If  the  drive  is  recognized  by  Windows,  it  will  be  recognized  by
Backup4all too. To back up to the USB drive, you should define a backup job in  Backup4all  that
has the destination set to the USB drive. When defining a new backup job using the New Backup
Wizard, in the destination section (1st page of the wizard), select Local,  then select your device
from the Drive list. Finally, you may type in or browse for a folder destination.

 
Some USB drives have a button to start the execution of an associated program. If  you have such a
device  you  can  configure  Backup4all  to  execute  a  backup  job  or  a  backup  tag  when  the  button  is
pressed.  After  the  USB  drive  is  ready,  go  to  the  File->Options->Backup  page  of  Backup4all.  Under
Backup on demand, check Enable One Touch Backup support. Press Detect to check if the USB drive
is compatible with the One Touch Backup feature of Backup4all.
  
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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2.22 How to Send Email Notifications

Email Notifications is a very useful feature that enables Backup4all to send an email containing the
status of a backup job upon its completion.

Enabling email notifications

Open File->Options->Email, then select the Enable email notifications box.

In "What do you want to use?" section, there are two options: to configure a custom SMTP Server or
use the Gmail SMTP server which you only have to authorize using your Gmail account when sending
the notifications.

If you select SMTP server option, you need to enter the following details:

· SMTP  Server  -  specify  the  name or  IP  address  of  the  SMTP server  used  for  sending  the
mail (example: smtp.novapdf.com) in the Server name or IP field and a Port number for it
(usually is 25); you can also use Secure Socket Layer when connecting to the SMTP server.

· Email addresses - you must specify the email address used to send the email (From field)
and optionally a Reply To email address

· Authentication  -  if  the  SMTP  server  requires  authentication  check  the  Server  requires
authentication box and enter an user name and a password.

· Dial-up  connection  -  if  you  are  using  a  dial-up  connection,  select  a  method  that
Backup4all should use for sending emails:  Automatically start-up (it will  connect without
user assistance) or Manually start-up (it will require the users' assistance for enabling the
connection).

If you select Gmail option:

· Press the Choose account button 

· Login to your account Gmail account

· Allow access for Backup4all application to send emails on your behalf

When ready, click on the Send test email button from the SMTP Server section and enter the email
address  where  you  want  to  receive  the  notification.  Once  you  press  OK  you  should  receive  a  test
email. If you didn't receive it, you must revise the settings you configured.
Press OK to save your settings

Sending email notifications
 
Email notifications can be enabled individually for each backup job. To do so follow these steps:

1) Select a backup job and open the Backup Properties window (right click and select Properties
or Ctrl+P)
2) Go to the Email page and check the Send emails option.
3) Type in a valid email address to which you want to receive the notifications for this job.
4) Optionally you can edit the default emails sent and also to attach the backup log to the email.
5) Press Save.
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Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

2.23 How to Configure One Touch Backup

Some USB enclosures have a button to start the execution of an associated program. If you have such
a device, you can configure Backup4all to execute a backup job or a backup tag when this button is
pressed. If your One Touch Backup  device is not detected by Backup4all (Backup4all  is  not  natively
compatible with the device), you could use the command line parameters to create a command that
can be associated to the One Touch button of your device. 
 
See this section for details.
  
If the One Touch Backup option is enabled when the application starts and there is no backup job or
backup tag set to be executed when the One Touch button of the USB enclosure is pressed, the user
will be asked to choose one from the options displayed in the One Touch Backup dialog:

· Create a new backup job for One Touch Backup. If you select this, the New Backup Wizard will
start and you can create a new backup job to be used with the One Touch Backup feature

· Select an existing backup job or backup tag for One Touch Backup. If you select this,  the File-
>Options->Backup page will  open and you can select  the backup job or  tag you want to use.
This option is disabled if there are no backup jobs.

· Disable this feature. This will disable the One Touch Backup feature. You can activate it again
from the File->Options->Backup page.

If you press Cancel, Backup4all will open, but when you will press the One Touch button of the USB
device,  the same dialog will  be displayed. This dialog will  appear again  if  the  backup  job (executed
when the One Touch button is pressed) was deleted.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

 

2.24 How to Use One Touch Backup

You enable the One Touch Backup support from File->Options->Backup page. When running for the
first  time,  there  will  be  no  configured  backup  job  to  execute,  so  you  will  have  to  configure  it  as
explained in the previous section, How to Configure One Touch Backup.
 
Once  everything  is  configured,  you  will  just  have  to  push  the  One  Touch  button  and  the  selected
backup job or backup tag will be executed.
 
If  Backup4all  is  not  started,  it  will  start  automatically.  If  it  is  already  started,  but  minimized  it  will
show a pop-up window or  the main window while backing up (depending on the settings from the
Options window).

http://www.backup4all.com/kb/which-one-touch-backup-hdd-enclosures-is-backup4all-compatible-with-127.html
http://www.backup4all.com/kb/which-one-touch-backup-hdd-enclosures-is-backup4all-compatible-with-127.html
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When the backup finishes,  Backup4all  is  automatically  closed if  the Exit  application when finished
option  is  checked.  If  the  main  window  of  the  application  was  already  open  when  the  One  Touch
button was pressed, the Exit application when finished option will be ignored.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

 

2.25 How to Enable Detailed Logging

Backup4all allows you to log detailed information about executed operations (backup, restore or
test). This means that, besides the warnings and errors, the log file will contain detailed information
about all files handled by the backup, restore or test process.
 
To enable detailed logging:

1) Go to File menu and open the Options window
2) Switch to the Logs and history page
3) Check the Log detailed information option
4) Check the Include summary in log option (this will add all the information available from the
Summary view to the log file)
5)  Additionally,  you  can  also  limit  the  size  of  the  log  folder.  In  the  Log  folder  section,  select
Restricted to and set the maximum size that the folder is allowed to reach.
6) From the Log Viewer section, you can change the program that opens the log files. From the
drop-down list  select  either Notepad or  Wordpad. You can also browse the  computer  to  select
another text editor.
7) From the log file extension list, you can select the extension of the generated log file: .log or .
txt
8) Click OK to close the window and save the changes

 
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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3 Backup Types

3.1 Backup Types

Backup4all  implements  the  fundamental  backup  types:  Smart,  Full,  Differential,  Incremental,  and
Mirror. With the exception of the Mirror type, the first time any job is executed, it will  run as a Full
Backup, irrespective of the job's type. Below you can find an overview of all backup types.
 

Smart Backup

Smart backup is the default backup type. When executed, Backup4all will  decide which backup type
should be performed: full, differential or incremental. It will also decide whether to merge or delete
older  backup  versions,  all  in  order  to  efficiently  use  the  destination  free  space  and  accommodate
other user options. It will try to keep as many backup versions as possible in the available destination
space.

Full Backup

The Full Backup creates an archive out of all the folders and files that were selected to be backed up.
Because  the  Full  Backup  stores  all  files  and  folders,  backing  up  frequently  will  allow  faster  and
simpler restore operations. When you choose other backup types, restore jobs may take longer.

Differential Backup

A  Differential  Backup  contains  all  the  files  that  have  been  added  or  changed  since  the  last  Full
Backup. The advantage of the Differential Backup is that it has a shorter backup time. However, if you
perform the differential backup too many times, eventually the size of a backup archive might grow
to be larger than the reference Full Backup archive.
 

Incremental Backup

An  Incremental  Backup  stores  all  the  files  that  have  been  added  or  changed  since  the  last  full,
differential or incremental backup. Since this method doesn't  back up the same exact  files multiple
times, an Incremental Backup takes the least time to complete. However, during a restore operation,
each Incremental Backup must be processed, which could result in a lengthy restore job.
 

Mirror Backup

A Mirror  Backup is  identical  to a  Full  Backup,  with  the  exception  that  the  files  are  not  compressed
into a single zip file. A Mirror Backup is most frequently used to create an exact copy of the backup
data.  It  has  the  benefit  that  the  backup  files  can  be  readily  accessed  using  tools  like  File  Explorer.
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Using  the  Mirror  Backup  type,  you  can  also  choose  to  archive  each  individual  file,  preserving  the
folder structure, which also allows you to use the zip compression and encryption features.
Using the mirror backup type, you can also choose to zip each file individually, preserving the folder
structure. This allows you to use the zip compression and encryption features.
 

Block backup

You can use block backup option to copy only the modified parts of the source files. This is useful for
large  files  (such  as  .PST  or  database  files),  as  only  the  modified  part  of  the  file  will  be  backed  up
instead of the entire file. You can use an automatic block size or you can set the block size manually.
You also have a checkbox to use block backup only for files larger than a given size.
Note:  The  block  backup  option  must  be  enabled  from  the  first  backup  execution,  otherwise  you
won't be able to use it on that backup job. If  you already have a backup job and want to use block
backup, you'll have to create a new backup job.

 
Save storage space

In Backup4all you have two options for saving storage space. To reduce the overall backup size, you
can either limit the number of file versions to be stored or limit the number of backups.  When you
limit the number of backups, you can also opt to Merge backups in order to avoid exceeding the set
limit. These options can only be used for Full, Differential, and Incremental backup types.

Backup4all stores a summary snapshot of the file information into a backup catalog file (".bkc") each
time a backup  is  executed.  For  every  file  backed up,  the  snapshot  contains  the  file  name,  size  and
attributes as well as the date and time of creation, latest modification and latest access.
Legacy backup applications inspect each file's archive flag to identify which files have been changed.
 Backup4all  will  not  interfere with any other backup software,  because  it  does  not  need  to  read or
change the archive flags, instead it  uses the catalog file  to decide which files have to be backed up
and which do not.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

3.2 Smart Backup

What is the Smart Backup?

Smart Backup is a backup type that combines the full, differential and incremental backup methods
along with cleanup operations, in  order to efficiently manage the backups according  to  the  backup
settings and the available disk space.  The advantage of the Smart  Backup is  that  you don't  need to
worry about the number of backups to store, which backup version to clean,  and which backups to
merge, as Backup4all will take care of that. The Smart Backup type starts with a Full Backup.

Description of the Smart Backup Type
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It would be ideal to make full backups all the time because they are the most extensive and are self-
contained. However, the amount of time it takes to run full backups often prevents us from using this
backup  type.  Full  backups  are  often  restricted  to  a  weekly  or  monthly  schedule.  However,  the
increasing  speed  and  capacity  of  backup  media  are  making  it  more  feasible  to  perform  these  full
backups overnight.
 
Full  backups,  if  you have  the  time  to  perform them,  offer  the  best  solution  for  data  protection.  In
effect, a single backup is sufficient to completely restore all backed-up files.
 
The  algorithm  takes  in  consideration  the  destination  size  and  follows  a  specific  configuration  for
selecting the backup type to be performed. The configuration dictates the following:

· Full  backup  -  if  the  sizes  of  last  differential  and  all  incremental  backups  since  last  full/
differential exceeds 80% of the full backup size.

· Differential  backup  -  if  there  isn't  a  last  differential  and  the  size  of  all  incremental  backups
since last full exceeds 30% of the full size, a differential backup will be executed.

· Differential backup - if there is a last differential and the size of all incremental backups since
last differential exceeds 50% of the last differential size, a new differential will be executed.

The maximum allowed size of the backups can be defined as an absolute value or as a percentage of
the space available in the destination.

Advantages

· It automatically decides the best backup type to be executed

· The  free  disk  space  in  the  destination  is  properly  managed,  so  you  won't  get  any  errors  for
running out of space

Disadvantages

· You cannot select how many backup/file versions to be saved

· Backup4all may create less efficient backup versions given the available space
 

Configuring a Smart Backup
 
The  output  of  the  Smart  Backup  is  a  compressed  zip  file  container.  You  can  select  the  zip
compression ratio from the Compression page in Backup Properties. Backup4all can also encrypt the
backup  archives.  This  gives  you  the  option  to  protect  your  backed  up  data  from  being  stolen  and
used.
The following options can be used to limit the maximum space to be occupied by the backup in the
destination:

· Limit backup size to ... % of destination size (default is 80%)

· Limit backup size to ... KB/MB/GB (default is 50 GB)

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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3.3 Full Backup

What is the Full Backup?

The Full  Backup is the starting point for all backup jobs and contains all  the data in the folders  and
files that are selected to be backed up. Because the Full Backup stores all files and folders, frequent
backups will result in faster and simpler restore operations. Remember that when you choose other
backup types, restore jobs may take longer.
 

Description of the Full Backup Type
 
It would be ideal to make full backups all the time because they are the most extensive and are self-
contained. However, the amount of time it takes to run full backups often prevents us from using this
backup  type.  Full  backups  are  often  restricted  to  a  weekly  or  monthly  schedule.  However,  the
increasing  speed  and  capacity  of  backup  media  are  making  it  more  feasible  to  perform  these  full
backups overnight.
 
Full  backups,  if  you have  the  time  to  perform them,  offer  the  best  solution  for  data  protection.  In
effect, a single backup is sufficient to completely restore all backed-up files.
 
Advantages

· The fastest restore time

Disadvantages

· The slowest backup time

· The  storage  space  requirements  are  the  highest  (compared  to  incremental  or  differential
backups) 

 

The Full Backup Type in Backup4all
 
When making full backups, storage space can become an issue. In Backup4all you have two options
for saving storage space.  To reduce the overall  backup size, you can either limit  the number  of  file
versions to be stored or limit the number of backups. The output of the Full Backup is a compressed
zip  file  container.  You  can  select  the  zip  compression  ratio  from  the  Compression  page  in  Backup
Properties.  Backup4all  can  also  encrypt  the  backup  archives.  This  gives  you  the  option  to  protect
your backed up data from being stolen and used.

 
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

3.4 Differential Backup

What is the Differential Backup?
 
A  Differential  Backup  contains  all  the  files  that  have  been  added  or  changed  since  the  last  Full
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Backup. The advantage of the Differential Backup is that it has a shorter backup time. However, if you
perform the differential backup too many times, eventually the size of a backup archive might grow
to be larger than the reference Full Backup archive.
 
 
Description of the Differential Backup Type
 
There is a significant distinction between The Differential Backup and the Incremental Backup types.
Although they seem similar, their usage reveals the true difference. 
The Differential backup only uses the last Full Backup as the reference for what to backup. Hence, it
keeps accumulating the changes until another Full backup becomes the new reference. 
In contrast, the Incremental Backup leaves out all changes that have already been backed up in one
way or another. So, while the Incremental backup is more efficient in terms of space, the Differential
Backup is more reliable as a backup source. The true versatility comes in combining the two methods
to suit your needs. 

Restoring a differential backup is a faster process than restoring an incremental backup because only
two backup container files are needed: the latest full backup and the latest differential backup.
 
Backup4all uses the information it has recorded in its catalog file (".bkc") to determine whether a file
has changed since the last full backup or not.
 
Use differential backup if you have a reasonable amount of time to perform backups. The upside is
that only  two backup container files are needed to perform a complete restore.  The downside  is  if
you run multiple differential backups after your full backup, you're probably including some files in
each differential backup that were already included in earlier differential backups, but haven't been
recently modified.
 
Advantages

· Restore is faster than restoring from incremental backup

· Backing up is faster than a full backup

· It uses less storage space than full backup

Disadvantages

· Restore is slower than restoring from full backup

· Backing up is slower than incremental backup

· It uses more storage space than incremental backup

 
Differential Backup Type in Backup4all

Backup4all supports the differential backup type and offers a solution for the slow backup issue.
In time, the differential can grow to a size that is equal or larger than the full version. Therefore the
following options can be used to trigger the creation of a new full backup:

· Automatically make full backup if the differential exceeds ...% of full backup size (default is
50%)
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· Automatically make full backup if the differential exceeds ... (default is 100 MB)

The system calculates the backup size for the differential backup and if the selected condition is met
it performs a full backup.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

3.5 Incremental Backup

What is Incremental Backup?
 
An  Incremental  Backup  stores  all  the  files  that  have  been  added  or  changed  since  the  last  full,
differential or incremental backup. Since this method doesn't  back up the same exact  files multiple
times, an Incremental Backup takes the least time to complete. However, during a restore operation,
each Incremental Backup must be processed, which could result in a lengthy restore job.
 
 
Description of the Incremental Backup Type
 
Incremental  backup  provides  a  faster  method  of  backing  up  data  than  repeatedly  running  full
backups.  During  an  incremental  backup  only  the  files  that  have  changed  since  the  most  recent
backup  are  included.  That  is  where  it  gets  its  name:  each  backup  is  an  increment  since  the  most
recent backup.
 
The  time  it  takes  to  execute  the  backup  may  be  a  fraction  of  the  time  it  takes  to  perform  a  full
backup. Backup4all uses the information recorded in its catalog file (".bkc") to determine whether a
file has changed since the most recent backup.
 
The  advantage  of  reduced  backup  duration  comes  with  a  price:  increased  restore  duration.  When
restoring  from  incremental  backup,  you  need  the  most  recent  full  backup  as  well  as  every
incremental backup you've made since the last full backup.
 
For example, if you did a full backup on Friday and incremental on Monday, Tuesday and Wednesday,
and the PC crashes Thursday  morning,  you would  need  all  four  backup  container  files:  Friday's  full
backup  plus  the  incremental  backup  for  Monday,  Tuesday  and  Wednesday.  By  comparison,  if  you
had  done  differential  backup  on  Monday,  Tuesday  and  Wednesday,  then  to  restore  on  Thursday
morning you'd have needed Friday's full backup plus Wednesday's differential backup.
 
Advantages

· Backing up is the fastest

· It uses the least storage space

Disadvantages

· Restore is the slowest 
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Incremental Backup Type in Backup4all
 
Backup4all supports incremental backup type and offers a solution for the slow restore issue.
To keep the number of stored backups to a reasonable number and reduce the size of the backups,
Backup4all provides three options: Yes, limit number of file versions, Yes, limit number of backups
and  Merge  backups.  These  options  will  perform  an  internal  merge  to  keep  the  number  of  stored
backups under the selected limit.
The following options can be used to trigger the creation of a new full backup:

· Automatically make full  backup if  all  increments  exceed ...  % of full  backup  size  (default  is
50%, not checked)

· Automatically make full backup if all increments exceed ... (default is 100 MB, not checked)

The  system  calculates  the  file  sizes  for  the  incremental  and  if  the  selected  condition  is  met,  it
performs a full backup.

 
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

3.6 Mirror Backup

What is Mirror Backup?
 
A  mirror  backup  is  identical  to  a  full  backup,  with  the  exception  that  the  files  and  folders  are  not
compressed  in  zip  files  and  they  cannot  be  protected  with  a  password.  A  mirror  backup  is  most
frequently used to create an exact copy of the backup source data.  It has the benefit that the backup
files can also be readily accessed using tools like File Explorer.
 
 
Description of the Mirror Backup Type
 
A mirror backup is an exact copy of the selected folders and files at a given time. Mirror backup is the
fastest  backup  method  because  it  copies  files  and  folders  to  the  destination  without  any
compression.  However, the increased speed has its  drawbacks:  it  needs larger storage space and it
cannot be password protected.
 
While the other backup types collect all the files and folders being backed up each time into a single
compressed container file, a mirror backup keeps all the individual files separately in the destination.
That  is,  the  destination becomes  a  mirror  (exact  copy)  of  the  source.  You  can  even  directly  access
files in the destination without needing to use Backup4all's restore feature, because each file is just
an exact copy of the original.
 
One handy feature of mirror backup is Backup4all's Fast mirror option. When this option is selected,
any mirror operation after the first will only copy new and modified files, making the operation very
fast.
 
Another important feature is that users can choose to zip each file individually using the Zip the files
option. In this case, the compression and encryption options can be used.
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A  mirror  backup  cannot  keep  track  of  different  versions  of  files.  However,  Backup4all  provides  an
option to customize destination folder names using user-defined parameters, giving you the ability to
save each mirror backup in a different folder location. Restore using Backup4all is possible only from
the latest mirror backup, but all previous mirror backups remain available in the destination and can
be accessed manually.
 
Advantages

· The fastest backup type, especially in conjunction with the Fast mirror option

· It creates a snapshot of the selected files and folders in the destination which you can browse
and access later without needing to run Backup4all

· If used with Zip the files option, a selective restore is faster than in any other backup type with
zip. 

Disadvantages

· If not zipped, it needs more storage space than any other backup type

· Cannot track different versions of files
 
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

3.7 Backup Types in Backup4all

How are the Backup Types Implemented in Backup4all?
 
Backup4all creates two main types of backups:

· Backup types with zip compression (Smart, Full, Differential, Incremental)

· Backup types without zip compression (Mirror backup type)

User can change the backup type from the Type page in Backup Properties,  or from a specific  type
page, by checking the box to select that type as default backup type.

Backup Types with Zip Compression
 
Full, differential and incremental backup use zip compression to reduce the size of the stored backup
versions.  To  keep the  number  of  stored  zip  files  at  a  reasonable  number,  the  application  provides
three options in the Storage page: Yes, limit number of file versions , Yes, limit number of backups
and Merge backups . These options either delete older stored backups or perform an internal merge
to keep the number of stored backups or file versions under the selected limit.
 
The Yes, limit  number of file  versions, Yes,  limit  number  of  backups and Merge  backups options
cannot be used when the backup destination is on a removable media: floppy disk, CD, DVD, Blu-ray
disc etc.
 
Customize zip name prefix
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Typically the name of the zip file is something like: "1_C.zip", "1_D.zip" etc. (one zip for each drive).
The  names of  these  zip  files  do not  make much sense  for  the  user  but  they  can  be  customized  by
pressing the Insert tag button. Following tags are predefined:

· Backup Name (<BACKUP NAME>)

· Backup Number (<BACKUP NUMBER>)

· Backup Type (<BACKUP TYPE>)

· Backup Date (<DATE>)

· Backup Time (<TIME>)

· Backup Hour (<HOUR>)

· Backup Minute (<MINUTE>)

· Backup Second (<SECOND>)

· Backup Year (<YEAR>)

· Backup Month (<MONTH_MMM>)

· Backup Month - numeric (<MONTH_MM>)

· Backup Week (<WEEK>)

· Backup Day of Week (<DAY OF WEEK>)

· Backup Day (<DAY>)

· Backup Day of the Week (use locale) (<DAY OF WEEK LOC>)

· Backup Day of Week (name) (<DAY OF WEEK NAME>)

· Computer Name (<COMPUTER NAME>)

· User Name (<USER NAME>)

You can also add your text in the edit tag field. Use the Preview button to see how the names of the
zip files will look like.
Windows does not allow the following characters in the file name: / \ * ? : " < > |, so Backup4all will
also not allow them to be entered in the edit tag field.

Smart backup type

The  smart  backup  type  will  perform  full,  differential  or  incremental  backups,  depending  on  the
destination free disk space or the limit size you set in Backup Properties. The smart backup type will
automatically decide which is the best action to perform by combining the backup types.

 
Full Backup Type

The  full  backup  type  will  always  backup  all  the  files  defined  in  the  sources.  Incremental  and
differential backups will create a full backup first, because they will back up the new files (all files are
new if the backup was never executed).
 

Differential Backup Type

For  a  differential  backup  the  system  will  always  backup  the  differences  from  the  last  full  backup,
regardless of the intermediate versions between the latest full  and  the  current  differential  backup.
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The first execution of a differential backup is a full backup, because it backs up the new files (and all
the files are new if the backup was never executed). 

Incremental Backup Type

In  case  of  incremental  backups  only  the  new and  the  modified  files  since  last  backup  (differential,
incremental or full backup) are added to the backup. Each file can have many versions stored in the
backup files..
  
Backup4all  can  generate  custom  zip  file  names,  set  a  size  limit  for  zip  files  and  encrypt  them.  For
more details look at the Compression page from the Backup Properties window.
 
If a new backup job is created and the backup type is set to incremental or differential, then when the
backup job is first run, the application will perform a full backup. This also happens when the catalog
(".bkc")  file  is  not  found  in  the  destination folder  or  the  Clear  backup  action  was  executed  before
backup (see the Advanced page of the Backup Properties window).
 
 
Backup types without zip compression - Mirror backup type
 
The mirror backup implementation provides some useful options to improve the backup quality.
 
Since the mirror backup keeps only one version of each file,  you can use the Create subfolder(s) in
destination  with  following  name  option  to  copy  the  files  to  customized  subfolders,  therefore
keeping more versions of the files. Backup4all can only use the latest version for the Restore or Test
operations. You can restore older versions manually.
 
If  the  Copy  files  in  a  subfolder  option  is  checked,  the  files  will  be  copied  in  a  subfolder  of  the
destination folder (typically you will see a ".bkc" file and a folder with the same name). If the option
is not set, the files (and folder structure) will be copied directly into the destination folder.
 
When  the  Fast  Mirror  (copy  only  new  or  modified  files)  option  is  used,  Backup4all  uses  the
information stored in ".bkc" files to copy only new or modified files to the destination. If this option
is not set, the system will copy all files each time the backup is executed.
 
Using  the  mirror  backup  type,  you  can  also  choose  to  Zip  the  files.  This  option  will  zip  each  file
individually,  preserving  the  folder  structure.  In  this  case,  you  can   use  the  zip  compression  and
encryption.
 
When changing the backup type between Smart, Full,  Incremental  or  Differential  the older backups
are not deleted, only the type of the next backup is changed. If the Yes, limit number of file versions,
Yes,  limit  number  of  backups and Merge  backups options  are  used,  the  application  will  delete  or
merge older backups so that the number of versions is less or equal to the specified limit.  However
when changing  between Mirror  and  Smart,  Full,  Incremental  or  Differential,  the  older  versions  are
deleted.
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On the Storage page, by default the Yes, limit number of file versions and the Yes, limit number of
backups  options  are  not  enabled.  This  means  that  the  system  will  keep  all  the  stored  backup
versions.  If  you choose to enable the  Merge backups  option,  when the limit  is  reached the system
will  perform an  internal  merge between the  older  versions  keeping the  number  of  stored  backups
equal to the specified limit (the merge between zip files is necessary to keep at the latest file version
from each zip file to be merged).
However  when  changing  between  Mirror  and  Smart,  Full,  Incremental  or  Differential,  the  older
versions are deleted.

 
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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4 Backup to CD, DVD or Blu-ray

4.1 Backup to CD, DVD or Blu-ray

Backing up to CD, DVD or Blu-ray media has become increasingly common due to mature technology
and cheap CD, DVD or Blu-ray burners.
If you plan to do a backup to a CD, DVD or Blu-ray disc, please consider our recommendations:

· Do not use the same CD, DVD or Blu-ray disc to store consecutive backup versions. It's better to
use different CD, DVD or Blu-ray media for each backup version (change the CD, DVD or Blu-ray
disc at each backup run). Use a set of CD, DVD or Blu-ray media and rotate them periodically (e.
g.:  take  7  CD  media,  one  for  each week day;  start  with  the  first  CD  again  every  7  days).  The
reason for this  is  that  in case the burn process fails  or  the CD,  DVD or  Blu-ray  data  becomes
corrupted, you still have the previous backup version on a different disc.

· Rewritable  CD,  DVD  or  Blu-ray  media  can  be  burned  only  a  limited  number  of  times.  When
strange  errors  happen  you  should  consider  that  the  CD,  DVD  or  Blu-ray  disc  might  be  over-
burned (worn out).

· Always test the backed up data after burning. Backup4all has a special option to automate the
test  after  backup  and  also  in  case  you  are  spanning  multiple  CD,  DVD  or  Blu-ray  discs  ,
Backup4all test each CD, DVD or Blu-ray disc before writing the next one.

Backup4all makes the backup to CD, DVD or Blu-ray disc process to be easy to perform: just set the
backup destination to the CD, DVD or Blu-ray burner drive and run the backup. By default Backup4all
uses its own built-in burning engine to backup to CD, DVD or  Blu-ray media  (you do not  need third
party drivers or burning software to be installed).
 
If you prefer packet writing (using third party software) you can select it in the Write method section.
 
If  the backup does not  fit  onto one CD, DVD or  Blu-ray disc,  Backup4all  will  automatically  span the
backup  over  multiple  media.  Each  disc  is  assigned  a  different  label  for  future  identification.  We
recommend marking the CD, DVD or Blu-ray disc with this label.
 
A few recommendations before backing up to CD, DVD and Blu-ray discs:

· Before backup execution, be sure to insert the CD, DVD or Blu-ray disc containing the latest ".
bkc"  file  if  you  have  the  option  Use  local  catalogs  unchecked  (in  Backup  Properties-
>Advanced->Backup options section, default is checked)

· On backups to hard disk, you can limit the number of stored zip backups by using the Yes, limit
number  of  file  versions,  Yes,  limit  number  of  backups  and  Merge  backups  options.  These
options  do  not  apply  to  CD,  DVD  or  Blu-ray  media,  you  cannot  limit  the  number  of  stored
backups on removable media.

· A mirror backup copies every file matching the sources and the file filter to CD, DVD or Blu-ray
disc. On a mirror backup to hard disk, files that are deleted and excluded from sources can be
deleted from destination too if you want so. This is not possible on the CD, DVD or Blu-ray disc,
so deleted and excluded files are just left there as they were burned before, but the catalog (".
bkc") file is updated and the restore operation will not copy these files back.

· When backing up to CD, DVD or Blu-ray discs Backup4all requires additional free space on the
drive  where  the  Temporary  Folder  is  located  (at  least  700Mb  when  backing  up  to  CDs,  or
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4.7Gb when backing up to DVDs)
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

4.2 Use Built in Driver

Backup4all  does  not  need  third  party  drivers  or  other  CD,  DVD  or  Blu-ray  burning  software  to  be
installed (like ActiveX, ASPI, etc) to be able to burn a CD, DVD or Blu-ray. Backup4all has a built-in CD,
DVD or Blu-ray burner to backup to CD, DVD or Blu-ray disc directly.
 
 
Set Up Internal CD, DVD or Blu-ray Burner
 
There are three simple steps to set up the internal CD, DVD or Blu-ray burner:

1) Open the Backup Properties window and go to the Destination page.
2) Click on Optical, then select the drive letter for the CD, DVD or Blu-ray burner device you want
to use.
3) In the same page, you can:

· configure the burn speed

· set the Erase disk before writing option

· switch the write method between build-in driver and UDF file system

· use a custom prefix

You can use two burners for UDF disc format: Use SCSI Pass Through Direct  layer (SPTD) and  Use
native  Win32  interface  (SPTI).  This  format  can  be  used  to  write  on  CD-R/CD-RW/DVD-R/DVD+R/
DVD-RW/DVD+RW/DVD-DL/HD-DVD/Blue-ray/Blu-ray DL.

 
Use internal CD, DVD or Blu-ray burner
 
Typically, a backup to CD, DVD or  Blu-ray disc  performs additional  steps shown in the status  bar at
the bottom of the main window: burning, finalizing, and loading disc. During the last operation, the
CD, DVD or Blu-ray disc is ejected and reloaded. After this step the backup is tested and the CD, DVD
or Blu-ray disc ejected again (if these options are set).
Backup4all  can  also  perform  an  additional  Erase  CD/DVD/Blu-ray...  action  for  appropriate  media
(rewritable CD, DVD or Blu-ray discs)
 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

4.3 Use Packet Writing

If you do not wish to use the built-in burner or your CD, DVD or Blu-ray device is not compatible, you
can use third party packet writing software.
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Packet Writing Software
 
Packet  writing  software  can  write  only  to  CD-RW,  DVD-RW  or  DVD+RW  if  the  disks  are  formatted
using the Universal Data Format (UDF) file system.
 
The advantage of packet  writing is  that  your rewritable media  can be used like  a  floppy  or  zip  disk
(drag and drop from File Explorer  is  also possible). The disadvantage of using packet writing is that
CD,  DVD  or  Blu-ray  discs  written  with  this  method  are  recognized  on  other  computers  only  if  the
same third party packet writing software is installed there too.
 
Set Up Packet Writing
 
There are three simple steps to set up the packet writing to work with Backup4all:

1) Open New Backup Wizard or Backup Properties and go to the Destination page.
2) Click on Optical, then select the drive letter for the CD, DVD or Blu-ray burner device you want
to use.
3)  You must select Use UDF file system. Here you can also set the Erase disk before writing
option. Press the OK button.
4) If packet writing is set, you will see the following message on the Destination page: [Device
name] Writing method is UDF

 
Use Packet Writing
 
Backup4all detects if the CD-RW, DVD-RW, DVD+RW or Blu-ray RW disc is UDF formatted. If the disc
is  not  UDF  formatted  it  will  show  the  following  message:  Disk  in  drive  [drive  letter]  is  not  UDF
formatted. Please insert a UDF formatted disc.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

 

4.4 Writing to CD, DVD or Blu-ray disc

By default,  the backup catalog (.bkc)  is  stored both on the destination CD,  DVD or  Blu-ray disc  and
locally. To see if the catalog will be stored locally too, select Backup Properties for a backup job, go
to Advanced and see if the Use local catalogs (.bkc) option is checked.
If it is unchecked the backup catalog is stored only on the destination. The recommended option is to
leave it checked.
 
When the backup process starts, Backup4all searches for the ".bkc" file locally (by default, assuming
that you didn't uncheck the option Use local catalogs), then:

· If the catalog file is found, Backup4all will make a new version for the backup job. If you wish to
write  the  new  backup  version  on  a  separate  CD,  DVD  or  Blu-ray  disc  (this  is  recommended)
then you should set the Ask for a new disk before backup option.

· If the backup catalog is not found locally (was deleted by mistake) or if the Use local catalogs
option  is  unchecked,  Backup4all  will  ask  for  the  last  CD,  DVD  or  Blu-ray  disc  used  for  the
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backup. When it finds the backup catalog, Backup4all will  make a new version for the files in
the backup job.

· If  the catalog file  is  not  found on the destination either,  Backup4all  will  start  with  a  new full
backup

         
Backup4all will automatically span the backup over multiple media if the size of the backup job does
not  fit  on  a  single  CD/DVD/Blu-ray  disc.  For  each  disc  Backup4all  will  assign  a  different  label  for
future identification. We recommend marking the CD, DVD or Blu-ray disc with this label.
When  spanning  multiple  CD,  DVD  or  Blu-ray  discs,  Backup4all  will  create  independent  zip  files,
meaning that if you have a backup that spans over 3 CDs and if one of the CDs becomes unreadable,
you will still be able to access and recover the data on the other 2 CDs.
 
It  is  recommended  to  always  leave  the  Test  after  backup  option  (Backup  Properties-  >Advanced)
checked,  especially  if  your  backup  is  written  on  CD,  DVD  or  Blu-ray  disc.  In  case  of  disk  spanning,
Backup4all will test your backed up data after each individual written disc. This way if one of the discs
has errors you know before the backup job is  finished and you can interrupt the backup process in
time.
 
Note that when backing up to CD, DVD or  Blu-ray disc  Backup4all  requires additional  free space on
the  drive  where  the  Temporary  Folder  is  located  (at  least  700Mb  when  backing  up  to  CDs,  4.7Gb
when backing up to DVDs or 25GB when backing up to Blu-ray discs).

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

 

4.5 Other CD/DVD/Blu-ray Settings

The File->Options->CD, DVD or Blu-ray window contains various settings related to the burn process.

CD, DVD or Blu-ray

Use SCSI Pass Through Direct Layer (SPTD)
Selected by default.  Backup4all uses this internal  burning engine to write CD,  DVD, HD-DVD or  Blu-
ray  discs.  SPTD is  a  new method of  access  to  storage  devices  and  has  the  ability  to  provide  direct
control of devices without risk of compromising it by some malicious 3rd party filter drivers or other
"rootkit" applications. 
SPTD  is  currently  supported  by  all  Microsoft  OS  newer  than  Windows  XP.  SPTD  (similar  to  other
access  layers)  is  not  removed  from  your  system  after  Backup4all  uninstall,  in  order  not  to  disrupt
other applications that may use it. 
 
Use native Win32 Interface (SPTI)
If you have problems backing up using the SPTD method, we recommend you to use this option.

Load CD, DVD or Blu-ray before backup
Check this option if you want the CD, DVD or Blu-ray to be loaded before backup execution.
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Eject CD, DVD or Blu-ray disc After Backup
You can leave the CD, DVD or Blu-ray disc ejected after the backup is finished (and tested). To do so,
go  to  File->Options->CD,  DVD  or  Blu-ray  and  check  the  Eject  CD,  DVD  or  Blu-ray  after  backup
option.
 
Note:

· The Use SCSI Pass Through Direct Layer (SPTD) and Use native Win32 interface (SPTI) burning
methods use the UDF disc format.

  
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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5 Main Window

5.1 Getting Started

This window is displayed when you first run Backup4all. You can also access this window if you select
Getting Started from the File->Tools menu.
There are two large buttons for backup and restore and a list of articles about Backup4all.

Backup

Press this button to create or run backup jobs.

Backup - Run selected backup job
Select an existing backup job from the list and press Backup to run the selected job.
If you want to assign the selected backup job to your One touch device, check the Use job for One
Touch Backup option.
 
Create  - Create new Backup job
Pressing the Create button will open the New Backup Wizard.
If you want to assign the selected backup job to your One touch device, check the Use job for One
Touch Backup option.
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Restore

Restore - Restore from selected backup
Select an existing backup job from the list and press Restore to open the Restore Wizard.

Open - Load backup jobs
Use  the  Open  button  to  recreate  a  backup  job  from  the  backup  catalog  (.bkc)  or  from  the
initialization file (.ini).
The recreated backup job will be added to the backup list.

If  you don't want to show the Backup4all Startup window next time you open Backup4all,  uncheck
the Show this dialog at next start option.
By default this option is checked.

Links

Shows a list of the most popular articles from our knowledge base.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

5.2 Jobs View

5.2.1 Jobs List

Backup list, visible in the middle column of the main window, contains all the backup jobs defined.
The backup jobs can be grouped into tags, for easy handling.
By default, backup jobs are listed by Execution order column. In other words, if running all jobs one
after the other, they will be executed in order from top to bottom.
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To  configure  a  backup  job's  appearance  (icon  and  label)  in  the  backup  list,  you  have  to  open  the
Backup Properties window, switch to the General tab, change the name of the backup job, assign it
to  an  existing  tag  or  create  a  new  tag  and  select  a  backup  job  icon.  When  you  backup  a  tag,  the
backup jobs (containing that tag) are backed up in the order they are displayed in the tag list.
 
When right clicking a backup job, a menu is displayed giving the following options:

· View as:

· Card - will display all jobs as cards

· List - will display all jobs as list

· Run Job

· Backup - performs a backup with the type selected in Properties

· Full Backup - performs a full backup regardless of the backup type

· Differential Backup - performs a differential backup regardless of the backup type

· Incremental Backup - performs an incremental backup regardless of the backup type

· Restore

· Restore - opens the Restore Wizard window for the currently selected backup job

· Restore Latest Version - starts the latest version restore process for the selected backup job

· Restore Latest Version To - opens a window to select the folder were you want the backup to
be restored 

· Test

· Test... starts the test process for the currently selected backup job

· Quick Test -  starts  a  quick test for the selected backup job. The existence  of  the  files  in
destination is verified.
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· Repair

· Repair - use this option to repair the backup job in destination and re-copy all missing or
corrupted  files,  based  on  the  existing  information  in  the  backup  catalog.  A  test  will  be
performed, followed by a backup to also include the missing files.

· Repair Catalog Only -  use  this  option  to  remove from the  backup  catalog  the  missing  or
corrupted  files  in  destination.  A  test  will  be  performed,  followed  by  a  catalog  update  to
remove the missing files.

· Quick  Repair  -  use  this  option  to  repair  the  backup  job  in  destination  and  re-copy  all
missing or corrupted files, based on the existing information in the backup catalog. A quick
test will be performed, followed by a backup to also include the missing files.

· Quick Repair Catalog Only - use this option to remove from the backup catalog the missing
or  corrupted  files  in  destination.  A  quick  test  will  be  performed,  followed  by  a  catalog
update to remove the missing files.

· Clean... - opens the Clean Backup window for the selected backup job

· Cancel - aborts current backup process

· Pause - pause the current backup/test/cleanup/restore process

· Stop - stops the current backup/test/cleanup/restore process

· Job Logs - lets you open and view the Last Backup Log,  Last Restore Log,  Last Test Log ,  Last
Cleanup Log and Last Statistics Log

· Create Shortcut... creates a shortcut to the backup job

· Duplicate - duplicates a backup job

· Delete - deletes a backup job

· Properties... opens the Backup Properties window

Backup4all can process multiple backup jobs at the same time.  You can filter the backup list  to see
which backup jobs are executed at a certain time.
From  the  left  side  column  of  the  main  application  you  can  filter  the  backup  jobs  in  list.  You  can
choose to see all jobs, only the running jobs, failed jobs or only the jobs containing a specific tag.
If there are many backups listed, you can search for a backup job by typing its name in the Type to
search box on the bottom of the Backup List.  
  

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

5.2.2 Manage Tags

Create a new tag

1) When creating (or editing) a backup job using the New Backup Wizard in Advanced mode (or
Backup Properties), press Add new tag and type a new name (that does not exist) for the backup
tag.
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2) Right click on the left side list (left panel of the main window) and choose New Tag. The Create
a new tag  window will  appear and you can enter the name of the tag. A new empty tag will  be
created (which can be selected later from the Tags list  of  the New Backup Wizard  or  from the
Backup Properties window).

Rename a tag

Select the backup tag from the left side list. Right click it on the backup list and choose Rename Tag.
A window similar with the one for Create a  new tag  will  appear.  You can enter  the new name and
press OK. The tag will be renamed and it will keep all the backup jobs it had.
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Delete a tag
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Select the backup tag from the left  side list.  Right-click  in the backup list  and choose Delete Tag.  A
warning  message  will  appear  before  the  deletion.  If  you  choose  Yes,  only  the  backup  tag  will  be
deleted,  the backup jobs will  remain in the backup list.  To move backup jobs to  a  different  backup
tag, you must edit the backup job's properties and select a  different  tag for them or  drag and drop
the job on the tag you want to be assigned.

To assign a tag to a backup job, just drag and drop the tag from the left side list of tags to the
backup job name in the main window, or open Backup Properties->General and check the tag
name.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

 

5.2.3 Create Shortcut

The Create Shortcut window can be opened from the Create Shortcut... button located on the Jobs
tab or by right-clicking the backup job from the backup list and selecting Create Shortcut... It creates
a  shortcut  for  the  backup  job  on  a  designated  location  and  you  can  simply  run  the  backup  job  by
double-clicking it.
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General
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On this page you can define which backup job/tag you want to run, if the application will be visible or
not, the task priority and the icon.

Run

· Job - Select a backup job from the list to be executed

· Tag - Select a backup tag from the list to be executed

· All jobs - The shortcut will start the back up for all jobs

· One Touch Backup - The shortcut will start the backup job/tag assigned to One Touch Backup

Execute

Show main application
If  checked,  when you will  double-click  the  backup  shortcut,  the  main  application  will  start  and  the
backup will  be  executed.  Furthermore,  if  the  Close  after  run  option  is  checked,  Backup4all  will  be
closed after the action is executed.
By default this option is not checked so the action will run in background.
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Priority
User can change the priority of the action started by the shortcut: backup, test or cleanup. Just move
the cursor to a lower or higher priority level.

Notifications
Force all notifications to timeout 
Use this option if you want to timeout all notification messages during the backup.
 
Icon
Use icon from backup job
If this option is checked, the shortcut placed on the desktop, quick launch or other location, will have
the same icon as the one it has in the backup list.  If  unchecked,  the default  Backup4all  icon will  be
displayed.

What
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On this  page you can  select  and  configure  what  action  you want  to  execute  when double-click  the
shortcut: backup, test, repair, cleanup or restore.

What to execute

· Backup
Type

· Default - executes the default backup type defined in the backup job

· Full - executes a full backup, no matter what the backup type defined in the backup job is

· Differential  - executes a differential backup, no matter what the backup type defined in
the backup job is

· Incremental  - executes an incremental backup, no matter what the backup type defined
in the backup job is
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Clear backup before run
If  this  is  checked, Backup4all  will  first  delete the  ".bkc"  file  and  all  zip  files  associated  with  the
current backup job and after that execute the action.

· Test - you can create a shortcut to a test operation instead of a backup. When Test is selected,

the  Backup  Numbers  box  is  displayed  .  You  can  type  in  there  the  backup
numbers you want to test. The order you type them in is the order they will  be tested in. Use
the * character to test all backup numbers, or the # character to test only the last backup.

 

· Repair - you can repair the backup by running a test,  detect the missing/corrupted files from
destination and back then up again.

Repair catalog only  - this option will detect the missing/corrupted files from destination and
will remove them from catalog so they will be backed up next time you run the backup.

· Cleanup  -  you can  create  a  shortcut  for  a  scheduled  Cleanup  operation,  that  will  delete  the
selected  backup  numbers  at  the  scheduled  date.  When  Cleanup  is  selected,  other  options
become available to filter the backup numbers that will be deleted:

· Newer than  -  if  checked backup numbers that  are newer  than  the  selected date will  be
deleted when the shortcut is double-clicked

· Older  than  -  if  checked  backup  numbers  that  are  older  than  the  selected  date  will  be
deleted when the shortcut is double-clicked

· Older than (fixed date) - backup numbers that are Older than a certain fixed date will be
deleted when the shortcut is double-clicked

· Do not delete full backups - if  this is checked, the full  backups will  be kept even if  they
fall into the range of files filtered for deletion

· Do  not  delete  differential  backups  -  if  this  is  checked,  the  differential  backups  will  be
kept even if they fall into the range of files filtered for deletion

· Clear the destination folder  -  deletes  any files  and  folders  inside  the  destination folder
even if they are not related to the backup job.

· Restore - you can create a shortcut to restore a backup job, tag or all jobs.

· Where to restore - select the location for restore. You can use the original location or you
can specify another location. If you use another location for restore, you can avoid the
creation of a drive letter folder by checking the Do not create drive letter folder option.

· How to restore - you can restore the latest version of the files, restore all files as of a
specific date or restore some backup numbers. If you want to also restore excluded and
deleted files, you must check the Restore excluded and deleted files option.

Once you have selected the Action to be performed and the backup job/tag to run, press OK to create
the shortcut. A window will prompt you to select a name for your shortcut and its destination. Once
that's completed, the shortcut will be placed in the selected destination.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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5.2.4 Explore View

You can activate Explore view by:

· pressing the Explore button from the Jobs tab

· pressing F2 keyboard shortcut
 

The Explore View consists of a File Tree on top and a File Version List at the bottom. 

File Tree

The file tree content depends on the backup sources and file filters defined for the selected backup
job.  You can  right-click  on the  folders  and  files  in  the  tree  to  open  the  same  context  menu  that  is
available from File Explorer  if  the option Show context  menu  from File-  >Options->Preferences  is
checked.  If  that  option  is  unchecked,  the  right-click  operation  will  display  only  the  Restore  Latest
Version and Restore Latest Version to... You can select multiple files.
 
Be careful about handling files in the Explore view with the Show context menu option checked: all
actions are performed on the hard disk and any deletion will actually remove the file from your hard
disk!
 
Beside the File Explorer  context menu items, there are also two custom menu items,  which enable
the restore of the last version of a file: Restore Last Version and Restore Last Version To...
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If  you want to exclude a file/folder from the backup sources, you can right-click that file/folder and
choose  Exclude  from  backup  sources  option.  This  action  will  uncheck  the  file/folder  in  Backup
Properties->Sources.

The file tree shows the last modified date, size and attributes for each file in additional columns. This
information  is  the  same  as  shown  in  File  Explorer.  You  can  sort  the  files  by  name,  date,  size  or
attributes  by  simply  clicking  on  the  appropriate  column  header.  The  files  are  sorted  within  their
folders. Size, Modified and Attributes columns can be hidden if you right click on the column header
and uncheck the names of the columns that you want to remove.
 
There  are  seven  buttons  on  top  of  the  file  tree  that  help  you  show/hide  files  depending  on  their
status:
 

 If pressed, files that will be added to the backup are shown in the tree. All files with this status will

have  picture in front of them.

 If pressed, files that have not been changed since last backup are shown in the tree. All files with

this status will have  picture in front of them.

 If pressed, files that have been changed since last backup are shown in the tree. All files with this

status will have  picture in front of them.

 If pressed, files that are already present in backup and are now excluded by new changes in file

filter are shown in the tree. All files with this status will have  picture in front of them.

 If  pressed,  files that  have  been  deleted from hard  disk  are  shown in  the  tree.  All  files  with  this

status will have  picture in front of them.

 If pressed, all directories in the tree will be expanded. For a large number of files and directories,
this operation can take a longer time. Press the ESC key to stop the process.

 If pressed, all directories in the tree will be collapsed.

 
If  you do not want to see empty folders when clicking on Expand all,  check Hide empty folders  on
expand all in the File->Options->Preferences window. The tree will  show only folders containing at
least one file.
 
There is an easy way to search for a file in the files and folder tree: simply start typing the file's name
and the matching file name will be selected. Only files that are visible in the tree are found, so if you
want to search in all files, you have to do an Expand all first.

If you want to see only the backed up files press these buttons:    

For the files that will be added to the next backup press:  

 
File Version List

If  a  file  is  selected in the tree, at the bottom of the view,  you can  see  the  list  of  the  file's  versions
from the backup. Information provided for each version:

· Type - Type of the Backup. Each of the backup types is represented by a descriptive icon:  

Full,  Incremental,  Differential,  Mirror

· Ver. - File version number
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· Bck. No. - Number of the backup

· Backup Date - Date and time when the version was added to the backup

· Status - Status of operation performed on that file version (added, excluded...)

· Size - Size of the file version

· Modified - Date and time when the file version was last modified (at backup execution)

· Attributes - Attributes of the file version at backup execution (read-only, hidden, archive). This
column is hidden by default

· Bkc. Label - Label of the backup increment. This column is hidden by default

The file versions in the list can be sorted by clicking on the column headers. The right-click menu on
the  column  header  provides  a  handy  way  to  show/hide  unnecessary  columns  (except  the  Version
column which is grayed out).
 
Backup4all  provides  an  easy  way  to  restore any  file  version.  Just  right-click  on the  file  version  you
want to restore and:

· choose Restore version if you want to restore the version in the original location

· choose Restore to if you want to restore the version in another location

· choose Open  if  you want to open/view that  version of the file  with  the  associated  Windows
application

· choose View with Notepad if you want to open/view that version of the file with Notepad

· choose  Compare with  source  if  you want  to  compare  the  selected  version  with  the  existing
source

· choose Compare versions if you want to compare the selected versions

· choose Select columns to enable/disable the columns displayed

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

 

5.2.5 Backup View

You can activate Backup view by:

· pressing the Backup button from the Jobs tab

· pressing CTRL + F2 keyboard shortcut
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The Backup View consists of a Backup Version List on top and a  File Tree at the bottom. 
Above the Backup versions list, there is a "search for files" field. Here you can type the name of the
file/folder you are looking to restore, in order to easily find its location.

Backup Version List

If  a  backup  version  is  selected,  at  the  bottom  of  the  view,  you  can  see  the  list  of  the  files  in  that
backup and their status before that backup. Information provided for each version:

· Type - Type of the Backup. Each of the backup types is represented by a descriptive icon:  

Full,  Incremental,  Differential,  Mirror

· Backup Date - Date and time when the backup was created

· Bck No. - Number of the backup

· File No. - Number of files in that backup

· Folder No. - Number of folders in that backup

· Comp. Size - Compressed size of the file version

· Uncomp. Size - Uncompressed size of the file version

· Label - Label of the backup increment. 

The backup version list can be sorted by clicking on the column headers. The right-click menu on the
column header provides a  handy way to show/hide unnecessary  columns (except the Type  column
which is grayed out).
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Backup4all  provides an easy way to restore or  test a  backup version.  Just  right-click  on the  backup
version and:

· choose Restore Latest Version if you want to restore the version in the original location

· choose Restore Latest Version To... if you want to restore the version in another location

· choose Test if you want to test that backup version 

· choose  View  Backup  Log  if  you  want  to  open/view  that  log  with  the  selected  log  viewer.
Initially the default text editor is used.

File Tree

The file tree content depends on the files from the selected backup version. You can right-click on the
folders and files in the tree to open a menu that allows you to  choose the following options: 

· Restore if you want to restore the version in the original location

· Restore to... if you want to restore the version in another location

· Open  if  you  want  to  open/view  that  version  of  the  file  with  the  associated  Windows
application

· View with Notepad if you want to open/view that version of the file with Notepad

· Full expand to expand all the tree

The file  tree  shows  the  file/folder  name,  bck  no.  size,  last  modified  date,  attributes  and  status  for
each file  in additional  columns. You can sort  the files by simply clicking on the appropriate  column
header. The files are sorted within their folders. Except File/Folder, each column can be hidden if you
right click on the column header and uncheck the names of the columns that you want to remove.

There  are  seven  buttons  on  top  of  the  file  tree  that  help  you  show/hide  files  depending  on  their
status:

 If  pressed,  files that  were added to the backup as  new are  shown in  the  tree.  All  files  with  this

status will have  picture in front of them.

 If pressed, files that were added to the backup as modified are shown in the tree. All files with this

status will have  picture in front of them.

 If pressed, files that had been in backup and were excluded by new changes in file filter are shown

in the tree. All files with this status will have  picture in front of them.

 If pressed, all directories in the tree will be expanded. For a large number of files and directories,
this operation can take a longer time. Press the ESC key to stop the process.

 If pressed, all directories in the tree will be collapsed.

 If pressed, the Filter window will be shown. Use this option to filter the files displayed in the tree.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

5.2.6 Statistics View

You can activate Statistics view by:

· pressing the Statistics button from the Jobs tab

· pressing the F3 keyboard shortcut
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This  view provides statistical  information  about  the  last  backup  performed and  calculates  statistics
about the next backup, based on the current backup job configuration.

Information list:
 
Last backup on
Date and time of the last backup

Last backup type 
Shows the last backup type executed

Last backup duration
Shows the duration of the last backup execution
 
Last backup size
Shows the size of the last backup (compressed) / size of all files present in backup (uncompressed) /
compression percentage

Last full backup on (not displayed for mirror backup type)
The date and time when the last full backup was executed. Note that the first backup is always a full
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backup, even if the backup type is set to incremental or differential.

Last full backup duration (not displayed for mirror backup type)
Shows the duration of the last full backup execution
 
Last full backup size (not displayed for mirror backup type)
Shows  the  size  of  the  last  full  backup  (compressed)  /  size  of  all  files  present  in  backup
(uncompressed) / compression percentage.
For  example  10  MB/30  MB/33%  means  that  the  size  of  the  last  full  backup  was  10  MB,  the
uncompressed size of the files backed up was 30 MB and the compression ratio was 33%.
 
Total size of backup (not displayed for mirror backup type)
Total  size  of  the  backup  takes  into  consideration all  backup  increments,  ".bkc"  file  and  any  folders
that  might  have  been  created.  It  shows  the  total  size  after  compression  /  without  compression  /
compression percentage For mirror backup the compressed values are not  shown,  because there is
no compression.
 
Number of backups
Number of times the backup job was executed

Last backup status
Displays the following information:

· Last backup was successful when everything went OK

· Last backup failed when the backup was aborted due to an error

· Last backup had <X> warnings when the backup was done, but <X> files could not be backed
up

· Last backup was canceled when the user canceled the backup execution

Files/folders in backup
Shows the number of files in the backup. The number between the brackets is for the files added at
the last backup. For full backup the number of files added to the last backup will be always the same
with the total number of files. The same for mirror backup without the Fast mirror option activated.
 
Next scheduled backup
Date and time when the backup is scheduled to be executed again

Next scheduled tag backup
Date and time when the backup tag is scheduled to be executed again.
 

Statistics for next backup:

The  Calculate  Statistics  for  Next  Backup  (Ctrl+F5)  button  will  start  counting  the  new,  modified,
unchanged  and  excluded  files  since  the  last  backup  execution.  The  counters  will  be  shown  in  the
labels below, divided into two sections: Files to backup containing the counters for the files that will
be  added  to  the  next  backup,  and  Changes  since  last  backup  containing  the  counters  for  the  files
changed since the last backup.  For a  large number of files,  counting can be time consuming.  If  you
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want to stop the counting process press the Cancel button from the toolbar. Calculate Statistics for
Next Backup (Ctrl+F5) uses the catalog file (".bkc"). If this catalog is on a CD, DVD or Blu-ray disc and
you  enter  a  previous  backup  version,  the  counters  will  be  different.  Files  to  backup  counters  are
calculated depending on the  backup  job settings:  backup  type,  <Clear  backup> action  etc.  Changes
since last backup counters are always the same no matter the backup job settings.
 
Files/Folders to backup
For full and differential backup types these counters are calculated based on the changes since the
last full backup.For the  incremental backup type, the counts are based on the changes since the last
backup (differential, full or incremental).
 
New files/folders
The number of new files/folders that will be added to backup. For mirror backup (with the Fast mirror
option unchecked), the new files/folders counter equals the total number of files/folders.
 
Unchanged files/folders
Shows  the  number  of  unchanged  files/folders  to  be  added  to  backup.  For  differential,  incremental
and mirror backup with Fast mirror option unchecked, this number will always be 0.

Modified files/folders
Shows the number of modified files/folders to be added to backup. For mirror backup (with the "Fast
mirror" option unchecked), this number will always be 0.

Excluded files/folders
Shows the number of excluded files/folders, which will be removed from the backup.
 
Changes since last backup
Counts the changes since the last backup, regardless of the backup settings
 
New files/folders
Shows the number of new files/folders since last backup.
  
Unchanged files/folders
Shows the number of unchanged files/folders since last backup.

Modified files/folders
Shows the number of modified files/folders since last backup.
 
Excluded files/folders
Shows  the  number  of  excluded  files/folders.  A  file/folder  gets  excluded  because  of  the  changes  in
file/folder filter or because it was deleted or moved from the backup sources.
 
Total files/folders to backup
Shows the total number of files and folders  that  will  be added to backup next time.  This should be
the sum of the new, modified and unchanged file and folder counters.
 
Total size (uncompressed) to backup
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Shows the sum of all file sizes to be included in the backup next time it is executed.
 
Free disk space on destination
Shows the available free disk space on the destination drive.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

5.2.7 Progresss View

You can activate the Progress view by:

· pressing the Progress button from the Jobs tab

· pressing the CTRL+F3 keyboard shortcut

Please  note  Progress  view  is  active  only  when  the  backup  is  running.  When  the  backup  is  not
running, that option is grayed out.
When  the  backup  is  started,  Backup4all  will  switch  automatically  to  Progress  view  and  after  the
backup is done it will switch back to your previous view.

Action: Indicate the action in progress: Backup, Restore, Test, Clean

Operation: Indicate the operation in progress: Creating file list, Updating catalog, Testing backup etc

Current file: Displays the current file processed
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On the Progress view page you can also see the file progress, file count, total progress, elapsed time
and estimate time.
The Pause, Cancel and Stop buttons at the bottom of Progress view can be used for a better control
of the backup jobs. 
 
Shutdown computer when finished
If checked, at the end of the backup/test/repair/restore execution, the computer will shutdown. It is
useful for longer backups when the user does not want to wait til the end of the process. 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

5.2.8 Open backup

There are two ways to open a backup job in Backup4all.

· You can open the backup catalog (.bkc) or ini  file using the Open command from Files  menu.
You just need to browse your computer and indicate the catalog or ini file location.

· You can open the backup catalog (.bkc)  or  ini  file  using  the  Open From  command  from Files
menu. This option is recommended to be used if the catalog is located on a network location or
on  an  FTP/SFTP/Azure/Amazon  S3/Google  Cloud  Storage/Google  Drive/OneDrive/Box/
Dropbox/Hubic/HiDrive/S3 Compatible, but can also be used for local hard drives. 

Open from a local hard drive

Use this  page if  the catalog is  on a local  hard  drive.  Browse  your  computer  and  indicate  the  folder
containing the catalog(s) or ini file(s). 
Press Show to display the folders and selected file types  (.bkc or  ini).  Press Scan to display a  list  of
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only .bkc/ini files from all folders and subfolders in that location.

Open from a network drive

Use  this  page  if  the  catalog  is  on  a  network  drive.  Select  the  network  location  and  enter  the
username/password if necessarily. 
Press Show to display the folders and selected file types  (.bkc or  ini).  Press Scan to display a  list  of
only .bkc/ini files from all folders and subfolders in that location. 
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Open backup from an FTP server

Use  this  page  if  the  catalog  is  on  an  FTP  server.  Configure  the  FTP  server  or  choose  an  existing
configuration. 
Press Show to display the folders and selected file types  (.bkc or  ini).  Press Scan to display a  list  of
only .bkc/ini files from all folders and subfolders in that location. Here you can see how to configure
the FTP server.



Backup4all 9116

Backup4all 9 User Manual Copyright © 2021 Softland

Open backup from an SFTP server

Use  this  page  if  the  catalog  is  on  an  SFTP  server.  Configure  the  SFTP  server  or  choose  an  existing
configuration. 
Press Show to display the folders and selected file types  (.bkc or  ini).  Press Scan to display a  list  of
only .bkc/ini files from all folders and subfolders in that location. Here you can see how to configure
the SFTP server.
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Open backup from Azure 

Use  this  page  if  the  catalog  is  located  on  Azure  server.  Configure  Azure  or  choose  an  existing
configuration. 
Press Show to display the folders and selected file types  (.bkc or  ini).  Press Scan to display a  list  of
only .bkc/ini files from all folders and subfolders in that location. Here you can see how to configure
Azure.
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Open backup from Amazon S3

Use this page if the catalog is located on Amazon S3. Configure the Amazon S3 storage or choose an
existing configuration. 
Press Show to display the folders and selected file types  (.bkc or  ini).  Press Scan to display a  list  of
only .bkc/ini files from all folders and subfolders in that location. Here you can see how to configure
the Amazon S3.
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Open backup from Google Cloud Storage

Use this page if the catalog is located on Google Cloud Storage. Configure the Google Cloud Storage
or choose an existing configuration. 
Press Show to display the folders and selected file types  (.bkc or  ini).  Press Scan to display a  list  of
only .bkc/ini files from all folders and subfolders in that location. Here you can see how to configure
the Google Cloud Storage.
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Open backup from Google Drive

Use this page if the catalog is located on Google Drive. Configure Google Drive or choose an existing
configuration. 
Press Show to display the folders and selected file types  (.bkc or  ini).  Press Scan to display a  list  of
only .bkc/ini files from all folders and subfolders in that location. Here you can see how to configure
Google Drive.
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Open backup from OneDrive

Use  this  page  if  the  catalog  is  located  on  OneDrive.  Configure  OneDrive  or  choose  an  existing
configuration. 
Press Show to display the folders and selected file types  (.bkc or  ini).  Press Scan to display a  list  of
only .bkc/ini files from all folders and subfolders in that location. Here you can see how to configure
OneDrive.
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Open backup from Box

Use this page if the catalog is located on Box. Configure Box or choose an existing configuration. 
Press Show to display the folders and selected file types  (.bkc or  ini).  Press Scan to display a  list  of
only .bkc/ini files from all folders and subfolders in that location. Here you can see how to configure
Box.
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Open backup from Dropbox

Use  this  page  if  the  catalog  is  located  on  Dropbox.  Configure  Dropbox  or  choose  an  existing
configuration. 
Press Show to display the folders and selected file types  (.bkc or  ini).  Press Scan to display a  list  of
only .bkc/ini files from all folders and subfolders in that location. Here you can see how to configure
Dropbox.
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Open backup from Hubic

Use this page if the catalog is located on Hubic. Configure Hubic or choose an existing configuration. 
Press Show to display the folders and selected file types  (.bkc or  ini).  Press Scan to display a  list  of
only .bkc/ini files from all folders and subfolders in that location. Here you can see how to configure
Hubic.
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Open backup from HiDrive

Use  this  page  if  the  catalog  is  located  on  HiDrive.  Configure  HiDrive  or  choose  an  existing
configuration. 
Press Show to display the folders and selected file types  (.bkc or  ini).  Press Scan to display a  list  of
only .bkc/ini files from all folders and subfolders in that location. Here you can see how to configure
HiDrive.
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Open backup from S3 Compatible 

Use this page if the catalog is located on S3 Compatible. Configure S3 Compatible Storage or choose
an existing configuration. 
Press Show to display the folders and selected file types  (.bkc or  ini).  Press Scan to display a  list  of
only .bkc/ini files from all folders and subfolders in that location. Here you can see how to configure
S3 Compatible Storage.
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Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

5.2.9 Test

The backup test is meant to ensure the validity and the integrity of the backup files and the backup
catalog. During test, all files and folders from destination will be tested to make sure they were safely
copied. The files in destination are not compared with the backup sources but with the information
stored in backup catalog.

There is a second test option called Quick Test. It does a faster check of the files in destination, only
to verify their existence, without calculating the CRC for each file. 

The Test window can be opened from the Jobs tab, by pressing the Test... button or by pressing the
F9 keyboard shortcut.  It  lists  all  the available information about the backup versions of the current
backup job.
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When you open the window all the backup versions that can be tested are selected. You can select/
deselect multiple backup versions you want to be tested using batch selection on that list. To define
the selection, keep the Shift key pressed and use the up and down arrow keys from your keyboard or
the  mouse.  If  you  want  to  select  multiple  individual  items,  press  and  hold  the  Ctrl  key  and  select
using the mouse the items you want tested.
There are several columns in the Test window that provide information for each backup version:

· Type - Type of the backup. Each of the backup types is  represented by a descriptive icon:  

Full,  Differential,  Incremental,  Mirror

· Backup date - Date and time when the version was added to the backup

· Backup No. - Number of the backup

· File No. - Number of files included in that backup

· Folder No. - Number of folders included in that backup

· Comp. Size - The compressed size of the backup

· Uncomp. Size - The uncompressed size of the backup

· Label - Label of the backup increment.

The backup versions in the list can be sorted by clicking on the column headers. The right-click menu
on the  column header  provides  a  handy way  to  show/hide  unnecessary  columns  (except  the  Type
column which is grayed out).
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Using the Priority  slider  you can  set  the  test  execution  speed compared to  the  rest  of  the  running
processes on your computer. Default is Normal priority, but there are other 4 priority levels: Lowest
priority,  Low  priority,  High  priority  and  Highest  priority.  On  Lowest  priority  the  test  process  will
consume the  minimum amount  of  computer  resources  but  will  take  the  longer  to  complete,  while
Highest priority  will  consume the highest amount of  computer  resources  but  will  take  the  least  to
complete.

To test the  selected backup  versions  press  the  Test  button,  or  press  Cancel  (or  the  Escape  key)  to
close the window.
 
After finishing the test, a pop-up message is displayed with the test results:

· Testing <backup name> found no errors - means that there are no corrupted/missing files in
the backup

· Testing <backup name> found error(s). Do you want to see the log file?  -  means that  some
files are corrupted or missing from the backup; you should press Yes  to see the test log file  (
also available from the Jobs tab, Tools section, View Log->Last Test Log)
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Backup4all has also the option to test the files automatically after backup. This option is checked by
default and it is recommended to leave it this way. However, if  you want to modify it,  you can find
the Test  after  backup option in the Backup Properties- >Advanced window for  the  selected backup
job.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

5.2.10 Clean backup

The Clean backup  window can be opened from the Jobs tab by pressing the  Clean  button.  It  gives
options to delete backup numbers based on certain criteria.
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When you open the window all  the  backup  numbers  are  displayed.  You can  either  manually  check
multiple  backup  numbers  you  want  deleted  or  use  the  filter  options  to  have  them  automatically
selected if they match a certain criteria. Once you select a type of backup, if there are other backup
numbers  depending  on  it,  they  will  be  selected  too.  For  instance,  selecting  a  Full  Backup  (marked
with red in the list) will  also batch select the other incremental or differential backup numbers that
depend on the selected full backup (to keep some of the backup numbers that  depends on the full
backup, you will have to start unselecting them in the order they were created). 
Please note that when you delete a  certain backup  number  using  the  Clean Backup tool,  all  the
files in the destination that were created for that backup number will be removed.
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There  are  several  columns  in  the  Clean  Backup  window  that  provide  information  for  each  backup
number:

· Delete  - Shows if a backup number is selected for deletion.  You can manually  check/uncheck
the backup numbers you want deleted. Once selecting a backup number all the other backup
numbers that depend on it will also be selected.

· Type - Type of the backup. Each of the backup types is represented by a descriptive icon and

text:  Full,  Incremental,  Differential,  Mirror. Additionally, full backups are marked
with red.

· Backup No. - Number of the backup

· Backup date - Date and time when the backup was executed

· File No. - Number of files included in that backup

· Folder No. - Number of folders included in that backup

· Total size - Size of the backup

· Label - Label of the backup increment.

The backup numbers in the list can be sorted by clicking on the column headers. The right-click menu
on the column header provides a handy way to show/hide unnecessary columns. 

You can select a backup number by right-clicking it and choosing Check Selected (or uncheck it using
Uncheck  Selected).  The  right-click  menu  also  allows  selecting  all  backup  numbers  (Check  all)  or
unselecting them (Uncheck all).

Using  the  Priority  slider  you  can  set  the  execution  speed  compared  to  the  rest  of  the  running
processes on your computer. Default is Normal priority, but there are other 4 priority levels: Lowest
priority,  Low  priority,  High  priority  and  Highest  priority.  On  Lowest  priority  the  process  will
consume the  minimum amount  of  computer  resources  but  will  take  the  longer  to  complete,  while
Highest priority  will  consume the highest amount of  computer  resources  but  will  take  the  least  to
complete.

Filter backups by date

Newer than
If  checked backup numbers that are newer than the selected date will  be removed when the Clean
operation is executed.

Older than 
If  checked backup  numbers  that  are  older  than  the  selected date will  be  removed when  the  Clean
operation is executed.

Older than (fixed date)
The  backup  numbers  that  are  Older  than  a  certain  fixed  date  will  be  deleted  when  the  Clean
operation is executed.

Filter backups by type
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Do not delete Full backups 
If  this  is  checked,  the  full  backups  will  be  kept  even  if  they  fall  into  the  range  of  files  filtered  for
deletion.

Do not delete Differential backups
If this is checked, the differential backups will be kept even if they fall into the range of files filtered
for  deletion.  Note  that  this  option  is  available  only  when  Do  not  delete  full  backups  is  checked,
because differential backups depend on full backups.

Manual selection

In  this  section  you  can  manually  select  the  backup  versions  you  want  to  delete  by  clicking  the
checkbox in front of the backup version.

Reset to filters
Pressing this  will  ignore any  manual  selection  done  and  restore the  default  selection  based on the
filters applied.

Options

Clean the destination folder
Selecting this option will also delete from the destination folder all the files and folders which are not
related to the backup job. This action will be executed in addition with the cleanup selection you
made.

Clean process priority 
Using the Priority  slider  you can  set  the  test  execution  speed compared to  the  rest  of  the  running
processes on your computer. Default is Normal priority, but there are other 4 priority levels: Lowest
priority,  Low  priority,  High  priority  and  Highest  priority.  On  Lowest  priority  the  test  process  will
consume the  minimum amount  of  computer  resources  but  will  take  the  longer  to  complete,  while
Highest priority  will  consume the highest amount of  computer  resources  but  will  take  the  least  to
complete.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

5.3 History View

The History window can be open from the left side column by pressing the History button.
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In History window you can see all logs for the backup, restore, test  , test and cleanup actions.
The logs can be filtered by job/tag name, action type, status (success, warning or error) and date.
Double click or right-click on a log to open it.

You can customize the History window if you right-click on the header and check another columns.
The available columns are: 

· Name - shows the name of the backup job/tag. It cannot be unchecked

· Type - shows the type of the backup: job or tag

· Default Backup Type - shows the default backup type for each backup job

· Action Type - shows what action was performed: backup, restore, test or cleanup

· Action Backup Type - shows what type of backup was performed: full, differential, incremental
or mirror

· Forced - shows if the backup type was forced or it was the default one

· Application - shows if the main application or command line was used to run that backup

· Start Date - shows the backup start date 

· End Date - shows the backup end date 

· Duration - shows the backup duration

· Status - shows the backup status: success, warning or error

· Files - shows the number of files backed up

· Folders - shows the number of folders backed up

· Size Uncomp - shows the uncompressed backup size

· Size Comp - shows the compressed backup size
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· Log Path - shows the path of the log file

The logs can be grouped by each of the available columns. Just drag one or more column headers on
the top of the columns to group the logs by that column.

In the top menu there is the Export button which can be used to export all columns.
Selecting one of these two options,  will  open the Save as  window where you can type a name and
select the path for the file.
The history will be exported into a CSV file format.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

5.4 Schedulers View

The Schedulers window can be opened from the bottom left-side column, by pressing the Scheduler
button  or  by  pressing  the  F11  keyboard  shortcut.  It  lists  all  the  available  information  about  the
scheduled tasks and allows you to Add, Edit, Delete and Schedule the tasks.

 

There are several options available for the scheduled tasks:
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Manage

· Add - allows you to easily add a new scheduled task

· Edit - opens the Scheduler Properties window where you can edit selected task's options: when
and what to run.

· User/password - opens a window where you can set the username and the password.

· Delete - removes the selected scheduled task

· Refresh - use this button to refresh the scheduled tasks list

Filter - shows only the tasks matching the selected filters.

· Default backup - only the scheduled tasks running the default backup type will be displayed

· Full - only the scheduled tasks running the full backup type will be displayed

· Differential - only the scheduled tasks running the differential backup type will be displayed

· Incremental - only the scheduled tasks running the incremental backup type will be displayed

· Smart - only the scheduled tasks running the smart backup type will be displayed

· Restore - only the scheduled tasks running a restore will be displayed

· Repair - only the scheduled tasks running a repair action will be displayed

· Test - only the scheduled tasks running a test will be displayed

· Cleanup - only the scheduled tasks running a cleanup action will be displayed

· Show main - only the scheduled tasks running using the main application will be displayed

· Run in background - only the scheduled tasks running in background will be displayed

· Windows - only the scheduled tasks using the Windows scheduler will be displayed

· Shutdown - only the scheduled tasks running at shutdown will be displayed

· Jobs - only the scheduled tasks running jobs will be displayed

· Tags - only the scheduled tasks running tasks will be displayed

· OTB - only the scheduled tasks running One Touch Backup will be displayed

· All jobs - only the scheduled tasks configured to run All jobs will be displayed
 
In the scheduled tasks list, you can drag any column to group the tasks by that column.

· Enabled - if the checkbox is marked then the scheduled task will run, if is unchecked it will not
be executed

· Name - displays the name of the backup job as defined in its backup properties

· Job Type - displays the type of the job: job or tag

· Scheduler - displays the scheduler used

· Run  in  -  displays  if  the  scheduler  will  be  run  using  main  application  or  command  line
application

· Action  -  shows  the  type  of  action  associated  with  the  scheduled  task  (default,  smart,  full,
differential, incremental, cleanup, test)

· Backup Type - shows the type of the backup configured to be executed

· Task file - displays the name of the task file as you can find it on your computer

· Status - displays the status of the scheduled task

· Next Run Time - calculates the date and time when the scheduled task will run next

· Last Run Time - shows the date and time when the scheduled task last ran

· Last Run Result - shows the status of the last scheduled action executed

· Schedule - shows the scheduler time and frequency

· User - shows the user name for which the job is scheduled to run
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The scheduled tasks in the list can be sorted by clicking on the column headers. The right-click menu
on the column header provides a handy way to show/hide unnecessary columns (except the Enabled
and Name columns which are grayed out).

You  can  also  schedule  a  task  from  the  Backup  Properties->Scheduler  window.  The  difference
between the two methods is that the Backup Properties->Scheduler window displays the scheduled
tasks only for the selected backup job, while Schedulers (F11) will show you the scheduled tasks for
all the backup jobs and tags.
 
Backup4all  uses  the  Windows  Task  Scheduler  in  order  to  run  the  scheduled  tasks  so  you  need  to
make sure that  the Task Scheduler service is  enabled  on your  computer.  Use  the  Windows  Help  in
order to find out more information about scheduling a task using the Task Scheduler. 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

 

5.4.1 General

This is the fist page of the Scheduler Properties window which appears when you click on the Add or
Edit button in the Scheduler window of Backup Properties or in the global Scheduler (F11) page of the
application. This allows you to add or edit a scheduled task for the current backup job.
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Run

· Job - This option allows you to schedule a backup job from the ones already defined. You can
choose the backup job to execute from the drop-down list.

· Tag - This allows you to schedule a tag. In the drop-down list, select a tag to execute but you
can't select an action. Each backup job containing the tag will perform the action you select.

· All jobs  -  This  allows  you to  run all  backup  jobs.  The backup  jobs  will  be  executed  one  after
another.

· One Touch Backup -  If  this  is  selected,  the scheduled  task  will  run the  backup  using  settings
from File->Options->Backup->Backup on demand.  If the option Enable "One Touch Backup"
support is not enabled, the scheduled task will not run.

Execute

Show main application
Use this  option  if  you want  the  main  application  window to  be  shown when the  scheduled  task  is
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executed. By default, this option is unchecked and the scheduled tasks will run in background. 

Close after run
If this option is checked, Backup4all will be closed after the task is executed.

Scheduler

With Windows scheduler

· Run only if  the user is  logged on -  the task will  run under  the  specified  user  account  only  if
there is an user logged on

· Run whether the user is logged on or not - the task will run even if there is no user logged on 
Password  -  press  this  button  to  set  the  Windows  login  password  for  the  specified  user

account 
At system shutdown - If this is selected, the task will  be executed when the shutdown command is
started.  Backup4all  intercepts the shutdown message and there is  no way to  know  if  a  restart  or  a
shutdown  was  requested.  This  is  why  it  will  always  shutdown  your  computer  after  the  task  is
executed.

Priority

Indicates  the  task  priority.  Move  the  cursor  to  right  or  left  in  order  to  increase  or  decrease  the
priority.

Notifications

Force all notifications to timeout - use this option to close all notification messages, even if they are
set to never expire.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

5.4.2 When

On this page you can set when do you want to execute the scheduled task.
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When to run

In this section you can specify the conditions that will trigger the task. Use the Add, Edit and Delete
buttons to manage the triggers for this task.
Pressing Add or Edit button will open the Trigger Properties window. 

When
Here you can select when to run the task: one time, daily,  weekly, monthly, at user logon or on
idle.
The Synchronize across time zones option allows you to run the scheduled backups at the same
hour if you change the time zone.
Select the recurrence option you want to use.
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· One time - select this option if you want the scheduler to be executed only one time

· Daily - select this option if you want the scheduler to be executed daily.
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· Weekly - select this option if you want the scheduler to be executed weekly on the days
you select.

· Monthly  -  select  this  option  if  you  want  the  scheduler  to  be  executed  monthly  on  the
months and days you select.
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· At user logon - select this option if you want the scheduler to be executed every time at
user logon.
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· On idle - select this option if you want the scheduler to be executed when the computer is
idle.

Advanced
On this page, you can set the expiration date and time or the repeat frequency.
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There are additional options in the Scheduler Properties, on "When" page:

Run task as soon as possible after a scheduled start is missed
Use this option to run missed tasks as soon as possible.

Start task only if the computer is on AC power
Select this option if you use a laptop and you want to run the task only if the AC cable is connected.

Wake the computer to run this task
Use this option to wake the computer from sleep mode at the scheduled time.

Start the task only if the computer is idle for
Use this  option  to  indicate  how  long  to  wait  when the  computer  is  idle  before  the  scheduled  task
starts.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

5.4.3 What

On this page you can set what action to be executed.
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What to execute

· Backup
Type

· Default - executes the default backup type defined in the backup job's properties

· Smart - executes a smart backup, no matter what the backup type defined in the backup
job is

· Full - executes a full backup, no matter what the backup type defined in the backup job is

· Differential  - executes a differential backup, no matter what the backup type defined in
the backup job is
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· Incremental  - executes an incremental backup, no matter what the backup type defined
in the backup job is

Clear backup before run
If  this  is  checked, Backup4all  will  first  delete the  ".bkc"  file  and  all  zip  files  associated  with  the
current backup job and after that execute the scheduled backup.

Erase disk before backup
This checkbox can be selected only if the backup destination is a CD/DVD or Blu-ray drive.

 

· Test - you can schedule a test operation instead of a backup. When Test is selected, the Backup

Numbers  box is  displayed .  You  can  type  in  there  the  backup  numbers  you
want to test. The order you type them in is the order they will be tested in. Use the * character
to test all backup numbers, or the # character to test only the last backup.

· Quick  Test  -  performs  a  test  operation  for  the  specified  backup  numbers,  without
calculating  the  CRC for  each file.  Only  the  existence  of  the  source  files  in  destination  is
verified.

 

· Repair - you can schedule a repair action to be executed. The missing or corrupted files from
destination will be backed up again.

· Repair catalog only - if this option is checked, only the backup catalog will be repaired, the
missing or corrupted files in destination will be removed from the backup catalog, so they
will be backed up again next time.

· Cleanup  -  at  the  scheduled  date  it  deletes  the  selected  backup  numbers.  When  Cleanup  is
selected, other options become available to filter the backup numbers that will be deleted:

· Newer than  -  if  checked backup numbers that  are newer  than  the  selected date will  be
deleted when the scheduled Cleanup operation runs

· Older  than  -  if  checked  backup  numbers  that  are  older  than  the  selected  date  will  be
deleted when the scheduled Cleanup operation runs

· Older than (fixed date) - backup numbers that are Older than a certain fixed date will be
deleted when the scheduled Cleanup operation runs

· Do not delete full backups - if  this is checked, the full  backups will  be kept even if  they
fall into the range of files filtered for deletion

· Do  not  delete  differential  backups  -  if  this  is  checked,  the  differential  backups  will  be
kept even if they fall  into the range of files filtered for deletion.  Note that  this  option is
available only when Do not delete full backups is  checked, because differential  backups
depend on full backups.

· Clear  the  destination  folder  -  Deletes  files  and  folders  that  should  not  be  in  the
destination folder. Only the files mentioned in backup catalog are kept.

· Restore - select this option if you want to schedule a restore action.

· Original location - use this option to restore files in the original location

· Other location - use this option to restore files in another location
Do not create drive letter folder  -  if  this  option is  checked,  when restoring to  another
location, the drive letter folder won't be created.
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· Restore the latest  version of all  files -  use this  option to restore the latest version of  all
files

· Restore all files as of - use this option to restore the files as they were on a specified date

· Restore backup numbers - use this option to restore one or more backup numbers

· Restore excluded and deleted files - if this option is checked, excluded and deleted files will
be also restored.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

5.5 File

5.5.1 Commands

File

New - creates a new backup job

· Open - creates a new backup job from the opened ".bkc" or ".ini" file

· Open from...  -  creates  a  new backup  job  from  the  opened  ".bkc"  or  ".ini"  file,  and  user  can
select  to  open  the  catalog  from multiple  locations  as:  Local  hard  drive,  Network,  FTP  server,
SFTP server, Azure Storage, Amazon S3 Storage, Google Cloud Storage, Google Drive, Dropbox,
Box, OneDrive, Hubic, HiDrive, S3 compatible Storage.

· Tools

· Plugins - opens the Manage Plugins window

· Erase Disc - opens the Erase CD, DVD or Blu-ray window
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· Getting Started - opens the Getting Started window

· Check for Updates - displays a window with the available updates 

· Import from version 9 - imports the backup jobs from version 9 of Backup4all

· Import from version 8 - imports the backup jobs from version 8 of Backup4all

· Import from version 7 - imports the backup jobs from version 7 of Backup4all

· Import from version 6 - imports the backup jobs from version 6 of Backup4all

· Import from version 5 - imports the backup jobs from version 5 of Backup4all

· Import from version 4 - imports the backup jobs from version 4 of Backup4all

· Licensing

· Buy Now - Purchase Backup4all product key online

· Change product key - Activate a different product key

· Register - Register product key

· Deactivate this product key - Remove the activations from this computer

· Reactivate - Reactivate this computer immediately
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· Help

· Backup4all Help - opens the Help file

· Support Request - starts a new email message that will be sent to the support team 

· Backup4all Forum - opens the Backup4all Support Forum in a new web browser tab.

· Options - opens the Options window

· Exit - exits the application, same as the keyboard shortcut Alt+F4

Jobs
The Jobs toolbar contains  the  most  important  Backup4all  buttons  which can  be  applied  on backup
jobs.

Manage - this group includes the buttons necessarily to manage the backup jobs.

 

· New - starts the New Backup Wizard

· Properties - opens a dialog to edit the backup job configuration

· Open - creates a new backup job from the opened ".bkc" or ".ini" file

· Open from... - creates a new backup job from the opened ".bkc" or ".ini" file, and user can
select to open the catalog from multiple locations as: local hard drive, network, FTP, SFTP,
Azure,  Amazon  S3,  Google  Cloud  Storage,  Google  Drive,  OneDrive,  Box,  Dropbox,  Hubic,
HiDrive or S3 Compatible.

· Delete  -  removes  the  current  selected  backup,  same  as  the  toolbar  button  Delete  or  the
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keyboard shortcut Ctrl+Del

· Duplicate - duplicates the selected backup job, same as pressing the keyboard shortcut Ctrl+L

· Create Shortcut...  creates a  shortcut to a  backup job or  tag  (for  easy  backup  execution  from
outside the program) on your desktop, quick launch or other location

· Destination Folder - opens the backup destination folder

· Scheduler - opens the scheduler page, showing all scheduled tasks for the selected job 

· Refresh - reloads the selected backup job

· Refresh all jobs - reloads all backup jobs

Execute - this group includes the buttons for all actions that can be executed on a backup job

· Backup

· Backup - performs the backup type defined in Backup Properties

· Full - performs a full backup regardless of the backup type defined in Backup Properties

· Differential  -  performs  a  differential  backup  regardless  of  the  backup  type  defined  in
Backup Properties

· Incremental  -  performs an  incremental  backup  regardless  of  the  backup  type  defined  in
Backup Properties

· Restore

· Restore - starts the Restore wizard

· Latest  version  -  restores  the  latest  version  to  its  original  location  without  showing  the
Restore wizard

· Latest version to... - restores the latest version to a specified location without showing the
Restore wizard

· Repair

· Repair - starts the backup repair

· Repair Catalog Only - starts the repair of the backup catalog

· Quick Repair - starts a quick backup repair, without calculating the CRC for each file

· Quick  Repair  Catalog  Only  -  starts  the  quick  repair  of  the  backup  catalog,  ,  without
calculating the CRC for each file

· Test  

· Test - opens the Test backup window

· Quick Test - opens the Test backup window

· Clean 

· Clean backups - opens the Clean backup window

· Clean destination folder - will delete from the backup destination, all files which does not
belong to the backup job

Views
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· Explore - switches to Explore View

· Backup - switches to Backup View

· Statistics - switches to Statistics View

· Progress - switches to Progress View

Tools

· View Log

· Last Backup Log - shows the latest backup log for the selected backup job.  If there is no log
file, the menu is disabled.

· Last Restore Log - shows the latest restore log for the selected backup job.  If there is no
log file, the menu is disabled.

· Last Test Log - shows the latest test log for the selected backup job.  If there is no log file,
the menu is disabled.

· Last Cleanup Log - shows the latest cleanup log for the selected backup job.  If there is no
log file, the menu is disabled.

· Last Statistics Log - shows the latest statistics log for the selected backup job.  If there is no
log file, the menu is disabled.

· History - opens the history page for that job

· Open Log Folder - opens the folder where all log files are stored

· Messages  -  opens  the  application  messages  popup.  If  there  are  no  messages,  the  button  is
disabled.

Explore View

Files & Folders

· Restore
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· Latest Latest Version - restores the latest version of the selected file/folder to its original
location without showing the Restore wizard

· Latest  Latest  Version  to...  -  restores  the  latest  version  of  the  selected  file/folder  to  a
specified location without showing the Restore wizard

· Expand All - expands all folders

· Expand Subfolders - expands subfolders for the selected folder

· Collapse All - collapses all folders

· Exclude from Sources - excludes from backup sources the selected file/folder

File Versions

· Restore

· Restore Version - restore the selected file version to the original location

· Restore Version to... - restore the selected file version to a specified location

· Open - open the selected file version

· View with Notepad - open the selected file version with Notepad

· Compare with Source - compare the selected file version with the current source file 

· Compare Versions - compare two file versions

Layout

· Versions Pane: if pressed, will display the version pane on the bottom of the Explore view

Filter

 - show/hide the new files to be backed up

 - show/hide the unchanged files

 - show/hide the modified files

 - show/hide the excluded files

 - show/hide the deleted files

Backup View

Backups

· Restore
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· Restore - restore the selected version to the original location

· Restore to... - restore the selected version to a specified location

· Test - test the selected backup version

· View Backup Log - open the backup log for that backup execution

Files & Folders

· Restore

· Restore - restore the selected file to the original location

· Restore to... - restore the selected file to a specified location

· Open - open the selected file

· View with Notepad - open the selected file with Notepad

· Expand Folder - expands all folders from the selected backup

· Expand All - expands all folders

· Collapse All - collapses all folders

Layout

· Versions Pane: if pressed, will display the version pane on the bottom of the Explore view 

Filter

 - show/hide files which were added in the selected backup execution

 - show/hide files which were modified in the selected backup execution

 - show/hide files which were excluded in the selected backup execution

 Filter files - open the Filters window 

Tags
The Tags toolbar contains all the Backup4all buttons which can be applied on backup tags.

Manage
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· New - creates a new tag in the left side list

· Rename - renames a tag from the left side list

· Delete - deletes a tag from the left side list

· Create Shortcut... - creates a shortcut to a backup job or tag (for easy backup execution from
outside the program) on your desktop, quick launch or other location

Execute

· Backup

· Backup  -  performs  the  backup  type  defined  in  Backup  Properties  for  all  jobs  containing
that tag

· Full - performs a full backup for all jobs containing that tag, regardless of the backup type
defined in Backup Properties

· Differential - performs a differential backup for all  jobs containing that  tag,  regardless of
the backup type defined in Backup Properties

· Incremental - performs an incremental backup for all  jobs containing that  tag,  regardless
of the backup type defined in Backup Properties

· Backup All Jobs - will back up all jobs with the backup type defined in Backup Properties

· Restore

· Restore -  restores  the  latest  version  to  its  original  location  without  showing  the  Restore
wizard, for all jobs containing that tag

· Restore  to...    -  restores  the  latest  version  to  a  specified  location  without  showing  the
Restore wizard, for all jobs containing that tag

· Repair

· Repair - starts the backup repair for all jobs containing that tag

· Repair Catalog Only - starts the repair of the backup catalog for all jobs containing that tag

· Test

· Test Latest Version - starts the test for the latest backup version of all jobs containing that
tag

· Test All Versions - starts the test for all backup versions of all jobs containing that tag

· Clean - opens the Clean tag window

Layout
This page contains the buttons for the Backup4all interface.
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General

· Navigation Pane - indicate how the left side navigation pane is displayed

· Expanded - shows the navigator pane expanded

· Collapsed - shows the navigator pane collapsed

· Off - hides the navigator pane

· Restore Default Layout - restores the default layout of Backup4all

Jobs

· View as - indicate how backup jobs are displayed

· Card - shows the backup jobs as cards

· List - shows the backup jobs in a list

· Details Pane - indicates how the Details view pane is displayed

· Right - shows the job view pane on the right

· Bottom - shows the job view pane on the bottom

· Off - hides the job view pane

Control
This page contains the buttons for suspend

System

· Suspend System -  if  pressed,  all  actions  in  progress  will  be  paused.  No  other  actions  can  be
started until the system is resumed

· Cancel All Running - if pressed, all running actions will be canceled

· Stop All Running - if pressed, all running actions will be stopped

· Scheduled Suspend - when pressed, the Scheduled Suspend window (from File->Options) will
be opened, so you can manage the scheduled suspend intervals

Note: One or more of the features mentioned in this chapter might not be available in your edition.
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The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

5.5.2 Erase CD/DVD/Blu-ray

The Erase CD/DVD/Blu-ray window can be opened from the File->Tools->Erase disc menu item.

 

When the window is shown, devices capable of writing to CD, DVD or Blu-ray disc are listed in it. The
first device from the list is selected by default.
A summary of properties is shown for each device (calculated by Backup4all's internal burner):

· Maximum read speed of device - shows the maximum reading speed of the device (kb/s)

· Maximum write speed of device - shows the maximum writing speed of the device (kb/s)

· Reading capabilities - displays a list of media the device can read from

· Writing capabilities - displays a list of media the device can write to

· Disk type - shows the type of media inserted

· Sessions on disk - number of sessions on the disk

· Disk free space - free space on disk

· Disk size - total size of disk

· Maximum read speed of media - maximum reading speed of media

· Maximum write speed of media - maximum writing speed of media
When an erase is performed, the progress bar shows the percentage of the operation completed.
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Options

Load
Closes the CD/DVD/Blu-ray tray. The button is enabled only when a device is selected.
 
Eject
Opens the CD/DVD/Blu-ray tray. The button is enabled only when a device is selected.
 
Refresh list
Will reload all information about the CD/DVD/Blu-ray burners.

Quick erase
Erases the CD/DVD/Blu-ray disc. Additional options are available in the combo:

· Quick  erase  -  disk  appears  to  be  empty,  but  the  data  is  not  physically  erased  (selected  by
default)

· Full erase - will physically erase all data on disk. Takes longer to perform

Close
Closes the Erase CD/DVD/Blu-ray window.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

5.5.3 Plugins

Backup4all includes a plugin manager that can be found in File->Tools->Plugins. The Manage Plugins
window allows you to download, add, remove, enable or disable the Backup4all plugins.
After installing a plugin,  you can use it  on the What do you want to backup page when creating a
new  backup  job  using  the  New  Backup  Wizard  or  on  the  Sources  page  using  Advanced  mode
(Backup Properties).
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Refresh plugin list
Pressing this button will download and show the list of all available plugins available on our website.

Install
This button appears when you select a plugin which is not installed on your computer. Pressing the
Install button will download and enable the selected plugin.

Uninstall
This  button  appears  when  you  select  a  plugin  which  is  installed  on  your  computer.  Pressing  the
Uninstall button will delete the selected plugin from your computer.
If you try to uninstall a backup plugin which is in use by any of the backup jobs from Backup4all, you
will get a warning message that the plugin cannot be deleted as it is used by a backup job.

Enable
This button appears when you select a plugin which is installed but not enabled on your computer.
Pressing the Enable button will activate the selected plugin on your computer so it will  be visible in
the New Backup Wizard.

Disable
This  button  appears  when  you  select  a  plugin  which  is  installed  and  enabled  on  your  computer.
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Pressing  the  Disable  button  will  disable  the  plugin,  it  will  not  appear  in  the  New  Backup  Wizard
anymore, but the plugin remains on your computer.

Load plugin ...
Press this button to install a new backup plugin. 
You will  be asked to select the plugin file location from your computer.  Multiple plugin files can be
selected and open. 

Suggest a plugin
Pressing  this  button  will  open  a  website  page  in  browser,  were  you  can  suggest  us  the  plugin  to
create.

Close
Press this button to close the Manage Plugins window.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

5.5.4 Logging

Backup4all provides a  log engine that  helps  you track the backup, restore, test,  clean and calculate
statistics operations. It is composed of four subsystems: backup logging, restore logging, test logging
and cleanup logging. Log files are accessible from the Jobs tab, History section. 
 
For each operation the system logs:

· start time and date

· the operation

· errors or warnings

· end time and date

The File->Options->Logs and history configuration window provides additional options that you can
select to further customize the logging process.

Log Overview

Backup4all  generates  log  files  in  various  instances.  Some  logs  deal  with  the  running  components
(applications)  of  Backup4all,  while  others  are  generated  every  time  a  backup  related  action  is
performed.  These  logs  are  generated  during  backup,  testing,  restoring,  cleanup  and  statistics
calculation.

The format of an action related log file is as follows:

<job-name>_YYYYMMDDHHMMSS.<action>.log

<job-name> - refers to the specific job on which the action was executed
YYYYMMDDHHMMSS  -  is  the  year,  month,  day,  hour,  minute  and  second  in  which  this  log  was
generated
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<action> - refers to the action (backup, restore etc.)

The easiest way to examine specific logs is to right click on a job in the Main Window, go to Job Logs
and select the latest log of a certain type from the list. Alternatively, from the Jobs tab, you may click
on Open Log Folder. This will open the log folder in Explorer. The log folder contains all the logs that
Backup4all has created. The tags in the file names are helpful for sorting the logs and finding specific
ones.

Content

Log detailed information
If this option is enabled, the logs will contain information about every file used in the backup, restore
or test process.

Include summary in log
If this option is checked, the logs will include all the text available in the Summary view.

Log folder

After a long period the application will generate a large number of log files. Since all the log files are
stored  in  the  same  folder,  the  system  has  an  option  to  limit  the  size  of  the  log  folder.  Just  select
Restricted to  and choose a Size  and Unit  for the log folder (default is  200MB).  If  the log file  of the
running  backup  job is  larger  than  the  limit,  it  will  still  be  stored  in  the  log  folder.  When  the  same
operation will run again, the previous log file will be deleted.
If you want to keep all log files no matter the size, select the Unlimited size option. 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

5.5.5 Import

The  Import  window  can  be  opened  from  the  File->Tools  menu.  Depending  on  your  previous
Backup4all version, you can select one of these options: 

· Import from version 9

· Import from version 8

· Import from version 7

· Import from version 6

· Import from version 5

· Import from version 4
 

The Import from a previous version option also appears when you run for the first time a newly
installed Backup4all major version on a computer where a previous major version of Backup4all is
installed. If you select this option and no previous major versions were installed, you'll be informed
that there are no backup jobs to import.
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If you had previous major versions installed, you'll have the option to import the backup jobs from a
previous major version of Backup4all.
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Select ini files to import

When  the  Import  window  is  opened,  a  list  with  all  the  .ini  files  found  from  a  previous  version  is
displayed and you can check the ones that you want to import in the backup list of the new version.
For your convenience, you can use the Uncheck all  or Check all  options if  you have lots  of .ini  files
and want to deselect/select them all at once. Note that the backup jobs will  be actually copied into
the latest version, thus you will not be able to use them in the previous version. After the import, the
backup catalog in the old version will be renamed to .upg. If for any reason you want to return to the
previous version of  the application,  just  remove the .upg suffix   from the catalog file  name and you
can open it back with Backup4all.

There are three main columns in the display list:

· Import - if the checkbox is marked, the backup job will be imported

· Name - it displays the name of the backup job as it was defined in the previous version

· Scheduled - it shows if the respective backup job was a scheduled backup or not

· Tags - shows the tag name the backup job belonged to

Note: the old backup groups will be now converted to tags in order to keep them organized.
 
Scheduler

If  the  backup  jobs  were  scheduled  to  run  in  the  previous  version,  when  importing  the  scheduled
tasks,  you will  be  asked  to  type  the  password  for  your  current  Windows  login  account  in  order  to
have them correctly set up.
 
Tip:

· if you want to open an .ini file of a current version instead, you can use the File->Open (Ctrl+O)
option - this will recreate the backup job opened (if is not in the backup list already) 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

5.5.6 Check for updates
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You can manually check for updates from File->Tools->Check for Updates. 
In the Updates window, you can see if there are any updates available and what is new in the update.

5.5.7 Keyboard Shortcuts

Keyboard shortcuts configured in Backup4all:

 New backup wizard - CTRL + N

 Open backup - CTRL + O

 Backup job properties - CTRL + P

 Explore - F2

 Backup - CTRL + F2

 Statistics - F3
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 Progress

 Refresh - F5

 Execute backup - F6

 Restore - F7

 Pause - CTRL + F8

 Stop - CTRL + S

 Cancel - F8

 Test - F9

Scheduler - F11

 Show New Files - CTRL + 1

 Show Unchanged Files - CTRL + 2

 Show Modified Files - CTRL + 3

 Show Excluded Files - CTRL + 4

 Show Deleted Files - CTRL + 5

 Expand All - CTRL + 6

 Collapse All - CTRL + 7

 Focus menu - F10
 
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

5.6 System Tray

When is Backup4all shown in the system tray?

Backup4all icon is also shown in tray if the Show tray icon  option from File->Options->Startup and
updates is checked. If this option is selected, the tray icon will remain in taskbar after you close the
main interface. This way you can easily open the main interface.
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The right-click menu of the tray icon allows to:

· Show Backup4all - shows Backup4all's main window

· Suspend system - will  pause all  the Backup4all  activity,  all  actions in progress will  be paused
too

· Stop all running - will stop all running actions

· Cancel all running - will cancel all running actions

· Show messages - will display all active notification messages

The left click menu of the tray icon displays the following options:

· Backup4all  -  will  open the  main  interface.  If  there  are  backup  jobs  in  progress,  there  is  be  a
message indicating how many jobs are active.

· Suspend sustem - will suspend all the application activity, all actions in progress will be paused
too

· Cancel all running - will stop all running actions

· Stop all running - will cancel all running actions

· Show messages - will display the Notifications window

If  the  system  is  suspend,  a  message  will  appear  on  the  Backup4all  interface:  Backup  system  is
paused. No actions will be executed while the system is paused.
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Tray Icon Hint:
When backups are executed, restored or tested, the tray icon is  animated and the name of the
backup jobs are shown in the hint along with the current operation.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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6 New Backup Wizard

6.1 Overview

Using the New Backup Wizard you can easily create a new backup job. The steps in wizard must be
followed in the given order.

If  you  want  to  create  a  new  backup  job  using  advanced  options,  you  can  do  that  by  pressing  the
Advanced  mode  button  that  will  open  the  Backup  Properties  window.  All  settings  from  the  New
Backup Wizard are included in the Backup Properties.
 
The New Backup Wizard will be used to create new backup jobs, if  the Use New Backup Wizard to
create backup jobs option (from the Other  section in File->Options->Preferences) is checked. If that
option is not checked, the Backup Properties will be used to create new backup jobs.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

6.2 Destination - Where do you want to save your backup?

6.2.1 Local hard drive

You can use a valid local destination for your backup: hard disk drives, floppy disk drives or zip drives.
The Local hard drive option is selected by default when you define a new backup. From the Drive list,
you can select one of your hard disk partitions. By default, the largest partition is selected.
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In  the Folder field,  there is  a  default  folder destination (\My Backup4all  9\<user  name>\).  You can
click  the  Browse  button  and  select  a  destination  folder  of  your  choice  where  the  backup  will  be
stored.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.2.2 External hard drive

You can use an external hard drive as backup destination. 
From the Drive list, you can select one of your external hard disks. By default, the first external drive
is selected.
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In  the  Folder  field  you  can  type  a  destination  folder  or  you  can  click  Browse  button  to  select  an
existing folder where the backup will be stored.
If the destination drive is missing when running the backup, an error message is shown. The user can
choose Cancel  to stop the backup process or  Retry  to check the drive again. If  the scheduler starts
the backup then the system will retry as many times as set in the File->Options->Backup window and
if still not possible to access the drive it will abort the backup process.

Rotate disks option is used if you want to rotate the destination drives, backing up alternatively on
them.  Selecting  that  option  will  automatically  disable  the  Use  local  catalogs  option  from  Backup
Properties->Advanced.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.2.3 CD, DVD or Blu-ray

Backup4all supports CD, DVD and Blu-ray as backup destinations. 
From  the  Drive  list,  you  can  select  one  of  your  optical  drives.  By  default,  the  first  optical  drive  is
selected.
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In  the  Folder  field  you  can  type  a  destination  folder  or  you  can  click  Browse  button  to  select  an
existing folder where the backup will be stored.
If the destination drive is missing when running the backup, an error message is shown. The user can
choose Cancel  to stop the backup process or  Retry  to check the drive again. If  the scheduler starts
the backup then the system will retry as many times as set in the File->Options->Backup window and
if still not possible to access the drive it will abort the backup process.

Erase before writing option can be used to erase the existing disk in destination before running the
backup. That is useful if you want to reuse the same disk as backup destination.
Rotate disks option is used if you want to rotate the destination drives, backing up alternatively on
them.  Selecting  that  option  will  automatically  disable  the  Use  local  catalogs  option  from  Backup
Properties->Advanced.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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6.2.4 Removable

Backup4all supports removable drives as backup destinations. 
From the Drive list, you can select one of your removable drives. By default, the first removable drive
is selected.
 

 

In  the  Folder  field  you  can  type  a  destination  folder  or  you  can  click  Browse  button  to  select  an
existing folder where the backup will be stored.
If the destination drive is missing when running the backup, an error message is shown. The user can
choose Cancel  to stop the backup process or  Retry  to check the drive again. If  the scheduler starts
the backup then the system will retry as many times as set in the File->Options->Backup window and
if still not possible to access the drive it will abort the backup process.

Rotate disks option is used if you want to rotate the destination drives, backing up alternatively on
them.  Selecting  that  option  will  automatically  disable  the  Use  local  catalogs  option  from  Backup
Properties->Advanced.

Lock the destination to this removable drive
When disconnecting and reconnecting a removable drive, your computer may not assign it the same
drive  letter.  If  the  drive  letter  was  changed,  the  backup  might  fail  because  Backup4all  is  trying  to
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backup to the same old drive letter which probably does not exist.
Use this option if you want Backup4all to detect the removable drive after its own serial number and
automatically change the backup destination according with the new drive letter.
You should not check this option if you use a rotation backup scheme with two or more removable
hard drives. 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.2.5 Network drives

Backup4all supports mapped network drives as backup destinations. 
From the Drive list, you can select one of the available network drives. By default, the first network
drive is selected.
 

 

In  the  Folder  field  you  can  type  a  destination  folder  or  you  can  click  Browse  button  to  select  an
existing folder where the backup will be stored.
If the destination drive is missing when running the backup, an error message is shown. The user can
choose Cancel  to stop the backup process or  Retry  to check the drive again. If  the scheduler starts
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the backup then the system will retry as many times as set in the File->Options->Backup window and
if still not possible to access the drive it will abort the backup process.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.2.6 Network

You can use a network destination for your backup by selecting the Network option on the Where do
you want to save your backup? page.
 
 

Click the Browse  button and go through the  My Network  Places  to  select  a  destination where  the
backup will be stored.

You can also enter network paths in the Folder field. Only a full path is allowed. For example, this is a
valid path: \\Backup_Server\PC1\Backup

Make sure you can write in the destination and in the selected folder (you have the proper rights and
the media  is  not  write-protected)  before finishing the backup configuration.  You can enter  an User
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name and Password to access the network destination if it requires authentication. 

If the destination is missing (when the network is disconnected), an error message is shown.

 
The  user  can  choose Cancel  to  stop the  backup  process  or  Retry  to  check  the  network  connection
again. If the scheduler starts the backup then the system will  retry as many times as set in the File-
>Options->Backup window and if still is not possible to access the network destination, it will  abort
the backup process.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.2.7 Online

6.2.7.1 FTP

Backup4all  supports  backing  up  to  a  remote  computer  or  device  using  FTP  (File  Transfer  Protocol)
connection. This is a practical backup destination because the backed up data can be easily accessed
from any other computer with an Internet connection. Select the FTP server option from the Where
do you want to save your backup? section to be able to configure the backup to FTP.
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Use configuration
You can select an already defined FTP configuration given that you added one in the File->Options-
>Online  connections->FTP  window.  All  the  fields  will  be  filled  with  the  information  from  the
configuration file. If no configuration was previously defined, you will have to enter the configuration
settings. Check the Lock checkbox to make this configuration uneditable and responsive to changes
made  to  the  defined  configuration  file.  If  you  leave  it  unchecked,  then  this  configuration  will  be
considered to be custom.

Host / Port
In this field you have to enter the name or IP address for the FTP server and a port if different than
the  default  FTP  port  (21).  The format  is  host:port;  e.g.  ftp.Backup4all.com:1002  will  backup  to  ftp.
Backup4all.com connecting through port 1002.

Folder
Enter  a  folder  name where  the  backup  files  will  be  stored  on  the  remote  computer  via  FTP.  If  the
folder does not exist, a new one is created with that name. If that field is left blank, Backup4all will
automatically create a folder using the name of the backup job and place the backup files in there.

User
In this field you can enter the user name for the FTP server.
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Password
Type the password used for FTP server access.

There are FTP  servers  that  allow anonymous  access  (public  FTP  servers).  You  can  connect  to  these
types of FTP servers using as user name Anonymous and your email  address as  password.  It  is  not
recommended to backup important files to public FTP servers.

By pressing the Test button you can check to see if the settings you have entered are correct. If the
test was successful, The ftp connection was tested successfully message will be displayed.

Save configuration - pressing this button will save the online configuration so you can use it again for
other backup jobs. To view/edit the saved configurations, go to File->Options->Online connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.2.7.2 SFTP

Backup4all  supports  backing  up  to  a  remote  computer  or  device  using  SFTP  (SSH  File  Transfer
Protocol) connection. This is a practical backup destination because the backed up data can be easily
accessed from any other computer with an Internet connection. Select the SFTP server  option from
the Where do you want to save your backup? section to be able to configure the backup to SFTP.
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Use configuration
You can select an already defined SFTP configuration given that you added one in the File->Options-
>Online  connections->SFTP  window.  All  the  fields  will  be  filled  with  the  information  from  the
configuration file. If no configuration was previously defined, you will have to enter the configuration
settings. Check the Lock checkbox to make this configuration uneditable and responsive to changes
made  to  the  defined  configuration  file.  If  you  leave  it  unchecked,  then  this  configuration  will  be
considered to be custom.

Host / Port
In this field you have to enter the name or IP address for the SFTP server and a port if different than
the default SFTP port (22). The format is host:port; e.g. Backup4all.com:22 will backup to Backup4all.
com connecting through port 22.

Folder
Enter  a  folder name where the backup files will  be stored on the remote computer via SFTP.  If  the
folder does not exist, a new one is created with that name. If that field is left blank, Backup4all will
automatically create a folder using the name of the backup job and place the backup files in there.

User
In this field you can enter the user name for the SFTP server.
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Password
Type the password used for SFTP server access.

There are SFTP servers that allow anonymous access (public SFTP servers). You can connect to these
types of SFTP servers using as user name Anonymous and your email address as password. It is not
recommended to backup important files to public SFTP servers.

By pressing the Test button you can check to see if the settings you have entered are correct. If the
test was successful, The SFTP connection was tested successfully message will be displayed.

Save configuration - pressing this button will save the online configuration so you can use it again for
other backup jobs. To view/edit the saved configurations, go to File->Options->Online connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

6.2.7.3 Azure

Backup4all  supports  backing  up  to  Azure  remote  server.  This  is  a  practical  backup  destination
because  the  backed  up  data  can  be  easily  accessed  from  any  other  computer  with  an  Internet
connection. Select the Azure  option from the Where do you want to save your backup? section to
be able to configure the backup to Azure.
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Use configuration
You can select an already defined Azure configuration given that you added one in the File->Options-
>Online  connections->Azure  window.  All  the  fields  will  be  filled  with  the  information  from  the
configuration file. If no configuration was previously defined, you will have to enter the configuration
settings. Check the Lock checkbox to make this configuration uneditable and responsive to changes
made  to  the  defined  configuration  file.  If  you  leave  it  unchecked,  then  this  configuration  will  be
considered to be custom.

Account name
In this field you have to enter the Azure account name.

Key
Type the key for your Azure account
If the key is Shared Access Signature, you need to also select that option.

Container
In this field you can type the Azure container name where the backup files will be uploaded.

Folder
Enter a folder name where the backup files will be stored on the Azure server. If the folder does not
exist,  a  new one  is  created with  that  name.  If  that  field  is  left  blank,  Backup4all  will  automatically
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create a folder using the name of the backup job and place the backup files in there.

By pressing the Test button you can check to see if the settings you have entered are correct. If the
test was successful, The Azure connection was tested successfully message will be displayed.

Save configuration - pressing this button will save the online configuration so you can use it again for
other backup jobs. To view/edit the saved configurations, go to File->Options->Online connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

6.2.7.4 Amazon S3

Backup4all  supports  backing  up  to  Amazon  S3.  This  is  a  practical  backup  destination  because  the
backed up data can be easily accessed from any other computer with an Internet connection. Select
the  Amazon  option  from  the  Where  do  you  want  to  save  your  backup?  section  to  be  able  to
configure the backup to Amazon.

Use configuration
You  can  select  an  already  defined  Amazon  configuration  given  that  you  added  one  in  the  File-
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>Options->Online  connections->Amazon  window.  All  the  fields  will  be  filled  with  the  information
from  the  configuration  file.  If  no  configuration  was  previously  defined,  you  will  have  to  enter  the
configuration  settings.  Check  the  Lock  checkbox  to  make  this  configuration  uneditable  and
responsive  to  changes  made  to  the  defined  configuration  file.  If  you  leave  it  unchecked,  then  this
configuration will be considered to be custom.

Access key ID 
In this field you have to enter the access key ID for your Amazon account.

Secret key
Type here the secret access key for your account.

Region
Select a region from the list, where your backups will be stored.

Bucket
Type the bucket name you want to use as backup destination.

Folder
Enter a folder name where the backup files will be stored on Amazon. If the folder does not exist, a
new one is  created with that  name. If  that  field  is  left  blank,  Backup4all  will  automatically  create  a
folder using the name of the backup job and place the backup files in there.

Storage class
Here you can select a different storage class than the default one you configured in your account. 

By pressing the Test button you can check to see if the settings you have entered are correct. If the
test was successful, The Amazon connection was tested successfully message will be displayed.

Save configuration - pressing this button will  save the online configuration, so you can use it  again
for  other  backup  jobs.  To  view/edit  the  saved  configurations,  go  to  File->Options->Online
connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

6.2.7.5 Google Cloud Storage

Backup4all  supports  backing  up  to  Amazon  S3.  This  is  a  practical  backup  destination  because  the
backed up data can be easily accessed from any other computer with an Internet connection. Select
the  Amazon  option  from  the  Where  do  you  want  to  save  your  backup?  section  to  be  able  to
configure the backup to Amazon.
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Use configuration
You  can  select  an  already  defined  Amazon  configuration  given  that  you  added  one  in  the  File-
>Options->Online  connections->Amazon  window.  All  the  fields  will  be  filled  with  the  information
from  the  configuration  file.  If  no  configuration  was  previously  defined,  you  will  have  to  enter  the
configuration  settings.  Check  the  Lock  checkbox  to  make  this  configuration  uneditable  and
responsive  to  changes  made  to  the  defined  configuration  file.  If  you  leave  it  unchecked,  then  this
configuration will be considered to be custom.

Access key ID 
In this field you have to enter the access key ID for your Amazon account.

Secret Access key
Type here the secret access key for your account.

Region
Select a region from the list, where your backups will be stored.

Bucket
Type the bucket name you want to use as backup destination.
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Folder
Enter a folder name where the backup files will be stored on Amazon. If the folder does not exist, a
new one is  created with that  name. If  that  field  is  left  blank,  Backup4all  will  automatically  create  a
folder using the name of the backup job and place the backup files in there.

By pressing the Test button you can check to see if the settings you have entered are correct. If the
test was successful, The Amazon connection was tested successfully message will be displayed.

Save configuration - pressing this button will  save the online configuration, so you can use it  again
for  other  backup  jobs.  To  view/edit  the  saved  configurations,  go  to  File->Options->Online
connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

6.2.7.6 Google Drive

Backup4all  supports  backing up to Google Drive.  This is  a  practical  backup  destination because  the
backed up data can be easily accessed from any other computer with an Internet connection. Select
the Google Drive  option from the Where do you want to save your backup? section to be able  to
configure the backup to Google Drive.
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Use configuration
You can select an already defined Google  Drive configuration given that  you added one in the File-
>Options->Online  connections->Google  Drive  window.  All  the  fields  will  be  filled  with  the
information from the configuration file. If no configuration was previously defined, you will  have to
enter  the  other  details.  Check  the  Lock  checkbox  to  make  this  configuration  uneditable  and
responsive  to  changes  made  to  the  defined  configuration  file.  If  you  leave  it  unchecked,  then  this
configuration will be considered to be custom.

Authentication -  press  "Choose  account"  button  to  log  in  to  your  Google  Drive  account.  Here  you
need to authorize Backup4all application to view and manage files in your Google Drive account.

Account type - here you can choose "Personal" or "Team", depending on the account type you have.

Folder - In this field you have to select the folder where you want to store the backups. If no folder is
selected the backup will be stored in the root of your Google Drive account.

By pressing the Test button you can check to see if the settings you have entered are correct. If the
test was successful, The Google Drive connection was tested successfully message will be displayed.

Save configuration - pressing this button will  save the online configuration, so you can use it  again
for  other  backup  jobs.  To  view/edit  the  saved  configurations,  go  to  File->Options->Online
connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

6.2.7.7 Microsoft OneDrive

Backup4all  supports  backing  up  to  OneDrive.  This  is  a  practical  backup  destination  because  the
backed up data can be easily accessed from any other computer with an Internet connection. Select
the  OneDrive  option  from  the  Where  do  you  want  to  save  your  backup?  section  to  be  able  to
configure the backup to OneDrive.
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Use configuration
You  can  select  an  already  defined  OneDrive  configuration  given  that  you  added  one  in  the  File-
>Options->Online connections->OneDrive window. All  the fields will  be filled with the information
from  the  configuration  file.  If  no  configuration  was  previously  defined,  you  will  have  to  enter  the
other  details.  Check  the  Lock  checkbox  to  make  this  configuration  uneditable  and  responsive  to
changes made to the defined configuration file. If you leave it unchecked, then this configuration will
be considered to be custom.

Account type  -  here you can  choose "Personal"  or  "Business",  depending  on the  account  type  you
have.

Authentication - press "Choose account" button to log in to your OneDrive account. Here you need
to authorize Backup4all application to view and manage files in your OneDrive account.

Folder - In this field you have to select the folder where you want to store the backups. If no folder is
selected the backup will be stored in the root of your OneDrive account.

By pressing the Test button you can check to see if the settings you have entered are correct. If the
test was successful, "The OneDrive connection was tested successfully" message will be displayed.
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Save configuration - pressing this button will  save the online configuration, so you can use it  again
for  other  backup  jobs.  To  view/edit  the  saved  configurations,  go  to  File->Options->Online
connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

6.2.7.8 Box

Backup4all supports backing up to Box. This is a practical backup destination because the backed up
data  can  be  easily  accessed  from  any  other  computer  with  an  Internet  connection.  Select  the  Box
option  from  the  Where  do  you  want  to  save  your  backup?  section  to  be  able  to  configure  the
backup to Box.

Use configuration
You can select an already defined Box configuration given that you added one in the File->Options-
>Online  connections->Box  window.  All  the  fields  will  be  filled  with  the  information  from  the
configuration file. If no configuration was previously defined, you will have to enter the other details.
Check the Lock checkbox to make this configuration uneditable and responsive to changes made to
the defined configuration file. If you leave it unchecked, then this configuration will be considered to
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be custom.

Authentication  -  press  "Choose  account"  button  to  log  in  to  your  Box  account.  Here  you  need  to
authorize Backup4all application to read and write files/folders in your Box account.

Folder - In this field you have to select the folder where you want to store the backups. If no folder is
selected the backup will be stored in the root of your Box account.

By pressing the Test button you can check to see if the settings you have entered are correct. If the
test was successful, The Box connection was tested successfully message will be displayed.

Save configuration - pressing this button will  save the online configuration, so you can use it  again
for  other  backup  jobs.  To  view/edit  the  saved  configurations,  go  to  File->Options->Online
connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

6.2.7.9 Dropbox

Backup4all supports backing up to Dropbox. This is a practical backup destination because the backed
up  data  can  be  easily  accessed  from  any  other  computer  with  an  Internet  connection.  Select  the
Dropbox option from the Where do you want to save your backup? section to be able to configure
the backup to Dropbox.
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Use configuration
You  can  select  an  already  defined  Dropbox  configuration  given  that  you  added  one  in  the  File-
>Options->Online  connections->Dropbox  window.  All  the  fields  will  be  filled  with  the  information
from  the  configuration  file.  If  no  configuration  was  previously  defined,  you  will  have  to  enter  the
other  details.  Check  the  Lock  checkbox  to  make  this  configuration  uneditable  and  responsive  to
changes made to the defined configuration file. If you leave it unchecked, then this configuration will
be considered to be custom.

Authentication - press "Choose account" button to log in to your Dropbox account. Here you need to
authorize Backup4all application to read and write files/folders in your Dropbox account.

Folder - In this field you have to select the folder where you want to store the backups. If no folder is
selected the backup will be stored in the root of your Dropbox account.

By pressing the Test button you can check to see if the settings you have entered are correct. If the
test was successful, The Dropbox connection was tested successfully message will be displayed.

Save configuration - pressing this button will  save the online configuration, so you can use it  again
for  other  backup  jobs.  To  view/edit  the  saved  configurations,  go  to  File->Options->Online
connections.
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Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

6.2.7.10 HiDrive

Backup4all supports backing up to HiDrive. This is a practical backup destination because the backed
up  data  can  be  easily  accessed  from  any  other  computer  with  an  Internet  connection.  Select  the
HiDrive  option from the Where do you want to save your backup? section to be able  to configure
the backup to HiDrive.

 
Use configuration
You  can  select  an  already  defined  HiDrive  configuration  given  that  you  added  one  in  the  File-
>Options->Online  connections->HiDrive  window.  All  the  fields  will  be  filled  with  the  information
from  the  configuration  file.  If  no  configuration  was  previously  defined,  you  will  have  to  enter  the
other  details.  Check  the  Lock  checkbox  to  make  this  configuration  uneditable  and  responsive  to
changes made to the defined configuration file. If you leave it unchecked, then this configuration will
be considered to be custom.

Authentication - press "Choose account" button to log in to your HiDrive account. Here you need to
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authorize Backup4all application to read and write files/folders in your HiDrive account.

Folder - In this field you have to select the folder where you want to store the backups. If no folder is
selected the backup will be stored in the root of your HiDrive account.

By pressing the Test button you can check to see if the settings you have entered are correct. If the
test was successful, The HiDrive connection was tested successfully message will be displayed.

Save configuration - pressing this button will  save the online configuration, so you can use it  again
for  other  backup  jobs.  To  view/edit  the  saved  configurations,  go  to  File->Options->Online
connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

6.2.7.11 Hubic

Backup4all supports backing up to Hubic. This is a cloud backup destination and the backed up data
can be easily accessed from any other computer with an Internet connection. Select the Hubic option
from the Where do you want to save your backup? section to be able  to  configure  the  backup  to
Hubic.
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Use configuration
You can select an already defined Hubic configuration given that you added one in the File->Options-
>Online  connections->Hubic  window.  All  the  fields  will  be  filled  with  the  information  from  the
configuration file. If no configuration was previously defined, you will have to enter the other details.
Check the Lock checkbox to make this configuration uneditable and responsive to changes made to
the defined configuration file. If you leave it unchecked, then this configuration will be considered to
be custom.

Authentication -  press "Choose account"  button to log in to your Hubic account.  Here you need to
authorize Backup4all application to read and write files/folders in your Hubic account.

Folder - In this field you have to select the folder where you want to store the backups. If no folder is
selected the backup will be stored in the root of your Hubic account.

By pressing the Test button you can check to see if the settings you have entered are correct. If the
test was successful, The Hubic connection was tested successfully message will be displayed.

Save configuration - pressing this button will  save the online configuration, so you can use it  again
for  other  backup  jobs.  To  view/edit  the  saved  configurations,  go  to  File->Options->Online
connections.
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Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

6.2.7.12 S3 Compatible

Backup4all supports backing up to S3 Compatible. This is a practical backup destination because the
backed up data can be easily accessed from any other computer with an Internet connection. Select
the S3 Compatible option from the Where do you want to save your backup? section to be able to
configure the backup to S3 Compatible.

The  following  Amazon  S3  Compatible  clouds  can  be  selected  as  backup  destination:  Akaza,  Aruba
Cloud,  Backblaze  B2,  Caringo,  CenturyLink,  Cisco,  Claudian,  Connectia,  Constant,  DDN,  dinCloud,
Dream  Objects,  Dunkel,  T  Cloud,  Exoscale,  Green  Qloud,  HGST,  Hitachi,  HostEurope,  IDC  Frontier,
LeoNovus, Mandic, Minio, NetApp, NiftyClouds, Numergy, QNAP, Revera, Scality, Seeweb, SwiftStack,
ThinkOn, Tiscali,  vCloud Air, Verizon, Walrus and Zettagrid. You can also use a custom S3 Compatible
server by entering the specific information.

Use configuration
You can select an already defined S3 Compatible configuration given that you added one in the File-
>Options->Online  connections->S3  Compatible  window.  All  the  fields  will  be  filled  with  the
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information from the configuration file. If no configuration was previously defined, you will  have to
enter  the  other  details.  Select  the  Lock  checkbox  to  make  this  configuration  not-editable  and
responsive  to  changes  made  to  the  defined  configuration  file.  If  you  leave  it  unchecked,  then  this
configuration will be considered to be custom.

S3 server - Select from the dropdown list the S3 compatible server you want to use

Endpoint - Enter the endpoint for your selected server. For some servers, the endpoint will be filled
automatically, otherwise you need to manually enter it.

Access ID - In this field you have to enter the access key ID for your account.

Secret key - Type here the secret access key for your account.

Region - Select a region from the list, where your backups will be stored.

Signature - Select the signature version for your server. 

Bucket - Type the bucket name you want to use as backup destination.

Folder - In this field you have to select the folder where you want to store the backups. If no folder is
selected the backup will be stored in the root of your S3 Compatible account.

Storage class - Here you can select a  different  storage class  than the default  one you configured in
your account. 

By pressing the Test button you can check to see if the settings you have entered are correct. If the
test was successful, The S3 Compatible connection was tested successfully message will be displayed.

Save configuration - pressing this button will  save the online configuration, so you can use it  again
for  other  backup  jobs.  To  view/edit  the  saved  configurations,  go  to  File->Options->Online
connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

6.3 Sources - What do you want to backup?

In  the second step of the New Backup Wizard,  you must select  the files and folders  to be  used  by
Backup4all for the backup.
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On this page you can select the backup sources. You can make your own files & folders selection from
local hard drives, external hard drives, CD, DVD, Blu-ray, removable, network drives, network
locations or you can select a backup plugin from the Applications section. The plugin will
automatically select the source files to be backed up.

You can combine sources from local drives with backup plugins and with online sources.

Online connections available are: 

· LAN 

· FTP 

· SFTP

· Azure 

· Amazon S3

· Google Cloud Storage

· Google Drive 

· Microsoft OneDrive

· Box

· Dropbox 

· HiDrive

· Hubic

· S3 Compatible
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All  these  online  connections  can  be  used  as  backup  sources  to  copy  your  files  from  them  to
destination you prefer.
Press Define new button to add a new online connection which you can use as backup source.
All  online  connections  added  in  File->Options->Online  connections,  will  also  be  available  in  New
Backup Wizard, on Sources page.

Change source selection style - pressing this button will display the old source selection window.

 

You can:

· add a whole folder by pressing the Add folder button

· add one or several files by pressing the Add files button

· remove any file or folder by selecting it and pressing the Remove button

· exclude subdirectories and files from backup by un-checking the thickbox 

You must add at least one file or directory in order to continue with the next step of the wizard.

During backup, if the source drive is missing (when the network is disconnected for instance or CD/
DVD/Blu-ray is missing), a warning message is shown containing the list  of  missing drives.  The user
can  choose  Abort  to  stop  the  backup  process,  Retry  to  check  the  drive  again,  Ignore  to  mark  the
source folder as deleted and continue with the next sources. If the backup is started by the scheduler,
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then the system will try to access the sources for as many times as set in the File->Options->Backup
window. When all retries are done with no success, the backup will abort.

Tips:

· try to keep the number of checked files and folders greater than the number of unchecked files
and folders - backup process will run faster this way.

· you  can  add  files/folders  to  the  Sources  window  by  dragging  and  dropping  them  from  File
Explorer.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

6.3.1 Local

You can select the backup sources from the local hard drives, USB connected drives as external hard
drive or removable, CD/DVD/Blu-ray discs.



New Backup Wizard 199

Backup4all 9 User Manual Copyright © 2021 Softland

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.3.2 Network

You can add backup sources from network as:
- Network drives - here are the mapped drives
- Network - here you can browse for network shares or you can define a new network configuration,
by pressing the Define new button link

Configuration name - type a name for the new configuration

Network path  (UNC)  -  here  you  can  enter  network  path.  Only  a  full  path  is  allowed.  For  example,
suppose  \\Backup_Server\PC1 is  mapped  on your  workstation  as  drive  X,  then  the  following  paths
are both valid and indicate the same folder: \\Backup_Server\PC1\Backup

User - enter the user name used to access the network share
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Password - enter the password used to access the network share

Try Windows user and password first - If you are logged in as an user that has rights to write to the
specified network destination, you can check this option

Reconnect if already connected - You can set Backup4all  to disconnect  and reconnect the network
drive if already connected by checking this option

Test - press this button to test the network connection

Save - press this button to Save the new source you defined

The configurations defined can also be edit/deleted later if you right click the configuration entry in
New Backup Wizard or in File->Options->Online connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.3.3 Applications

You can use multiple application plugins as backup sources.
Press More applications button to install more plugins in Backup4all.
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Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.3.4 FTP

If you want to add backup sources from FTP, press Define new button under Online section.
Then enter the connection details for the FTP Server.



Backup4all 9202

Backup4all 9 User Manual Copyright © 2021 Softland

Host - In this field you have to enter the name or IP address for the FTP server.
Port - In this field you have to enter the port number if different than the default FTP ports (21).
Folder - Here you can enter the destination path if different than root.
User  -  If  this  is  a  private  FTP  server  (no  anonymous  access  allowed)  enter  the  user  name  for  your
account.
Password - In this field enter the password for the FTP server.

Test - press this button to test the FTP connection
Save - press this button to Save the new source you defined

The configurations defined can also be edit/deleted later if you right click the configuration entry in
New Backup Wizard or in File->Options->Online connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
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The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.3.5 SFTP

If you want to add backup sources from SFTP, press Define new button under Online section.
Then enter the connection details for the SFTP Server.

Host - In this field you have to enter the name or IP address for the SFTP server.
Port - In this field you have to enter the port number if different than the default SFTP ports (22).
Folder - Here you can enter the destination path if different than root.
User -  If  this  is  a  private SFTP server (no anonymous access  allowed) enter  the user name for  your
account.
Password - In this field enter the password for the SFTP server.

Test - press this button to test the SFTP connection
Save - press this button to Save the new source you defined

The configurations defined can also be edit/deleted later if you right click the configuration entry in
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New Backup Wizard or in File->Options->Online connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.3.6 Azure

If you want to add backup sources from Azure, press Define new button under Online section.
Then enter the connection details for your Azure account.

Account name - In this field you have to enter the name of your Azure account
Key - In this field you have to enter the key for your Azure account
Key  is  shared  Access  Signature  -  check  this  option  if  the  key  is  shared  access  signature.  A  shared
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access signature provides delegated access to resources in your storage account. This means that you
can grant a client limited permissions to your blobs, queues, or tables for a specified period of time
and with a specified set of permissions, without having to share your account access keys.
Container - In this field you have to enter the container you want to use as destination
Folder - In this field you have to enter the folder where you want to store the backups. If the folder
does not exist, it will be created.

Test - press this button to test the Azure connection
Save - press this button to Save the new source you defined

The configurations defined can also be edit/deleted later if you right click the configuration entry in
New Backup Wizard or in File->Options->Online connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.3.7 Amazon S3

If you want to add backup sources from Amazon S3, press Define new button under Online section.
Then enter the connection details for your Amazon S3 account.
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Access Key ID - In this field you have to enter the access key ID for your Amazon S3 account
Secret Key - In this field you have to enter the Secret Access Key for your Amazon S3 account
Region - select a region from the list, where your backups will be stored
Bucket - In this field you need to enter  the bucket to be used as destination. You can also create a
new  bucket  if  you  type  its  name  and  press  Create  button.  If  you  already  have  the  bucket  created
outside Backup4all, please make sure you also select the correct region for it.
Folder - In this field you have to enter the folder where you want to store the backups. If the folder
does not exist, it will be created.
Storage class

· Default - uses the default storage class configured in your Amazon S3 account

· Standard  -  this  option  offers  high  durability,  availability,  and  performance  object  storage  for
frequently accessed data.

· Standard - Infrequent Access Storage - is an Amazon S3 storage class for data that is accessed
less frequently, but requires rapid access when needed.

· One Zone - Infrequent Access Storage -  designed for customers who want a lower-cost option
for infrequently accessed data

· Reduced  redundancy  (not  recommended)  -  enables  customers  to  store  noncritical,
reproducible  data  at  lower  levels  of  redundancy  than  Amazon  S3’s  standard  storage.  It
provides  a  highly  available  solution for  distributing  or  sharing  content  that  is  durably  stored
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elsewhere, or for storing thumbnails,  transcoded media,  or  other processed data that  can be
easily reproduced.

Test - press this button to test the Amazon S3 connection
Save - press this button to Save the new source you defined

The configurations defined can also be edit/deleted later if you right click the configuration entry in
New Backup Wizard or in File->Options->Online connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.3.8 Google Cloud Storage

If  you  want  to  add  backup  sources  from  Google  Cloud  Storage,  press  Define  new  button  under
Online section.
Then enter the connection details for your Google Cloud Storage account.



Backup4all 9208

Backup4all 9 User Manual Copyright © 2021 Softland

Access ID - In this field you have to enter the access key ID for your Google Cloud Storage account
Secret  Key  -  In  this  field  you  have  to  enter  the  Secret  Access  Key  for  your  Google  Cloud  Storage
account
Region - select a region from the list, where your backups will be stored
Bucket - In this field you need to enter  the bucket to be used as destination. You can also create a
new  bucket  if  you  type  its  name  and  press  Create  button.  If  you  already  have  the  bucket  created
outside Backup4all, please make sure you also select the correct region for it.
Folder - In this field you have to enter the folder where you want to store the backups. If the folder
does not exist, it will be created.
Storage class

· Default - uses the default storage class configured in your Google Cloud Storage account

· Regional Storage  - used to store frequently accessed data in the same region as your Google
Cloud DataProc or Google Compute Engine.

· Multi-Regional Storage - used to store data that is frequently accessed ("hot" objects) around
the  world,  such  as  serving  website  content,  streaming  videos,  or  gaming  and  mobile
applications.

· Nearline Storage - used to store data you do not expect to access frequently

· Coldline Storage - used to store data you expect to access infrequently
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Test - press this button to test the Google Cloud Storage connection
Save - press this button to Save the new source you defined

The configurations defined can also be edit/deleted later if you right click the configuration entry in
New Backup Wizard or in File->Options->Online connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.3.9 Google Drive

If  you  want  to  add  backup  sources  from  Google  Drive,  press  Define  new  button  under  Online
section.
Then press the Choose account button and connect to your Google Drive account, to give Backup4all
the necessarily permissions.
You can select the account type: Personal or Team and you can also select the root folder.
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The configurations defined can also be edit/deleted later if you right click the configuration entry in
New Backup Wizard or in File->Options->Online connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.3.10 Microsoft OneDrive

If you want to add backup sources from Microsoft OneDrive, press Define new button under Online
section.
Then  press  the  Choose  account  button  and  connect  to  your  Microsoft  OneDrive  account,  to  give
Backup4all the necessarily permissions.
You can select the account type: Personal or Business and you can also select the root folder.
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The configurations defined can also be edit/deleted later if you right click the configuration entry in
New Backup Wizard or in File->Options->Online connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.3.11 Box

If you want to add backup sources from Box, press Define new button under Online section.
Then  press  the  Choose  account  button  and  connect  to  your  Box  account,  to  give  Backup4all  the
necessarily permissions.
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The configurations defined can also be edit/deleted later if you right click the configuration entry in
New Backup Wizard or in File->Options->Online connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.3.12 Dropbox

If you want to add backup sources from Dropbox, press Define new button under Online section.
Then press the Choose account button and connect to your Dropbox account, to give Backup4all the
necessarily permissions.
You can select the account type: Personal or Business and you can also select the root folder.
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The configurations defined can also be edit/deleted later if you right click the configuration entry in
New Backup Wizard or in File->Options->Online connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.3.13 HiDrive

If you want to add backup sources from HiDrive, press Define new button under Online section.
Then press the Choose account button and connect to your HiDrive account, to give Backup4all the
necessarily permissions.
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The configurations defined can also be edit/deleted later if you right click the configuration entry in
New Backup Wizard or in File->Options->Online connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.3.14 Hubic

If you want to add backup sources from Hubic, press Define new button under Online section.
Then  press  the  Choose account  button  and  connect  to  your  Hubic  account,  to  give  Backup4all  the
necessarily permissions.
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The configurations defined can also be edit/deleted later if you right click the configuration entry in
New Backup Wizard or in File->Options->Online connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.3.15 S3 Compatible

If  you  want  to  add  backup  sources  from  S3  Compatible,  press  Define  new  button  under  Online
section.
Then enter the connection details for your S3 Compatible account.
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S3 server - Select one of the predefined servers or choose the <Custom> option
Endpoint  -  enter  the  server  endpoint.  For  most  of  the  predefined  servers,  the  endpoint  is  filled
automatically. Example: s3.akaza.lk:80
Use SSL - select this option if the server requires SSL usage 
Access  ID - In this field you have to enter the access key ID for your Amazon S3 account
Secret Key - In this field you have to enter the Secret Access Key for your Amazon S3 account
Region - select a region from the list, where your backups will be stored
Signature - chose the signature version used by your server
Bucket - In this field you need to enter  the bucket to be used as destination. You can also create a
new  bucket  if  you  type  its  name  and  press  Create  button.  If  you  already  have  the  bucket  created
outside Backup4all, please make sure you also select the correct region for it.
Folder - In this field you have to enter the folder where you want to store the backups. If the folder
does not exist, it will be created.
Storage class

· Default - uses the default storage class configured in your Amazon S3 account

· Standard  -  this  option  offers  high  durability,  availability,  and  performance  object  storage  for
frequently accessed data.

· Standard - Infrequent Access Storage - is an Amazon S3 storage class for data that is accessed
less frequently, but requires rapid access when needed.
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· One Zone - Infrequent Access Storage -  designed for customers who want a lower-cost option
for infrequently accessed data

· Reduced  redundancy  (not  recommended)  -  enables  customers  to  store  noncritical,
reproducible  data  at  lower  levels  of  redundancy  than  Amazon  S3’s  standard  storage.  It
provides  a  highly  available  solution for  distributing  or  sharing  content  that  is  durably  stored
elsewhere, or for storing thumbnails,  transcoded media,  or  other processed data that  can be
easily reproduced.

Test - press this button to test the Amazon S3 connection
Save - press this button to Save the new source you defined

The configurations defined can also be edit/deleted later if you right click the configuration entry in
New Backup Wizard or in File->Options->Online connections.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

6.4 Filters - Filter the backup sources

On this page you can filter the backup sources in order to back up only the files and folders you need.
There are two type of filters: include filters and exclude filters.
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Backup empty folders
After applying a file filter, some folders might have no files matching the filter. In such a case, if  the
option is unchecked, those empty folders won't be backed up. If you still want the empty folders to
be backed up, make sure this option is selected.

Filter the sources

If you have filters defined in Tools->Options->Filters, they will be listed in the Filter the sources  list.
You can use thes filters to customize the backup sources selection. All filters listed are include filters.
Do not select any filter if you want to backup all files.

In the User defined section of the window there is a list of predefined filters. You can use these filters
to customize the file selection. 
The  filters  are  defined  in  File->Options->Filters.  Only  the  filters  that  have  "Show  filter  in  New
Backup  Wizard"  option  set  are  shown.  Filters  can  be  of  type  include  (backup  files  that  match  the
filter) or exclude (do not backup files that match the filter).
By  default,  the  Automatic  filters  list  contains  filters  to  exclude  temporary  and  system  files/folders
such as: hiberfil.sys, pagefile.sys, System Volume Information, Temp, etc. If you don't want to use a
filter from that list, simply clear (un-check) it. Clear all filters if you want to backup all files.
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6.5 Type - How do you want to backup?

In the third step of the New Backup Wizard you can choose the backup type.
 

How do you want to backup?

From the drop-down list, you can choose one of the available options:

· Smart

· Make full

· Make differential

· Make incremental

· Make mirror
 
Smart
The smart backup type will combine full, differential and incremental types with cleanup actions in
order to efficiently manage the stored backups according with the free disk space in destination or
the maximum allowed space set by the user. This backup type will  automatically  decide which is
the best action to perform when a new backup will be executed. 
By default, 80% of the destination size is used by the smart backup. If you want to use the full size
of  the  destination  drive  for  backup  storage,  you  can  select  the  Use  the  entire  available
destination space option.
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Make full
Full backup is the starting point for all other backups and contains all the data in the folders and files
that  are  selected  to  be  backed  up.  Because  full  backup  stores  all  files  and  folders,  frequent  full
backups  result  in  faster  and  simpler  restore  operations.  Remember  that  when  you  choose  other
backup types, restore jobs may take longer.

Make differential 
A differential backup contains all files that have changed since the last full backup. The advantage of
a differential backup is that it shortens restore time compared to an incremental backup. However, if
you perform the differential backup too many times, the size of the differential backup might grow to
be larger than the baseline full backup.
 
Make incremental
An incremental backup stores all files that have changed since the last full, differential or incremental
backup. The advantage of an incremental backup is that it takes the least time to complete. However,
during  a  restore  operation,  each  incremental  backup  must  be  processed,  which  could  result  in  a
lengthy restore job.
   
Make mirror
A mirror backup is identical to a full backup, with the exception that the files are not compressed in
zip files and they cannot be protected with a password. A mirror backup is most frequently used to
create an exact copy of the backup data.  It has the benefit that the backup files can also be readily
accessed using tools like File Explorer.
If  you choose the  Make mirror  option,  you can  also  check  the  Zip  the  files  option  to  zip  each  file
individually,  preserving  the  folder  structure.  This  allows  you  to  use  the  zip  compression  and
encryption features.

Encryption - Do you want to encrypt the backup?

Use this option if you want to add zip protection to your backups. Type the password you want to use
for this backup.
The default encryption used is Advanced Encryption Standard (AES), the best choice in zip protection,
but  recognized  only  by  the  latest  version  of  third  party  zip  applications.  The  default  size  of  the
encryption key  is  128  bits.  If  you want  to  configure  more  encryption  settings  or  choose a  stronger
encryption key, press the Advanced mode button.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

6.6 Scheduler - When do you want to backup?

On the last page of the New Backup Wizard, you can choose When to run the backup.
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Scheduler - When do you want to backup?

How often?
From the drop-down list, you can select one of the available option:

· Manually - the backup job will be started manually by the user

· Daily - the backup job will be started daily at its scheduled time

· Weekly - the backup job will be started weekly at its scheduled time

· Monthly - the backup job will be started monthly at its scheduled time

· Shutdown - the backup job will be started at the computer shutdown
By default, the selected option is Manually.

What day?
This field is activated only when the Weekly or Monthly option is selected in the How often list.
If the Weekly option is selected, you can choose the day of the week when to run the backup.
If  the  Monthly  option  is  selected,  you  can  choose  the  day  number  of  the  month  when  to  run  the
backup.

What hour?
From this field, you can select the hour for the backup job to start.
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Email - Do you want to receive email notifications?

Configure SMTP  -  if  the SMTP server is  not  yet configured in Backup4all,  press this  button to open
File->Options->Email window.

Select Yes to enable the configuration options, or leave No selected if you don't want to receive email
notifications.

Send emails to -  enter  the email  address where notification emails  will  be sent.  If  you want to use
multiple addresses, please enter them separated by a comma (",").

Attach log file to email - if this option is selected, the log file will be attached to notification email.

Compress  the  log  file  -  selecting  this  option  will  also  compress  the  log  file  before  attaching  it  to
email.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

6.7 Job - Personalize your backup job

In the first step of the New Backup Wizard  you can configure the backup name, icon and a custom
description.
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Backup Name 
Enter the name of the backup job. This name will  appear in the backup list,  right under  the chosen
picture. This field is mandatory.
The  name of  the  backup  job  is  closely  related  to  the  name  of  the  subdirectory  in  destination  that
contains zipped and mirrored files and to the name of the catalog. That is why when you rename the
backup  job,  the  name  of  the  catalog  and  the  name  of  the  subdirectory  from  destination  are  also
changed if possible.
If the destination is on HDD (local), LAN (network) FTP, SFTP, Azure, Amazon, DropBox, Google Drive,
Box or OneDrive (cloud) the name of the subdirectory and the name of the catalog can be changed,
except for the case when you do not have enough permissions to rename it, or some files are locked.
If the destination is on a removable disk CD,  DVD or  Blu-ray disc,  floppy disc  and you have run the
backup job, the catalog and the subdirectory in destination are already created and they will  not be
changed.  If  the  backup  job  has  not  been  run  yet,  then  the  catalog  and  the  subdirectory  will  be
created with a name similar to the backup job at first backup run.

Description
In this field you can enter a description for the backup job.

Job icon
You can change the icon of the current backup job by selecting a new icon from the list we provided.
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7 Backup Properties

7.1 Overview

The Backup Properties window can be used to create new backup jobs in the advanced mode, or to
edit an existing backup job. 

By  default,  the  New  Backup  Wizard  will  be  used  to  create  new  backup  jobs.  To  use  the  Backup
Properties  when  creating  new  jobs,  uncheck  the  Use  New  Backup  Wizard  to  create  backup  jobs
option from the Other section in File->Options->Preferences. 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.2 General

The General page defines the appearance of the backup job in the backup list.

General

Name
Enter the name of the backup job. This name will appear in the backup list, near the chosen picture.
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This field is mandatory.
The  name of  the  backup  job  is  closely  related  to  the  name  of  the  subdirectory  in  destination  that
contains zipped and mirrored files and to the name of the catalog. That is why when you rename the
backup  job,  the  name  of  the  catalog  and  the  name  of  the  subdirectory  from  destination  are  also
changed if possible.
If  the  destination  is  on  HDD  (local),  LAN  (network)  FTP,  SFTP,  Azure,  Amazon  S3,  Google  Drive,
OneDrive, Box or Dropbox the name of the subdirectory and the name of the catalog can be always
changed, except for the case when you do not have enough permission to rename or some files are
locked.
If the destination is on a removable disk, CD, DVD or Blu-ray disc, floppy disc and you have run the
backup job, the catalog and the subdirectory in destination are already created and they will  not be
changed.  If  the  backup  job  has  not  been  run  yet,  then  the  catalog  and  the  subdirectory  will  be
created with a name similar to the backup job at first backup run.
 
Tag
Select the tag where you want the backup job to appear. If no tag is available or you want to define a
new  tag,  just  press  Add  new  tag  and  type  the  name  of  the  tag  to  create  it.  The  new  tag  will  be
automatically assigned to the current backup job.
  

Description
You can write in here a text describing the backup job defined.

Icon

Press the Change Icon button to manage the backup job icons. This icon will be shown in the Backup
List.  You  can  add  a  new  icon  by  clicking  on  the  Add  button.  Only  Windows  icons  (files  with  ".ico"
extension) or bitmaps (files with ".bmp" extension) can be added to the list. To remove an icon from
the list, you have to select it and then click on the Delete  button.  By default,  each new backup job
icon will be the first icon from the Change Icon list. 
 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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7.3 Destination

The Destination page defines where the backup archive will be stored.

 

Destination

Valid destination types:

· Local hard drive

· External hard drive

· Optical

· Removable media (USB flash drive, floppy)

· Network

· FTP

· SFTP

· Azure

· Amazon S3

· Google Cloud Storage 

· Google Drive

· Dropbox

· OneDrive

· Box

· HiDrive

· Hubic

· S3 Compatible

Selecting a backup destination type on the Destination page, will enable the advanced options on the
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same page bellow.
 
If you lost your backup job from the backup list and you want to recreate it, you can do so by using
the File->Open option and selecting an existing ".bkc" or ".ini" file. The same action takes place if you
double  click  on the  ".bkc"  file.  If  the  backup  destination is  on  a  remote  location,  you can  use  File-
>Open  from  window  to  easily  locate  and  retrieve  the  backup  catalog/ini  file.  A  new  backup  job
configuration will be added to the backup list and the configuration of the new backup job is copied
from the ".bkc" file.
 
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.1 Local hard drive

You  can  use  a  valid  local  hard  disk  destination  for  your  backup.  The  Local  hard  drive  option  is
selected by default when you define a new backup.

Destination settings

In Local hard drive field, select the destination drive you want to be used.

In the Folder field the default path is \My Backup4all\Admin. You can click on the Browse button and
select a location of your choice where the backup will be stored.
In destination folder field, you can use Environment Variables as %Computername%, %SystemDrive
%, %UserName% etc.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
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feature matrix topic.

7.3.2 External hard drive

You can select an external hard drive as destination for backup. 

 

Destination settings

From the External hard drive list, you can select either an USB or a Firewire external hard drive.
You can type a folder name in the Folder field or you can click the Browse button to choose another
folder where the backup will be stored.
In destination folder field, you can use Environment Variables as %Computername%, %SystemDrive
%, %UserName% etc.

Lock the destination to this external hard drive
When disconnecting and reconnecting an external drive, your computer may not assign it the same
drive  letter.  If  the  drive  letter  was  changed,  the  backup  might  fail  because  Backup4all  is  trying  to
backup to the same old drive letter which probably does not exist.
Use this option if you want Backup4all  to detect the external drive after  its  own serial  number and
automatically change the backup destination according with the new drive letter.
You should not check this option if you use a rotation backup scheme with two or more external hard
drives.
By default, this option is not checked.

Enable disk spanning
The  option  is  effective  when  there  is  not  enough  space  to  copy  all  files  in  the  external  drive
destination. If checked, the application will copy files to the destination until a file will not fit. Then it
will ask you for another drive to continue with the rest of the files. If the option is not set, Backup4all
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will stop when the destination drive is full. 
By default, this option is not checked.

Rotate disks
Select this option if you want to set up a rotation scheme. Selecting this option will disable the "Use
local catalog" option from Backup Properties->Advanced page.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.3 Optical

You can select a CD, DVD or Blu-ray drive as destination for backup.
 

 If the Smart backup type is selected, you cannot use CD, DVD or Blu-ray as backup destination. In this
case, you have to select another backup type.

Destination settings

From the "CD, DVD or Blu-ray drive" drop down list you can select the optical drive you want to use.
You can type a folder name in the Folder field or you can click the Browse button to choose another
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folder where the backup will be stored.
In destination folder field, you can use Environment Variables as %Computername%, %SystemDrive
%, %UserName% etc.

Erase before writing
When  this  option  is  checked,  the  rewritable  CD,  DVD  or  Blu-ray  disc  is  erased  before  burning  the
backup files. By default this option is not checked.
Rotate disks
Select this option if you want to set up a rotation scheme. Selecting this option will disable the "Use
local catalog" option from Backup Properties->Advanced page.

Write method

Burn using built-in driver
Backup4all has built-in burning capabilities. Depending on the option selected in CD, DVD or Blu-ray
(from Tools->Options->Backup), one of the internal burners will be used to write the CD, DVD or Blu-
ray disc. This option is checked by default.
 
Speed
Use this option to specify a different speed for burning the CD,  DVD or  Blu-ray disc.  By default  this
option is set to Maximum speed.
 
Use third-party packet writing software
UDF is a platform-independent file system; the same media can be written and read by any operating
system or vendor. Each CD, DVD or Blu-ray disc must be UDF formatted before burning otherwise the
backup will  fail.  The limitation  of  this  type  is  that  you  must  have  an  UDF  reader  installed  on  each
computer you wish to use the CD, DVD or Blu-ray disc.

Volume label

Use custom prefix
You can type your own volume label prefix to customize the backups.
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

 

7.3.4 Removable

You  can  save  your  backup  to  a  removable  drive  (USB  flash  drive,  floppy  etc)  as  destination  for
backup. 
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Destination settings

Select from the drop down list the removable drive you want to use as backup destination.
You can type a folder name in the Folder field or you can click the Browse button to choose another
folder where the backup will be stored.
In destination folder field, you can use Environment Variables as %Computername%, %SystemDrive
%, %UserName% etc.

Lock the destination to this removable drive
When disconnecting and reconnecting a removable drive, your computer may not assign it the same
drive  letter.  If  the  drive  letter  was  changed,  the  backup  might  fail  because  Backup4all  is  trying  to
backup to the same old drive letter which probably does not exist.
Use this option if you want Backup4all to detect the removable drive after its own serial number and
automatically change the backup destination according with the new drive letter.
You should not check this option if you use a rotation backup scheme with two or more removable
hard drives.
By default, this option is not checked.
Erase disk before writing
When this option is checked, the removable disk is erased before burning the backup files. By default
this option is not checked.
Rotate disks
Select this option if you want to set up a rotation scheme. Selecting this option will disable the "Use
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local catalog" option from Backup Properties->Advanced page.

Volume label

Use custom prefix
You can type your own volume label prefix to customize the backups.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

7.3.5 Network

You can choose to save your backup to a shared network drive (another computer or NAS).

 
Destination settings
Click the Browse button to open My Network Places and select a destination where the backup will
be stored.
You can also enter  network paths  in the Network path (UNC)  field.  Only a  full  path is  allowed.  For
example,  suppose  \\Backup_Server\PC1  is  mapped  on  your  workstation  as  drive  X,  then  the
following  paths  are  both  valid  and  indicate  the  same  folder:  \\Backup_Server\PC1\Backup  or  X:
\Backup.
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Authentication

Make sure you can write in the destination and in the selected folder (you have the proper rights and
the media  is  not  write-protected)  before finishing the backup configuration.  You can enter  an User
name and Password to access the network destination if it requires authentication. If you are logged
in  as  an  user  that  has  rights  to  write  to  the  specified  network  destination,  you  can  check  the  Try
Windows user  and  password  first  option.  What  this  option  does  is  that  it  checks  on  the  network
destination if the logged in user has rights to access it.

You  can  set  Backup4all  to  disconnect  and  reconnect  the  network  drive  if  already  connected  by
checking the Reconnect if already connected option. By default, this option is not checked.
After  entering  the  path  and  eventually  the  username/password,  use  the  Test  network  connection
button  to  see  if  the  destination  is  reachable  and  that  you  have  sufficient  rights  to  access  it.  The
network connection was  tested successfully  pop-up  message means that  the  network  destination
was  accessible.  In  case  of  insufficient  rights  the  following  error  message  will  appear:  Network
connection  error.  Access  is  denied.  In  this  case  you  have  to  either  make  sure  that  the  entered
username/password values are correct, or contact the network administrator to obtain the necessary
rights.
 

Connection

One network errors retry -  here you can  set  the  number  of  retries  and  the  wait  time  (in  seconds)
between retries.

If the destination is missing (when the network is disconnected), an error message is shown. 
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The user  can  choose Cancel  to  stop the  backup  process  or  Retry  to  check  the  network  connection
again. If the scheduler starts the backup then the system will  retry as many times as set in the File-
>Options->Backup window and if still is not possible to access the network destination, it will  abort
the backup process.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

7.3.6 FTP server

Backup4all  supports  backing  up  to  a  remote  computer  or  device  using  FTP  (File  Transfer  Protocol)
connection. This is a practical backup destination because the backed up data can be easily accessed
from any other computer with an Internet connection. 
 

Destination settings

Use existing configuration
Use  this  option  if  you  want  to  use  an  already  defined  FTP  location  in  File->Options->Online
connections->FTP. From the drop-down list, select the FTP location you want to use.
The advantage is that if you use the same FTP destination for multiple backup jobs and a modification
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is  needed  for  destination,  you  can  change  only  the  FTP  configuration  from  File->Options->Online
connections->FTP and all backup jobs destinations will be updated.

Custom configuration
Use this option to add a new FTP location or to edit an existing one by pressing the Edit configuration
button. 

Description

Here you can see a listing of the FTP settings.
If you configured a new FTP location or you edit an existing one, you should use the Test connection
button to see if the FTP settings are correct. If the test was successful, The FTP connection was tested
successfully message will be displayed.
Once  you press  the  OK  button,  Backup4all  will  try  to  connect  to  the  FTP  server  to  see  if  a  backup
catalog already exists on the destination. If the FTP destination is not available, a Cannot connect to
the FTP server message is displayed in the status bar (bottom of the main window).

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

7.3.6.1 Edit configuration

This window is shown when selecting Edit configuration from the Destination->FTP window.



Backup Properties 237

Backup4all 9 User Manual Copyright © 2021 Softland

General

Existing configuration
If you want to add a new FTP location, the <New> option should be selected. To edit an existing FTP
location, select it from the drop-down list. All fields will be filled with the values of the selected FTP.  

FTP server

· Server name or IP - In this field you have to enter the name or IP address for the FTP server

· Transfer mode - Here you can select the transfer mode: Binary, ASCII or Auto.

· Binary: it refers to transferring files as a binary stream of data. The binary mode transmits
the raw bytes  of the file  being  transferred.  In  this  way,  the  file  is  transferred  in  its  exact
original form.

· ASCII: it stands for American Standard Code for Information Interchange, and is  a  type of
character encoding based on the English language used on devices that handle information
stored in text. It includes 33 non-printed control characters and 94 printed characters such
as letters and punctuation.

· Auto:  according  to  the  list  of  ASCII  files  defined  in  File->Options->FTP,  the  files  will  be
uploaded in ascii or binary mode, depending on their extension.

By default, binary mode is selected and it applies only to Mirror backup type. That is useful if
you have a Linux FTP server as backup destination and want to download the backed up files
with another  application which uses the Auto transfer mode.  Uploading the files to a  Linux
server in binary mode and downloading them in Auto mode, causes the files to be modified
by adding a new empty line at the end of each file.
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· Port  -  In  this  field  you have  to  enter  the  port  number  if  different  than  the  default  FTP  ports
(21).

· Destination folder - Here you can enter the destination path if different than root.

· User name - If this is a private FTP server (no anonymous access allowed) enter the user name
for your account.

· Password - In this field enter the password for the FTP server.

Bandwidth limitation

In this section you can set different limitations for upload/download speed:

· Upload speed - if checked you can set a maximum upload speed for the FTP transfer

· Download speed - if checked you can set a maximum upload speed for the FTP transfer

Advanced

FTPS  (SSL  encryption)  -  indicates  the  level  of  Transport  Layer  Security  (TLS)  required  for  control
channel and data channel connections to the FTP server:

· No SSL - the server does not require Secure Socket Layer transport

· Implicit SSL - implies that Secure Socket Layer is in use

· Only explicit SSL - allows the connection to the FTP server only if TLS is available.

· Explicit  SSL,  if  available  -  when  SSL  is  available,  uses  explicit  security  by  default.  The  server
allows regular FTP sessions without encryption as well as encrypted FTP sessions using SSL.

Use  passive  mode  for  transfers  (like  WWW  browsers)  -  each  file  transfer  (upload  or  download)
needs an additional connection for the data stream. Normally (in active mode), the server establishes
this  connection.  In  passive  mode,  however,  the  client  establishes  the  connection.  This  may  be
necessary through some firewalls, which do not allow connections from outside.

Use extended passive mode - the FTP Server operates exactly the same as passive mode, however it
only  transmits  the  port  number  (not  broken  into  high  and  low bytes)  and  Backup4all  is  to  assume
that it connects to the same IP address that was originally connected to. Use this option if the normal
passive mode connection failed.

Use  XCRC  when  testing  (if  available)  -  if  the  server  supports  the  XCRC  extension  Backup4all  can
verify that files transferred to the server have been transmitted correctly using the CRC information
received  from  the  FTP  server.  This  results  in  faster  testing,  as  the  files  will  not  be  downloaded  to
perform the CRC testing.

Resume  upload/downloads  (if  available)  -  it  resume  the  backup  upload  if  the  server  supports
resume command. 

Limit file  size to -  specify  the maximum file  size  you want  to  have.  Larger  files  will  be  split.  Please
note that many FTP servers does not allow you to upload files larger than 2 GB.

Timeout - you can set the time interval (in  seconds)  that  is  allowed for no data transfer before the
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transfer operation is interrupted and must be resumed. Default is 30 seconds.

Firewall

Proxy  type  -  select  one  of  the  options  below  (supported  by  your  firewall)  if  you  use  a  proxy  to
connect to the FTP:

· None  - Sends the User name and optional  Password for the FTP server as entered in the FTP
window

· Send  command  USER  -  Sends  the  User  name  and  optional  Password  defined  in  the  proxy
settings, followed immediately by the User name and optional Password for the FTP server.

· Send  command  SITE  -  Sends  the  User  name  and  optional  Password  defined  in  the  proxy
settings, the SITE command with the Host value, and the User name and optional Password for
the FTP site.

· Send  command  OPEN  -   Sends  the  User  name  and  optional  Password  defined  in  the  proxy
settings,  sends  the  OPEN  command  with  the  Host  value,  and  the  User  name  and  optional
Password for the FTP site.

· USER  user@firewalluser@hostname  /  PASS  pass@firewallpass  -  Sends  the  command  USER
user@proxyuser@host, then the command PASS pwd@proxypwd, or optionally PASS pwd.

· Transparent  -   Sends  the  User  name  and  optional  Password  defined  in  the   proxy  settings,
followed immediately by the FTP server User name and optional Password.

Host  name  or  IP  -  In  this  field  you  have  to  enter  the  name  or  IP  address  for  the  proxy  server
(firewall).
Host port - Type the port number if different than the default port (80).
User name - This field is used to enter the proxy user name.
Password - In this field you can enter the password for the specified user name.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
 

7.3.7 SFTP server

Backup4all  supports  backing  up  to  a  remote  computer  or  device  using  SFTP  (SSH  File  Transfer
Protocol) connection. This is a practical backup destination because the backed up data can be easily
accessed from any other computer with an Internet connection. 
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Destination settings

Use existing configuration
Use  this  option  if  you  want  to  use  an  already  defined  SFTP  location  in  File->Options->Online
destination->SFTP. From the drop-down list, select the SFTP location you want to use.
The  advantage  is  that  if  you  use  the  same  SFTP  destination  for  multiple  backup  jobs  and  a
modification  is  needed  for  destination,  you  can  change  only  the  SFTP  configuration  from  File-
>Options->Online destination->SFTP and all backup jobs destinations will be updated.

Custom configuration
Use  this  option  to  add  a  new  SFTP  location  or  to  edit  an  existing  one  by  pressing  the  Edit
configuration button. 

Description 

Here you can see a listing of the SFTP settings.
If you configured a new SFTP location or you edit an existing one, you should use the Test connection
button  to  see  if  the  SFTP settings  are  correct.  If  the  test  was  successful,  The  SFTP  connection  was
tested successfully message will be displayed.
Once you press the OK  button,  Backup4all  will  try to connect  to the SFTP server to see  if  a  backup
catalog already exists on the destination. If the SFTP destination is not available, a Cannot connect to
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the SFTP server message is displayed in the status bar (bottom of the main window).

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.7.1 Edit configuration

This window is shown when selecting Edit configuration from the Destination->SFTP window.

General

Existing configuration
If  you want  to  add  a  new SFTP location,  the  <New>  option  should  be  selected.  To  edit  an  existing
SFTP location, select it from the drop-down list. All fields will be filled with the values of the selected
SFTP.  
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SFTP server

· Server name or IP - In this field you have to enter the name or IP address for the SFTP server

· Port - In this field you have to enter  the port  number if  different  than the default  SFTP ports
(22).

· Destination folder - Here you can enter the destination path if different than root.

· User name - If this is a private SFTP server (no anonymous access allowed) enter the user name
for your account.

· Password - In this field enter the password for the SFTP server.

Private key

· None - no private key is used

· Key file - allows user to specify a key file that will be used

· Personal certificate store - allows user to import and use different certificate formats 

Bandwidth limitation

In this section you can set different limitations for upload/download speed:

· Limit upload speed - if checked you can set a maximum upload speed for the SFTP transfer

· Limit download speed - if checked you can set a maximum upload speed for the SFTP transfer
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Advanced

· Verify host key: If checked, the host key will be verified each time

· Limit file size to - specify the maximum file size you want to have. Please note that many SFTP
servers does not allow you to upload files larger than 2 GB.

· Timeout - you can set the time interval (in seconds) that is allowed for no data transfer before
the transfer operation is interrupted and must be resumed. Default is 15 seconds.

Authentication

You  can  select  which  authentication  methods  will  be  used  when  backing  up.  Available  options:
publickey, password and keyboard-interactive.
The priority of these options can also be changed.

Encryption

· Ciphers:  clear  or  select  the  check  boxes  to  specify  which  ciphers  you  want  to  allow  for
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encrypting SFTP sessions. A Cipher is the algorithm(s) used for symmetric  session encryption.
To  give  a  cipher  a  lower  priority  rating,  select  it  with  the  mouse  and  then  click  the  Down
button.

· MACs: clear or select the check boxes to specify which MACs you want to allow for encrypting
SFTP sessions. A MAC (Message Authentication Code) is the algorithm(s) used for data integrity
verification. To give a MAC a lower priority rating, select it with the mouse, and then click the
Down button.

Compression

SFTP supports  the use of data compression to reduce the amount of data that  is  transmitted.  Both
the client and server agree on a compression algorithm. They then compress data before sending and
decompress data when it is received.
Typically, zlib compression is the compression algorithm most commonly supported in SFTP servers.
No compression is set as the default, and zlib is specified as an option. If the server forces use of zlib
compression it will happen automatically

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.8 Azure

Backup4all supports backing up to Azure storage. This is a practical backup destination because the
backed up data can be easily accessed from any other computer with an Internet connection. 
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Destination settings

Use existing configuration
Use  this  option  if  you  want  to  use  an  already  defined  Azure  location  in  File->Options->Online
connections->Azure. From the drop-down list, select the Azure location you want to use.
The  advantage  is  that  if  you  use  the  same  Azure  destination  for  multiple  backup  jobs  and  a
modification  is  needed  for  destination,  you  can  change  only  the  Azure  configuration  from  File-
>Options->Online connections->Azure and all backup jobs destinations will be updated.

Custom configuration
Use  this  option  to  add  a  new  Azure  location  or  to  edit  an  existing  one  by  pressing  the  Edit
configuration button. 

Description 

Here you can see a listing of the Azure settings.
If  you  configured  a  new  Azure  location  or  you  edit  an  existing  one,  you  should  use  the  Test
connection  button  to  see  if  the  Azure  settings  are  correct.  If  the  test  was  successful,  The  Azure
connection was tested successfully message will be displayed.
Once you press the OK  button, Backup4all will  try to connect to the Azure server to see if a backup
catalog already exists on the destination. If the Azure destination is not available, a Cannot connect



Backup4all 9246

Backup4all 9 User Manual Copyright © 2021 Softland

to the Azure server message is displayed in the status bar (bottom of the main window).

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.8.1 Edit configuration

This window is shown when selecting Edit configuration from the Destination->Azure window.

General

Existing configuration
If  you want to add a new Azure location, the <New>  option should be selected. To edit  an existing
Azure location, select it from the drop-down list. All fields will be filled with the values of the selected
Azure configuration.  

Settings

· Account name - In this field you have to enter the name of your Azure account

· Key - In this field you have to enter the key for your Azure account
Key  is  shared  Access  Signature  -  check  this  option  if  the  key  is  shared  access  signature.  A
shared access signature provides delegated access to resources in your storage account. This
means that you can grant a client limited permissions to your blobs, queues, or tables for a
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specified period of time and with a specified set of permissions, without having to share your
account access keys.

· Container - In this field you have to enter the container you want to use as destination

· Folder - In this field you have to enter the folder where you want to store the backups. If the
folder does not exist, it will be created.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.9 Amazon S3

Backup4all supports backing up to Amazon S3 storage. This is a practical backup destination because
the backed up data can be easily accessed from any other computer with an Internet connection. 
 

Destination

Use existing configuration
Use this option if you want to use an already defined Amazon S3 location in File->Options->Online
connections->Amazon S3. From the drop-down list, select the Amazon S3 location you want to use.
The  advantage  is  that  if  you  use  the  same  Amazon  S3  destination  for  multiple  backup  jobs  and  a
modification is needed for destination, you can change only the Amazon S3 configuration from File-
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>Options->Online connections->Amazon S3 and all backup jobs destinations will be updated.

Custom configuration
Use  this  option  to  add  a  new  Amazon  S3  location  or  to  edit  an  existing  one  by  pressing  the  Edit
configuration button. 

Description 

Here you can see a listing of the Amazon S3 settings.
If  you  configured  a  new  Amazon  S3  location  or  you  edit  an  existing  one,  you  should  use  the  Test
connection  button  to  see  if  the  Amazon  S3  settings  are  correct.  If  the  test  was  successful,  The
Amazon S3 connection was tested successfully message will be displayed.
Once  you press  the  OK  button,  Backup4all  will  try  to  connect  to  the  Amazon  S3  server  to  see  if  a
backup  catalog  already  exists  on  the  destination.  If  the  Amazon  S3  destination  is  not  available,  a
Cannot connect to the Amazon S3 server message is displayed in the status bar (bottom of the main
window).

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.9.1 Edit configuration

This  window  is  shown  when  selecting  Edit  configuration  from  the  Destination->Amazon  S3
window.
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General

Existing configuration
If  you  want  to  add  a  new  Amazon  S3  location,  the  <New>  option  should  be  selected.  To  edit  an
existing Amazon S3 location, select it from the drop-down list. All fields will be filled with the values
of the selected Amazon S3 configuration.  

Settings

· Access Key ID - In this field you have to enter the access key ID for your Amazon S3 account

· Secret Access Key - In this  field  you have to enter  the Secret  Access Key for your Amazon S3
account

· Region - select a region from the list, where your backups will be stored

· Bucket  -  In  this  field  you  need  to  enter  the  bucket  to  be  used  as  destination.  You  can  also
create  a  new  bucket  if  you  type  its  name  and  press  Create  button.  If  you  already  have  the
bucket created outside Backup4all, please make sure you also select the correct region for it.

· Folder - In this field you have to enter the folder where you want to store the backups. If the
folder does not exist, it will be created.

· Storage class

· Standard  -  this  option  offers  high  durability,  availability,  and  performance  object
storage for frequently accessed data.

· Standard - Infrequent Access Storage - is an Amazon S3 storage class for data that is
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accessed less frequently, but requires rapid access when needed.

· Reduced  redundancy (not  recommended)  -  enables  customers  to  store  noncritical,
reproducible data at lower levels of redundancy than Amazon S3’s standard storage. It
provides a highly available solution for distributing or sharing content that is durably
stored  elsewhere,  or  for  storing  thumbnails,  transcoded  media,  or  other  processed
data that can be easily reproduced.

Transfer acceleration - this option enables fast, easy, and secure transfers of files over long distances
between  Backup4all  and  the  S3  bucket.  Transfer  Acceleration  takes  advantage  of  Amazon
CloudFront’s  globally  distributed  edge  locations.  As  the  data  arrives  at  an  edge  location,  data  is
routed to Amazon S3 over an optimized network path.  Please note it  takes about 20 minutes since
the bucket creation until the acceleration is enabled for that bucket.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.10 Google Cloud Storage

Backup4all  supports  backing  up  to  Google  Cloud  Storage.  This  is  a  practical  backup  destination
because  the  backed  up  data  can  be  easily  accessed  from  any  other  computer  with  an  Internet
connection. 
 

Destination
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Use existing configuration
Use  this  option  if  you  want  to  use  an  already  defined  Google  Cloud  Storage  location  in  File-
>Options->Online connections->Google Cloud Storage.  From the drop-down list,  select  the Google
Cloud Storage location you want to use.
The advantage is that if you use the same Google Cloud Storage destination for multiple backup jobs
and  a  modification  is  needed  for  destination,  you  can  change  only  the  Google  Cloud  Storage
configuration  from  File->Options->Online  connections->Google  Cloud  Storage  and  all  backup  jobs
destinations will be updated.

Custom configuration
Use this option to add a new Google Cloud Storage location or to edit an existing one by pressing the
Edit configuration button. 

Description 

Here you can see a listing of the Google Cloud Storage settings.
If you configured a new Google Cloud Storage location or you edit an existing one, you should use the
 Test  connection  button  to  see  if  the  Google  Cloud  Storage  settings  are  correct.  If  the  test  was
successful, The Google Cloud Storage connection was tested successfully message will be displayed.
Once you press the OK button, Backup4all will  try to connect to the Google Cloud Storage server to
see if a backup catalog already exists  on the destination. If  the Google  Cloud Storage destination is
not  available,  a  Cannot  connect  to  the  Google  Cloud  Storage  server  message  is  displayed  in  the
status bar (bottom of the main window).

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.10.1 Edit configuration

This  window is  shown  when  selecting  Edit  configuration  from  the  Destination->Google  Cloud
Storage window.
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General

Existing configuration
If  you want to add a new Google Cloud Storage location, the <New>  option should be selected. To
edit  an  existing  Google  Cloud  Storage  location,  select  it  from  the  drop-down  list.  All  fields  will  be
filled with the values of the selected Google Cloud Storage configuration.  

Settings

· Access Key ID - In this field you have to enter the access key ID for your Google Cloud Storage
account

· Secret Access Key - In this field you have to enter the Secret Access Key for your Google Cloud
Storage account

· Region - select a region from the list, where your backups will be stored

· Bucket  -  In  this  field  you  need  to  enter  the  bucket  to  be  used  as  destination.  You  can  also
create  a  new  bucket  if  you  type  its  name  and  press  Create  button.  If  you  already  have  the
bucket created outside Backup4all, please make sure you also select the correct region for it.

· Folder - In this field you have to enter the folder where you want to store the backups. If the
folder does not exist, it will be created.

· Storage class - Select the storage class you want to use. You can choose between: 

· Default - uses the default storage class configured in your Google Cloud Storage account

· Regional  Storage  -  used  to  store  frequently  accessed  data  in  the  same  region  as  your
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Google Cloud DataProc or Google Compute Engine.

· Multi-Regional  Storage  -  used  to  store  data  that  is  frequently  accessed  ("hot"  objects)
around  the  world,  such  as  serving  website  content,  streaming  videos,  or  gaming  and
mobile applications.

· Nearline Storage - used to store data you do not expect to access frequently

· Coldline Storage - used to store data you expect to access infrequently

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.11 Google Drive

Backup4all  supports  backing  up  to  Google  Drive  storage.  This  is  a  practical  backup  destination
because  the  backed  up  data  can  be  easily  accessed  from  any  other  computer  with  an  Internet
connection. 
 

Destination

Use existing configuration
Use this option if you want to use an already defined Google Drive location in File->Options->Online
connections->Google Drive.  From the drop-down list,  select  the Google  Drive location you want to
use.
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The advantage is  that  if  you use the same Google  Drive destination for multiple  backup  jobs  and  a
modification is needed for destination, you can change only the Google Drive configuration from File-
>Options->Online connections->Google Drive and all backup jobs destinations will be updated.

Custom configuration
Use this  option  to  add  a  new Google  Drive  location  or  to  edit  an  existing  one  by  pressing  the  Edit
configuration button. 

Description 

Here you can see a listing of the Google Drive settings.
If  you configured a new Google  Drive location or  you edit  an existing one, you should use the Test
connection  button  to  see  if  the  Google  Drive  settings  are  correct.  If  the  test  was  successful,  The
Google Drive connection was tested successfully message will be displayed.
Once you press the OK  button, Backup4all will  try to connect  to the Google  Drive server to see if  a
backup catalog already exists  on the  destination.  If  the  Google  Drive  destination is  not  available,  a
Cannot connect  to  the  Google  Drive  server  message is  displayed in  the  status  bar  (bottom  of  the
main window).

Bandwidth limitation

This option allows you to set a limit for the upload and download speed between the working hours.
If your bandwidth is important for your company and you run a long backup, you can set Backup4all
to use only a limited bandwidth between the specified hours.

Download speed - here you can set the maximum download speed for backup. It will be used when
testing the files after backup.

Upload speed - here you can set the maximum upload speed for backup. 

Limit only between - indicate the hours between which the specified upload/download limits will be
applied.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.11.1 Edit configuration

This  window  is  shown  when  selecting  Edit  configuration  from  the  Destination->Google  Drive
window.
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General

Existing configuration
If you want to add a new Google Drive configuration, the <New>  option should be selected. To edit
an existing Google Drive configuration, select it from the drop-down list. All  fields will  be filled with
the values of the selected Google Drive configuration.  

Settings

· Drive type  -  here you can choose "Personal"  or  "Team",  depending  on the  account  type  you
have.

· Authentication - press "Choose account" button to log in to your Google Drive account. Here
you  need  to  authorize  Backup4all  application  to  view  and  manage files  in  your  Google  Drive
account.
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· Folder - In this field you have to select the folder where you want to store the backups. If no
folder is selected the backup will be stored in the root of your Google Drive account.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.12 Microsoft OneDrive

Backup4all supports backing up to Microsoft OneDrive storage. This is a practical backup destination
because  the  backed  up  data  can  be  easily  accessed  from  any  other  computer  with  an  Internet
connection. 
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Destination

Use existing configuration
Use  this  option  if  you  want  to  use  an  already  defined  OneDrive  location  in  File->Options->Online
connections->OneDrive. From the drop-down list, select the OneDrive location you want to use.
The  advantage  is  that  if  you  use  the  same  OneDrive  destination  for  multiple  backup  jobs  and  a
modification is  needed for  destination,  you can  change  only  the  OneDrive  configuration  from  File-
>Options->Online connections->OneDrive and all backup jobs destinations will be updated.

Custom configuration
Use  this  option  to  add  a  new  OneDrive  location  or  to  edit  an  existing  one  by  pressing  the  Edit
configuration button. 

Description 

Here you can see a listing of the OneDrive settings.
If  you  configured  a  new  OneDrive  location  or  you  edit  an  existing  one,  you  should  use  the  Test
connection  button  to  see  if  the  OneDrive  settings  are  correct.  If  the  test  was  successful,  The
OneDrive connection was tested successfully message will be displayed.
Once  you  press  the  OK  button,  Backup4all  will  try  to  connect  to  the  OneDrive  server  to  see  if  a
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backup  catalog  already  exists  on  the  destination.  If  the  OneDrive  destination  is  not  available,  a
Cannot connect to the OneDrive server message is displayed in the status bar (bottom of the main
window).

Bandwidth limitation

This option allows you to set a limit for the upload and download speed between the working hours.
If your bandwidth is important for your company and you run a long backup, you can set Backup4all
to use only a limited bandwidth between the specified hours.

Download speed - here you can set the maximum download speed for backup. It will be used when
testing the files after backup.

Upload speed - here you can set the maximum upload speed for backup. 

Limit only between - indicate the hours between which the specified upload/download limits will be
applied.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.12.1 Edit configuration

This window is shown when selecting Edit configuration from the Destination->Microsoft OneDrive
window.
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General

Existing configuration
If you want to add a new Microsoft OneDrive location, the <New> option should be selected. To edit
an existing Microsoft OneDrive location, select it from the drop-down list. All fields will be filled with
the values of the selected Microsoft OneDrive configuration.  

Settings

· Account type - here you can choose "Personal" or "Business", depending on the account type
you have.

· Authentication - press "Choose account" button to log in to your OneDrive account. Here you
need to authorize Backup4all application to view and manage files in your OneDrive account.



Backup Properties 261

Backup4all 9 User Manual Copyright © 2021 Softland



Backup4all 9262

Backup4all 9 User Manual Copyright © 2021 Softland

· Folder - In this field you have to select the folder where you want to store the backups. If no
folder is selected the backup will be stored in the root of your OneDrive account.

· Custom max file size - this option allows you to set a custom file size (by default is 15 GB). It is
useful if you don't want large files to be split on upload.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.13 Box

Backup4all  supports  backing  up  to  Box  storage.  This  is  a  practical  backup  destination  because  the
backed up data can be easily accessed from any other computer with an Internet connection. 
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Destination

Use existing configuration
Use  this  option  if  you  want  to  use  an  already  defined  Box  location  in  File->Options->Online
connections->Box. From the drop-down list, select the Box location you want to use.
The  advantage  is  that  if  you  use  the  same  Box  destination  for  multiple  backup  jobs  and  a
modification  is  needed  for  destination,  you  can  change  only  the  Box  configuration  from  File-
>Options->Online connections->Box and all backup jobs destinations will be updated.

Custom configuration
Use  this  option  to  add  a  new  Box  location  or  to  edit  an  existing  one  by  pressing  the  Edit
configuration button. 

Description 

Here you can see a listing of the Box settings.
If you configured a new Box location or you edit an existing one, you should use the Test connection
button to see if the Box settings are correct. If the test was successful, The Box connection was tested
successfully message will be displayed.
Once  you press  the  OK  button,  Backup4all  will  try  to  connect  to  the  Box  server  to  see  if  a  backup
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catalog already exists on the destination. If the Box destination is not available, a Cannot connect to
the Box server message is displayed in the status bar (bottom of the main window).

Bandwidth limitation

This option allows you to set a limit for the upload and download speed between the working hours.
If your bandwidth is important for your company and you run a long backup, you can set Backup4all
to use only a limited bandwidth between the specified hours.

Download speed - here you can set the maximum download speed for backup. It will be used when
testing the files after backup.

Upload speed - here you can set the maximum upload speed for backup. 

Limit only between - indicate the hours between which the specified upload/download limits will be
applied.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.13.1 Edit configuration

This window is shown when selecting Edit configuration from the Destination->Box window.
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General

Existing configuration
If you want to add a new Box location, the <New> option should be selected. To edit an existing Box
location, select it from the drop-down list. All fields will be filled with the values of the selected Box
configuration.  

Settings

· Authentication -  press "Choose account" button to log in to your Box account.  Here you need to
authorize Backup4all application to read and write files/folders in your Box account.
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· Folder - In this field you have to select the folder where you want to store the backups. If no folder
is selected the backup will be stored in the root of your Box account.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.14 Dropbox

Backup4all  supports  backing  up  to  Dropbox  storage.  This  is  a  practical  backup  destination because
the backed up data can be easily accessed from any other computer with an Internet connection. 
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Destination

Use existing configuration
Use  this  option  if  you  want  to  use  an  already  defined  Dropbox  location  in  File->Options->Online
connections->Dropbox. From the drop-down list, select the Dropbox location you want to use.
The  advantage  is  that  if  you  use  the  same  Dropbox  destination  for  multiple  backup  jobs  and  a
modification  is  needed  for  destination,  you  can  change  only  the  Dropbox  configuration  from  File-
>Options->Online connections->Dropbox and all backup jobs destinations will be updated.

Custom configuration
Use  this  option  to  add  a  new  Dropbox  location  or  to  edit  an  existing  one  by  pressing  the  Edit
configuration button. 

Description 

Here you can see a listing of the Dropbox settings.
If  you  configured  a  new  Dropbox  location  or  you  edit  an  existing  one,  you  should  use  the  Test
connection button to see if the Dropbox settings are correct. If the test was successful, The Dropbox
connection was tested successfully message will be displayed.
Once you press the OK button, Backup4all will try to connect to the Dropbox server to see if a backup
catalog  already  exists  on  the  destination.  If  the  Dropbox  destination  is  not  available,  a  Cannot
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connect to the Dropbox server message is displayed in the status bar (bottom of the main window).

Bandwidth limitation

This option allows you to set a limit for the upload and download speed between the working hours.
If your bandwidth is important for your company and you run a long backup, you can set Backup4all
to use only a limited bandwidth between the specified hours.

Download speed - here you can set the maximum download speed for backup. It will be used when
testing the files after backup.

Upload speed - here you can set the maximum upload speed for backup. 

Limit only between - indicate the hours between which the specified upload/download limits will be
applied.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.14.1 Edit configuration

This window is shown when selecting Edit configuration from the Destination->Dropbox window.



Backup Properties 269

Backup4all 9 User Manual Copyright © 2021 Softland

General

Existing configuration
If you want to add a new Dropbox location, the <New> option should be selected. To edit an existing
Dropbox  location,  select  it  from  the  drop-down  list.  All  fields  will  be  filled  with  the  values  of  the
selected Dropbox configuration.  

Settings

· Account type - here you can choose "Personal" or "Business", depending on the account type
you have.

· Authentication -  press "Choose account" button to log in to your Dropbox account. Here you
need  to  authorize  Backup4all  application  to  read  and  write  files/folders  in  your  Dropbox
account.
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· Folder - In this field you have to select the folder where you want to store the backups. If no
folder is selected the backup will be stored in the root of your Dropbox account.

· Custom max file size - this option allows you to set a custom file size (by default is 5 GB). It is
useful if you don't want large files to be split on upload.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.15 HiDrive

Backup4all supports backing up to HiDrive storage. This is a practical backup destination because the
backed up data can be easily accessed from any other computer with an Internet connection. 
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Destination

Use existing configuration
Use  this  option  if  you  want  to  use  an  already  defined  HiDrive  location  in  File->Options->Online
connections->HiDrive. From the drop-down list, select the HiDrive location you want to use.
The  advantage  is  that  if  you  use  the  same  HiDrive  destination  for  multiple  backup  jobs  and  a
modification  is  needed  for  destination,  you  can  change  only  the  HiDrive  configuration  from  File-
>Options->Online connections->HiDrive and all backup jobs destinations will be updated.

Custom configuration
Use  this  option  to  add  a  new  HiDrive  location  or  to  edit  an  existing  one  by  pressing  the  Edit
configuration button. 

Description 

Here you can see a listing of the HiDrive settings.
If  you  configured  a  new  HiDrive  location  or  you  edit  an  existing  one,  you  should  use  the  Test
connection  button to see if  the HiDrive settings are correct.  If  the test  was  successful,  The HiDrive
connection was tested successfully message will be displayed.
Once you press the OK button, Backup4all will try to connect to the HiDrive server to see if a backup
catalog already exists on the destination. If the HiDrive destination is not available, a Cannot connect
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to the HiDrive server message is displayed in the status bar (bottom of the main window).

Bandwidth limitation

This option allows you to set a limit for the upload and download speed between the working hours.
If your bandwidth is important for your company and you run a long backup, you can set Backup4all
to use only a limited bandwidth between the specified hours.

Download speed - here you can set the maximum download speed for backup. It will be used when
testing the files after backup.

Upload speed - here you can set the maximum upload speed for backup. 

Limit only between - indicate the hours between which the specified upload/download limits will be
applied.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.15.1 Edit configuration

This window is shown when selecting Edit configuration from the Destination->HiDrive window.
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General

Existing configuration
If you want to add a new HiDrive location, the <New> option should be selected. To edit an existing
HiDrive  location,  select  it  from  the  drop-down  list.  All  fields  will  be  filled  with  the  values  of  the
selected HiDrive configuration.  

Settings

· Authentication -  press  "Choose  account"  button  to  log  in  to  your  HiDrive  account.  Here  you
need  to  authorize  Backup4all  application  to  read  and  write  files/folders  in  your  HiDrive
account.
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· Folder - In this field you have to select the folder where you want to store the backups. If no
folder is selected the backup will be stored in the root of your HiDrive account.

· Custom max file size - this option allows you to set a custom file size (by default is 2 GB). It is
useful if you don't want large files to be split on upload.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.16 Hubic

Backup4all supports backing up to Hubic storage. This is a practical backup destination because the
backed up data can be easily accessed from any other computer with an Internet connection. 
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Destination

Use existing configuration
Use  this  option  if  you  want  to  use  an  already  defined  Hubic  location  in  File->Options->Online
connections->Hubic. From the drop-down list, select the Hubic location you want to use.
The  advantage  is  that  if  you  use  the  same  Hubic  destination  for  multiple  backup  jobs  and  a
modification  is  needed  for  destination,  you  can  change  only  the  Hubic  configuration  from  File-
>Options->Online connections->Hubic and all backup jobs destinations will be updated.

Custom configuration
Use  this  option  to  add  a  new  Hubic  location  or  to  edit  an  existing  one  by  pressing  the  Edit
configuration button. 

Description 

Here you can see a listing of the Hubic settings.
If  you  configured  a  new  Hubic  location  or  you  edit  an  existing  one,  you  should  use  the  Test
connection  button  to  see  if  the  Hubic  settings  are  correct.  If  the  test  was  successful,  The  Hubic
connection was tested successfully message will be displayed.
Once you press the OK  button, Backup4all will  try to connect to the Hubic server to see if a backup
catalog already exists on the destination. If the Hubic destination is not available, a Cannot connect
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to the Hubic server message is displayed in the status bar (bottom of the main window).

Bandwidth limitation

This option allows you to set a limit for the upload and download speed between the working hours.
If your bandwidth is important for your company and you run a long backup, you can set Backup4all
to use only a limited bandwidth between the specified hours.

Download speed - here you can set the maximum download speed for backup. It will be used when
testing the files after backup.

Upload speed - here you can set the maximum upload speed for backup. 

Limit only between - indicate the hours between which the specified upload/download limits will be
applied.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.16.1 Edit configuration

This window is shown when selecting Edit configuration from the Destination->Hubic window.
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General

Existing configuration
If  you want to add a new Hubic location, the <New>  option should be selected. To edit  an existing
Hubic location, select it from the drop-down list. All fields will be filled with the values of the selected
 Hubic configuration.  

Settings

· Authentication  -  press  "Choose  account"  button  to  log  in  to  your  Hubic  account.  Here  you
need to authorize Backup4all application to read and write files/folders in your Hubic account.

· Folder - In this field you have to select the folder where you want to store the backups. If no
folder is selected the backup will be stored in the root of your Hubic account.

· Custom max file size - this option allows you to set a custom file size (by default is  5 GB). It is
useful if you don't want large files to be split on upload.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.17 S3 Compatible

Backup4all  supports  backing  up  to  S3  Compatible  storage.  This  is  a  practical  backup  destination
because  the  backed  up  data  can  be  easily  accessed  from  any  other  computer  with  an  Internet
connection. 
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Destination

Use existing configuration
Use  this  option  if  you  want  to  use  an  already  defined  S3  Compatible  location  in  File->Options-
>Online  connections->S3  Compatible.  From  the  drop-down  list,  select  the  S3  Compatible  location
you want to use.
The advantage is that if you use the same S3 Compatible destination for multiple backup jobs and a
modification is  needed for  destination,  you can  change  only  the  S3  Compatible  configuration  from
File->Options->Online connections->S3 Compatible and all backup jobs destinations will be updated.

Custom configuration
Use this option to add a new S3 Compatible location or to edit an existing one by pressing the Edit
configuration button. 

Description 

Here you can see a listing of the S3 Compatible settings.
If you configured a new S3 Compatible location or you edit an existing one, you should use the Test
connection button to see if the S3 Compatible settings are correct. If the test was successful, The S3
Compatible connection was tested successfully message will be displayed.
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Once you press the OK button, Backup4all will try to connect to the S3 Compatible server to see if a
backup catalog already exists on the destination. If the S3 Compatible destination is not available, a
Cannot connect to the S3 Compatible server  message is displayed in the status bar (bottom of the
main window).

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.3.17.1 Edit configuration

This  window  is  shown  when  selecting  Edit  configuration  from  the  Destination->S3  Compatible
window.

General

Existing configuration
If  you want to add a new S3 Compatible location, the <New>  option should be selected. To edit  an
existing  S3  Compatible  location,  select  it  from  the  drop-down  list.  All  fields  will  be  filled  with  the
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values of the selected S3 Compatible configuration.  

S3 Server
Select  one  of  the  predefined  S3  compatible  servers,  or  define  a  custom  one.  The  S3  compatbile
clouds  available  are:  Akaza,  Aruba  Cloud,  Backblaze  B2,  Caringo,  CenturyLink,  Cisco,  Claudian,
Connectia, Constant, DDN, dinCloud, Dream Objects, Dunkel, T Cloud, Exoscale, Green Qloud, HGST,
Hitachi, HostEurope, IDC Frontier, LeoNovus, Mandic, Minio, NetApp, NiftyClouds, Numergy, QNAP,
Revera, Scality, Seeweb, SwiftStack, ThinkOn, Tiscali,  vCloud Air, Verizon, Walrus and Zettagrid.

Settings

· Endpoint - enter the server endpoint. For most of the predefined servers, the endpoint is filled
automatically. Example: s3.akaza.lk:80

· Use SSL - select this option if the server requires SSL usage

· Access Key ID - enter the access key ID as received from your server provider

· Secret Access Key - enter the secret access key as received from your server provider

· Signature version - chose the signature version used by your server 

· Region - select the region where your bucket is located

· Bucket - enter the name of the existing bucket or type a new one and press the Create button.

· Folder - In this field you have to select the folder where you want to store the backups. If no
folder is selected the backup will be stored in the root of your S3 Compatible account.

· Storage class

· Standard  -  this  option  offers  high  durability,  availability,  and  performance  object
storage for frequently accessed data.

· Standard - Infrequent Access Storage - is an Amazon S3 storage class for data that is
accessed less frequently, but requires rapid access when needed.

· Reduced  redundancy (not  recommended)  -  enables  customers  to  store  noncritical,
reproducible data at lower levels of redundancy than Amazon S3’s standard storage. It
provides a highly available solution for distributing or sharing content that is durably
stored  elsewhere,  or  for  storing  thumbnails,  transcoded  media,  or  other  processed
data that can be easily reproduced.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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7.4 Sources

The Sources page defines what files and folders will be used by Backup4all for the backup.

You can:

· add a whole folder by pressing the Add folder button

· add one or several files by pressing the Add files button

· remove any file or folder by selecting it and pressing the Remove button

· add sources from a remote location by pressing the Add remote button

· add sources from backup plugins by pressing the Add plugins button

· exclude subdirectories and files from backup by un-checking the thickbox 

· select all files and folders by pressing the Check all button

· unselect all files and folders by pressing the Uncheck all button

Depending on how they are added to a backup job, the backup sources can be:

· Sources  from  local  or  network  locations:  use  the  buttons  "Add  folder"  and  "Add  file"  to
manually select the sources from a local connected drive or from a network share.



Backup Properties 283

Backup4all 9 User Manual Copyright © 2021 Softland

· Sources from plugins: use the "Add plugins" button to select the backup plugin(s) you want to
use. If you want to install new plugins, please go to File->Tools->Plugins.

· Sources from remote locations: use the "Add remote" button to select the source files from
FTP, SFTP, or cloud locations, such as: Azure, Amazon S3, Google Cloud Storage, Google Drive,
Microsoft OneDrive, Box, Dropbox, HiDrive, Hubic or S3 Compatible
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At least one source must be added to the backup job.
If  the source drive is  missing (when the network is  disconnected for  instance  or  CD/DVD/Blu-ray  is
missing),  a  warning  message  is  shown  containing  the  list  of  missing  drives.  The  user  can  choose
Abort to stop the backup process, Retry to check the drive again, Ignore to mark the source folder as
deleted and continue with the next sources. If the scheduler starts the backup then the system will
retry as many times as set in the File->Options->Backup window and if still not possible to access the
drive it will abort the backup process.

Tips:

· try to keep the number of checked files and folders greater than the number of unchecked files
and folders - backup process will run faster this way.

· you  can  add  files/foders  to  the  Sources  window  by  dragging  and  dropping  them  from  File
Explorer

 
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.5 Filters

The Filters page defines files and folders filters to be applied to backup sources. Only files and folders
that match the filters will be added to backup.
You can use the Add include and Add exclude buttons to add filter rules for the current backup job.
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The system selects only  files that  match the include filter and do not  match the exclude filter.  This
means the exclude filter is more powerful: if a file satisfies both include and exclude filters, it will be
excluded.

Include and exclude filters are composed from filter restrictions. Two or more filter restrictions in the
include filter means that a file must satisfy at least one restriction to be included in the backup. Two
or  more  filter  restrictions  in  the  exclude  filter  means  that  a  file  must  satisfy  any  restriction  to  be
excluded.

All filters with the Active box checked will be used by the current backup job. To disable a filter, just
uncheck the Active box.

Note:
Filters on files and filters on folders must be created individually. If you use a file and a folder filter
condition in the same filter, files will be filtered only if both filter conditions were met. 

Example:
If  you use  a  single  filter  for  .jpg  files  and  Temp folder,  only  the  .jpg  files  from Temp folder  will  be
filtered.  If  you use separate filters  for files  and  folders,  all  .jpg  files  and  whole  Temp folder  will  be
filtered.

You can manage filter restrictions using the buttons:
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· Add  include  -  this  will  open  a  new Filter  Properties  window from where  you can  add  a  new
include restriction to the filters list.

· Add exclude -  this will  open a  new Filter  Properties  window from where  you can  add  a  new
exclude restriction to the filters list.

· Edit - will open the selected filter's properties window. You will be able to modify the selected
restriction.

· Copy - this will create a copy of the selected filter.

· Delete - will remove the selected filter from the list of include or exclude filters.

· Change to include/exclude - pressing this button will change the type of filter from include to
exclude or vice versa. 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.5.1 Customize

On the Customize page you can override the main backup filter. It will  show a tree with all selected
sources for the backup job.
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The customized filter can be defined only for folders. That is why add button is not enabled for files. 

Any customized filter completely replaces the main filter. Once defined, the customized filter applies
on the current folder and recursively on all its subfolders until another customized filter is met. The
behavior is the same for include and exclude filters.

Suppose we have the folder structure in the picture above. Backup source is "D:\Backup sources". A
main filter is defined to include all .txt and .doc files. Suppose we do not want to backup .txt files
from "ccc" folder. For this we define a customized filter on "ccc" that includes only .doc files.

The result is that all .txt and .doc files will be included except the .txt files inside "ccc" folder as in the
picture bellow:

When a folder is selected, the Add include and Add exclude buttons from the bottom are activated
(these are activated only for folders,  not  for individual  files).  That means you can replace the main
filter  with  a  different  one.  The  customized  filter  is  valid  only  for  the  selected  folder  and  its
descendants. Click the Add include or Add exclude  button to define the customized filter.  This will
open a Filter Properties window. You can define include or exclude filters in this window just as you
do in the Filter page.
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All files and folders for which a customized filter is applied are shown in red color. You can Edit, Copy
or Delete a customized filter by selecting the folder and clicking one of the buttons bellow.
 
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.5.2 Filter Properties

When you add or edit a filter, the following options will appear:

 

What do you want to do?

If the Add include or Add exclude button was pressed, the following options will be show:
User can Create new filter, Create new starting from existing filter or Use existing filter. The existing
filters  are  listed  in  the  drop down  list  and  they  can  be  added,  edit  or  deleted  from  File->Options-
>Filters

If the edit button was pressed, the Edit filter properties window will show the following options: 
Customize filter - allows you to edit the current filter
Reset to filter - allows you to reset the current filter to a predefined filter from the dropdown list
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Lock to filter - allows you to lock the current filter to a predefined filter from the dropdown list

General 

In  the  Filter  name  field  you  can  type  the  name  of  the  created  filter.  By  default,  the  "New  filter
configuration" name is assigned. If you use an existing filter, the name of that filter is used.

File name

Enabling this will allow defining filters based on file name pattern. 
Press Add and select an existing file extension from the Filter combo (*.doc, *.pdf, *.zip etc.). If the
extension does not exist in the combo, just type it  in  and press OK. You can use the Edit  or  Delete
buttons to modify/remove the file name filters defined.
  
File name patterns can include:

· * - it matches one or more letters. For example a*.doc  matches all  files that  start with a  and
have .doc extension

· ? - it matches only one letter. For example a*.do?  matches all files that start with a  and have
any extension composed of three letters, the first two being do

 
Folder name

Enabling this will allow defining filters based on folder name pattern. 
Enter the directory name that you want to filter in the following format: *\directory_name\* (leading
*\ and  ending  \*  are  required).  Backup4all  will  apply  the  filter  to  all  the  directories  that  are  called
directory_name.  If  you want  to  apply  the  filter  to  directories  containing  a  specific  word,  you  must
enter  it  in  the  following  format  *\*keyword*\*.  Now  Backup4all  will  apply  the  filter  to  all  the
directories  that  have  the  word  keyword in  their  names.  You  can  use  the  Edit  or  Delete  buttons  to
modify/remove the folder name filters defined.
You can also use environment variables when creating filters: %temp%, %SystemRoot% etc.
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File attributes

Enabling this section allows the user to specify file filters depending on the file attributes.
There is a list of quick sets to choose for predefined filter criteria:

· Custom - this is the default option and allows you to check whatever attributes you want

· None - if this is selected all the file attributes check boxes are unchecked

· FAT attributes - if this is selected, a set of File Allocation Table attributes will be used for file
filtering.

· NTFS attributes - if this is selected, a set of NTFS (New Technology File System) attributes will
be used for filtering. Note that these attributes are available only on Windows XP and above.

 
File attributes available for file filters:

· Read-Only - if checked files with read-only attribute will be selected

· Archived - if checked files with archived attribute will be selected

· Hidden - if checked files with hidden attribute will be selected

· System - if checked files with system attribute will be selected

· Compressed (only NTFS) - if checked files with compressed attribute will be selected

· Temporary (only NTFS) - if checked files with temporary attribute will be selected

· Encrypted (only NTFS) - if checked files with encrypted attribute will be selected

· Not indexed (only NTFS) - if checked files with "not indexed" attribute will be selected

· Offline (only NTFS) - if checked files with offline attribute will be selected

· Reparse point (only NTFS) - if checked files with reparse point attribute will be selected

· Sparse file (only NTFS) - if checked files with sparse file attribute will be selected

For  example,  if  you  want  to  include  files  with  read-only  and  archived  attributes  set,  you  have  to
check both attributes checkboxes in a single restriction. If you want to include files with read-only or
archived  attributes set, you have to make two separate restrictions: one for read-only and another
for archived.
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File dates

This section allows the user to build restrictions based on file dates and times. To enable options in
this section, check the Filter by date option.
Filters in this section can be applied by selecting one of the available date filters:

· date accessed

· date and time accessed

· date modified

· date and time modified

· date created

· date and time created

You can compare these dates and times with a fixed date  or a relative date: today,  yesterday,  one
week ago or one month ago.
Comparison operators available:

· < >  date (and time) not equal to fixed or relative date

· < =  date (and time) less than or equal to fixed or relative date

· > =  date (and time) greater than or equal to fixed or relative date

· <  date (and time) less than fixed or relative date

· >  date (and time) greater than fixed or relative date

· in interval - date (and time) in a particular time interval between the Start date and End date

File size

This section provides the possibility to build restrictions based on the file size. To enable the options
in this section, check the Filter by size option. You can enter a file size in the Size  field and select a
measurement  Unit.  The  filter  will  compare  the  file  size  on  disk  with  the  size  you  enter  using  the
comparison filters you selected:

· < >  file size on disk not equal to the value in the Size field

· < =  file size on disk less than or equal to the value in the Size field

· > =  file size on disk greater than or equal to the value in the Size field

· <  file size on disk less than the value in the Size field

· >  file size on disk greater than the value in the Size field
 
Note:
Filters on files and filters on folders must be created individually. If you use a file and a folder filter
condition in the same filter, files will be filtered only if both filter conditions were met. 

Examples

· If you use a single filter for .jpg files and Temp folder, only the .jpg files from Temp folder will  be
filtered. If you use separate filters for files and folders, all .jpg files and whole Temp folder will be
filtered.

· Suppose you want to backup (or restore) all .pdf files accessed in the last month and all .doc  files
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modified in the last week, but you don't want to backup (or restore) system or hidden files.
Here are the steps to define this filter starting from the default filter:

1) Add a new restriction in the include filter: enable File name, add *.pdf file pattern and set date
accessed to be greater than or equal to fixed date one month ago; click OK
2)  Add a  new restriction:  add  *.doc  file  pattern  and  set  date  and  time  modified  to  be  greater
than or equal to fixed date one week ago; click OK
3) Add a new restriction: enable File attributes and the System checkbox, then click OK
4) Add a new restriction: enable File attributes and the Hidden checkbox, then click OK
5) For the last two restrictions, check the Use as exclude filter boxes.

 

7.6 Type

Backup type

User can select one of these backup types:

· Smart 

· Full

· Differential

· Incremental

· Mirror

The backup type can be changed from the Type page in Backup Properties, by selecting the icon for
the desired backup type.
The smart, full, differential and incremental backup types use zip compression to reduce the size of
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the stored backup versions.
The mirror backup type creates in destination an exact copy of the source file without zipping them.

Smart 
Smart  backup  is  a  backup  type  which combines  the  full,  differential  and  incremental  backup  types
with  cleanup  operations  in  order  to  efficiently  manage  the  backups  according  with  the  backup
settings and the free disk space in destination. The Smart backup type starts with a full backup. The
advantage is that you don't need to worry about the number of backups to store in order to fit on the
destination drive, which backup version to clean or merge, as Backup4all will take care of that. Click
here to see all options available for Smart type.

Full 
Full  backup  type  will  create  in  destination  a  zip  file  with  all  source  files  and  folders.  There  are  no
other options available for Full type.

Differential 
The Differential backup will create in destination a zip file containing all new and modified files since
the last full backup. Click here to see all options available for Differential type.

Incremental

The Incremental backup type will create in destination a zip file containing all new and modified files
since the last backup. Click here to see all options available for Incremental type.

Mirror

The Mirror backup will create in destination an exact copy of the source files, without zipping them.
Click here to see all options available for Mirror type.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

Backup Properties - Storage
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7.6.1 Smart

Smart

Maximum space to take in the destination

In time, the disk space occupied by the backups will  grow.  You can select  the maximum size of the
destination drive to be used for backups. You can set the limit in percents or in MB/GB. If you want to
use the entire destination drive only for backups, set the limit to 100%. By default the limit is set to
80% of the destination size.
 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.6.2 Full

Full backup is the starting point for all other backups, and contains all the data in the folders and
files that are selected to be backed up. Because the full backup stores all files and folders, frequent
full backups result in faster and simpler restore operations. This backup type is slow on large
volumes of data, so it is recommended to be done periodically (each Week/Month) and in between
to use other backup types like Incremental or Differential. The advantage is that you only need
the result of one backup execution to make a full restore.
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Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.6.3 Differential

A differential backup contains all files that have changed since the last full backup. The advantage of
a  differential  backup  is  that  it  shortens  restore  time  compared  to  a  full  backup  or  an  incremental
backup. However, if you perform the differential backup too many times, the size of the differential
backup  might  grow  to  be  larger  than  the  baseline  full  backup.  At  the  first  backup  execution  the
catalog was  not  created yet,  so  the  application  will  perform a  full  backup.  The rest  of  the  backups
contain only the files that differ from the latest full backup.
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Differential

Automatically make full backup

If the differential exceeds % of full backup size
In time, the size of the differential can outgrow the full version. For maximum efficiency, the size of
the  differential  should  be  kept  as  small  as  possible.  This  option  will  trigger  the  creation  of  a  full
backup when a certain percentage of the full backup will be exceeded (default is 50%).

Make full backup when the differential exceeds
If  this  is  checked,  Backup4all  will  trigger  the  creation  of  a  full  backup  when  that  custom  size  is
reached  (default is 100 MB).
 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.6.4 Incremental

An  incremental  backup  stores  all  files  that  have  changed  since  the  last  full,  differential  or
incremental  backup.  The  advantage  of  an  incremental  backup  is  that  it  takes  the  least  time  to
complete. However, during a restore operation, each incremental backup is processed, which could
result in a lengthy restore job.
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Incremental

Automatically make full backup

Make full backup when all increments exceed % of full backup size
In time, the size of the incremental can outgrow the full version. For maximum efficiency, the size of
the  incremental  should  be  kept  as  small  as  possible.  This  option  will  trigger  the  creation  of  a  full
backup when a certain percentage of the full backup will be exceeded (default is 50%).

Make full backup when all increments exceed
If  this  is  checked,  Backup4all  will  trigger  the  creation  of  a  full  backup  when  that  custom  size  is
reached  (default is 100 MB).
 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.6.5 Mirror

A mirror  backup  is  identical  to  a  full  backup,  with  the  exception  that  the  files  and  folders  are  not
compressed  in  zip  files  and  they  cannot  be  protected  with  a  password.  A  mirror  backup  is  most
frequently used to create an exact  copy of  the  backup  source  data.  The sources  folder  tree  will  be
recreated in the destination.
This backup type is the fastest, provided that Fast mirror option is checked.
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Mirror

 
Create subfolder(s) in destination

Use this option to create a subfolder in the destination. The name of the folder can be customized by
pressing the Insert tags button. Following tags are predefined:

· Backup Name (<BACKUP NAME>)

· Backup Number (<BACKUP NUMBER>)

· Backup Type (<BACKUP TYPE>)

· Backup Date (<DATE>)

· Backup Time (<TIME>)

· Backup Hour

· Backup Minute

· Backup Second

· Backup Year (<YEAR>)

· Backup Month (<MONTH_MMM>)

· Backup Month - numeric (<MONTH_MM>)

· Backup Day (<DAY>)

· Backup Week (<WEEK>)

· Backup Day of Week (<DAY OF WEEK>)

· Backup Day of Week (locale)

· Backup Day of Week (numeric)
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You can also add your text in tag field. Use the Preview button to see how the name of the subfolder
will look like.

Note that the Fast mirror option will be ignored if you choose to create subfolders in the destination
with a different name each time.

The  option  is  useful  to  store  "snapshots"  of  the  backup  sources  at  different  points  in  time.  For
example, if  you insert a <DATE> tag in the Create subfolder(s)  in destination with following name
and schedule Backup4all to do a mirror backup daily, Backup4all will create every day a copy of your
backup sources in a subfolder named as the date when the backup was executed. On the other hand,
if you insert a <MONTH_MMM> tag and execute the backup daily, the first time your sources will be
copied  entirely  in  a  subfolder  named  as  the  month  when  it  was  performed,  but  in  the  other
remaining days of the  month  only  the  new or  changed files  will  be  copied in  the  same  subfolder  -
when the month name will change another subfolder will be created and the procedure repeated.

Options
 
Fast mirror (copy only new or modified files)
Use  this  option  to  make  mirror  backups  even  faster.  When  this  option  is  set,  Backup4all  uses  the
information stored in ".bkc" files to copy only new or modified files to the destination. If this option
is not  set,  the system will  copy all  files  each time  the  backup  is  executed.  By  default  this  option  is
checked.

Create full paths (including drive letter)
Sometimes there can be sources with the same names. The system will  detect this conflict situation
and will show a warning message.
To avoid files to be overwritten check the Save full folder info option. This will create the full path of
the source in the destination.
For  example,  suppose  we  have  the  backup  source  "C:\My  Documents\My  Pictures".  Without  this
option,  only  the  My  Pictures  folder  will  be  created  and  its  subfolders.  With  this  option  set,  the
destination  will  contain  the  C  folder,  My  Documents  inside  C  folder,  My  Pictures  inside  My
Documents folder and so on. By default this option is unchecked.
  
Copy files in a subfolder
If checked, the files will be copied in a subfolder of the destination folder (typically you will  see a ".
bkc" file and a folder with the same name). If the option is not set, the files (and folder structure) will
be copied directly into the destination folder.

Remove excluded or deleted files from backup
Use this option to remove from the backup the files that were deleted (or excluded) from the backup
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sources. This option is not selected by default.
 
Only if the source drive is available
Use this option to avoid removing your files from backup if the sources are not available all the time.
If you don't use this option, when the source files are not reachable, Backup4all will consider them as
being deleted or excluded.
The deleted or excluded files will be removed from the backup.
  
 
Others
Zip the files
Use this option to zip each file individually. The folder structure will be preserved, only the files will
be zipped. 
 
Copy NTFS security permissions
Use this option to copy the files NTFS security permissions. Please note the NTFS permissions can be
copied only if the backup destination drive is also formatted as NTFS. If the destination is FTP/SFTP/
cloud, it does not work.

Copy NTFS alternate file streams
Use this option to copy the NTFS alternate file streams
 
Allow file splitting when spanning
The  option  is  effective  only  when  there  is  not  enough  space  in  the  destination  to  copy  all  files
(removable  media  is  full,  USB  drive  is  full,  etc.).  If  checked,  the  application  will  copy  files  to  the
destination until a file will not fit. Then it will split that file and continue with the rest of it on the next
disk. If the option is not set, files are not split. If you are backing up media files (music, videos) you
should uncheck this option so that you will not have any melody/movie split. By default this option is
checked.
 
Sort mirror files for optimized spanning
This  option  is  useful  when spanning  the  backup  over  multiple  removable  drives.  If  this  is  checked,
Backup4all will sort the files by size (descending) before copying them on the removable drive. This
way  it  will  start  with  the  larger  files  and  put  the  smaller  ones  towards  the  end  of  the  backup
(optimizing the space used on the removable drive). By default this option is not checked.
 
Be aware that  you can restore only  from the latest version of a  mirror  backup from the Backup4all
interface.  You can restore however manually  previous versions as they  are  accessible  from any  file
manager, like File Explorer.
 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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7.6.6 Storage

Block backup

Block backup feature can be used in Backup4all only if it was enabled before the first execution of the
backup job. That is because the blocks must be identified during the backup and used later when the
source  files  are  modified.  If  no  previous  blocks  exists,  there  are  no  blocks  to  compare  for  later
executions. After the first execution of the backup job without the block backups option selected, the
"Use block backup" option is disabled and cannot be enabled for that job.

Use block backup 
When this option is selected, Backup4all will identify the blocks for each source file. This way, when
large files are modified in small parts (as database files), it is useful to back up only the modified part
(block)  of  the  file,  without  backing  up  the  entire  file  every  time.  This  way  you will  get  smaller  and
faster backups. 

Automatically decide block size
If this option is selected, the size of the block will be determined automatically by Backup4all. 

Custom
If this option is selected, the size of the block will be set manually by moving the slider to a larger or
smaller size.
The slider steps are: 16 KB (smallest size), 34 KB (smaller size),  52 KB (default),  282 KB (larger  size)
and 512 KB (largest size). For files smaller than the size of a block, this feature won't be applied. A file
can have a maximum of 100,000 blocks.
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Use block backup only for files larger than
This  option  can  be  used  only  if  "Custom"  size  option  is  enabled.  If  selected,  it  will  use  the  block
backup only for the files larger than the value you set.

 
Save storage space?

To  keep  the  number  of  stored  zip  files  at  a  reasonable  number,  the  application  provides  three
options: Limit number of file versions, Limit number of backups and Merge backups. These options
either  delete  older  stored  backups  or  perform  an  internal  merge  to  keep  the  number  of  stored
backups or file versions under the selected limit.

The  Limit number of file versions, Limit number of backups and Merge backups options cannot be
used when the backup destination is on a removable media, CD, DVD or Blu-ray disc etc.

By  default  the  Limit  number  of  file  versions  and  the  Limit  number  of  backups  options  are  not
enabled. This means that the system will keep all the stored backup versions. If you choose to enable
the  Merge  backups  option,  when  the  limit  is  reached  the  system  will  perform  an  internal  merge
between the older versions keeping the number of stored backups equal  to the specified limit  (the
merge  between  zip  files  is  necessary  to  keep  at  the  latest  file  version  from  each  zip  file  to  be
merged).
However when changing between Mirror and Full, Incremental or Differential, the older versions are
deleted.

The Limit number of file versions option will delete from the backups only the files that have more
versions than the maximum allowed limit, to keep the number of versions under the specified limit. 
The Limit number of backups option will delete the backups to maintain the maximum limit.
 

Customize prefix of backup files

Typically the name of the zip file is something like: "1_C.zip", "1_D.zip" etc. (one zip for each drive).
The  names of  these  zip  files  do not  make much sense  for  the  user  but  they  can  be  customized  by
pressing the Insert tag button. Following tags are predefined:

· Backup Name (<BACKUP NAME>)

· Backup Number (<BACKUP NUMBER>)

· Backup Type (<BACKUP TYPE>)

· Backup Date (<DATE>)

· Backup Time (<TIME>)

· Backup Hour

· Backup Minute

· Backup Second

· Backup Year (<YEAR>)

· Backup Month (<MONTH_MMM>)
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· Backup Month - numeric (<MONTH_MM>)

· Backup Day (<DAY>)

· Backup Week (<WEEK>)

· Backup Day of Week (<DAY OF WEEK>)

· Backup Day of Week (locale)

· Backup Day of Week (numeric)

You can also add your text in the edit tag field. Use the Preview button to see how the names of the
zip files will look like.
Windows does not allow the following characters in the file name: / \ * ? : " < > |
Therefore  Backup4all  will  prompt  you  to  change  these  characters  if  present  in  the  Customize  zip
name prefix field.

Other

If the Clear archive bit option is checked, the application will remove the Archive flag of the files that
were  added  to  the  backup.  By  default  Backup4all  uses  the  current  comparison  criteria  and  the
information from catalog file  to detect  if  a  file  was  modified  or  not  since  the  last  backup,  which is
more accurate than using only the Archive bit (as other backup programs do). However, if  you want
to backup files based only on the Archive bit attribute, you can change the comparison criteria from
the Backup Properties->Advanced window.
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7.7 Compression

On the Compression page, you can configure the compression and encryption settings.

Zip compression

Level
You can set different compression levels for the backup:

· Zip  without  compression  (Fastest)  -  files  are  just  copied  inside  the  zip  archive,  without  any
compression

· Low compression (Fast)  - select this option if the size of the zip archive is not important, but
the speed of the backup is

· Normal  compression  (Medium)  -  this  is  usually  the  best  choice  because  it  provides  the
optimum rate between zip archive size and the backup speed

· Best compression (Slow) - use this compression level to reduce the zip archive size as much as
possible (the backup speed is reduced)

Use Zip without compression or Low compression if you backup large files to speed up the backup
process. Use High compression  when you want to create the smallest  archive possible.  This option
takes more time if the files included in archive are large.

Do not compress files of type
The filter can be applied to increase the compression performance. It defines what types of files to be
stored uncompressed in the zip file. These are files that are already compressed (e.g. zip, rar, mp3 or
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avi) and using the zip compression on them wouldn't result in a smaller sized backup. You can use the
already  defined  file  types  or  you  can  add  others  using  the  Default  compression  filter  list  in  File-
>Options->Backup. The result will be that the backup will take less time when using compression.

Always use temporary folder to create zip files
If checked, the zip files are created in the temporary folder and then moved to the destination folder.
This means that there should be enough free disk space on the drive where the temporary folder is
located.

When backing up to removable media  (CD,  DVD or  Blu-ray disc,  floppy, zip  disk,  etc.)  this  option is
ignored, the zip files are always created in the temporary folder and then copied to the destination.
When  backing  up  to  internal  hard  drives  or  LAN,  you  should  uncheck  this  option  to  speed  up  the
backup execution. By default this option is not checked.
 
Use alternate zipping mode
If not checked (default zipping mode), each file is compressed in blocks that are immediately added
to  the  final  zip  file.  If  checked  (alternate  zipping  mode),  each  file  is  compressed  in  blocks  in  a
temporary file. When the whole file is compressed in the temporary file,  it  is  added to the final  zip
file.
This option has effect only  when backing up to internal  hard drives and LAN. In all  other cases this
option  is  ignored.  When  backing  up  to  LAN  drives,  it  is  recommended  to  check  this  option  and
uncheck Always use temporary folder to create zip files  option.  When backing up to internal  hard
drives, it is recommended to uncheck both options. By default this option is not checked.

Encrypt the zip files

No encryption
The zip files created are not protected by password for unauthorized access.
 
Strong encryption (AES)
This is the Advanced Encryption Standard, the best  choice in zip  protection, but  recognized only by
the latest version of third party zip applications.
Backup4all supports AES encryption in three different strengths:

· 128  bit  (strong)  -  size  of  the  encryption  key  is  128  bits.  This  provides  significantly  better
security than standard zip 2.0 encryption.

· 192 bit (stronger) - size of the encryption key is 192 bits

· 256  bit  (strongest)  -  size  of  the  encryption  key  is  256  bits.  This  is  the  strongest  encryption
method for zip files and it provides the best security.

 
Standard encryption (Zip2 compatible)
This is the standard Zip 2.0 encryption: an older encryption technique that provides relatively  weak
security  compared  to  AES  encryption.  Zip  2.0  encryption  format  cannot  provide  protection  from
individuals with access to specialized password recovery tools. Its advantage over AES encryption is
the compatibility with all third party zip applications.

Set password
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After you press this button, a windows with the following fields will appear:

· New password
Manually enter the password you want to use for your zip files in this field

· Confirm new password
Re-enter the password in this field to avoid typing errors.

· Old password
This field is enabled only when the backup job already has a password. You can change the password
only if you enter the old one in this field. This way only the owner of the backup will  be allowed to
change the password.
The system makes it possible to set different passwords for the same backup job, so the backup may
contain zip files with different passwords.

Obfuscate file names in zip
Using this option, all file names will be obfuscated and they will have in zip new names as numbers.
This  way you will  get in destination a zip  file  with the source real  names changed in order to get  a
higher  protection.  Normally,  in  zip  file  only  the  file  content  is  protected,  but  anyone  can  see  the
name of the files.  When the obfuscate option is  used,  even if  the real  names of the  files  in  zip  are
replaced  with  numbers,  you  can  still  restore  the  files  with  the  original  names  if  the  correct  zip
password is used.
 
Tips:

· when  choosing  a  password,  it  is  recommended  that  you  use  a  combination  of  letters  and
numbers and at least 8 characters.

· make sure that you remember all passwords that have been used for a backup job, or you will
not be able to restore your files.

 
Split (does not apply to Mirror backup type)
 
Split by size type

· Automatic
This is the default split option, meaning that the size of the zip is limited to the maximum file size
allowed by the file system.

· Predefined
The predefined values are provided for floppy disks, zip disks and different CD media types.
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· Custom size
Sometimes these predefined values are not enough. Therefore you can select Custom size in the
combo and specify the maximum archive size you want. The minimum span size is 512 kilobytes.
The value in the Size field means that each span should not exceed this value. However, because
of  the  zip  algorithm  limitation,  the  system  might  create  spans  with  size  up  to  32-64  kilobytes
smaller than this value.

Split by file number type

· None - The split by file number option is disabled

· Custom  files  and  folders  number  -  Specify  the  maximum  number  of  files  and  folders  to  be
included in a zip file. This option is useful if the application is using a lot of computer memory

 
Create independent splits
Using this option, each backup split can be independently restored. 

If  you have a large backup that spans over several  removable media  (CD/DVD/Blu-ray,  floppy) each
spanned  backup  can  be  independently  restored.  Thus,  if  one  of  the  spanned  backup  disks  is
corrupted you can still restore the other files.
Example:  you  have  a  backup  that  was  spanned  over  20  CDs,  and  you  didn't  leave  the  Create
independent splits option checked. If you need to do a restore and one of the zip files is damaged,
you  lose  all  the  data  from  the  20  CDs.  Now,  if  the  Create  independent  splits  would  have  been
checked, even if one zip file would have been damaged, the data from the other 19 could have been
recovered.

Each  zip  file  created  with  Backup4all  can  be  extracted  with  standard  zip  utilities.  However,  when
using the Create Independent Splits  option and backing up a file  big  enough to  be  split  into  more
than  one  zip  file,  you will  need  to  perform an  additional  operation  if  you  want  to  restore  that  file
manually (without using Backup4all).
Here are the steps for restoring a split file from independent zip archives:

1.  Unzip the archives  that  were  created by  Backup4all.  Assuming  that  the  initial  file  was  called
music.wav,  if  the  file  was  split  in  2  parts  the  problem  is  that  both  will  have  the  same  name,
music.wav. Thus, when un-zipping the archive that contains the second part of the original music.
wav,  you'll  get  a  message  that  a  file  with  the  same  name  already  exist  -  you  need  to  press
Rename and name it music2.wav. Also, to make things easier, you need to rename the first part
of the split file to music1.wav. The files you have renamed, music1.wav and music2.wav, need to
be combined so that you have the entire original file, music.wav.
2.  Open  the  Windows  command  prompt  (Start->Run,  type  cmd  and  press  Enter).  Using  the
command copy (write copy/? and press Enter to see the help for this function) write copy music1.



Backup4all 9308

Backup4all 9 User Manual Copyright © 2021 Softland

wav /b + music2.wav /b music.wav (first two files are the sources, last file is the destination) and
press Enter.  Note that  you have to be in the folder where the source files are in order for it  to
work.

 
  
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.8 Advanced

Options on this page affect the way a particular backup job is executed. 
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Backup options
Use local catalogs (.bkc)
If  this  option  is  checked,  Backup4all  will  keep  a  local  copy  of  the  backup  catalog  for  the  current
backup job. Keeping a local copy of the catalog is recommended in most cases, except when using a
backup rotation scheme to back up to CD, DVD or Blu-ray disc, USB or external drives.
 
Example: the option Use locals catalogs is unchecked and you are performing an incremental backup
to DVD, but on each working day you're changing the DVD so that if one DVD fails you'll still be able
to recover most of your files.  So on Monday you insert DVD 1,  Backup4all  runs and performs a full
backup. On Tuesday you insert DVD 2 (which is  empty)  and Backup4all  performs a full  backup that
includes all the data that's on DVD 1 plus the data that was added in between.
Now, if the Use local catalogs option would have been checked, Backup4all would have executed on
DVD 2 an incremental backup because of the full backup already executed on DVD 1.

Compress catalog in destination
If this option is checked, the .bkc catalog file in destination will be compressed. This is required if you
use the obfuscate option from the Compression page and it's also useful for large catalogs to save the
storage space and also reduces the catalog size to upload in destination.

Keep [n] catalog versions in destination
Use  this  option  to  keep  multiple  versions  of  the  catalog  in  destination.  This  is  useful  if  for  some
reasons the current catalog gets corrupt, you'll have multiple previous versions of the catalog to use.
You can set how many versions of the catalog to keep in destination.
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Test after backup
If  this  option  is  set  Backup4all  will  test  the  resulting  backup  for  data  integrity  after  every  backup
process. Only the latest backup number will be tested after the backup execution. If you wish to test
other backup numbers you can do so from the Test Backup window.

Quick test 
If this option is selected, the files in destination are tested quickly after backup, to check if they exists
and they have the correct size, without calculating the CRC for each file.  It  does not  apply to cloud
destinations and it is not as safe as the normal test.

Remove from catalog all files with errors
This  option,  selected  by  default,  is  used  to  also  repair  the  backup  catalog  during  the  test  after
backup.  If  there  are  files  backed  up  with  problems  and  the  test  on  those  files  fails,  they  will  be
removed from the backup catalog. Next time you run the backup, Backup4all will try to back up those
files again.

Delete sources after successful backup
If this option is checked the backup sources will be deleted after performing the backup. 
This option is disabled if the Test after backup option is not enabled.

Verify backup integrity before execution
If this option is selected, the backup catalog will be also repaired after the current backup version is
tested if there were files not correctly backed up or missing from the backup destination. Those files
will be removed from the backup catalog and they will  be backed up again  next time the backup is
executed.
If this option is selected, the backup integrity will be verified before running the new execution.

Ask for backup label before execution
If this option is set a window will be shown and will prompt the user to enter the label description of
the backup increment.
If you do not want to give a label to the current backup, leave the edit control empty. Check the Don't
label next backups if you do not want to see this window when the current backup job is executed in
the  future.  This  feature  is  particularly  useful  for  incremental  backup  types,  when  the  label  can  be
seen  as  a  milestone  for  all  files  backed  up.  These  labels  are  visible  on  the  Versions  page  of  the
Restore Wizard and in the list of file versions in the Explore view.

Backup open files
If checked, the application will back up open files. Please note backing up open files is possible only
on Windows XP or higher, if the file is stored on a local NTFS hard drive and the VSS service is running
and properly configured.

Backup empty folders
If  checked, the application will  back up empty folders.  Empty folders  may result from their  content
being completely deleted or filtered out.
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Store temporary catalog data in memory
If  checked,  the  catalog  file  will  be  stored  in  RAM  memory.  If  you  receive  an  "Out  of  memory"
warnings or you have a large catalog file,  we recommend you to uncheck that option. If unchecked,
the catalog file will be stored in a temporary file on your hard drive.

Smart file scanning mode
Backup4all  can use the USN journal  to get a  faster detection of  the  modified  source  files.  The USN
Journal (Update Sequence Number Journal), or Change Journal, is a feature of NTFS which maintains
a record of changes made to the volume.
Since version 5.4 of Backup4all, this option is activated by default for all new jobs. It can be activated
manually for jobs created with an older version of Backup4all. 
This feature will scan all files changed on your computer using the NTFS journal. It is faster for large
number of files and frequent backup executions. 

The “Smart file scanning mode” option is used in all cases with the following exceptions:
1. User is not an administrator and the sources are on local drives. For standard users this option

works only for external drives.
2. The source drive is not NTFS formatted.
3. Sources are not on local drives (ex: network drives). This option also works for local removable

NTFS drives (stick, external hard drive, removable drives)
4. Backup job has relative file date filters are (ex: "older than x days"). 
5. If the file/folder filter has changes since the previous backup. 
6. The journal will not be used at first backup (all sources are newly added).
7. The journal will not be used for full backup executions.
8. The journal will not be used when a source is newly added to backup
9. The  journal  will  not  be  used  when the  source  is  changed by  including  other  subfolders/files

that were previously excluded 
10.  Because  parsing  the  NTFS  journal  can  be  slower  in  some  cases  than  parsing  the  files,  the

option will not be used if there are less than 200,000 files & folders in the backup. The 200,000
count is calculated as sum of all files and all folders already present in backup catalog, before
the current backup execution.

Only  if  the  previous  backup  was  in  the  last  X  days  Y  hours  -  use  this  option  to  restrict  when  the
"Smart file scanning mode" option will be used. If the backup executions are rare and there are many
file changes on your computer between two consecutive backups, you should uncheck the "Smart file
scanning mode" option or prevent the backup to use the large USN journal for such cases. 

Backup priority
Using  the  slider  you  can  set  the  backup  execution  priority  compared  to  the  rest  of  the  running
processes  on your system. Setting it  to Highest priority,  for instance, will  determine the  system to
allocate most of its resources for this backup execution.

Run action before backup

Run program or action
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Check this option and select one of the predefined actions or choose a different executable file. You

can either enter directly the path to the program (has to be between quotes) or click the  button
to browse for the file. Backup4all waits until the action is finished before proceeding with the actual
backup process.

The  <Clear  backup>  predefined  action  deletes  the  ".bkc"  file  and  all  zip  files  associated  with  the
current  backup  job.  If  this  action  is  set,  then  the  backup  performed  is  a  full  backup,  even  if  the
backup type is set to incremental or differential . You can customize it with the following parameters
(numbers can be changed as necessary):

· <Clear backup d=7> - Clear backup is executed only if 7 days have passed since the first backup
increment (the full backup).

· <Clear backup n=10> - Clear backup is executed only if the number of file versions is 10.

· <Clear  backup  d=7  n=10>  -  Clear  backup  is  executed  if  7  days  have  passed  since  the  first
backup increment (the full backup) or if the number of file versions is 10.

· <Clear backup dw=1,2,7> - Clear backup is executed only in the first,  second and seventh day
of  the  week  (Monday,  Tuesday  and  Sunday  in  the  given  example).  Valid  values:  1-7  (if  a
parameter outside of these values is set, it will be ignored).

· <Clear  backup  dm=23,  30>  -  Clear  backup  is  executed  only  in  the  23rd  and  30th  day  of  the
month. Valid values: 1-31 (if a parameter outside of these values is set, it will be ignored, same
as using the value 31 for a month having only 30 days).

 
Run only once
If this option is set, the action will run only once at the next backup execution and the Run program/
action option will be reset and disabled afterwards.
 
Abort backup when action fails
User can check this option to abort the backup if the action ran before the backup failed.
Backup4all uses the exit codes returned by the applications.
If the exit code is 0 (zero), it means the action was successful.
If  the  exit  code  is  different  than  0  (zero),  the  action  was  not  successful  and  the  backup  will  be
aborted.

Run action after backup

Run program or action
Check this option and select one of the predefined actions or choose a different executable file. You

can either enter directly the path to the program (has to be between quotes) or click the  button
to browse for the file. Backup4all does not wait for the action to be finished before proceeding.

Available predefined actions:

· <Stand by> - The computer will enter in the Stand by state after the backup is executed.

· <Hibernate> - Computer enters in Hibernate (if available) after the backup execution.

· <Log  off>  -  Closes  all  applications  and  logs  off  current  user.  When  force  parameters  is  set
(example: <Log off /f>), the system will force applications to be closed. Force parameter might
cause some applications to loose unsaved data.

· <Shut down> - Shuts down the computer. When force parameters is set (example: <Shut down



Backup Properties 313

Backup4all 9 User Manual Copyright © 2021 Softland

/f>),  the  system  will  force  applications  to  be  closed.  Force  parameter  might  cause  some
applications to loose unsaved data.

 
Run only once
If this option is set, the action will run only once at the next backup execution and the Run program/
action option will be reset and disabled.

Run program or action on
You can set conditions to run the action after the backup: on Success, on Warnings or on Errors. You
can check multiple options or a single one, but at least one option must be checked.

Comparison
 
Criteria
This section contains special settings for advanced file comparison. You can set what properties of a
file will be used when deciding if a file was modified or not.
 
There is a list of quick sets to choose for predefined comparison criteria:

· None  -  if  this  is  selected,  a  warning  window is  shown asking  you to  confirm if  you want  the
Date modified criteria disabled or not. If this criterion is disabled, Backup4all will only backup
files that have the size changed.

· Custom  -  this  is  the  default  option  and  has  several  important  file  properties  and  attributes
selected as comparison criteria (Size, Date modified, Date created,  Archived,  Hidden, System,
Read-Only).

· Archive attribute only - if this is selected, a warning window is shown asking you to confirm if
you want the Date modified criteria disabled or not. If this criteria is disabled, Backup4all will
only backup files that have the archive attribute changed.

· FAT  attributes  -  if  this  is  selected,  a  set  of  File  Allocation  Table  attributes  will  be  used  for
comparison

· NTFS attributes - if this is selected, a set of NTFS (New Technology File System) attributes will
be  used  for  comparison.  Note  that  these  attributes  are  available  only  on  Windows  XP,  and
above.

Available file properties are:

· Size - file size (it is mandatory)

· Date  modified  -  the  latest  date  and  time  when  the  file  was  modified  (a  warning  message  is
displayed if you uncheck it)
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· Date created - the date and time when the file was created

· CRC32  -  the  most  comprehensive  criteria  because  it  calculates  a  checksum  based  on  file
contents and compares it with the checksum from the backup (this slows the process)

Available file attributes are:

· Read-Only - file can be read, but not modified or deleted

· Archived  (unavailable  when  the  Clear  archive  bit  option  is  checked  from  the  Backup
Properties->Type window) - file attribute used for backup. When a file is created, the archive
bit is turned on. When a backup program copies the file, it turns off the archive attribute.

· Hidden - files marked Hidden do not normally display unless the file manager option to display
them is selected

· System - files marked System do not normally display unless the file manager option to display
them is selected

· Compressed (only NTFS) - file that is made generally much smaller than the original size of file.
Decompression occurs automatically when the file is read. The file is compressed again when it
is closed or saved.

· Temporary (only NTFS) - the file is being used for temporary storage.

· Encrypted  (only  NTFS)  -  file  is  encrypted  on  a  NTFS  volume  to  protect  it  from  unauthorized
access

· Not indexed (only NTFS) - file not indexed by the content indexing service

· Offline (only NTFS)  -  content  of  the  file  is  not  immediately  available.  This  attribute  indicates
that the file data has been physically moved to an offline storage.

· Reparse point (only NTFS) - reparse points are used as building blocks by Microsoft and third-
parties to enhance NTFS file system behavior.

· Sparse file (only NTFS) - in a sparse file, large ranges of zeroes may not require disk allocation.
Space for nonzero data will be allocated as needed as the file is written.

If  you  select  more  than  one  attribute,  Backup4all  will  consider  the  file  for  backup  if  any  of  the
attributes selected is changed.
Legacy (use archive bit)
If this is selected, Backup4all will  determine which files will  be backed up by verifying if the archive
bit attribute is set. If the archive bit attribute for a file is not set, that file will  be ignored (even if its
size  was  modified  for  instance).  Our  recommendation  is  to  use  the  Criteria  option  since  it's  more
accurate than using the archive bit alone.
 
 
Play sounds after backup

Use this section to set sound notifications to be played when the backup is finished. There are three
types of sound notifications depending on the backup status: success, warning and error.

Play sounds
If checked then success, warning and error sounds will be played at the end of the backup. By default
this option is not checked.

On success
It indicates the sound that will be played when the backup is finished with success. The default sound
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is  <Default  beep  sound>,  but  you can  change  it  using  the  Open  button  .  If  you press  the  Play

button  you can hear the selected sound file. To disable this sound you can select from the drop-
down box <No success sound>.

On warning
It  indicates  the  sound  that  will  be  played  when  the  backup  is  finished  with  warnings.  The  default

sound is <Exclamation sound>, but you can change this using the Open button . If you press the

Play button   you can hear the selected sound file. To disable this sound you can select from the
drop-down box <No warning sound>.

On error
It indicates the sound that will be played when the backup has failed because of an error. The default

sound is <Asterisk sound>, but you can change this using the Open button . If you press the Play

button  you can hear the selected sound file. To disable this sound you can select from the drop-
down box <No error sound>.

Open sounds
This  button  will  open  the  standard  Sounds  and  Multimedia  Properties->Sounds  window  of  the
operating system (that can also be opened from the Control Panel). You can use this to configure or
troubleshoot your sounds settings.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.9 Email

Use this  section  to  set  email  notifications  to  be  sent  when the  backup  is  finished.  There  are  three
types  of  email  notifications  depending  on  the  backup  status:  success,  warning  and  error  email
notifications.
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Emails

Send emails:
If checked then notification emails will be sent at the end of the backup, test or cleanup operation to
the specified email addresses (email addresses must be separated by comma to be recognized). This
option  can  be  checked/unchecked  only  if  the  File->Options->Email  window  has  the  Enable  email
notification option checked.

Send emails to:
Specify  the  email  address  where  the  notification  emails  will  be  sent.  You  can  enter  multiple  email
addresses separated by comma.

Log

Attach log file to email
If this option is checked, the backup log file will be attached to the email.

Compress the log file
Option is active only if Attach log file to email option is checked. If this option is enabled, Backup4all
will zip the log file before sending it. Additionally you can encrypt the log file.
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No encryption
The zipped log file created is not protected by password for unauthorized access.

AES encryption(*)
This is the Advanced Encryption Standard, the best  choice in zip  protection, but  recognized only by
the  latest  version  of  third  party  zip  applications.  Backup4all  supports  AES  encryption  in  three
different strengths:

· 128  bit  (strong)  -  size  of  the  encryption  key  is  128  bits.  This  provides  significantly  better
security than standard zip 2.0 encryption.

· 192 bit (stronger) - size of the encryption key is 192 bits

· 256  bit  (strongest)  -  size  of  the  encryption  key  is  256  bits.  This  is  the  strongest  encryption
method for zipped log file and it provides the best security.

Zip(2) compatible encryption
This is the standard Zip 2.0 encryption: an older encryption technique that provides relatively  weak
security  compared  to  AES  encryption.  Zip  2.0  encryption  format  cannot  provide  protection  from
individuals with access to specialized password recovery tools. Its advantage over AES encryption is
the compatibility with all third party zip applications.

Set password
After you press this button, a windows with the following fields will appear:

· New password
Manually enter the password you want to use for your zipped log file in this field. If you enter
a password with less than 8 characters, a warning window will  be displayed when you click
OK notifying that the password is not secure enough.

 

· Confirm new password
Re-enter the password in this field to avoid typing errors.

· Old password
This  field  is  enabled  only  when  the  log  file  encryption  already  has  a  password.  You  can
change the password only if you enter the old one in this field. This way only the owner will
be allowed to change the password.

Tips:

· when  choosing  a  password,  it  is  recommended  that  you  use  a  combination  of  letters  and
numbers and at least 8 characters.

· make sure that you remember the password used, or you will not be able to extract the log file.
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Email Messages

Use HTML format for emails
If  this  option  is  selected,  the  email  template  used  will  be  sent  as  html.  This  way,  the  notification
emails can be customized in many ways.

On successful backup send
It indicates the email that will be sent when the backup is finished with success. The default email is

<Default email>, but you can change it using the Open button . If you press the Edit button 
you can modify the selected email file (except the default email). Also there is the option to choose
<No email> if you don't want Backup4all to send an email if a backup was successful.

On backup with warnings send
It indicates the email that will be sent when the backup is finished with warnings. The default email is

 <Default email>,  but you can change this using the Open  button .  If  you press the Edit  button

 you  can  modify  the  selected  email  file  (except  the  default  email).  Also  there  is  the  option  to
choose  <No email>  if  you don't  want  Backup4all  to  send an  email  if  a  backup  was  completed  and
there were warnings during execution.

On backup with errors send 
It indicates the email that will  be sent when the backup has failed because of an error.  The default

email is <Default email>,  but you can change this using the Open  button . If you press the Edit

button  you can edit the selected email file (except the default email). Also there is the option to
choose  <No  email>  if  you  don't  want  Backup4all  to  send  an  email  if  there  were  errors  during  the
execution of the backup.

On successful test send 
It indicates the email that will  be sent when the test operation is finished with success. The default

email  is  <Default  email>,  but  you  can  change  it  using  the  Open  button  .  If  you  press  the  Edit

button  you can modify the selected email file (except the default email). Also there is the option
to select <No email> if you don't want Backup4all to send an email if a test operation was successful.

On test with errors send
It indicates the email that will be sent when the test operation failed because of an error. The default

email is <Default email>,  but you can change this using the Open  button . If you press the Edit

button  you can modify the selected email file (except the default email). Also there is the option
to select  <No email>  if  you don't  want Backup4all  to send an email  if  there were errors during the
test operation.
 
On successful cleanup send
It  indicates  the  email  that  will  be  sent  when  the  cleanup  operation  is  finished  with  success.  The

default email is <Default email>, but you can change it using the Open button . If you press the
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Edit  button  you can modify  the selected email  file  (except the default  email).  Also there is  the
option to select <No email> if  you don't want Backup4all to send an email if  the cleanup operation
was successful.

On cleanup with error send
It  indicates the email  that  will  be  sent  when the  cleanup  operation  failed  because  of  an  error.  The

default email is <Default email>, but you can change this using the Open button . If you press the

 Edit  button  you can modify the selected email file (except the default email).  Also there is  the
option to select <No email> if you don't want Backup4all to send an email if there were errors during
the cleanup operation.
  

Customizing emails

If you want to create a customized email to be sent (on success/warning/error), the email template
will  have  to  include  special  tags  that  Backup4all  will  recognize  and  replace  according  to  the
description (note that the format of the tag must be <#tag_name>):

· <#BACKUP_NAME> - will insert the name of the executed backup job

· <#TAG_NAME> -  will insert the name of the backup tag

· <#SOURCES> -  will insert the sources of the executed backup

· <#DEST_DRIVE> - will insert the destination drive letter

· <#DEST_DRIVE_TYPE> - will insert the destination drive type

· <#DEST_FOLDER> - will insert the name of the destination folder

· <#DEST_CATALOG_FILE> - will insert the name of the catalog file created

· <#BACKUP_TYPE> - will insert the backup type that was performed

· <#SCHED_NEXT_EXECUTION> - will insert the next scheduled execution

· <#SCHED_NEXT_TAG_EXECUTION> - will insert the next scheduled tag execution

· <#BACKUP_START_TIME> - will insert the start time of the backup executed

· <#BACKUP_END_TIME> - will insert the end time of the backup executed

· <#TEST_START_TIME> - will insert the start time of test

· <#TEST_END_TIME> - will insert end time of test

· <#LAST_BACKUP_SIZE_COMPR> - will insert the resulted size of the last backup

· <#TOTAL_BACKUP_SIZE> - will insert the total backup size

· <#REMAINING_DISC_SPACE> - will insert the remaining space on the destination drive

· <#NBR_FILES_ADDED> - will insert the number of files added to the backup

· <#SIZE_FILE_ADDED> - will insert the size of the added files

· <#NBR_FILE_WARNINGS> - will insert the number of warnings

· <#NBR_ERRORS> - will insert the number of errors

· <#LAST_LOG_NAME> - will insert the name of the last log file

· <#EXCLUDED_SOURCES> - will insert the list of sources excluded

· <#TESTED_VERSIONS> - will insert the list of tested backup numbers

· <#TEST_SUMMARY> - will insert the detailed list of test backup numbers

· <#REMOVED_VERSIONS> - will insert the list of backups removed after cleanup

· <#CLEANUP_SUMMARY> - will insert the detailed list of backup numbers removed

· <#CLEANUP_START_TIME> - will insert the start time of cleanup
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· <#CLEANUP_END_TIME> - will insert the end time of cleanup

· <#PROCESSED_SIZE> - will insert the total size of the files removed

For an example of usage, open one of the 5 default  emails.  The emails  are stored in text format in
application's  directory  (i.e.  "C:\Program  Files  (x86)\Softland\Backup4all  9\")  with  the  following
filenames:  SuccessFullEmail.txt,  WarningFullEmail.txt,  ErrorFullEmail.txt  for  backup  emails,
TestSuccessFullEmail.txt and TestErrorFullEmail.txt for test emails.
Similar  same  file  names exists  for  the  html  version  of  the  email  template.  Depending  of  the  email
notification type you use (text or html), the corresponding email templates needs to be used.

The customized email template must be saved on your computer. Then select it to be used in Backup
Properties->Email page, under "Email messages" section.
If you change the default html email templates, the modifications will be applied to all jobs using the
default html email templates.
If  you change the text email template, you must load it in Backup Properties->Email  in  order to be
used, as the default one is in application not in the text file.

The subject line of the email sent can be customized too by adding the following line at the beginning
of the customized file that will be used by Backup4all as an email: <! Subject of the email !>
  
Here is  an example of a  customized email  that  can be  sent  when a  cleanup  operation  is  successful
(note that the first line of this will be used as the subject line of the email):

<!Cleanup for <#BACKUP_NAME> finished successfully at <#CLEANUP_END_TIME>!>
Cleanup for backup job <#BACKUP_NAME> at <#CLEANUP_START_TIME> finished successfully.
See log file <#LAST_LOG_NAME> for more information.
Removed backups : <#REMOVED_VERSIONS>
Removed version details:
<#CLEANUP_SUMMARY>
----- 
Total removed file size : <#PROCESSED_SIZE>
Free space on destination: <#REMAINING_DISC_SPACE>
Cleanup started at:  <#CLEANUP_START_TIME>
Cleanup finished at:  <#CLEANUP_END_TIME>

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.10 Scheduler

Scheduler

Scheduler  lists all the available information about the scheduled tasks and allows you to Add,  Edit,
Delete and Schedule new tasks. This only applies to the current backup job.
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Right-clicking an existing scheduled task (or using the top buttons) will display the following options:

· Add - opens the Scheduler Properties window and allows you to add a new scheduled task

· Edit 

· Properties  -  opens  the  Scheduler  Properties  window  where  you  can  edit  selected  the
scheduled task

· User and password - opens a window where you can set the username and the password.

· Delete - removes the selected scheduled task

· Refresh - refreshes the scheduled tasks list

There  are  several  columns  in  the  Schedulers  window  that  provide  information  for  each  scheduled
task:

· Enabled - if the checkbox is marked then the scheduled task will run, if is unchecked it will not
be executed

· Job Type - shows the job type

· Scheduler - shows the scheduler type: Windows or Shutdown.

· Run in - shows if the scheduled task will run using the main interface or in background

· Action - shows the type of action associated with the scheduled task (default, full, differential,
incremental, cleanup, test)

· Backup Type - shows the backup type set in scheduler

· Task file - shows the name of the task file 

· Status - displays the status of the scheduled task

· Next Run Time - calculates the next date and time when the scheduled task will run.

· Last Run Time - shows the last date and time when the scheduled task ran.

· Schedule - shows the type of schedule selected for the task

· User - shows the user name for which the job is scheduled to run

· Last run result - shows the status of the last scheduled executed action for that job
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The scheduled tasks in the list can be sorted by clicking on the column headers. The right-click menu
on the column header provides a  handy way to show/hide  columns  (except  the  Enabled which are
grayed out).
You can also drag a column header on the above grey zone, if you want to group the scheduled tasks
by that column.

Options
 
Abort backup when source drives are not available 
If this option is checked the backup will be aborted when using sources from unavailable drives
 

Backup4all uses by default the Windows Task Scheduler in order to run the scheduled tasks so you
need to make sure that the Task Scheduler service is enabled on your computer. Use the Windows
Help in order to find out more information about scheduling a task using the Task Scheduler. 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.10.1 General

This is the fist page of the Scheduler Properties window which appears when you click on the Add or
Edit  button  in  the  Scheduler  window  of  Backup  Properties  or  in  the  global  Scheduler  page  of  the
application. This allows you to add or edit a scheduled task for the current backup job.
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Execute

Show main application
Use this  option  if  you want  the  main  application  window to  be  shown when the  scheduled  task  is
executed. By default, this option is unchecked and the scheduled tasks will run in background. 

Close after run
If this option is checked, Backup4all will be closed after the task is executed. This option applies only
if the application was started by the current scheduled task.

Scheduler
We  use  only  the  Windows  scheduler  (no  more  built-in  scheduler),  which  can  be  set  up  with  or
without a password, depending if you want the task to run when no user is logged on or only when
there is an user logged on.
With Windows scheduler

· Run only if  the user is  logged on -  the task will  run under  the  specified  user  account  only  if
there is an user logged on

· Run whether the user is logged on or not - the task will run even if there is no user logged on 
Password - press this button to set the Windows login password for the above specified user

account 
At system shutdown - If this is selected, the task will  be executed when the shutdown command is
started.  Backup4all  intercepts the shutdown message and there is  no way to  know  if  a  restart  or  a
shutdown  was  requested.  This  is  why  it  will  always  shutdown  your  computer  after  the  task  is
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executed.

Priority

Indicates  the  task  priority.  Move  the  cursor  to  right  or  left  in  order  to  increase  or  decrease  the
priority.

Notifications
Force all notifications to timeout - use this option to force all notifications to timeout. This option is
useful  to  continue  the  overnight  backups  when  there  is  a  message  waiting  for  user  input.  That
message will be closed and the backup will continue.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.10.2 When

On this page you can set when do you want to execute the scheduled task.
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Run task as soon as possible after a scheduled start is missed
Use this option to run missed tasks as soon as possible.

Start the task only if the computer is on AC power
If this option is selected, the backup will be executed only if the computer is on AC power.

Wake the computer to run this task
Use this option to wake the computer from sleep mode at the scheduled time.

Start the task only if the computer is idle for
Use this  option  to  indicate  how  long  to  wait  when the  computer  is  idle  before  the  scheduled  task
starts.

When to run

In this section you can specify the conditions that will trigger the task. Use the Add, Edit and Delete
buttons to manage the triggers for this task.



Backup4all 9326

Backup4all 9 User Manual Copyright © 2021 Softland

Pressing Add or Edit button will open the Trigger Properties window. 

When -here you can select when to run the task: one time, daily, weekly, monthly, at user logon
or on idle.
The Synchronize across time zones option allows you to run the scheduled backups at the same
hour if you change the time zone.
Select the recurrence option you want to use.

· One time - select this option if you want the scheduler to be executed only one time
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· Daily - select this option if you want the scheduler to be executed daily.

· Weekly - select this option if you want the scheduler to be executed weekly on the days
you select.
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· Monthly  -  select  this  option  if  you  want  the  scheduler  to  be  executed  monthly  on  the
months and days you select.
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· At user logon - select this option if you want the scheduler to be executed every time at
user logon.
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· On idle - select this option if you want the scheduler to be executed when the computer is
idle.

Advanced
On this page, you can set the expiration date and time or the repeat frequency.
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Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

7.10.3 What

On this page you can set what action to be executed.
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What to execute

· Backup
Type

· Default - executes the default backup type defined in the backup job's properties

· Smart - executes a smart backup, no matter what the backup type defined in the backup
job is

· Full - executes a full backup, no matter what the backup type defined in the backup job is

· Differential  - executes a differential backup, no matter what the backup type defined in
the backup job is
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· Incremental  - executes an incremental backup, no matter what the backup type defined
in the backup job is

Clear backup before run
If  this  is  checked, Backup4all  will  first  delete the  ".bkc"  file  and  all  zip  files  associated  with  the
current backup job and after that execute the scheduled backup.

Erase disk before backup
This option is available only if the backup destination is a CD/DVD/Blu-ray disk.  When selected,
the CD/DVD/Blu-ray will be erased before the backup execution.

 

· Test - you can schedule a test operation instead of a backup. When Test is selected, the Backup

Numbers  box is  displayed .  You  can  type  in  there  the  backup  numbers  you
want to test. The order you type them in is the order they will be tested in. Use the * character
to test all backup numbers, or the # character to test only the last backup.

· Repair - you can schedule a repair action to be executed. The missing or corrupted files from
destination will be backed up again.

· Repair catalog only - if this option is checked, only the backup catalog will be repaired, the
missing or corrupted files in destination will be removed from the backup catalog, so they
will be backed up again next time.

· Cleanup  -  at  the  scheduled  date  it  deletes  the  selected  backup  numbers.  When  Cleanup  is
selected, other options become available to filter the backup numbers that will be deleted:

· Newer than  -  if  checked backup numbers that  are newer  than  the  selected date will  be
deleted when the scheduled Cleanup operation runs

· Older  than  -  if  checked  backup  numbers  that  are  older  than  the  selected  date  will  be
deleted when the scheduled Cleanup operation runs

· Older than (fixed date) - backup numbers that are Older than a certain fixed date will be
deleted when the scheduled Cleanup operation runs

· Do not delete full backups - if  this is checked, the full  backups will  be kept even if  they
fall into the range of files filtered for deletion

· Do  not  delete  differential  backups  -  if  this  is  checked,  the  differential  backups  will  be
kept even if they fall  into the range of files filtered for deletion.  Note that  this  option is
available only when Do not delete full backups is  checked, because differential  backups
depend on full backups.

· Clear  the  destination  folder  -  Deletes  files  and  folders  that  should  not  be  in  the
destination folder. Only the files mentioned in backup catalog are kept.

· Restore - select this option if you want to schedule a restore action.

· Original location - use this option to restore files in the original location

· Other location - use this option to restore files in another location
Do not create drive letter folder  -  if  this  option is  checked,  when restoring to  another
location, the drive letter folder won't be created.

· Restore the latest version - use this option to restore the latest version of all files

· Restore all files as of - use this option to restore the files as they were on a specified date

· Restore backup numbers - use this option to restore one or more backup numbers
Restore excluded and deleted files - if this option is checked, excluded and deleted files will be
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also restored.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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8 Restore Wizard

8.1 Where and how to restore

Using the  Restore Wizard  you can  restore from a  backup  job.  In  the  first  step  you can  choose the
destination, the priority of the execution and customize the restore operation if you wish.

Where do you want to restore?

Use original location
Copies the files from the zip  backup into the original  location. If  a  file  with the same name already
exists, a dialog will be shown prompting for an action before the restore can continue.
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Choose another location
Copies files from the zip backup to a different folder. If selected, you can choose a different folder to
restore files from the backup.

Do not create drive letter folder
If  checked,  Backup4all  will  restore  the  files  in  the  designated  location  using  the  original  directory
structure.  If  you  select  this  option  and  you  have  files  from  multiple  drives,  some  files  might  get
overwritten. For example, if you backed up your Users folder from your C drive, when you restore it
to a different  location having the Do not create drive letter folder  unchecked,  Backup4all  will  first
create a folder named C and in it place the Users folder. If you would have checked the Do not create
drive letter folder option, the folder named C wouldn't have been created.

How do you want to restore?

Restore the latest version of all files
Backup4all will restore the latest version for all the files in the backup.

Restore all files as of
Choose the date to which you want to restore the files. The restored files will be exactly as they were
on the selected date.

Note: If you used the Limit number of file versions  option, restoring the files as of a specified date
could not restore all your files if some of them were deleted by the file version limitation.

Choose files and restore the latest version
Backup4all will  restore the latest version for all the files in the backup. You will  be able to filter the
files using the Preview page.
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Choose/filter files and restore the latest version
Backup4all  will  restore  the  latest  version  of  the  files.  Files  that  are  excluded  from  backup  are  not
restored. Check the status of the files in the Explore view of the main screen.
 
Choose/filter files and restore any version
Lets you specify which version of the files will be restored. For example, you might restore all files in
their original state from the first backup number.
 
Restore excluded and deleted files
If  this  option  is  checked,  the  latest  version  of  all  files  will  be  restored,  even  if  these  files  were
excluded from the backup.

 
Preview files at the end of wizard
If checked, a preview page with the files to be restored will be shown at the end of wizard.

Using the slider from the bottom of the Restore Wizard window, you can set  the restore execution
priority  compared  to  the  rest  of  the  running  processes  on  your  system.  For  example,  setting  the
priority to Highest priority, will determine the system to allocate most of its resources for the restore
execution.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

8.2 What do you want to restore

This is the second step of the Restore Wizard. It appears only for Choose files and restore from the
latest version, Choose/filter files and restore the latest version and Choose/filter files and restore
from any version options.
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You can uncheck the files you don't want to restore. By default, all files are checked.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

8.3 To what date do you want to restore

This is the third step of the Restore Wizard if the Choose/filter files and restore any version option
was chosen.
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Restore as of
This option allows you to restore your files and folders to a specified date. Just select the data, press
Apply and then press Finish.

The purpose of this step is to let you select versions to restore. Use left mouse clicks together with
SHIFT and/or CTRL keys to select several backup numbers to restore. The most recent version of a file
in the selected backup number will be restored. If you select all backup numbers, then a full restore is
performed just as the Choose/filter files and restore the latest version restore option.

Note: If you used the Limit number of file versions  option, restoring the files as of a specified date
could not restore all your files if some of them were deleted by the file version limitation.

If you use the Mirror backup type, the Restore as of feature is not available. The Mirror backup type
does not keep track of file versions. Only the last version is available for restore.
 
Information provided for each version:

· Type - Type of the Backup. Each of the backup types is  represented by a descriptive icon:  

Full,  Incremental,  Differential,  Mirror

· Backup Date - Date and time when the version was added to the backup

· Backup No. - Number of the backup increment
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· File No. - Number of files in the backup

· Folder No. - Number of folders in the backup

· Excluded File No. - Number of excluded files in the backup

· Excluded Folder No. -  Number of excluded folders in the backup

· Comp. Size - Size of the file version (compressed)

· Uncomp. Size - Size of the file version (uncompressed)

· Label - Label of the backup number. This column is hidden by default

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

8.4 Do you want to filter the files

This  is  the  third  step  of  the  Restore  Wizard  for  Choose/filter  files  and  restore  the  latest  version
restore type. For Choose/filter files and restore any version restore type, this is the fourth step. You
can filter the files to be restored.
Its  behavior  is  the  same  as  the  Filters  page  of  the  New  Backup  Wizard  or  the  Backup  Properties
window, except that the process is restore and not backup.

The Filters page defines files filters to be applied to files that are going to be restored. Only files and
folders that match the filters will be restored.

You can add include or exclude filters. By default all files are included in the list to be restored.
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The system selects only  files that  match the include filter and do not  match the exclude filter.  This
means the exclude filter is more powerful: if a file satisfies both include and exclude filters, it will not
be processed by the system.
Include and exclude filters are composed from filter restrictions:

· two or  more filter restrictions in the include  filter  means that  a  file  must  satisfy  at  least  one
restriction to be restored.

· two or more filter restrictions in the exclude filter means that a file must satisfy any restriction
to be excluded.

In the Type column you can see if the filter is for include or exclude. To change the filter type, press
the "Change to Include" or "Change to Exclude" button.

You can manage filter restrictions using the buttons:

· Add include - this will open a new window from where you can add a new restriction to the list
of include filters.

· Add exclude - this will open a new window from where you can add a new restriction to the list
of exclude filters.

· Edit - will open the same window as Add, with the selected filter's properties. You will be able
to modify the selected restriction.

· Copy - will create a copy of the selected filter.

· Delete - will delete the selected filter from the list.
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Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

8.5 Preview the files to be restored

This page is the final step of the Restore Wizard. It appears only if the Preview files at the end of
wizard option is checked. The purpose of this step is to show a preview of the files that will be
restored. If any other customization is required, user must go back and reselect the files to be
restored.

For the Choose/filter files and restore any version restore type, files and folders shown in the tree
are calculated based on selected backup versions. Files that have not been backed up in the selected
backup versions or  were filtered will  not  be shown in  the  tree.  Selecting  all  backup  versions  in  the
Choose/filter files and restore any version restore type is the same as using the Choose/filter files
and restore the latest version type.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
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feature matrix topic.
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9 File Filtering

9.1 Overview

File  filtering  in  Backup4all  provides  an  intuitive  way  to  define  what  files  and  folders  to  back  up  or
restore.

Select Folders and Files for filtering
 
The files can be filtered when added to backup. On the "What do you want to backup" page, from the
Backup Wizard or Backup Properties->Sources page each file and folder is shown in the tree with a
checkbox in front of it. If you uncheck it, the file or folder will be excluded from the backup or restore
process. 

After  applying filters,  each file  and folder is  shown in the tree with a  checkbox in front  of it.  If  you
uncheck it, the file or folder will be excluded from the backup or restore process.

Filter
 
The role of the filter is to restrict the files from the sources or destination that will participate in the
backup or restore process. The filter actually consists of two filters: the include filter and the exclude
filter.

Include filter shows which files will be included in the backup or restore process. If the filter type is
"Include", it means the files which match the filter will be included in backup.
Exclude  filter  shows  the  files  that  will  be  excluded  from the  backup  or  restore.  If  the  filter  type  is
"Exclude", it means the files which match the filter will be excluded from backup.
You can change the  filter  type  from Include to  Exclude  or  from Exclude  to  Include if  you press  the
"Change  to  Include"/"Change  to  Exclude"  button.  If  no  filters  are  defined,  then  all  the  files  and
folders from sources will be backed up or restored.
 
 
Customize
 
There are special situations when the main filter is not enough to define the files to be backed up or
restored. In this case, you can refine the filters adding individual filters for folders. The refined filter
applies to all the files and subfolders of that  folder.  All  files and folders  for which a refined filter is
applied are marked with red.
To remove a refined filter, select the folder, select the filter and press the Delete button.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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9.2 File Filter

The Edit file filter item window is shown every time a file filter restriction is added or modified. It can
be opened by pressing the Add button from the Filters page (New Backup Wizard, Backup Properties,
Restore Wizard window or Files->Options) or the Edit button (if filters are already defined).

 

 
What do you want to do?

User can Create new filter, Create new starting from existing filter or Use existing filter. The existing
filters  are  listed  in  the  drop down  list  and  they  can  be  added,  edit  or  deleted  from  File->Options-
>Filters

General 

In  the  Filter  name  field  you  can  type  the  name  of  the  created  filter.  By  default,  the  "New  filter
configuration" name is assigned. If you use an existing filter, the name of that filter is used.

File name
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Enabling this will allow defining filters based on file name pattern. 
Press Add and select an existing file extension from the Filter combo (*.doc, *.pdf, *.zip etc.). If the
extension does not exist in the combo, just type it  in  and press OK. You can use the Edit  or  Delete
buttons to modify/remove the file name filters defined.
  
File name patterns can include:

· * - it matches one or more letters. For example a*.doc  matches all  files that  start with a  and
have .doc extension

· ? - it matches only one letter. For example a*.do?  matches all files that start with a  and have
any extension composed of three letters, the first two being do

 
Folder name

Enabling this will allow defining filters based on folder name pattern. 
Enter the directory name that you want to filter in the following format: *\directory_name\* (leading
*\ and  ending  \*  are  required).  Backup4all  will  apply  the  filter  to  all  the  directories  that  are  called
directory_name.  If  you want  to  apply  the  filter  to  directories  containing  a  specific  word,  you  must
enter  it  in  the  following  format  *\*keyword*\*.  Now  Backup4all  will  apply  the  filter  to  all  the
directories  that  have  the  word  keyword in  their  names.  You  can  use  the  Edit  or  Delete  buttons  to
modify/remove the folder name filters defined.
You can also use environment variables when creating filters: %temp%, %SystemRoot% etc.

 

File attributes

Enabling this section allows the user to specify file filters depending on the file attributes.
There is a list of quick sets to choose for predefined filter criteria:
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· Custom - this is the default option and allows you to check whatever attributes you want

· None - if this is selected all the file attributes check boxes are unchecked

· FAT attributes - if this is selected, a set of File Allocation Table attributes will be used for file
filtering.

· NTFS attributes - if this is selected, a set of NTFS (New Technology File System) attributes will
be used for filtering. Note that these attributes are available only on Windows XP and above.

 
File attributes available for file filters:

· Read-Only - if checked files with read-only attribute will be selected

· Archived - if checked files with archived attribute will be selected

· Hidden - if checked files with hidden attribute will be selected

· System - if checked files with system attribute will be selected

· Compressed (only NTFS) - if checked files with compressed attribute will be selected

· Temporary (only NTFS) - if checked files with temporary attribute will be selected

· Encrypted (only NTFS) - if checked files with encrypted attribute will be selected

· Not indexed (only NTFS) - if checked files with "not indexed" attribute will be selected

· Offline (only NTFS) - if checked files with offline attribute will be selected

· Reparse point (only NTFS) - if checked files with reparse point attribute will be selected

· Sparse file (only NTFS) - if checked files with sparse file attribute will be selected

For  example,  if  you  want  to  include  files  with  read-only  and  archived  attributes  set,  you  have  to
check both attributes checkboxes in a single restriction. If you want to include files with read-only or
archived  attributes set, you have to make two separate restrictions: one for read-only and another
for archived.

File dates

This section allows the user to build restrictions based on file dates and times. To enable options in
this section, check the Filter by date option.
Filters in this section can be applied by selecting one of the available date filters:

· date accessed

· date and time accessed

· date modified

· date and time modified

· date created

· date and time created

You can compare these dates and times with a fixed date  or a relative date: today,  yesterday,  one
week ago or one month ago.
Comparison operators available:

· < >  date (and time) not equal to fixed or relative date

· < =  date (and time) less than or equal to fixed or relative date

· > =  date (and time) greater than or equal to fixed or relative date

· <  date (and time) less than fixed or relative date

· >  date (and time) greater than fixed or relative date
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· in interval - date (and time) in a particular time interval between the Start date and End date

File size

This section provides the possibility to build restrictions based on the file size. To enable the options
in this section, check the Filter by size option. You can enter a file size in the Size  field and select a
measurement  Unit.  The  filter  will  compare  the  file  size  on  disk  with  the  size  you  enter  using  the
comparison filters you selected:

· < >  file size on disk not equal to the value in the Size field

· < =  file size on disk less than or equal to the value in the Size field

· > =  file size on disk greater than or equal to the value in the Size field

· <  file size on disk less than the value in the Size field

· >  file size on disk greater than the value in the Size field
 
Note:
Filters on files and filters on folders must be created individually. If you use a file and a folder filter
condition in the same filter, files will be filtered only if both filter conditions were met. 

Examples

· If you use a single filter for .jpg files and Temp folder, only the .jpg files from Temp folder will  be
filtered. If you use separate filters for files and folders, all .jpg files and whole Temp folder will be
filtered.

· Suppose you want to backup (or restore) all .pdf files accessed in the last month and all .doc  files
modified in the last week, but you don't want to backup (or restore) system or hidden files.

Here are the steps to define this filter starting from the default filter:
1) Add a new restriction in the include filter: enable File name, add *.pdf file pattern and set date
accessed to be greater than or equal to fixed date one month ago; click OK
2)  Add a  new restriction:  add  *.doc  file  pattern  and  set  date  and  time  modified  to  be  greater
than or equal to fixed date one week ago; click OK
3) Add a new restriction: enable File attributes and the System checkbox, then click OK
4) Add a new restriction: enable File attributes and the Hidden checkbox, then click OK
5) For the last two restrictions, check the Use as exclude filter boxes.

 

You may create your own filters, edit predefined filters, or simply using predefined filters (as they are
set in File->Options->Filters). With the Use existing option, the filter that you select is considered to
be locked to the predefined filter.

By locking a filter in  Backup  Properties  to  a  predefined  filter  (File->Options->Filters),  all  changes  of
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the predefined filter will  propagate to the job filter.  This  is  useful  when you want  to  use  the  same
predefined filter  in  several  backup  jobs.  All  locked  job filters  will  be  updated  when the  predefined
filter is changed in Options->Filters.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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10 Command Line

10.1 Backup

Backup4all  uses  for  each  action  a  small  application  that  runs  independently  from  the  main
application. They can be used to create batch files. 
The command line parameters for backup action are described bellow.

Backup jobs

Syntax
bBackup [{/f|/d|/i|/r}] job_name [/e][/c] [-Priority{1|2|3|4}]

Formatting legend
          Italic - Information that must be supplied by the user
          Bold - Elements that the user must type exactly as shown
          / - Switches are preceded by slash
          [] - Elements between square brackets are optional
          | - Vertical line separates possible choices
          {} - Items between braces are a set of choices from which the user must choose only one

Command line backup can have as parameters an ".ini" file (with its full path), a ".bkc" file (with its
full path) or the name of the backup job. The ".ini" or ".bkc" file must exist in the specified path, the
backup job must be defined in  Backup4all or otherwise the backup will not run.

Switches that apply to this parameter (case insensitive, preceded by "/" or "-"):

· /f - force the execution of a full backup

· /d - force the execution of a differential backup

· /i - force the execution of an incremental backup

· /r - execute the backup with its defined type in Backup Properties (this is the default behavior
when the backup name is specified without switches)

· /e - erase the disc(Floppy/CD/DVD/Blu-ray) before backup

· /c - deletes the .bkc file and all zip files associated with the named backup job

If  the  backup  job  to  be  executed  has  the  backup  type  set  to  Mirror,  then  a  mirror  backup  will  be
performed and the "/f", "/d", "/i" switches will be ignored even if they are set.
For  the  priority  level  you  can  select  a  value  between  1-4,  as  1  is  the  lowest  priority  and  4  is  the
highest priority.

Examples
To execute a backup for My Pictures job, with the default backup type, use:

bBackup /r "My Pictures" -Priority 2
To  force  a  full  backup  on  the  backup  job  associated  with  the  IE  Favorites.bkc  located  in  the  "E:
\Backup Destination" folder, use:

bBackup /f "E:\Backup Destination\IE Favorites..bkc" -Priority 2
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To force an incremental backup on the My Documents backup job, use:

bBackup /i "My Documents" -Priority 2

 

Tags

Syntax
bTagBackup tag_name [-Priority{1|2|3|4}]

You can also have as parameter an existing tag.  This tag must be defined in  Backup4all,  otherwise
the backup will not run.
Switch to apply to this parameter (case insensitive, preceded by "/" or "-"):

For  the  priority  level  you  can  select  a  value  between  1-4,  as  1  is  the  lowest  priority  and  4  is  the
highest priority.

Examples
 
To execute all backup jobs from the Samples tag, use:

bTagBackup Samples -Priority 2
 
Backup4all returns exit codes after each task execution (backup, independent test or cleanup).
As a general case, if the backup was successful, the exit code is 0, otherwise is different.
Here are the possible exit codes:

· 0 : action was successful

· 1 : action has not started, parameter errors, syntax errors, other errors

· 2 : action finished with errors

· 3 : action was finished with warnings

· 4 : independent test was finished with errors

· 5 : independent test was finished with warnings

Backup job definitions  (".ini"  files)  are  saved separately  for  each Windows  user.  These files  can  be
found in the "AppData\Softland\Backup4all 9\IniFiles" folder of your user profile (if it's not changed
in  the  File->Options->File  locations  window).  Backup  catalogs  (".bkc"  files)  are  saved  locally  and  in
the backup destination together with the backup  files.  When  a  backup  job is  executed  for  the  first
time, a .bkc file is created. There is only one .bkc file for each backup job.
 
The command line application uses the same engine, same configuration files and the same log files
as  the  main  application.  It  always  performs  an  unattended  backup.  You  can  use   Backup4all's
interface  to  define  backup  jobs  and  backup  tags  which  can  be  used  later  as  parameters  for  the
command line application. You can create a shortcut to a backup job or to a backup tag so you won't
have to use complicated paths.  To create a  shortcut,  use  the  Create  Shortcut  menu  item from the
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File menu.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

10.2 Test

Backup4all  uses  for  each  action  a  small  application  that  runs  independently  from  the  main
application. They can be used to create batch files. 
The command line parameters for test action are described bellow.

Backup jobs

Syntax
bTest [/t] job_name [-Priority{1|2|3|4}] 

Formatting legend
          Italic - Information that must be supplied by the user
          Bold - Elements that the user must type exactly as shown
          / - Switches are preceded by slash
          [] - Elements between square brackets are optional
          | - Vertical line separates possible choices
          {} - Items between braces are a set of choices from which the user must choose only one

· /t - tests the named backup job. Supports also an additional parameter [/TN 1,2,5..20|*|#] - if
no TN is set then it will test all backup jobs same as using *; if # is used it will test only the last
backup job (# can be used in the same time with other numbers too).

For  the  priority  level  you  can  select  a  value  between  1-4,  as  1  is  the  lowest  priority  and  4  is  the
highest priority.

Examples:
To execute a test for all backup numbers of the My Pictures backup job

bTest /t "My Pictures" /tn * -Priority 2

To execute a test for first two and last backup number of the My Pictures backup job

bTest /t "My Pictures" /tn 1,2,# -Priority 2

Tags

Syntax
bTagTest tag_name [/TN 1,2,5...20|*|#] [-Priority{1|2|3|4}] 

You can also have as parameter an existing tag.  This tag must be defined in  Backup4all,  otherwise
the backup will not run. 
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Switch to apply to this parameter (case insensitive, preceded by "/" or "-"):

· /TN 1,2,5...20|*|# - if no TN is set then it will test all backup jobs same as using *; if # is used it
will test only the last backup job (# can be used in the same time with other numbers too).

For  the  priority  level  you  can  select  a  value  between  1-4,  as  1  is  the  lowest  priority  and  4  is  the
highest priority.

Examples:
To execute a test for the first backup of all jobs in Samples tag, use:

bTagTest Samples /TN 1 -Priority 2

Backup4all returns exit codes after each task execution (backup, independent test, repair, restore or
cleanup).
As a general case, if the action was successful, the exit code is 0, otherwise is different.
Here are the possible exit codes:

· 0 : action was successful

· 1 : action has not started, parameter errors, syntax errors, other errors

· 2 : action finished with errors

· 3 : action was finished with warnings

· 4 : independent test was finished with errors

· 5 : independent test was finished with warnings

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

10.3 Repair

Backup4all  uses  for  each  action  a  small  application  that  runs  independently  from  the  main
application. They can be used to create batch files. 
The command line parameters for repair action are described bellow. The repair action is composed
by  a  test  action  followed  (or  not  -  it  depends  if  you  want  to  repair  only  the  catalog)  by  a  backup
action.

Backup jobs

Syntax
bTest [[/T] job_name /RP /RPWB] [-Priority[{1|2|3|4}] 

Formatting legend
          Italic - Information that must be supplied by the user
          Bold - Elements that the user must type exactly as shown
          / - Switches are preceded by slash
          [] - Elements between square brackets are optional
          | - Vertical line separates possible choices
          {} - Items between braces are a set of choices from which the user must choose only one
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· /t - tests the named backup job to find the problems in backup.

· /RP - repairs the backup catalog only. All  files and folders in backup execution will  be tested.
Those not  found in destination will  be also removed from the backup catalog so they will  be
backed up on the next backup execution. 

· /RPWB  -  repairs  the  backup  in  destination.  All  files  and  folders  added  in  the  last  backup
execution  will  be  tested.  Those  not  found  in  destination will  be  backed  up  again  in  order  to
reflect the backup catalog.

If only the catalog needs to be repaired, use only the /RP switch.
For  the  priority  level  you  can  select  a  value  between  1-4,  as  1  is  the  lowest  priority  and  4  is  the
highest priority.

Examples:
To execute a repair for My Pictures backup job

bTest /t "My Pictures" /RP /RPWB -Priority 2

To execute only a catalog repair for My Pictures backup job

bTest /t "My Pictures" /RP -Priority 2

Tags

Syntax

bTagTest tag_name [/RP /RPWB] [-Priority{1|2|3|4}] 

· /RP  -  execute  the  repair  for  the  backup  catalogs  only.  All  files  and  folders  added  in  the  last
backup execution will be tested. Those not found in destination will be also removed from the
backup catalog so they will be backed up on the next backup execution. 

· /RPWB -  execute the repair  for the  backups  in  destination.  All  files  and  folders  added  in  the
last backup execution will be tested. Those not found in destination will be backed up again in
order to reflect the backup catalog.

For  the  priority  level  you  can  select  a  value  between  1-4,  as  1  is  the  lowest  priority  and  4  is  the
highest priority.

Examples:
To execute a repair for Samples tag

bTagTest "Samples" /RP /RPWB -Priority 2

To execute a repair for Projects tag, only the backup catalogs:

bTagTest "Projects" /RP -Priority 2

Backup4all returns exit codes after each task execution (backup, independent test, repair, restore or
cleanup).
As a general case, if the action was successful, the exit code is 0, otherwise is different.
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Here are the possible exit codes:

· 0 : action was successful

· 1 : action has not started, parameter errors, syntax errors, other errors

· 2 : action finished with errors

· 3 : action was finished with warnings

· 4 : independent test was finished with errors

· 5 : independent test was finished with warnings

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

10.4 Restore

Backup4all  uses  for  each  action  a  small  application  that  runs  independently  from  the  main
application. They can be used to create batch files. 
The command line parameters for restore action are described bellow.

Backup jobs

Syntax
bRestore [/RE] job_name [/DEST path] [/NDL] [/DATE] [/RNC] [/RDE] [-Priority[{1|2|3|4}] 

Formatting legend
          Italic - Information that must be supplied by the user
          Bold - Elements that the user must type exactly as shown
          / - Switches are preceded by slash
          [] - Elements between square brackets are optional
          | - Vertical line separates possible choices
          {} - Items between braces are a set of choices from which the user must choose only one

· /RE - execute the restore for the named backup job

· /DEST - execute the restore into the specified destination. You also need to enter the path for
restore.

· /NDL - execute the restore without creating the drive letter folder

· /DATE - execute the restore of all files as of a specified date

· /RNC - execute the restore of the specified backup numbers

· /RDE - execute the restore including excluded and deleted files

Examples:
To execute a restore for My Pictures backup job

bRestore /RE "My Pictures" -Priority 2

To execute a restore for My Pictures backup job to another destination as of a specified date

bRestore /RE "My Pictures" /DEST "C:\Restore" /DATE 12.30.2011 -Priority 2
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Tags

Syntax
bTagRestore [/RE] tag_name [/DEST path] [/NDL] [-Priority[{1|2|3|4}] }] 

· /RE - execute the restore for the named backup tag

· /DEST - execute the restore into the specified destination. You also need to enter the path for
restore.

· /NDL - execute the restore without creating the drive letter folder

For  the  priority  level  you  can  select  a  value  between  1-4,  as  1  is  the  lowest  priority  and  4  is  the
highest priority.

Examples:
To execute a restore for Samples tag in original location:

bTagRestore /RE "Samples" -Priority 2

To execute a restore for Documents backup tag to another destination without creating drive letter:

bRestore /RE "Documents" /NDL /DEST "C:\Restore"  -Priority 2

Backup4all returns exit codes after each task execution (backup, independent test, repair, restore or
cleanup).
As a general case, if the action was successful, the exit code is 0, otherwise is different.
Here are the possible exit codes:

· 0 : action was successful

· 1 : action has not started, parameter errors, syntax errors, other errors

· 2 : action finished with errors

· 3 : action was finished with warnings

· 4 : independent test was finished with errors

· 5 : independent test was finished with warnings

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

10.5 Cleanup

Backup4all  uses  for  each  action  a  small  application  that  runs  independently  from  the  main
application. They can be used to create batch files. 
The command line parameters for cleanup action are described bellow.

Backup jobs

Syntax
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bCleanup [/X] job_name [-Priority[{1|2|3|4}] 

Formatting legend
          Italic - Information that must be supplied by the user
          Bold - Elements that the user must type exactly as shown
          / - Switches are preceded by slash
          [] - Elements between square brackets are optional
          | - Vertical line separates possible choices
          {} - Items between braces are a set of choices from which the user must choose only one

· /x - cleans the backup. Supports additional parameters:

· [/IE mm.dd.yyyy] - clean the backups older than the specified date

· [/IS mm.dd.yyyy] - clean the backups newer then the specified date

· [/OT n /OTU {D|W|M|Y}] - n is the number of days (D), weeks (W), months (M) or years
(Y)

· [/KD] - keep Differential backups

· [/KF] - keep Full backups

Examples:
 
To clean all backup versions older than two weeks and keep the full and differential backups of the
My Pictures backup job, use:

bCleanup /X "My Pictures" /OT 2 /OTU W /KF / KD  -Priority 2
 

Tags

Syntax
bTagCleanup [/X] tag_name [-Priority[{1|2|3|4}] 

Additional parameters can be used:

· [/IE mm.dd.yyyy] - clean the backups older than the specified date

· [/IS mm.dd.yyyy] - clean the backups newer then the specified date

· [/OT n /OTU {D|W|M|Y}] - n is the number of days (D), weeks (W), months (M) or years
(Y)

· [/KD] - keep Differential backups

· [/KF] - keep Full backups
The  mirror  backup  jobs  will  be  ignored  when  running  a  cleanup  for  a  tag  including  mirror  backup
jobs.

Examples:
 
To clean all backup versions older than two weeks and keep the full and differential backups of the
Pictures tag, use:

bCleanup /X "Pictures" /OT 2 /OTU W /KF / KD  -Priority 2
 
To execute a cleanup for Samples tag
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bTagCleanup /X "Samples" /OT 2 /OTU W -Priority 2
 
Backup4all returns exit codes after each task execution (backup, independent test, repair, restore or
cleanup).
As a general case, if the action was successful, the exit code is 0, otherwise is different.
Here are the possible exit codes:

· 0 : action was successful

· 1 : action has not started, parameter errors, syntax errors, other errors

· 2 : action finished with errors

· 3 : action was finished with warnings

· 4 : independent test was finished with errors

· 5 : independent test was finished with warnings

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

10.6 History

Backup4all can be used to export the history into a csv file. 
The command line parameters for history are described bellow.

Syntax
bBackup /ExpHist [/EHI switches] [/EHE email] [/EHF filepath] [/EHA {B|R|T|C}] [/EHS {S|W|
E}] [/EHJ "job names"} [/EHC]      

Formatting legend
          Italic - Information that must be supplied by the user
          Bold - Elements that the user must type exactly as shown
          / - Switches are preceded by slash
          [] - Elements between square brackets are optional
          | - Vertical line separates possible choices
          {} - Items between braces are a set of choices from which the user must choose only one

· /ExpHist - execute the history export

· /EHI - defines the history interval to be exported

· Today - exports the history of all actions executed today

· Yesterday - exports the history of all actions executed yesterday

· ThisWeek - exports the history of all actions executed this week

· LastWeek - exports the history of all actions executed last week

· ThisMonth - exports the history of all actions executed this month

· LastMonth - exports the history of all actions executed last month

· ThisYear - exports the history of all actions executed this year

· LastYear - exports the history of all actions executed last year

· Custom - for this switch there are other parameters to be used (example: /EHI Custom /
EHSD 1.21.2020 /EHED 2.21.2020)

· /EHSD - export history start date
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· /EHED - export history end date

· /EHE - exports the history and sends it to the specified email address

· /EHF - exports the history and saves it into the specified file

· /EHA - exports only the history of only the specified actions:

· B - Backup

· R - Restore

· T - Test

· C - Cleanup

· /EHS - exports only the history of only the specified statuses:

· S - Success

· W - Warning

· E - Error

· /EHJ - exports only the specified backup jobs, tags or guids (example: "job1|job3|job7")

· /EHC - if used, the history csv file will be compressed before sending it by email

Example:
To export the history for the last year, save it in a csv file on your computer and also send it by email

bbackup.exe /ExpHist /EHI ThisYear /EHE test@backup4all.com /EHF D:\history.csv 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

mailto:test@backup4all.com
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11 Options

11.1 General

The  General  page  of  the  Options  window  (accessible  from  the  File,  Options  menu  item)  contains
general settings of the program.

 
Use settings for

Current User
If  this  is  selected,  the settings used in Backup4all  (including backup jobs)  are  available  only  for  the
current logged in user. This way if there are 3 people using the same computer and each logging in
through a different  account,  Backup4all  will  have different  settings and  jobs  for  each account.  This
can be selected upon installation too, in the Select Default Settings step. These settings are kept in a
file whose location is customizable.

All Users
If this is selected, the settings used in Backup4all (including backup jobs) are available for all users on
the computer where it's installed. This way if there are 3 people using the same computer and each
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logging  in  through  a  different  account,  Backup4all  will  have  the  same  settings  and  jobs  for  each
account  (kind  of  like  a  shared  profile).  This  can  be  selected  upon  installation  too,  in  the  Select
Default Settings step. These settings are kept in a file whose location is customizable.
  

 
Security
 Backup4all allows you to lock the program interface, using a password.
Press the Set password button to add or change the password. Near this button, the security status is
displayed: "No password" or "Password protected".
When opening the program's interface, if the interface is locked, you will be asked for the password.
To remove the password, press the Set password button, type the old password and press OK. 
 

Language

In  the Language  section you can select  the language of the program interface  by  choosing  another
one from the drop down list. Only the languages that were installed with the program are displayed.
The language of the interface changes only  after  the Options  window is  closed  by  pressing  the  OK
button.  The  selected  language  is  kept  as  long  as  you  don't  change  it  or  it  becomes  invalid  due  to
software updates.

The  text  box  below  the  Language  field  shows  details  about  the  selected  language  (like  translator
name and contact information).
 

Proxy server

A proxy server can be configured and used to activate/deactivate Backup4all if the computer where it
is installed does not have direct access to internet.
In order to use it, just select the server type: HTTPS or SOCKS, then enter the IP and port. If the server
requires authentication, enter the username and password in the corresponding fields.

Online connections
Enable less secure online connection (using HTTP in case HTTPS fails) - selecting this option allows
you to activate  Backup4all over HTTP if your OS does not recognize newer TLS or SSL protocols.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.2 Preferences

The Preferences page of the Options window (accessible from the File, Options menu item) contains
settings related to the display of the Toolbar menu.
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Toolbar
Minimize the Ribbon
If checked, the ribbon menu will be minimized. By default it is not checked. 

Customize Quick Access Toolbar
If  pressed,  the Quick Access Toolbar  Customizer  will  open  and  you can  add/remove  buttons  in  the
Quick Access Toolbar.

Views

Default view
The selected view will be assigned as default to the Views button from the application toolbar. 
The possible views are:  Explore, Backup and Statistics.

Show explorer icons
If  checked  a  small  icon  is  shown  for  each  file  in  the  Explore  view.  The  icon  is  the  standard  icon
associated with the type of the file. You will see the same icons as in File Explorer. If the Explore view
contains  a  large  number  of  files,  you  can  uncheck  this  option  to  show  files  faster.  By  default  this
option is checked.
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Hide empty folders on expand all
If  checked  the  folders  that  do  not  show  any  file  in  the  Explore  view  will  be  automatically  hidden
when pressing the Expand All button. By default this option is not checked.

Show context menu in Explore View
If checked it will display the context menu when right clicking on a file or folder in the main window's
Explore  view or  the Sources  page of the Backup  Properties  and  New Backup Wizard  windows.  By
default this option is checked.

Measurement unit

Auto
If checked the file sizes are shown like in File Explorer. By default this option is checked.

Custom
If checked you can see all file sizes in the same unit. You can set the desired unit from the drop down
list. Possible choices are: Bytes, KB (kilobytes), MB (megabytes) or GB (gigabytes). Be advised that if
you select GB as a unit, for files under 10MB the size will be shown as 0GB. By default this option is
not checked.

External program 

 
Difference viewer: Choose an application to compare the selected file version with the source file in
Explore View. You can also use parameters for difference viewer application.

Other

  
 
Warn when insecure passwords are used
If  checked Backup4all  will  display  a  warning  window when you enter  passwords  for  zip  encryption
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that contain less than 8 characters.
 
Show hidden files in open dialogs
If checked files marked as hidden will be displayed in Open dialogs. This is very useful if you want to
add hidden files to your backup sources. By default this option is checked.

Use New Backup Wizard to create backup jobs
If checked, when pressing the File->New Backup button, the New Backup Wizard will be open.
If unchecked, the Backup Properties will be used to create the new job.

Use old sources selection mode
Enable this option to use in New Backup Wizard the old selection mode for sources. By default it is
unchecked.
 
Add backup actions in File Explorer context menu
If selected, the backup options (add to job, add to new job) will appear in Explorer context menu of
Windows, when you right-click a file/folder. When changing this option you will be prompted by the
UAC to confirm the modification.

Sort jobs/tags alphabetically in Navigation Pane
Select this option if you want to sort jobs/tags alphabetically in Navigation Pane.

Show "New features" message
Select this option if you want to be informed by a message about the new features in Backup4all.

Check task scheduler folder rights at startup
If  selected,  the  task  scheduler  folder  permissions  will  be  verified  at  Backup4all  startup.  If  the
necessarily  permissions are not  assigned for the current  user,  Backup4all  will  try  to  set  the  correct
permissions. 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.3 Startup and updates

The  Startup  page  of  the  Options  window  (accessible  from  the  File,  Options  menu  item)  contains
startup related settings of the program.
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Startup and tray
 
Start at Windows startup
If  checked  the  program  is  started  when  Windows  starts  using  the  window  state  set  in  the
Visualization mode group. By default this option is not checked.
 
Show "Getting Started"
If checked, the "Getting Started" window is displayed when you start Backup4all.
 
Show tray icon
If checked the program icon is displayed in the Taskbar Notification Area.

Visualization mode

Manual  Run  -  You  can  select  the  way   Backup4all's  main  window  will  be  displayed  after  a  normal
startup. The options are: Last window state, Normal and Maximized.
 
Windows  Startup  -  You  can  select  the  way   Backup4all's  main  window  will  be  displayed  after
Windows starts. The options are: Last window state, Minimized, Normal and Maximized. This setting
is available only if Start at Windows startup is checked.

Scheduled  Startup  -  You  can  select  the  way   Backup4all's  main  window  will  be  displayed  when  a
scheduled backup starts it. The options are: Last window state, Minimized, Normal and Maximized.
 

Check for updates
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Check mode
User can choose one of these modes: 

· Manual - user will manually check for new updates. This option is selected by default.

· Reminder - the program will remind you with the selected frequency to check for new updates 

· Automatic  -  the  program  will  automatically  check  for  new  updates  with  the  selected
frequency.

Frequency 
User can set the frequency for Backup4all to remind or to automatically check for new updates.

Check at application startup
If checked, the program will check for new updates at application startup.
 
Send anonymous usage statistics
If selected, the program will send anonymous statistics about the application usage.

Show News page
If selected, the news page will be shown in the ribbon menu.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.4 Application folders

The Application folders  page of the Options window (accessible from the File, Options menu item)
contains general settings of the program.
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Override settings folder

This is the folder where the program's settings are kept. You can use the Browse button  to select
an existing folder. By default this option is set to the "AppData\Softland\Backup4all 9\" folder of your
Window login account profile.
 
Override default destination folder
This  is  the  folder  used  as  destination  for  the  newly  created  backup  jobs.  The  existing  backup  job
destinations  will  not  be  affected  if  you  change  this  option  (you  have  to  manually  change  the

destination for them). You can use the Browse button  to select an existing folder. By default, the
location is set on the largest drive from your computer, under "My Backup4all 9\" folder.

Override temporary folder
This  folder is  used  by  the  compression  engine to  handle  compressed files  (.zip).  Only  a  full  path  is
allowed. The recommendation is to set  the temporary directory on the hard disk partition with the

most free space available. You can use the Browse button  to select an existing folder. By default
the option is set to the operating system's temporary folder.
 
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.5 Backup

The  Backup  page  of  the  Options  window  (accessible  from  the  File,  Options  menu  item)  contains
settings related to the backup operations.
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Options
 
Warn  before  canceling  the  backup  -  If  checked  a  confirmation  message  will  be  displayed  when  a
backup is canceled before being completely executed.  By default this option is checked.

NTFS daylight saving correction - The Windows NT File System (NTFS) reports wrong file times
after the clock changes according to daylight saving time rules. As a consequence, the program
sees these files as changed and backs them up. When you check this option these files will not be
reported as modified. By default this option is checked.

Default compression filter

This default filter is applied to new backup jobs by default, to increase the compression performance.
It defines what types of files to be stored uncompressed in the zip file. These are files that are already
compressed  (e.g.  zip,  rar,  mp3 or  avi)  and  using  the  zip  compression  on them  wouldn't  result  in  a
smaller  sized  backup.  This  can  also  be  modified  individually  from  each  backup  job's  Properties-
>Types->Advanced window in the Filters box.
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When destination not ready

The  options  from  this  group  affects  scheduled  backups.  The  first  number  (Retry  option)  indicates
how  many  times  the  application  tries  to  access  the  destination  location  if  it  is  not  available.  By
default  this  option  is  set  to  3  attempts.  The  second  number  (Wait  option)  indicates  how  many
seconds to wait between two consecutive attempts to access the destination location. By default this
option is set to 60 seconds.
 

Smart file scanning mode
Select when the "Smart file scanning mode" option from Backup Properties->Advanced page will  be
used.

· Never - the option will never be used.

· Always - the option will be used every time.

· When source file  count  is  -  move the  slider  to  left  or  right  to  decrease  or  increase  the  limit
when the "Smart file scanning mode" will be used. 

The slider steps are: 20,000 (Very small)/ 50,000 (Small)  / 200,000 (Regular) / 500,000 (Large) /
1,000,000 (Very large) of source files and folders.

Backup on demand 
Enable One Touch Backup support
Use  this  option  to  enable  the  Plug-and-Backup  functionality.  If  the  option  is  set,  you  can  choose
which Backup job or Backup tag will be executed when the portable drive is plugged in. Sometimes
(when  the  backup  job  or  the  backup  tag  is  deleted  or  renamed)  the  target  backup  cannot  be
executed. In this case a dialog will be shown asking you to either create a new backup, select another
backup or disable the Plug-and-Backup functionality.
 
Detect
Please connect your USB enclosure and make sure it is turned on and ready. Press the Detect button
to check  the  compatibility  with  the  One Touch  Backup  feature.  If  there  is  at  least  one  compatible
device,  a  message  will  be  shown  listing  all  the  disk  partitions  (drives)  on  the  devices.  You  will  be
informed  if  there  are  no  compatible  devices.  In  this  case  the  Enable  One  Touch  Backup  support
option will have no effect even if it is set.

What to execute

· Backup job
Use this option to select a backup job.

· Backup tag
Use this option to select a backup tag.

Exit  application when finished -  use  this  option  to  close  the  application  when  the  above  selected
action is finished.

Memory usage
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This option allows you to change the memory usage level. You can move the memory indicator to a
lower or a higher level.
 
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.6 Filters

On the  Filters  page  of  the  Options  window (accessible  from  the  File,  Options  menu  item)  you  can
add,  edit  or  delete  filters.  The  filters  created  here  can  be  found  as  global  filters  all  over  the
application: in New backup wizard or in Backup Properties.
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General

Filter name
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Type a name for the filter to be recognized when you want to use it later.

File name

Enabling this will allow defining filters based on file name pattern.
Press Add and select an existing file extension from the Filter combo (*.doc, *.pdf, *.zip etc.). If the
extension does not exist in the combo, just type it  in  and press OK. You can use the Edit  or  Delete
buttons to modify/remove the file name filters defined.

File name patterns can include:

· * - it matches one or more letters. For example a*.doc  matches all  files that  start with a  and
have .doc extension

· ? - it matches only one letter. For example a*.do?  matches all files that start with a  and have
any extension composed of three letters, the first two being do

 

Folder name

Enabling this will allow defining filters based on folder name pattern.
Enter  the  directory  name  that  you  want  to  filter  in  the  following  format:  *\directory_name\*  .
Backup4all  will  apply the filter to all  the directories  that  are  called  directory_name.  If  you want  to
apply  the  filter  to  directories  containing  a  specific  word,  you must  enter  it  in  the  following  format
*\*keyword*\*.  Now  Backup4all  will  apply  the  filter  to  all  the  directories  that  have  the  word
keyword in their names. You can use the Edit or Delete buttons to modify/remove the folder name
filters defined.
You can also use environment variables when creating filters: %temp%, %SystemRoot% etc.

File attributes

This section allows the user to specify file filters depending on the file attributes. To enable the filter
options in this section you have to check the Filter by attributes option.
There is a list of quick sets to choose for predefined filter criteria:

· None - if this is selected all the file attributes check boxes are unchecked

· Custom - this is the default option and allows you to check whatever attributes you want

· FAT attributes - if this is selected, a set of File Allocation Table attributes will be used for file
filtering

· NTFS attributes - if this is selected, a set of NTFS (New Technology File System) attributes will
be used for filtering. Note that these attributes are available only on Windows XP and above. 

File attributes available for file filters:

· Read-Only - if checked files with read-only attribute will be selected

· Archived - if checked files with archived attribute will be selected

· Hidden - if checked files with hidden attribute will be selected

· System - if checked files with system attribute will be selected

· Compressed (only NTFS) - if checked files with compressed attribute will be selected
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· Temporary (only NTFS) - if checked files with temporary attribute will be selected

· Encrypted (only NTFS) - if checked files with encrypted attribute will be selected

· Not indexed (only NTFS) - if checked files with "not indexed" attribute will be selected

· Offline (only NTFS) - if checked files with offline attribute will be selected

· Reparse point (only NTFS) - if checked files with reparse point attribute will be selected

· Sparse file (only NTFS) - if checked files with sparse file attribute will be selected

For  example,  if  you  want  to  include  files  with  read-only  and  archived  attributes  set,  you  have  to
check both attributes checkboxes in a single restriction. If you want to include files with read-only or
archived  attributes set, you have to make two separate restrictions: one for read-only and another
for archived.

File dates

This section allows the user to build restrictions based on file dates and times. To enable options in
this section, check the Filter by date option.
Filters in this section can be applied by selecting one of the available date filters:

· date accessed

· date and time accessed

· date modified

· date and time modified

· date created

· date and time created

You can compare these dates and times with a fixed date  or a relative date: today,  yesterday,  one
week ago or one month ago.
Comparison operators available:

· < >  date (and time) not equal to fixed or relative date

· < =  date (and time) less than or equal to fixed or relative date

· > =  date (and time) greater than or equal to fixed or relative date

· <  date (and time) less than fixed or relative date

· >  date (and time) greater than fixed or relative date

· in interval - date (and time) in a particular time interval between the Start date and End date

File size

This section provides the possibility to build restrictions based on the file size. To enable the options
in this section, check the Filter by size option. You can enter a file size in the Size  field and select a
measurement  Unit.  The  filter  will  compare  the  file  size  on  disk  with  the  size  you  enter  using  the
comparison filters you selected:

· < >  file size on disk not equal to the value in the Size field

· < =  file size on disk less than or equal to the value in the Size field

· > =  file size on disk greater than or equal to the value in the Size field

· <  file size on disk less than the value in the Size field
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· >  file size on disk greater than the value in the Size field

Settings

Show filter in the New Backup Wizard
If checked, the current filter can be selected from the Filters list in New Backup Wizard.

Automatically add filter to new backup jobs
If checked, the current filter will  be automatically added to backup jobs you create. You can specify
the default type as: include filter or exclude filter. 
Using this option you can automatically exclude specific file types from your backups.

Example
Suppose you want  to  backup  (or  restore)  all  .pdf  files  accessed  in  the  last  month  and  all  .doc  files
modified in the last week, but you don't want to backup (or restore) system or hidden files.
Here are the steps to define this filter starting from the default filter:

1) Add a new restriction in the include filter: enable File name, add *.pdf file pattern and set date
accessed to be greater than or equal to fixed date one month ago; click OK
2)  Add a  new restriction:  add  *.doc  file  pattern  and  set  date  and  time  modified  to  be  greater
than or equal to fixed date one week ago; click OK
3) Add a new restriction: enable File attributes and the System checkbox, then click OK
4) Add a new restriction: enable File attributes and the Hidden checkbox, then click OK
5) For the last two restrictions, check the Use as exclude filter boxes.

 
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.7 Remote Monitor

Backup4all allows you to send notifications to the Backup4all Monitor application. This way, all your
backup executions  from  multiple  computers  can  be  monitored  from  your  computer.  (more  details
here: https://www.backup4all.com/backup4all-monitor.html) 

Send information to remote monitor 
Select this option if you want to enable the Remote monitoring feature.

Server
Address  -  on  this  field  you can  manually  enter  the  monitoring  server’s  IP  followed by  the  port
number and Instance name (example http://127.0.0.1:9502/Backup4allMonitoringSrv-Test).  You
can  also  press  the  search  icon  from  the  right  side  of  the  field  to  open  “Scan  for  monitoring
servers” window, where the monitoring servers from your network will be listed.

Instance name - enter the Instance name for the monitor you want to send backup information
to. Or you can press the search icon from the right side of the field to open “Scan for monitoring
servers” window, where the monitoring servers from your network will be listed.

https://www.backup4all.com/backup4all-monitor.html
http://127.0.0.1:9502/Backup4allMonitoringSrv-Test
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Computer alias
Select this option if you want to use an alias name for this computer. 

Test connection
Press  this  button  to  test  the  connection  with  the  Address  or  Instance  name  you  entered  for  the
Remote Monitor.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.8 Logs and history

On the Logs and history page of the Options window (accessible from the File, Options menu item)
you can change log and history options.
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Content

Log detailed information
If checked the program will log detailed information about all files handled by the backup, restore or
test process. By default this option is not checked.

Include summary in log
If checked the logs will contain all the text available in the main window's Summary view. By default
this option is not checked.

Log folder

In this section you can set the size limits for the folder where the logs are stored. The path to the logs
is set on the File Locations page of the Options window.

Unlimited size
If  checked the log folder size is not limited, and its size will  increase as needed. After a  long period
the program will  generate a large number of log files, so you might want to clean up the log folder
manually. By default this option is not checked.

Restricted to
If  checked the log folder size  is  limited to the value set  in the Size field  below.  If  the log file  of the
running  backup  job is  larger  than  the  limit,  it  will  still  be  stored  in  the  log  folder.  When  the  same
operation will run again, the previous log file will be deleted. By default this option is checked.
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The log folder size will be less or equal then the selected value. By default this option is set to 50 MB.
You can set the desired unit from the drop down list. Possible choices are: Bytes, KB (kilobytes), MB
(megabytes) or GB (gigabytes). By default this option is set to MB.

Log Viewer

Program
User can choose which program to be used when opening the log files with Backup4all. The available
options are: <Default text editor>, <Notepad> or <Wordpad>. User can also browse the computer to
choose another program.

Log file extension
User can change the extension of log files. The available options are: log and txt.

History

Delete records older than
If checked the history records older than the selected period will be deleted. The available time units
are: Days, Weeks, Months and Years. By default, this period is set to 3 Months.

Delete corresponding log files too
This  option  can  be  used  only  if  the  Delete  records  older  than  option  is  checked.  This  option  is
equivalent with: delete log files older than the period selected above.
 
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.9 CD, DVD or Blu-ray

The CD, DVD or Blu-ray  page of the Options window (accessible from the File, Options menu item)
contains the settings of the CD, DVD or Blu-ray burners.
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Engine

Use SCSI Pass Through Direct Layer (SPTD)
Selected by default if drivers are available. Backup4all uses this internal burning engine to write CD,
DVD, HD-DVD or Blu- ray discs. SPTD is a new method of access to storage devices and has the ability
to provide direct control of devices without risk of compromising it by some malicious 3rd party filter
drivers or other "rootkit" applications.
 SPTD  is  currently  supported  only  on  Microsoft  OS  Windows  XP  and  above.  SPTD  (similar  to  other
access  layers)  is  not  removed  from  your  system  after  Backup4all  uninstall,  in  order  not  to  disrupt
other applications that may use it.

Use native Win32 Interface (SPTI)
If you have problems backing up using the SPTD method, we recommend you to use this option.
 

Other

Load CD, DVD or Blu-ray before backup
If  checked, the CD, DVD or Blu-ray media is loaded before the execution of a backup. This option is
useful when the CD, DVD or Blu-ray disc was previously ejected by another process.

Eject CD, DVD or Blu-ray after backup
If  checked,  the  CD,  DVD  or  Blu-ray  media  is  ejected,  but  not  reloaded  after  burning  process  is
finished. By default this option is not checked.
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Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.10 Online connections

11.10.1 LAN

The LAN page of the Options->Online connections menu item, allows you to add LAN locations.

 

 

When Network not ready

The  first  number  (Retry  option)  indicates  how  many  times  the  application  tries  to  access  the
destination server if it is not available. By default this option is set to 5 attempts. The second number
(wait option) indicates how many seconds to wait between two consecutive attempts to access  the
destination location. By default this option is set to 60 seconds.

Configurations
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The File->Options->Online connections->LAN  window allows you to  define  FTP  configurations  that
can be used on the Destination page in the New Backup Wizard or Backup Properties windows. You
can add, edit, copy or delete an FTP connection using this window.
In order to add a new LAN connection press the Add button. The Define LAN configuration window
will appear in the list and you can enter the other settings for this connection.
 
General

Configuration name
Enter  here  an  arbitrary  name  for  the  connection.  By  default  the  New  LAN  configuration  name  is
assigned.

LAN Server

Network path (UNC)
Browse for the network location or manually type the UNC path.

User name
Type the user name for connection, if the network share requires authentication

Password
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Enter the password for the above user name.

Connection settings

Try Windows user and password first
Select this option if you want to try the connection using the current Windows user and password.

Reconnect if already connected
Select this option if you want to reconnect if you were already connected from this computer.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.10.2 FTP

The FTP  page of the Options  window (accessible from the  File,  Options->Online  connections  menu
item) contains FTP settings.
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When FTP server not ready

The  first  number  (Retry  option)  indicates  how  many  times  the  application  tries  to  access  the
destination server if it is not available. By default this option is set to 5 attempts. The second number
(wait option) indicates how many seconds to wait between two consecutive attempts to access  the
destination  location.  By  default  this  option  is  set  to  60  seconds.  This  option  is  useful  when  the
destination FTP server has restrictions (i.e. only 2 users logged in the same time, no. of accesses etc.)
and  insures  that  if  the  FTP  server  cannot  accept  your  connection,  it  will  not  be  "hammered"  by
sending log-in requests frequently.

Configurations

The File->Options->Online  connections->FTP  window allows  you  to  define  FTP  configurations  that
can be used on the Destination page in the New Backup Wizard or Backup Properties windows. You
can add, edit, copy or delete an FTP connection using this window.
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In order to add a new FTP connection press the Add button. The Define FTP configuration  window
will appear in the list and you can enter the other settings for this connection.

 
General

Configuration name
Enter  here  an  arbitrary  name  for  the  connection.  By  default  the  New  FTP  configuration  name  is
assigned.

FTP Server

Server name or IP
In this field you have to enter the name or IP address for the FTP server

Transfer mode - Here you can select the transfer mode: Binary, ASCII or Auto.

· Binary: it refers to transferring files as a binary stream of data. The binary mode transmits the
raw bytes  of the file  being transferred. In this  way,  the  file  is  transferred  in  its  exact  original
form.

· ASCII:  it  stands  for  American  Standard  Code  for  Information  Interchange,  and  is  a  type  of
character  encoding  based  on  the  English  language  used  on  devices  that  handle  information
stored in text. It includes 33 non-printed control characters and 94 printed characters such as
letters and punctuation.

· Auto: according to the list of ASCII files defined in File->Options->FTP, the files will be uploaded
in ascii or binary mode, depending on their extension.

By default, binary mode is selected and it applies only to Mirror backup type. That is useful if you
have a  Linux  FTP  server  as  backup  destination and  want  to  download the  backed  up  files  with
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another application which uses the Auto transfer mode. Uploading the files to a  Linux server in
binary mode and downloading them in Auto mode, causes the files to be modified by adding a
new empty line at the end of each file.

Port 
In this field you have to enter the port number if different than the default FTP ports (21).

Destination folder
Here you can specify a destination folder on the remote FTP server where the backup will be stored.
If  the entered folder does not  exist,  it  will  be  created on the  server.  If  no  destination folder  is  set,
Backup4all will automatically create a folder using the name of the backup job.

User name
If  this  is  a  private  FTP  server  (no  anonymous  access  allowed)  you have  to  enter  the  user  name for
your account.

Password
In  this  field  you  can  enter  the  password  for  the  FTP  server.  There  are  FTP  servers  that  allow
anonymous access (public FTP servers). You can connect to these types of FTP servers using as user
name Anonymous and your email address as password. It is not recommended to backup important
files to public FTP servers. 

Bandwidth limitation

This section allows setting different limitations for upload/download speed:

· Upload speed - if checked you can set a maximum upload speed for the FTP transfer

· Download speed - if checked you can set a maximum upload speed for the FTP transfer
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FTPS (SSL encryption)
Indicates  the  level  of  Transport  Layer  Security  (TLS)  required  for  control  channel  and  data  channel
connections to the FTP server:

· No SSL - the server does not require Secure Socket Layer transport

· Implicit SSL - implies that Secure Socket Layer is in use

· Only explicit SSL - allows the connection to the FTP server only if TLS is available.

· Explicit SSL, if available - when SSL is available, uses explicit security by default. The server allows
regular FTP sessions without encryption as well as encrypted FTP sessions using SSL.

Use passive mode for transfers (like WWW browsers)
Each file transfer (upload or download) needs an additional connection for the data stream. Normally
(in  active  mode),  the  server  establishes  this  connection.  In  passive  mode,  however,  the  client
establishes  the  connection.  This  may  be  necessary  through  some  firewalls,  which  do  not  allow
connections from outside.

Use extended passive mode
The  FTP  Server  operates  exactly  the  same  as  passive  mode,  however  it  only  transmits  the  port
number  (not  broken  into  high  and  low  bytes)  and  Backup4all  is  to  assume  that  it  connects  to  the
same  IP  address  that  was  originally  connected  to.  Use  this  option  if  the  normal  passive  mode
connection failed.

Use XCRC when testing (if available)
If  the  server  supports  the  XCRC extension Backup4all  can  verify  that  files  transferred  to  the  server
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have been transmitted correctly using the CRC information received from the FTP server. This results
in faster testing, as the files will not be downloaded to perform the CRC testing.

Resume upload/downloads (if available)
If this option is selected, the application will try to resume the backup upload, if the server supports
resume command. 

Limit file size to
Here you can specify  the maximum size of the files to upload.  Larger  files will  be split.  Please  note
that many FTP servers does not allow you to upload files larger than 2 GB.

Timeout (seconds)
You  can  set  the  time  interval  (in  seconds)  that  is  allowed  for  no  data  transfer  before  the  transfer
operation is interrupted and must be resumed. Default is 30 seconds.

Firewall

Proxy type 
Select one of the options below (supported by your firewall) if you use a proxy to connect to the FTP:

· None  - Sends the User name and optional  Password for the FTP server as entered in the FTP
window

· Send  command  USER  -  Sends  the  User  name  and  optional  Password  defined  in  the  proxy
settings, followed immediately by the User name and optional Password for the FTP server.

· Send  command  SITE  -  Sends  the  User  name  and  optional  Password  defined  in  the  proxy
settings, the SITE command with the Host value, and the User name and optional Password for
the FTP site.

· Send  command  OPEN  -   Sends  the  User  name  and  optional  Password  defined  in  the  proxy
settings,  sends  the  OPEN  command  with  the  Host  value,  and  the  User  name  and  optional
Password for the FTP site.

· USER  user@firewalluser@hostname  /  PASS  pass@firewallpass  -  Sends  the  command  USER
user@proxyuser@host, then the command PASS pwd@proxypwd, or optionally PASS pwd.

· Transparent  -   Sends  the  User  name  and  optional  Password  defined  in  the   proxy  settings,
followed immediately by the FTP server User name and optional Password.

Host name or IP 
In this field you have to enter the host name or IP address for the proxy server (firewall).

Host port
Enter the host port number in this field. By default, the port number is set to 80.

User name
This field is used to enter the proxy user name.

Password
In this field you can enter the password for the specified user name.
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ASCII file types

It includes the list of all file extensions that will be transfered as ASCII when using Auto transfer mode
for FTP uploads. You can filter, add, edit or delete the file extensions listed here. 
Please note: if you add non-ASCII file types in this list, when you back up such files in ASCII mode they
will get corrupted and you won't be able to use them. 

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.10.3 SFTP

The SFTP page of the Options window (accessible from the File, Options->Online connections menu
item) contains SFTP settings.

 

When SFTP server not ready

The  first  number  (Retry  option)  indicates  how  many  times  the  application  tries  to  access  the
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destination server if it is not available. By default this option is set to 5 attempts. The second number
(wait option) indicates how many seconds to wait between two consecutive attempts to access  the
destination  location.  By  default  this  option  is  set  to  60  seconds.  This  option  is  useful  when  the
destination  SFTP server  has  restrictions  (i.e.  only  2  users  logged  in  the  same  time,  no.  of  accesses
etc.) and insures that if the SFTP server cannot accept your connection, it will not be "hammered" by
sending log-in requests frequently.

Configurations

The File->Options->Online connections->SFTP window allows you to define SFTP configurations that
can be used on the Destination page in the New Backup Wizard or Backup Properties windows. You
can add, edit, copy or delete an SFTP connection using this window.

In order to add a new SFTP connection press the Add button. The Define SFTP configuration window
will appear in the list and you can enter the other settings for this connection.

General
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Reset to configuration
If  you want  to  add  a  new SFTP location,  the  <New> option  should  be  selected.  To  edit  an  existing
SFTP location, select it from the drop-down list. All fields will be filled with the values of the selected
SFTP.  

SFTP server

· Server name or IP - In this field you have to enter the name or IP address for the SFTP server

· Port - In this field you have to enter  the port  number if  different  than the default  SFTP ports
(22).

· Destination - Here you can enter the destination path if different than root.

· User name - If this is a private SFTP server (no anonymous access allowed) enter the user name
for your account.

· Password - In this field enter the password for the SFTP server.

Private key

· None - no private key is used

· Key file - allows user to specify a key file that will be used

· Personal certificate store - allows user to import and use different certificate formats 

Bandwidth limitation

This section allows you to set different limitations for upload/download speed:

· Upload speed - if checked you can set a maximum upload speed for the SFTP transfer

· Download speed - if checked you can set a maximum upload speed for the SFTP transfer
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· Verify host key: If checked, the host key will be verified each time

· Maximum file  size -  specify  the maximum file  size  you want  to  have.  Please  note  that  many
SFTP servers does not allow you to upload files larger than 2 GB.

· Timeout - you can set the time interval (in seconds) that is allowed for no data transfer before
the transfer operation is interrupted and must be resumed. Default is 15 seconds.

Authentication

You  can  select  which  authentication  methods  will  be  used  when  backing  up.  Available  options:
publickey, password and keyboard-interactive.
The priority of these options can also be changed.

Encryption
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· Ciphers:  clear  or  select  the  check  boxes  to  specify  which  ciphers  you  want  to  allow  for
encrypting SFTP sessions. A Cipher is the algorithm(s) used for symmetric  session encryption.
To  give  a  cipher  a  lower  priority  rating,  select  it  with  the  mouse  and  then  click  the  Down
button.

· MACs: clear or select the check boxes to specify which MACs you want to allow for encrypting
SFTP sessions. A MAC (Message Authentication Code) is the algorithm(s) used for data integrity
verification. To give a MAC a lower priority rating, select it with the mouse, and then click the
Down button.

Compression

SFTP supports  the use of data compression to reduce the amount of data that  is  transmitted.  Both
the client and server agree on a compression algorithm. They then compress data before sending and
decompress data when it is received.
Typically, zlib compression is the compression algorithm most commonly supported in SFTP servers.
No compression is set as the default, and zlib is specified as an option. If the server forces use of zlib
compression it will happen automatically.

Hot keys

Host keys folder - Clear cache -  press this  button if  you want to delete the host keys stored in the
keys folder.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.10.4 Azure

The Azure page of the Options window (accessible from the File, Options->Online connections menu
item) contains Azure settings.
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When Azure server not ready

The  first  number  (Retry  option)  indicates  how  many  times  the  application  tries  to  access  the
destination server if it is not available. By default this option is set to 5 attempts. The second number
(wait option) indicates how many seconds to wait between two consecutive attempts to access  the
destination  location.  By  default  this  option  is  set  to  60  seconds.  This  option  is  useful  when  the
destination Azure server has restrictions (i.e.  only  2 users logged in the same time,  no.  of  accesses
etc.) and insures that if the Azure server cannot accept your connection, it will not be "hammered" by
sending log-in requests frequently.

Configurations

The  File->Options->Online  connections->Azure  window  allows  you  to  define  Azure  configurations
that can be used on the Destination page in the New Backup Wizard or Backup Properties windows.
You can add, edit, copy or delete an Azure connection using this window.
In  order  to  add  a  new  Azure  connection  press  the  Add  button.  The  Define  Azure  configuration
window will appear in the list and you can enter the other settings for this connection.
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General

Configuration name
Enter  here an arbitrary name for  the  connection.  By  default  the  New Azure configuration name  is
assigned.

Settings

· Account name - In this field you have to enter the name of your Azure account

· Key - In this field you have to enter the key for your Azure account
Key is shared Access Signature - check this option if the key is shared access signature

· Container - In this field you have to enter the container you want to use as destination

· Folder - In this field you have to enter the folder where you want to store the backups. If the folder
does not exist, it will be created.

Note:  If  you configured a  new Azure  location  or  you edit  an  existing  one,  you should  use  the  Test
button to see if the Azure settings are correct. If the test was successful, The Azure connection was
tested successfully message will be displayed.
 
Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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11.10.5 Amazon S3

The Amazon S3 page of the Options window (accessible from the File, Options->Online connections
menu item) contains Amazon settings.

 

When Amazon S3 server not ready

The  first  number  (Retry  option)  indicates  how  many  times  the  application  tries  to  access  the
destination server if it is not available. By default this option is set to 5 attempts. The second number
(wait option) indicates how many seconds to wait between two consecutive attempts to access  the
destination  location.  By  default  this  option  is  set  to  60  seconds.  This  option  is  useful  when  the
destination  Amazon  S3  server  has  restrictions  (i.e.  only  2  users  logged  in  the  same  time,  no.  of
accesses etc.) and insures that if the Amazon S3 server cannot accept your connection, it will not be
"hammered" by sending log-in requests frequently.

Configurations

The  File->Options->Online  connections->Amazon  S3  window  allows  you  to  define  Amazon
configurations  that  can  be  used  on  the  Destination  page  in  the  New  Backup  Wizard  or  Backup
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Properties windows. You can add, edit, copy or delete an Amazon S3 connection using this window.
In  order  to  add  a  new  Amazon  S3  connection  press  the  Add  button.  The  Define  Amazon  S3
configuration window will appear in the list and you can enter the other settings for this connection.

 
General

Configuration name
Enter here an arbitrary name for the connection. By default the New Amazon S3 configuration name
is assigned.

Settings

· Access Key ID - In this field you have to enter the access key ID for your Amazon S3 account

· Secret  Access  Key  -  In  this  field  you  have  to  enter  the  Secret  Access  Key  for  your  Amazon  S3
account

· Region - select a region from the list, where your backups will be stored

· Bucket - In this field you need to enter the bucket to be used as destination. You can also create a
new bucket if you type its name and press Create button.  If  you already have the bucket created
outside Backup4all, please make sure you also select the correct region for it.

· Folder - In this field you have to enter the folder where you want to store the backups. If the folder
does not exist, it will be created.

· Storage class

· Standard - this option offers high durability,  availability, and performance object  storage for
frequently accessed data.



Backup4all 9400

Backup4all 9 User Manual Copyright © 2021 Softland

· Standard - Infrequent Access Storage - is an Amazon S3 storage class for data that is accessed
less frequently, but requires rapid access when needed.

· Reduced  redundancy  (not  recommended)  -  enables  customers  to  store  noncritical,
reproducible  data  at  lower  levels  of  redundancy  than  Amazon  S3’s  standard  storage.  It
provides a  highly available solution for distributing or  sharing content  that  is  durably  stored
elsewhere, or for storing thumbnails, transcoded media, or other processed data that can be
easily reproduced.

· Transfer  acceleration  -  this  option  enables  fast,  easy,  and  secure  transfers  of  files  over  long
distances between Backup4all and the S3 bucket. Transfer Acceleration takes advantage of Amazon
CloudFront’s  globally  distributed  edge  locations.  As  the  data  arrives  at  an  edge  location,  data  is
routed to Amazon S3 over an optimized network path.

Note:  If  you configured a new Amazon S3 location or  you edit  an  existing  one,  you should  use  the
Test button to see if the Amazon S3 settings are correct.  If  the test was successful,  The Amazon S3
connection was tested successfully message will be displayed.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.10.6 Google Cloud Storage

The Google  Cloud  Storage  page  of  the  Options  window (accessible  from the  File,  Options->Online
connections menu item) contains Google Cloud Storage settings.
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When Google Cloud Storage server not ready

The  first  number  (Retry  option)  indicates  how  many  times  the  application  tries  to  access  the
destination server if it is not available. By default this option is set to 5 attempts. The second number
(wait option) indicates how many seconds to wait between two consecutive attempts to access  the
destination  location.  By  default  this  option  is  set  to  60  seconds.  This  option  is  useful  when  the
destination Google Cloud Storage server has restrictions (i.e.  only  2 users logged in the same time,
no.  of  accesses  etc.)  and  insures  that  if  the  Google  Cloud  Storage  server  cannot  accept  your
connection, it will not be "hammered" by sending log-in requests frequently.

Configurations

The File->Options->Online connections->Google Cloud Storage window allows you to define Google
Cloud Storage configurations that can be used on the Destination page in the New Backup Wizard or
 Backup Properties windows. You can add, edit, copy or delete an Google Cloud Storage connection
using this window.
In order  to  add  a  new Google  Cloud Storage  connection  press  the  Add  button.  The Define Google
Cloud Storage configuration window will appear in the list and you can enter the other settings for
this connection.
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General

Configuration name
Enter  here  an  arbitrary  name  for  the  connection.  By  default  the  New  Google  Cloud  Storage
configuration name is assigned.

Settings

· Access  Key  ID  -  In  this  field  you  have  to  enter  the  access  key  ID  for  your  Google  Cloud  Storage
account

· Secret  Access  Key -  In  this  field  you  have  to  enter  the  Secret  Access  Key  for  your  Google  Cloud
Storage account

· Region - select a region from the list, where your backups will be stored

· Bucket - In this field you need to enter the bucket to be used as destination. You can also create a
new bucket if you type its name and press Create button.  If  you already have the bucket created
outside Backup4all, please make sure you also select the correct region for it.

· Folder - In this field you have to enter the folder where you want to store the backups. If the folder
does not exist, it will be created.

· Storage class - Select the storage class you want to use. You can choose between: 

· Default - uses the default storage class configured in your Google Cloud Storage account

· Regional Storage - used to store frequently accessed data in the same region as your Google
Cloud DataProc or Google Compute Engine.

· Multi-Regional Storage - used to store data that is frequently accessed ("hot" objects) around



Options 403

Backup4all 9 User Manual Copyright © 2021 Softland

the  world,  such  as  serving  website  content,  streaming  videos,  or  gaming  and  mobile
applications.

· Nearline Storage - used to store data you do not expect to access frequently

· Coldline Storage - used to store data you expect to access infrequently

Note: If you configured a new Google Cloud Storage location or you edit an existing one, you should
use the Test button to see if the Google Cloud Storage settings are correct. If the test was successful,
The Google Cloud Storage connection was tested successfully message will be displayed.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.10.7 Google Drive

The  Google  Drive  page  of  the  Options  window  (accessible  from  the  File,  Options->Online
connections menu item) contains Google Drive settings.

 

When Google Drive server not ready

The  first  number  (Retry  option)  indicates  how  many  times  the  application  tries  to  access  the
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destination server if it is not available. By default this option is set to 5 attempts. The second number
(wait option) indicates how many seconds to wait between two consecutive attempts to access  the
destination  location.  By  default  this  option  is  set  to  60  seconds.  This  option  is  useful  when  the
destination  Google  Drive  server  has  restrictions  (i.e.  only  2  users  logged  in  the  same  time,  no.  of
accesses etc.) and insures that if the Google Drive server cannot accept your connection, it will not be
"hammered" by sending log-in requests frequently.

Configurations

The  File->Options->Online  connections->Google  Drive  window  allows  you  to  define  Google  Drive
configurations  that  can  be  used  on  the  Destination  page  in  the  New  Backup  Wizard  or  Backup
Properties windows. You can add, edit, copy or delete a Google Drive connection using this window.
In  order  to  add  a  new  Google  Drive  connection  press  the  Add  button.  The  Define  Google  Drive
configuration window will appear in the list and you can enter the other settings for this connection.

 
General

Configuration name
Enter  here  an  arbitrary  name  for  the  connection.  By  default  the  New  Google  Drive  configuration
name is assigned.

Settings

· Drive type - here you can choose "Personal" or "Team", depending on the account type you have.
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· Authentication - press "Choose account" button to log in to your Google Drive account. Here
you  need  to  authorize  Backup4all  application  to  view  and  manage files  in  your  Google  Drive
account.
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· Folder - In this field you have to select the folder where you want to store the backups. If no
folder is selected the backup will be stored in the root of your Google Drive account.

Note: If you configured a new Google Drive location or you edit an existing one, you should use the
Test  button  to  see  if  the  Google  Drive  settings  are  correct.  If  the  test  was  successful,  The  Google
Drive connection was tested successfully message will be displayed.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.10.8 OneDrive

The OneDrive  page  of  the  Options  window (accessible  from the  File,  Options->Online  connections
menu item) contains OneDrive settings.
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When OneDrive server not ready

The  first  number  (Retry  option)  indicates  how  many  times  the  application  tries  to  access  the
destination server if it is not available. By default this option is set to 5 attempts. The second number
(wait option) indicates how many seconds to wait between two consecutive attempts to access  the
destination  location.  By  default  this  option  is  set  to  60  seconds.  This  option  is  useful  when  the
destination OneDrive server has restrictions (i.e. only 2 users logged in the same time, no. of accesses
etc.)  and  insures  that  if  the  OneDrive  server  cannot  accept  your  connection,  it  will  not  be
"hammered" by sending log-in requests frequently.

Configurations

The  File->Options->Online  connections->OneDrive  window  allows  you  to  define  OneDrive
configurations  that  can  be  used  on  the  Destination  page  in  the  New  Backup  Wizard  or  Backup
Properties windows. You can add, edit, copy or delete an OneDrive connection using this window.
In  order  to  add  a  new  OneDrive  connection  press  the  Add  button.  The  Define  OneDrive
configuration window will appear in the list and you can enter the other settings for this connection.
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General

Configuration name
Enter here an arbitrary name for the connection. By default the New OneDrive configuration name is
assigned.

Settings

· Account type - here you can choose "Personal" or "Business", depending on the account type you
have.

· Authentication - press "Choose account" button to log in to your OneDrive account. Here you need
to authorize Backup4all application to view and manage files in your OneDrive account.
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· Folder - In this field you have to select the folder where you want to store the backups. If no folder
is selected the backup will be stored in the root of your OneDrive account.

· Custom max file  size -  this option allows you to set  a  custom file  size  (by  default  is  15  GB).  It  is
useful if you don't want large files to be split on upload.

Note: If you configured a new OneDrive location or you edit an existing one, you should use the Test
button to see if the OneDrive settings are correct. If the test was successful, The OneDrive connection
was tested successfully message will be displayed.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.10.9 Box

The Box  page of the Options  window (accessible from the File,  Options->Online connections  menu
item) contains Box settings.
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When Box server not ready

The  first  number  (Retry  option)  indicates  how  many  times  the  application  tries  to  access  the
destination server if it is not available. By default this option is set to 5 attempts. The second number
(wait option) indicates how many seconds to wait between two consecutive attempts to access  the
destination  location.  By  default  this  option  is  set  to  60  seconds.  This  option  is  useful  when  the
destination Box server has restrictions (i.e. only 2 users logged in the same time, no. of accesses etc.)
and  insures  that  if  the  Box  server  cannot  accept  your  connection,  it  will  not  be  "hammered"  by
sending log-in requests frequently.

Configurations

The File->Options->Online connections->Box  window allows  you to  define  Box  configurations  that
can be used on the Destination page in the New Backup Wizard or Backup Properties windows. You
can add, edit, copy or delete a Box connection using this window.
In order to add a new Box connection press the Add button. The Define Box configuration window
will appear in the list and you can enter the other settings for this connection.
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General

Configuration name
Enter  here  an  arbitrary  name  for  the  connection.  By  default  the  New  Box  configuration  name  is
assigned.

Settings

· Authentication -  press "Choose account" button to log in to your Box account.  Here you need to
authorize Backup4all application to read and write files/folders in your Box account.
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· Folder - In this field you have to select the folder where you want to store the backups. If no folder
is selected the backup will be stored in the root of your Box account.

Note:  If  you  configured  a  new  Box  location  or  you  edit  an  existing  one,  you  should  use  the  Test
button to see if the Box settings are correct. If the test was successful, The Box connection was tested
successfully message will be displayed.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.10.10 Dropbox

The  Dropbox  page  of  the  Options  window  (accessible  from  the  File,  Options->Online  connections
menu item) contains Dropbox settings.
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When Dropbox server not ready

The  first  number  (Retry  option)  indicates  how  many  times  the  application  tries  to  access  the
destination server if it is not available. By default this option is set to 5 attempts. The second number
(wait option) indicates how many seconds to wait between two consecutive attempts to access  the
destination  location.  By  default  this  option  is  set  to  60  seconds.  This  option  is  useful  when  the
destination Dropbox server has restrictions (i.e. only 2 users logged in the same time, no. of accesses
etc.) and insures that if the Dropbox server cannot accept your connection, it will not be "hammered"
by sending log-in requests frequently.

Configurations

The  File->Options->Online  connections->Dropbox  window  allows  you  to  define  Dropbox
configurations  that  can  be  used  on  the  Destination  page  in  the  New  Backup  Wizard  or  Backup
Properties windows. You can add, edit, copy or delete a Dropbox connection using this window.
In order to add a new Dropbox connection press the Add button. The Define Dropbox configuration
window will appear in the list and you can enter the other settings for this connection.
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General

Configuration name
Enter here an arbitrary name for the connection. By default the New Dropbox configuration name is
assigned.

Settings

· Authentication - press "Choose account" button to log in to your Dropbox account. Here you need
to authorize Backup4all application to read and write files/folders in your Dropbox account.
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· Folder - In this field you have to select the folder where you want to store the backups. If no folder
is selected the backup will be stored in the root of your Dropbox account.

· Custom max  file  size  -  this  option  allows  you  to  set  a  custom  file  size  (by  default  is  5  GB).  It  is
useful if you don't want large files to be split on upload.

Note: If you configured a new Dropbox location or you edit an existing one, you should use the Test
button to see if the Dropbox settings are correct. If the test was successful, The Dropbox connection
was tested successfully message will be displayed.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.10.11 HiDrive

The  HiDrive  page  of  the  Options  window  (accessible  from  the  File,  Options->Online  connections
menu item) contains HiDrive settings.
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When HiDrive server not ready

The  first  number  (Retry  option)  indicates  how  many  times  the  application  tries  to  access  the
destination server if it is not available. By default this option is set to 5 attempts. The second number
(wait option) indicates how many seconds to wait between two consecutive attempts to access  the
destination  location.  By  default  this  option  is  set  to  60  seconds.  This  option  is  useful  when  the
destination HiDrive server has restrictions (i.e. only 2 users logged in the same time, no. of accesses
etc.) and insures that if the HiDrive server cannot accept your connection, it will not be "hammered"
by sending log-in requests frequently.

Configurations

The  File->Options->Online  connections->HiDrive  window  allows  you  to  define  HiDrive
configurations  that  can  be  used  on  the  Destination  page  in  the  New  Backup  Wizard  or  Backup
Properties windows. You can add, edit, copy or delete a HiDrive connection using this window.
In order to add a new HiDrive connection press the  Add  button.  The Define HiDrive  configuration
window will appear in the list and you can enter the other settings for this connection.
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General

Configuration name
Enter here an arbitrary name for the connection. By default the New HiDrive configuration name is
assigned.

Settings

· Authentication - press "Choose account" button to log in to your HiDrive account. Here you need
to authorize Backup4all application to read and write files/folders in your HiDrive account.
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· Folder - In this field you have to select the folder where you want to store the backups. If no folder
is selected the backup will be stored in the root of your HiDrive account.

· Custom max  file  size  -  this  option  allows  you  to  set  a  custom  file  size  (by  default  is  2  GB).  It  is
useful if you don't want large files to be split on upload.

Note: If  you configured a new HiDrive location or you edit an existing one, you should use the Test
button to see if  the  HiDrive  settings  are  correct.  If  the  test  was  successful,  The HiDrive  connection
was tested successfully message will be displayed.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.10.12 Hubic

The Hubic page of the Options window (accessible from the File, Options->Online connections menu
item) contains Hubic settings.
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When Hubic server not ready

The  first  number  (Retry  option)  indicates  how  many  times  the  application  tries  to  access  the
destination server if it is not available. By default this option is set to 5 attempts. The second number
(wait option) indicates how many seconds to wait between two consecutive attempts to access  the
destination  location.  By  default  this  option  is  set  to  60  seconds.  This  option  is  useful  when  the
destination Hubic server has restrictions (i.e.  only  2 users logged in the same time,  no.  of  accesses
etc.) and insures that if the Hubic server cannot accept your connection, it will not be "hammered" by
sending log-in requests frequently.

Configurations

The  File->Options->Online  connections->Hubic  window  allows  you  to  define  Hubic  configurations
that can be used on the Destination page in the New Backup Wizard or Backup Properties windows.
You can add, edit, copy or delete a Hubic connection using this window.
In  order  to  add  a  new  Hubic  connection  press  the  Add  button.  The  Define  Hubic  configuration
window will appear in the list and you can enter the other settings for this connection.
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General

Configuration name
Enter  here an arbitrary  name for  the  connection.  By  default  the  New Hubic  configuration name  is
assigned.

Settings

· Authentication - press "Choose account" button to log in to your Hubic account. Here you need to
authorize Backup4all application to read and write files/folders in your Hubic account.



Options 425

Backup4all 9 User Manual Copyright © 2021 Softland

· Folder - In this field you have to select the folder where you want to store the backups. If no folder
is selected the backup will be stored in the root of your Hubic account.

· Custom max  file  size  -  this  option  allows  you to  set  a  custom file  size  (by  default  is   5  GB).  It  is
useful if you don't want large files to be split on upload.

Note:  If  you configured a  new Hubic  location  or  you edit  an  existing  one,  you should  use  the  Test
button to see if the Hubic settings are correct. If the test was successful, The Hubic connection was
tested successfully message will be displayed.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.10.13 S3 Compatible

The  S3  Compatible  page  of  the  Options  window  (accessible  from  the  File,  Options->Online
connections menu item) contains S3 Compatible settings.
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When S3 Compatible server not ready

The  first  number  (Retry  option)  indicates  how  many  times  the  application  tries  to  access  the
destination server if it is not available. By default this option is set to 5 attempts. The second number
(wait option) indicates how many seconds to wait between two consecutive attempts to access  the
destination  location.  By  default  this  option  is  set  to  60  seconds.  This  option  is  useful  when  the
destination S3 Compatible server has  restrictions  (i.e.  only  2  users  logged in  the  same  time,  no.  of
accesses etc.) and insures that if the S3 Compatible server cannot accept your connection, it will not
be "hammered" by sending log-in requests frequently.

Configurations

The File->Options->Online connections->S3 Compatible window allows you to define S3 Compatible
configurations  that  can  be  used  on  the  Destination  page  in  the  New  Backup  Wizard  or  Backup
Properties  windows.  You  can  add,  edit,  copy  or  delete  a  S3  Compatible  connection  using  this
window.
In order to add a new S3 Compatible connection press the  Add  button.  The Define S3  Compatible
configuration window will appear in the list and you can enter the other settings for this connection.
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General

Configuration name
Enter  here an arbitrary name for the connection.  By default  the New S3  Compatible  configuration
name is assigned.

S3 Server
Select  one  of  the  predefined  S3  compatible  servers,  or  define  a  custom  one.  The  S3  compatbile
clouds  available  are:  Akaza,  Aruba  Cloud,  Backblaze  B2,  Caringo,  CenturyLink,  Cisco,  Claudian,
Connectia, Constant, DDN, dinCloud, Dream Objects, Dunkel, T Cloud, Exoscale, Green Qloud, HGST,
Hitachi, HostEurope, IDC Frontier, LeoNovus, Mandic, Minio, NetApp, NiftyClouds, Numergy, QNAP,
Revera, Scality, Seeweb, SwiftStack, ThinkOn, Tiscali,  vCloud Air, Verizon, Walrus and Zettagrid.

Settings

· Endpoint  -  enter  the  server  endpoint.  For  most  of  the  predefined  servers,  the  endpoint  is  filled
automatically. Example: s3.akaza.lk:80
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· Use SSL - select this option if the server requires SSL usage

· Access Key ID - enter the access key ID as received from your server provider

· Secret Access Key - enter the secret access key as received from your server provider

· Signature version - chose the signature version used by your server 

· Region - select the region where your bucket is located

· Bucket - enter the name of the existing bucket or type a new one and press the Create button.

· Folder - In this field you have to select the folder where you want to store the backups. If no folder
is selected the backup will be stored in the root of your S3 Compatible account. 

 
Note: If you configured a new S3 Compatible location or you edit an existing one, you should use the
Test  button  to  see  if  the  S3  Compatible  settings  are  correct.  If  the  test  was  successful,  The  S3
Compatible connection was tested successfully message will be displayed.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.11 Email

On the Email page of the Options window (accessible from the File, Options menu item) you can set
configurations necessary to send emails.
 
Email notifications 

Enable email notifications
If checked, the email notifications are available in the backup jobs on the Emails page in the backup
job Properties or New Backup Wizard  (accessible from the File menu). By default this option is not
checked.

What do you want to use?

· SMTP  Server  -  using  this  option  you  can  manually  configure  the  SMTP  server  by  entering  all
required information

· Gmail - using this option you just need to login to your Gmail account and allow Backup4all to send
emails on your behalf

SMTP server
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Server Name or IP
Enter  the  DNS  name  or  IP  address  of  the  SMTP  server  to  be  used  to  send  emails  (example:  mail.
yourdomain.com) This field is mandatory.

Port
Enter the port number to be used by the SMTP server to send the emails. The default value is 25.

Connection enctyption

· None - if selected, no connection encryption will be used

· SSL - if selected the Secure Socket Layer (SSL) will be used for control channel and data channel
connections to the SMTP server. 

· TLS -  if  selected the  Transport  Layer  Security  (TLS)  will  be  used  for  control  channel  and  data
channel connections to the SMTP server. 

Send test email
Press Send Test Email if you want to test the configuration you just entered. In the box that pops-up,
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enter the email address where you want to receive notifications and press OK.  If all  the settings are
correct, a test email should arrive in your specified email account.

Email addresses
 
From
Enter the sender's email address. If you enter a wrong email address, the email notification will  not
be sent. This field is mandatory.

Reply To
Optionally you can specify a different reply email address. If no value is entered the From email will
be used.

Authentication

Server requires authentication
If  checked  the  SMTP  server  uses  authentication  and  you  will  need  to  supply  a  user  name  and  a
password. By default this option is not checked.

User name
Enter the user name to be used when authenticating on the SMTP server.

Password
Enter the password to be used when authenticating on the SMTP server.

Dial-up connection

In this group you can set how the program should handle dial-up connections. The available options
are: Do not start, Automatically start-up, Manually start-up.

Do not start
If selected email notifications are sent only if your computer is already connected to the Internet. If
you have a connection but you are not connected the program will not dial for you.

Automatically start-up
If selected and you are not connected to the Internet, the program attempts to make the connection
for you automatically.

Manually start-up
If selected and you are not connected to the Internet, the program asks you if it should connect. You
can approve or deny the request.

Hang up when finished
If checked the dial-up connection will be closed after the notification email is sent.
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Gmail

 

 

Gmail authentication - Press "Choose account" button. Then login to your Gmail account and allow
Backup4all to send emails on your behalf.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.12 Notifications

On the Notifications page of the Options window (accessible from the File, Options menu item) you
can configure the expiration time for each notification message type.
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Profiles

Active profile - Here you can select which profile to be used:

· Silent - no notifications will be displayed

· Normal - notifications will be shown for all basic actions

· Verbose - notifications will be shown for all actions

· Custom - user defined for which actions to display notifications

Here is the list of all message types:

· Action started

· Action finished with success

· Action finished with warnings

· Action paused

· Action resumed

· Action stopped

· Action canceled

· File or folder errors

· Ask for backup label

· Split mirror file confirmation

· SFTP host key confirmation
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· Overwrite confirmation at restore

· File not found at restore

· File not found in zip at restore

· FTP destination warnings

· SFTP destination warnings

· Backup folder creation errors

· Disk prompts and warnings

· CD, DVD or Bluray destination warnings

· Delete confirmation for smart backup

· Cloud storage destination warnings

· Force independent split warning

· Backup source not available warning

· Resume zip upload for previous backup

Select a message type to modify it. Here are the options available for each message type:

· Show notification - check this option if you want to see a notification message for the selected
action

· Popup noficiation - check this option if you want the message to be shown in a popup window.
Otherwise it will be shown in the Backup4all status bar.

· Expires in - set the expiration time for the selected message type. By default is 2 minutes.

Notifications window
The notifications window shows  different messages for user.  There could be informal  messages or
actions required.
At  the  bottom  there  are  3  buttons:  to  show  the  notifications  window  from  File->Options-
>Notifications, to expand all notifications and the last button to collapse all notifications.

You can also Dismiss all notifications or you can simply press Close to hide the notifications window.
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Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.13 Passwords

On the Passwords  page  of  the  Options  window (accessible  from the  File,  Options  menu  item) you
can configure how the passwords used in Backup4all will be stored.
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Password storage

Store the password in the local Windows account
The passwords will be stored in local configuration files and retrieved automatically when executing
an  action.  The  passwords  could  be  retrieved  if  your  Windows  account  gets  compromised.  No
passwords are stored in the destination folders.

Protect the stored password using a master password
The  passwords  will  be  stored  in  local  configuration  files  encrypted  using  a  master  password  and
retrieved automatically when executing an action. You will  have to enter  the master password only
when you start the application or  when the first  backup job starts.  No passwords are stored in  the
destination folder.

Do not store passwords
The passwords will  not  be stored  anywhere.  You  will  have  to  enter  the  passwords  everytime a  job
action starts. This is the most secure option.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

11.14 Suspend

On the Suspend page of the Options window (accessible from the File, Options menu item) you can
define  time  intervals  when  Backup4all  is  suspended  (all  actions  in  progress  will  be  paused).  This
option  is  very  useful  for  large  backups  which  takes  many  hours  or  days.  The  backup  can  be



Backup4all 9436

Backup4all 9 User Manual Copyright © 2021 Softland

suspended automatically in the working hours for the computer resources not to be intensively used
by the backup.

If you want to add new suspend intervals, press Add button. A new window will  appear, where you
can set the start time and the end time for the suspend interval. You can add as many intervals you
want. 
Select the days of the week when the suspend interval should be applied.
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Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.
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12 Help

The Help page from File menu of Backup4all contains information about the version and edition you
have installed.

Support

Backup4all Help
Before asking for support, please make sure you have installed the latest version of Backup4all. Also
visit  our  online  Knowledgebase,  as  it  contains  valuable  information  and  your  questions  might
already be answered there. 
Support request
If  you  can’t  find  an  answer  to  your  questions  in  our  Knowledgebase,  please  go  to  Backup4all’s
File->Help  menu  and  click  on  Support  Request.  This  will  open  an  email  and  it  will  include  at  the
bottom  some  basic  information  we  would  need  (application  build  number,  operating  system  and
registration details).

Please include in your support request the following details:

· Exactly what did you do?

· Can you reproduce the problem again?

· If possible send us a screenshot of the error message.
We might ask you for additional information, if we cannot reproduce the problem.

If you want to report bugs, feature requests or want to ask general software usage questions, you can
contact our support department.
Pressing the Support  Request  button,  starts  a  new email  message that  will  be  sent  to  the  support
team.

http://www.backup4all.com/kb/
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13 Licensing

Activation allows verifying that  your copy of Backup4all  is  genuine and  that  it  hasn't  been  used  on
more computers than the number of licenses purchased. It prevents this way software counterfeiting
(intentional or unintentional).

Buy Now
If  you  don't  own  a  product  key  for  Backup4all  and  want  to  purchase  one,  click  on  the  Buy  Now
button. This will open the browser and allow you to buy a license. There you can select the quantity
of licenses you need and finish the purchase. To test the application before purchasing it, click on the
Free trial button instead, to try it 30 days for free.
The Feature Matrix section presents in detail the differences between Lite, Standard and Professional
edition.

Enter product key
After  purchasing  a  Backup4all  license  you will  receive  an  email  that  contains  your  Product  key.  To
start using the application you'll have to validate the registration details by clicking on "Enter product
 key" and follow the activation steps, where you will be able to activate online or manually. 

Change trial edition
Pressing this button will open the Start trial window, where you can change the edition of Backup4all
you want to try. If you change the trial edition, Backup4all will continue with the remaining number
of days left.

Change product key
Press this button to open the activation window, where you can enter the new key for Backup4all.

Register
Press this button to open our website, where you can register with the same email address used for
purchasing Backup4all. This way you will be able to see and manage all your keys and activations.

Deactivate this product key
Press this button to deactivate Backup4all. That is useful if you want to move the Backup4all license
to another computer.

Reactivate
Press this button to reactivate Backup4all immediately.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

13.1 Free Trial

Use Backup4all as trial for 30 days
Before purchasing a license and activating it online you have the option of testing it for free. The trial
version has the same features as the paid version and it  will  work for 30 days.  To continue using it
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after  the  trial  expires,  you  will  have  to  purchase  a  license  and  activate  it.  Once  the  program  is
activated, you will be able to continue using Backup4all without having to reconfigure anything extra.
Follow the steps below to start your trial:

1. Open Backup4all. The activation window will appear.

2. Pressing the Free trial button opens a new page where you can select which edition you want to
use: Professional, Standard or Lite.



Licensing 443

Backup4all 9 User Manual Copyright © 2021 Softland

 3. Press Start trial to restart the application and start using it.
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13.2 Online Activation

After  you  purchase  a  license  you  will  receive  an  email  with  your  licensing  information.  Using  the
license  key  received via  email  you  can  easily  activate  Backup4all  automatically  if  your  computer  is
connected to the Internet. During the activation process your license key is verified online and after it
is detected as valid you can start using Backup4all. 

1.  Open  the  activation  window  from  File->Licensing,  by  pressing  the  Enter  product  key  under
"Registration information".
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2. In the activation window enter the product key and the registration name, then press Activate.

3. A message appears that the application was successfully activated.
Press Restart Backup4all button to restart the application. 
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Backup4all will be automatically reactivated every 30 days. As long as you are connected to internet,
that will run silently in background. If you are not connected to internet for more than 30 days, you
will be asked to reactivate the application within 15 days. 

13.3 Manual Activation

Online  Activation  requires  a  working  internet  connection  to  activate  the  program.  However  if  your
computer is  not  connected to  the  internet,  you can  still  activate  Backup4all  manually.  You  can  use
manual  activation  in  the  rare  case  when  the  automatic  activation  fails  due  to  firewall  issues  or
internet connection.

The manual activation process involves two computers:  computer  A,  where  Backup4all  is  installed,
and computer B, the one that has internet access. Follow the steps below to copy the activation file
from computer A to computer B from where you can obtain the activation response:

1. Open Backup4all (on computer A). The Activate application window will  appear. If you previously
used the trial, you need to open the activation window from File->Licensing,  by pressing the "Enter
product key" button.
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2. Press "Enter key" button. Copy paste or type the key, then press Activate.

3.  If the internet connection cannot be established, a popup message will appear asking you to retry
online activation (you can configure a proxy server and try again). If you use an older version of
Windows, you can select the "Enable less secure online connection (using HTTP in case HTTPS
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fails)" option, then try again to activate online. Selecting this option allows you to activate
 Backup4all over HTTP if your OS does not recognize newer TLS or SSL protocols.

If  your  computer  is  not  connected  to  internet,  press  Activate  offline  button.  In  the  email  received
after  you purchased  Backup4all,  there  is  also  a  license  .lic  file  attached.  Download that  license  file
and load it in the bellow step:

4. On the second step of the manual activation, you have two options:

· Email activation request. Using this option, the default email client will open to send the
activation request. After sending the activation request email, in a short moment you will get
an email containing the activation file. Please load that file on the next page in order to activate
the application.

· Save activation request. Using this option, you will be asked to indicate the location where the
activation request file will be saved. Take that file and go to Computer B where you have
internet access. Load the file on activate.backup4all.com and press Activate. You will then
have the option to download the activation response file.
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5. In both cases you will get a activation response file that you need to load on the 3rd page of that
activation wizard, then press Activate.
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6. A message appears that the application was activated without errors. After finishing the activation
wizard, Backup4all will be restarted to apply the changes. Please note the manual activation has to be
repeated every 3 months in order to keep the backup application activated and working.
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13.4 Deactivation

If you want to move Backup4all on another computer or you want to completely remove it from the
computer, you also need to deactivate it.
Go to File->Licensing and press the Deactivate this product key option.
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You will be asked if you are sure you want to deactivate the product key from that computer. Press
Yes

If the deactivation was performed, you will get a confirmation message.

Otherwise, the offline deactivation window will  appear. Select the option you prefer and follow the
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steps.

If  you lost your registration key, please send us an email to Sales Support.  You should specify  your
purchase information (purchase number and approximate date),  the name (or company name) and
email  address  you  used  to  buy  your  copy  of  Backup4all.  We  will  send  to  you  the  registration  key
again.
 
If you have questions or you experience problems related to the registration process, you can use the
 Support Request button (from Help menu) under Support section to contact us. We will be happy to
assist you with the registration.

Backup4all is available as Shareware - another way of saying Try before you buy.  It is fully functional
for a period of 30 days. After 30 days, the program will start only if you enter a valid registration key
(OEM version users might be asked to enter their registration keys sooner). You can buy Backup4all
online if you fill out the online purchase form.

Note: One or more of the features mentioned in this chapter might not be available in your edition.
The Professional edition includes all the features. For a  comparison between editions, please check
feature matrix topic.

13.5 Legal notices

This program includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit.

OpenSSL License

Copyright (c) 1998-2011 The OpenSSL Project.   All  rights reserved. Redistribution and use in source
and binary forms, with or without modification, are permitted provided that the following conditions
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are met:

1. Redistributions of source code must retain the above copyright notice,  this  list  of  conditions  and
the following disclaimer.

2.  Redistributions in binary form must reproduce the above copyright notice,  this  list  of  conditions
and  the  following  disclaimer  in  the  documentation  and/or  other  materials  provided  with  the
distribution.

3.  All  advertising  materials  mentioning  features  or  use  of  this  software  must  display  the  following
acknowledgment: "This product includes  software developed by the OpenSSL Project for use in the
OpenSSL Toolkit. (http://www.openssl.org/)"

4.  The  names  "OpenSSL  Toolkit"  and  "OpenSSL  Project"  must  not  be  used  to  endorse  or  promote
products derived from this software without prior written permission. For written permission, please
contact openssl-core@openssl.org.

5.  Products derived from this  software may not  be  called  "OpenSSL"  nor  may  "OpenSSL"  appear  in
their names without prior written permission of the OpenSSL Project.

6. Redistributions of any form whatsoever must retain the following acknowledgment: "This product
includes  software  developed  by  the  OpenSSL  Project  for  use  in  the  OpenSSL  Toolkit  (http://www.
openssl.org/)"

THIS SOFTWARE IS  PROVIDED  BY  THE OpenSSL  PROJECT  ``AS  IS''  AND  ANY  EXPRESSED OR  IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY
AND  FITNESS  FOR  A  PARTICULAR  PURPOSE  ARE  DISCLAIMED.   IN  NO  EVENT  SHALL  THE  OpenSSL
PROJECT  OR  ITS  CONTRIBUTORS  BE  LIABLE  FOR  ANY  DIRECT,  INDIRECT,  INCIDENTAL,  SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR  SERVICES;  LOSS  OF  USE,  DATA,  OR  PROFITS;  OR  BUSINESS  INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,  WHETHER IN  CONTRACT,  STRICT LIABILITY,
OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This  product  includes  cryptographic  software  written  by  Eric  Young  (eay@cryptsoft.com).   This
product includes software written by Tim Hudson (tjh@cryptsoft.com).
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CD/DVD/Blu-ray options    

Burning engine     381

Eject CD/DVD/Blue-ray     381

Load CD/DVD/Blue-ray     381

SPTD     381

SPTI     381

Change criteria     308

Change Icon     225

Changed files     104

Clean backup     130

Clear archive bit     292

Clear backup     137, 139, 145, 322, 324, 331

Close to tray     165

Collapse     148

Column headers     127

Command line    

Silent install     13

Commands     148

Comparison criteria     308

Comparison table     20

Compression     241, 246, 248

Configure new backup     28

Configure One Touch Backup     71

Copy     148

Create a new backup     28

Create like     148

Create shortcut     98

Customize filter     286

- D -
Default destination     370

Default paths     370

Delete     148

Delete group     148

Delete sources     308

Description     10

Detailed logging     72

Device name     87

Differential     74, 292

Differential backup     77, 219, 295

Disc     86

Drive letter folder     336

DVD     86, 230

- E -
Eject     87, 89, 157

Email notifications    

Authentication     70

Email address     70

Send test email     70

SMTP server     70

Email options    

Authentication     428

Dial-up connection     428

Email addresses     428

Email notifications     428

Hang up     428

IP     428

Port     428

SMTP server     428

SSL     428

Empty directories     308

Enable detailed logging     72

Enclosures     68, 71

Encryption     241, 246, 248

AES encryption     39

Zip encryption     39

Erase CD/DVD     157

Erase disc     87, 137, 139, 145, 322, 324, 331

Exact copy     80

Exclude     346

Execute backup     35

Exit     148, 165

Expand     148

Explicit SSL     236

Explore     148

Explore View     104

External device     68

- F -
Fast mirror     80, 297

Feature matrix    

Lite     20

Professional     20

Standard     20

Features summary     15

File filtering     346

File locations    



Index 457

Backup4all 9 User Manual Copyright © 2021 Softland

File locations    

BkcFiles     370

Catalog     370

Destination     370

IniFiles     370

Initialization     370

Log     370

Temporary     370

File tree     104

File version list     104

File versions     75, 77, 79

Backup number     339

Backup time     339

Label     339

Total size     339

Type     339

Files in backup     108

Filter    

By attribute     347

By date     347

By name     347

By size     347

Directories     347

Files     347

Folders     347

Filter backup    

Customize filter     284

Exclude files     284

Include files     284

Main filter     284

Filter restore    

Customize filter     341

Exclude files     341

Include files     341

Main filter     341

Finalizing CD/DVD     87

Firewall     236

Firewire     68, 229

flash     231

floppy     231

Floppy drive     227

Folder filtering     346

FTP     176, 227, 235

Hammering     42

Port number     42

Proxy server     42

Remote location     42

Retry times     42

SSL     42

XCRC     42

FTP options    

Host name     383, 385

Password     383, 385

Port     383, 385

Retry     383, 385

Username     383, 385

Wait     383, 385

Full     74, 292

Full backup     75, 77, 219, 294

Full erase     157

- G -
General options    

Align caption     364

Appearance     364

Background color     364

Blank passwords     364

Captions     364

Context menu     364

Daylight saving     364

Explorer icons     364

Hidden files     364

Hide empty folders     364

Hint     364

Icon size     364

Insecure passwords     364

Measurement     364

Sort backups     364

Toolbar     364

Getting Started    

Backup     92

New     92

Open     92

Restore     92

Group     225

- H -
Hard disk drive     227

Hide empty folders     104

High priority     127

Highest priority     127

Hint     365

Hints     165



Backup4all 9458

Backup4all 9 User Manual Copyright © 2021 Softland

History     133, 160

- I -
Icon size     365

Implicit SSL     236

Import     148, 161

Import inactive schedulers     161

Include     346

Incremental     74, 292

Incremental backup     79, 219, 296

Independent zip files     88

Installation    

Install     11

License agreement     11

Setup language     11

Uninstall     11

Introduction     10

- K -
Keyboard shortcuts     164

- L -
Labeling     86, 308

LAN     175, 227, 233

Last backup size     108

Last backup status     108

Last CD/DVD/Blu-ray     88

Legacy     308

Limit     86

Load     157

Loading CD/DVD     87

Local catalog     86, 308

Local destination     228

Local drives     169, 170, 173, 174, 227

Logging     72, 160

Logging options    

Detailed log     379

Error logging     379

Restricted size     379

Summary log     379

Warning logging     379

Logs     133

Low priority     127

Lowest priority     127

- M -
Make     148

Make differential     148

Make full     148

Make incremental     148

Manage backup jobs    

Copy backup     35

Delete backup     35

Modify backup     35

Manage backup tags     95

Manage plugins     158, 195

Mapped network drive     227

Merge     86

Minimize to tray     165

Mirror     74, 292

Mirror backup     80, 219, 297

Mirror with zip     297

My Documents     225

My Pictures     225

- N -
Name     225

New     148

New backup     28

New backup wizard    

Advanced     28

Destination     28

Explore     28

Filters     28

General     28

Scheduler     28

Sources     28

Statistics     28

Summary     28

Type     28

New features     20

New group     148

Next scheduled backup     108

No SSL     236

Normal priority     127

Not changed     104

Notifications     70

NTFS     308

Number of backups     108



Index 459

Backup4all 9 User Manual Copyright © 2021 Softland

- O -
One Touch Backup     71

Open backup     113, 148, 161

Open Backup From     113

Open files     308

OTB     71

Outlook Express     225

Override catalog     227

Override filter     284, 341, 346

- P -
Packet writing software     87

Passive mode     236

Firewalls     45

Password     39

Password protect a backup     39

Portability     68

Predefined backup     158, 195, 225

Preview     343

Previous version     161

Priority slider     127

Private key     241, 246, 248

Product description     10

Progress View     112

Properties     148

Proxy    

Port     45

Transparent     45

Proxy type     236

- Q -
Quick erase     157

- R -
Refresh     148

Refresh list     157

Reload     87

removable     231

Remove password     39

Rename group     148

Reset node     343

Reset tree     343

Restore     148

Advanced     336

Basic     336

Full     336

Restore latest version     36

Restore to     36

Restore wizard     36

Standard     336

Restore from a backup     36

Restore versions     339

Restrictions     284, 341

Run a backup job     35

Run at shutdown     137, 139, 145, 322, 324, 331

Run backup     35

Running     148

- S -
Save storage space     74

Schedule     220

Add     135, 320

Close window     137, 139, 145, 322, 324, 331

Command line     137, 139, 145, 322, 324, 331

Delete     135, 320

Edit     135, 320

Hide window     137, 139, 145, 322, 324, 331

Main application     137, 139, 145, 322, 324, 331

Refresh     135

Schedule     320

Schedule a backup     41

Scheduler     148

Standalone scheduler     41

Task scheduler     41

Send email notifications     70

SFTP     178, 239

Hammering     47

Port number     47

Remote location     47

Retry times     47

SSH     47

SFTP options    

Host name     391

Password     391

Port     391

Retry     391

Username     391

Wait     391

Shortcut     98



Backup4all 9460

Backup4all 9 User Manual Copyright © 2021 Softland

Show context menu     104

Show deleted     148

Show disk label message     89

Show excluded     148

Show modified     148

Show new     148

Show unchanged     148

Size     104

Smart backup     294

Snapshot     80

Sources    

Abort     195, 282

Add files     195, 282

Add folder     195, 282

Ignore     195, 282

Remove     195, 282

Retry     195, 282

Spanning     86

Speed     230

SPTD     89

SPTI     89

SSH     391

SSL     383, 385

Encryption     46

Explicit SSL     46

Implicit SSL     46

Layer     46

Secure     46

Sockets     46

SSL encryption level     236

Standalone scheduler     135, 137, 139, 145, 320,
322, 324, 331

Start backup     35

Startup options    

Windows startup     368

Statistics     148

Statistics View     108

Status     104

Summary     148, 338

System requirements     11

System tray     165

- T -
Task     320

Task scheduler     135

Temporary folder     86

Test     148, 308

Test a backup     38

Test after backup     38

Test backup     38, 127

Test log     38

Timeout     236

Toolbar     148, 365

Tray icon     165

Close     368

Minimize     368

Show errors     368

Type differential     295

Type full     294

Type incremental     296

Type mirror     297

Type Smart     294

- U -
UDF     87, 230

UNC network drive     227

Universal Data Format     87

usb     229, 231

USB backup    

Detect device     68

Format device     68

One Touch Backup     68

Start device     68

USB drive     68, 227

Use built in driver     87

Use One Touch Backup     71

Use packet writing     87

- V -
View menu     104

Visualization    

Maximized     368

Window state     368

Volume Shadow Copy     308

- W -
Warn before erasing     89

Windows 2000     11

Windows 2003 Server     11

Windows 98 SE     11

Windows Me     11



Index 461

Backup4all 9 User Manual Copyright © 2021 Softland

Windows NT SP6     11

Windows scheduler     137, 139, 145, 320, 322, 324,
331

Windows XP     11

Wizard     169, 225

Writing to Blu-ray     88

Writing to CD     88

Writing to DVD     88

- X -
XCRC     236

- Z -
Zip backup     75, 77, 294

Zip compression     304

Zip drive     227

Zip encryption     304


	Introduction
	Product Description
	System Requirements
	Installation
	Command Line Parameters

	Features Summary
	Feature Matrix

	Getting Started
	How to Configure a New Backup
	How to Run a Backup Job
	How to Manage Backup Jobs
	How to Restore from a Backup
	How to Test a Backup
	How to Repair a Backup
	How to Password Protect a Backup
	How to Schedule a Backup
	How to Backup to FTP
	Passive and Active modes
	Connecting Through Proxy
	Using SSL Encryption

	How to Backup to SFTP
	How to Backup to Azure
	How to Backup to Amazon S3
	How to Backup to Google Cloud Storage
	How to Backup to Google Drive
	How to Backup to OneDrive
	How to Backup to Box
	How to Backup to Dropbox
	How to Backup to HiDrive
	How to Backup to Hubic
	How to Backup to S3 Compatible
	How to Backup to USB or Firewire drives
	How to Send Email Notifications
	How to Configure One Touch Backup
	How to Use One Touch Backup
	How to Enable Detailed Logging

	Backup Types
	Backup Types
	Smart Backup
	Full Backup
	Differential Backup
	Incremental Backup
	Mirror Backup
	Backup Types in Backup4all

	Backup to CD, DVD or Blu-ray
	Backup to CD, DVD or Blu-ray
	Use Built in Driver
	Use Packet Writing
	Writing to CD, DVD or Blu-ray disc
	Other CD/DVD/Blu-ray Settings

	Main Window
	Getting Started
	Jobs View
	Jobs List
	Manage Tags
	Create Shortcut
	Explore View
	Backup View
	Statistics View
	Progresss View
	Open backup
	Test
	Clean backup

	History View
	Schedulers View
	General
	When
	What

	File
	Commands
	Erase CD/DVD/Blu-ray
	Plugins
	Logging
	Import
	Check for updates
	Keyboard Shortcuts

	System Tray

	New Backup Wizard
	Overview
	Destination - Where do you want to save your backup?
	Local hard drive
	External hard drive
	CD, DVD or Blu-ray
	Removable
	Network drives
	Network
	Online
	FTP
	SFTP
	Azure
	Amazon S3
	Google Cloud Storage
	Google Drive
	Microsoft OneDrive
	Box
	Dropbox
	HiDrive
	Hubic
	S3 Compatible


	Sources - What do you want to backup?
	Local
	Network
	Applications
	FTP
	SFTP
	Azure
	Amazon S3
	Google Cloud Storage
	Google Drive
	Microsoft OneDrive
	Box
	Dropbox
	HiDrive
	Hubic
	S3 Compatible

	Filters - Filter the backup sources
	Type - How do you want to backup?
	Scheduler - When do you want to backup?
	Job - Personalize your backup job

	Backup Properties
	Overview
	General
	Destination
	Local hard drive
	External hard drive
	Optical
	Removable
	Network
	FTP server
	Edit configuration

	SFTP server
	Edit configuration

	Azure
	Edit configuration

	Amazon S3
	Edit configuration

	Google Cloud Storage
	Edit configuration

	Google Drive
	Edit configuration

	Microsoft OneDrive
	Edit configuration

	Box
	Edit configuration

	Dropbox
	Edit configuration

	HiDrive
	Edit configuration

	Hubic
	Edit configuration

	S3 Compatible
	Edit configuration


	Sources
	Filters
	Customize
	Filter Properties

	Type
	Smart
	Full
	Differential
	Incremental
	Mirror
	Storage

	Compression
	Advanced
	Email
	Scheduler
	General
	When
	What


	Restore Wizard
	Where and how to restore
	What do you want to restore
	To what date do you want to restore
	Do you want to filter the files
	Preview the files to be restored

	File Filtering
	Overview
	File Filter

	Command Line
	Backup
	Test
	Repair
	Restore
	Cleanup
	History

	Options
	General
	Preferences
	Startup and updates
	Application folders
	Backup
	Filters
	Remote Monitor
	Logs and history
	CD, DVD or Blu-ray
	Online connections
	LAN
	FTP
	SFTP
	Azure
	Amazon S3
	Google Cloud Storage
	Google Drive
	OneDrive
	Box
	Dropbox
	HiDrive
	Hubic
	S3 Compatible

	Email
	Notifications
	Passwords
	Suspend

	Help
	Licensing
	Free Trial
	Online Activation
	Manual Activation
	Deactivation
	Legal notices


